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This Tutorial 

Tutorial Objective 
This training tutorial is designed get you started with GeoMedia® Map Publisher.   
 

Tutorial Data Set 
The sample data set used in the GeoMedia Map Publisher tutorial exercises represents a typical 
1:50,000 scale map sheet produced by the Danish National Mapping Agency, Kort & 
Matrikelstyrelsen (KMS) – Danish Ministry of the Environment, National Survey and Cadastre.  

It should be noted that the original data set provided by KMS represented a completed 
cartographic product prior to lithographic processing.  However, liberties have been taken within 
the data set in order to illustrate a typical starting point in the cartographic editing process.  The 
exercises provided in this tutorial do not necessarily represent standard workflows employed at 
KMS, nor do the exercises claim to represent the type of cartographic edits performed at KMS.  
The tutorial exercises simply illustrate standard cartographic editing procedures that mapping 
agencies and mapping companies would expect to be available using a cartographic editing 
software application such as GeoMedia Map Publisher.  

The cartographic results produced within this training tutorial reflect the results of standard 
cartographic processes and editing concepts.  The resulting data set should be viewed as a 
representative sample of the type of data modifications that typically occur during the 
cartographic production process, and in no way illustrate the "truth on the ground." 

Hexagon Geospatial would like to extend its appreciation to Kort & Matrikelstyrelsen (KMS) for 
their cooperation in this endeavor. 

 
Tutorial Text Conventions 
There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb group, click Ccc. 

 Dialog box names, field names, and button names are depicted using Bolded Text. 

 Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 

 
Tutorial Prerequisites 
Familiarity with the GeoMedia Desktop. 
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Getting Started with Section 1:  
GeoMedia Map Publisher  

Section Objective 
This section will get you started with GeoMedia Map Publisher.  
You will learn about: 
 

 Installing the tutorial dataset 

 Workflow Concepts  

 Setting the Cartographic Edit Options 

 

Tools Used 
GeoMedia Professional and GeoMedia Map Publisher 
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 Install the Tutorial Dataset Exercise 1:

Objective: 
This exercise will instruct you on installing the tutorial dataset and provide a basic workflow 
overview. 

Task 1: Install the Tutorial Data Set.  

1. A training data set is provided in a Zip file, GeoMedia Map Publisher Tutorial Dataset.zip. 
To use the data set, extract the files to your C drive, preserving the path and folder 
names.  For example, in WinZip®, you would select the Use folder names option.  This 
will deposit the tutorial files in the following path: C:\GeoMedia Desktop 
Training\Introduction to Mapping Manager\GeoMedia Map Publisher\Lessons.  

a) When done you fill find a GMMappubTutorial folder in the GeoMedia Desktop 
Training folder (C:\GeoMedia Desktop Training\).  

b) Cut and paste the GMMappubTutorial folder to the C: drive.  

c) When done it should be here C:\GMMappubTutorial. 

d) Ensure that your Lessons folder looks like this: 
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e) Ensure that the Symbols folder is in the following path (please double-check 
this): C:\GMMappubTutorial\Symbols and the folder looks like this: 

 

 

2. The data set is self-contained and includes all of the necessary files for the tutorials, 
including workspaces, and assorted warehouses.  

 
 

Task 2: Basic Workflow Overview 

GeoMedia Map Publisher is designed to address the cartographic edits that are required when 
transforming generic source data into a suitable cartographic representation.   
 
Cartographic edits generally involve performing assorted style and geometric modifications to the 
source data to ensure that the optimal cartographic representation is obtained.  The type and 
degree of cartographic editing required is based on variations between the source data and the 
cartographic data required for the finished map product.  This variation can be influenced by 
many factors, such as differences in projections, reductions in map scale, or differences in the 
style definitions used.   
 
The basic workflow for GeoMedia Map Publisher involves defining the cartographic editing 
environment necessary to produce the finished map product, and then performing the appropriate 
cartographic edits.  This involves the following steps: 
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1. Create a blank GeoWorkspace. 

2. Define the projection for the finished map product. 

3. Define the print scale (Nominal Map Scale) for the finished map product. 

4. Define the necessary warehouse connections for the Cartographic Sources, the 
Cartographic Edits, and the Generalization Rules. 

5. Add the necessary legend entries (feature classes and queries) required for the 
finished map product. 

6. Assign default styles to each of the legend entries, and set their Style Scaling to 
Paper. 

7. Define the Cartographic Editing environment (Cartographic Options). 

8. Perform the necessary interactive cartographic edits (Modify Style, Modify 
Geometry). 

9. Perform the necessary automated cartographic edits (Generalization). 

10. Compose the map design of the finished map product in the layout window. 

11. Perform the desired lithographic processing. 

The lessons in this tutorial will concentrate on the GeoMedia Map Publisher components of the 
workflow: Steps 7, 8, and 9. Step 11 includes the CMYK PDF option available using GeoMedia 
GeoPDF Publisher. Steps 1 through 6 and Step 10 involve standard GeoMedia Professional 
functionality and have already been performed on the data, and they serve as the starting point 
for the lessons outlined in this tutorial as follows: 

1. Geoworkspace – there is a geoworkspace for each lesson: 

2. Projection – UTM Zone 32 North 

3. Print Scale – the Nominal Map Scale in Display Properties is set to 1:50,000. 

4. Warehouse connections – multiple connections exist: 

a. KMS_Cosmetic.mdb 
A read-only warehouse that contains cartographic features collected specifically 
for this 1:50,000 map product and does not require any cartographic editing. 

b. KMS_Source.mdb 
A read-only warehouse that contains source features collected independently of 
this 1:50,000 map product and requires cartographic editing. 

c. KMS_Rules.mdb 
A read-write warehouse that contains the Generalization Rules for this 1:50,000 
map product.  No cartographic editing will be performed on its contents.  
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d. KMS_Carto.mdb 
A read-write warehouse that will be used to store the cartographic edits for this 
1:50,000 map product.  

5. Legend entries – the necessary feature classes and queries appear in MapWindow1. 

6. Default Styles – style definitions have been assigned based on KMS 1:50,000 map 
specifications.  The Style Scaling for each legend entry has been set to Paper. 

7. Map composition – the necessary marginalia has been added to the 
VORDINGBORG layout sheet in the layout window. 

Task 3: Useful Information 

The starting point for several of the lessons in these tutorials is dependent upon the successful 
completion of previous lessons.  For best results, the lessons should be performed in the order in 
which they are presented. 

The interactive editing commands in GeoMedia Map Publisher work in two different operational 
modes:  object-action and action-object.  In object-action mode, the feature(s) to edit are selected 
first, and then the command is selected.  

 In action-object mode, the command is selected first, and then the feature(s) to edit are selected.  
Commands remain active until you press the ESC key, select the Select Tool, select Exit from 
the right-click menu, or select another command.  Many of the commands in GeoMedia Map 
Publisher are dependent upon specific geometry types and/or style definitions.  For example, the 
Adjust Line Style command requires a linear geometry that has a dashed style definition.  When 
this command is active, features that do not meet these criteria are not selectable and will not 
highlight when hovering the cursor over them.  If features that do not meet these criteria are in the 
select set when the command is invoked, a warning message will appear stating "None of the 
feature(s) selected are valid for this edit."  

The majority of lessons in this tutorial operate using a consistent display scale:  1:12,500.  With 
the exception of the Generalization lessons, each lesson operates in a specific geographic area 
within the data set to ensure that appropriate features are in view for the Map Publisher command 
being processed in the lesson.   
 
Navigation in the map window to the specific geographic locations will be accomplished using 
Queued Edit in combination with specific settings defined for the map window properties.  To 
accommodate this, a feature class was created in the Cartographic Edits database:  
MappubTutorial.  The feature class is a point geometry with a single attribute:  
Command_Name. Features were digitized in a relevant location for each command.  This feature 
is not displayed in the map window and is used only for the purpose of Queued Edit.  This is not 
a standard operating procedure for GeoMedia Map Publisher workflows.  Its sole purpose is to 
aid in the map window navigation for this tutorial. 

It is not necessary to run through all the tutorials in a single session.  At any point, you can stop, 
exit GeoMedia, and then continue at a later date.  If you do stop in the middle of the tutorial, you 
must save the GeoWorkspace in order to retain the cartographic edits that have been performed.  
Upon re-entering GeoMedia, you will likely need to invoke Queued Edit again before continuing 
with other lessons.  Instructions for starting Queued Edit can be found at the beginning of the 
Performing Style Edits tutorial. 
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 Getting Started with Exercise 2:
GeoMedia Map Publisher 

Objective: 
Opening a geoworkspace and setting the cartographic editing options. 

Task 1: Open the Tutorial Workspace 

GeoMedia Map Publisher is an extension product for GeoMedia Professional.  To use GeoMedia 
Map Publisher, you must first start GeoMedia Professional. 

1. Open C:\GeoMedia Desktop Training\Introduction to Mapping Manager\GeoMedia 
Map Publisher\Lessons\Lesson 1 Getting Started.gws. 

 

GeoMedia Professional starts, opening the selected GeoWorkspace. 
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The GeoMedia Map Publisher tab Carto is visible on the main menu bar. For more 
information, see Looking at the Ribbon Mode in the Help. 

 The sample data set provided by KMS has particular characteristics associated with their 
specific 1:50,000 map scale production environment.  The architecture of this data set has been 
specifically designed to take advantage of the functional capabilities available in GeoMedia 
Professional, and at the same time, to take advantage of third-party software applications that 
KMS uses to enhance their map production workflow.  In most cases, the data structures 
presented in this tutorial represent typical GeoMedia Professional data structures, but in some 
cases, the data structures presented are the result of third-party software application processing. 
 

Task 2: Defining the Cartographic Editing Environment 

Before performing any cartographic edits, the cartographic editing environment needs to be 
established.  This is accomplished with the Cartographic Options command.  The primary 
purpose of the Cartographic Options command is to define the associations between the 
cartographic source warehouse connection(s) and the cartographic edits warehouse 
connection(s).  There are additional settings available for defining the desired Display Properties 
and Legend Management settings.  In general, the Cartographic Options command is the first 
step in the workflow and should only need to be invoked a single time throughout the workflow.  
For additional information, see the Cartographic Options chapter in the Help.   

 Making changes to these settings after cartographic edits have been performed may 
invalidate existing cartographic edits. 

1. To define the cartographic editing environment, select Carto > Cartographic Edits > 
Options from the ribbon bar. 

 

The Cartographic Options dialog box displays with the Connections tab active.  
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Each of the warehouse connections defined in the GeoWorkspace are listed in the 
Cartographic Source column.  By default, the Cartographic Edits definitions will be 
blank. In this configuration, KMS 50K Source is the only connection that will have 
cartographic edits performed on its contents, and the cartographic edits will be stored in 
a separate database, KMS 50K Carto. 

2. For the KMS 50K Source connection, select KMS 50K Carto for the associated 
Cartographic Edits connection. 

3. Select None for the Cartographic Edits connection for each of the other Cartographic 
Source connections.  

 

 When warehouse configurations store the Cartographic Edits in a separate 
database from the Cartographic Source, it may be desirable to make the source 
connection read-only to eliminate the possibility that source data could be inadvertently 
modified during the cartographic editing process. 

4. Click the Display Properties tab. 
 
The Display Properties tab allows you to define the Nominal map scale (this is the 
same as defining it on the Display Properties dialog), to review the GeoWorkspace 
Coordinate System, and to define the settings for Carto legend entry title. 
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5. Ensure the Nominal map scale is set to 1:50,000.  

6. Optionally click GeoWorkspace Coordinate System to review the GeoWorkspace 
coordinate system. 

7. For the Carto legend entry title, make sure the Bold button has been clicked and the 
color selected is a dark cyan color. 

 The Nominal map scale setting should reflect the finished map scale and is 
used to calculate dimensions at Paper Scale during cartographic editing.  The 
GeoWorkspace Coordinate System should reflect the projection of the finished map 
product.  The Carto legend entry title settings are optional.  The default settings will 
match the current settings defined for the active map window Legend Properties.  
Changing these settings will provide visual feedback in the map window legend for 
those legend entries that have had cartographic edits performed on them. 

8. Click the Legend Management tab. 
The Legend Management settings allow you to define the Carto Master Legend 
(CML), and define the desired behavior of legend processing as cartographic edits 
occur. 
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9. Ensure MapWindow1 (Active MapWindow) is selected for the Carto Master Legend.  

10. Make sure the options Automatically update related legend entries, Set all added 
legend entries to use paper style scaling, and Convert legend entries to paper 
style scaling as encountered have been selected. 
 

 Legend Management plays an important role in the cartographic editing 
process.  The Carto Master Legend (CML) is used to store all of the cartographic style 
edits in addition to identifying which legend entries have had cartographic edits 
performed on them.  Before cartographic edits are performed, each legend entry 
references the source data.  As cartographic edits are performed, the legend entries of 
the edited features are converted from source legend entries to cartographic legend 
entries.  The cartographic legend entries reference the combined cartographic edited 
feature instances along with the non-edited source feature instances.  Map window 
legends often contain duplicate or derived legend entries.  For example, a single 
feature class may appear multiple times in the map window legend, or a query legend 
entry may be derived from a feature class legend entry.  Checking the Automatically 
update related legend entries check box ensures that related legend entries in the 
map window legend will also be converted to cartographic legend entries as 
cartographic edits occur. 
 
The sample data set used in this tutorial illustrates this scenario with each of the road 
feature classes (Motorvej, Vejo6, and so on.).  All of the road feature classes are 
displayed in the legend twice, once for the main road alignment and once for the bridge 
alignment.  For example, Motorvej and Bro_Motorvej both reference the Motorvej 
feature class.  Attribute Based Symbology (ABS) is used in the Style Properties of each 
legend entry to differentiate between the two.  Separating the bridge segments from the 
main road alignment segments with multiple legend entries enables the proper display 
priority to ensure that bridge segments display on top of the main road alignment 
segments. 
 
Checking the Set all added legend entries to use paper style scaling check box 
sets the option to Paper scaling in the When adding legend entries use group on the 
Map Display tab in the GeoMedia Professional Tools > Options dialog. This setting 
causes all newly added legend entries to use paper style scaling when added to the 
map window legend. In the event that existing legend entries are encountered that 
have their style scaling set to View when cartographic edits are initiated, checking the 
Convert legend entries to paper style scaling as encountered check box will set 
the encountered legend entry to paper style scaling. 

11. Click the General tab. 
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The General tab provides the ability to optionally create Carto Edit tables in the Carto 
Edits database and to specify the name and location for a log file where GeoMedia 
Map Publisher processing errors are logged.  For additional information on the creation 
of Carto Edit tables and multi-user editing mode, see Cartographic Options in the Help. 
 

 

12. Click OK. 
 
The cartographic editing environment has been defined.  Associations between the 
cartographic source and cartographic edits databases have been established.  The 
Carto Master Legend (CML) has been saved as a Named Legend and will be updated 
as cartographic edits occur. 
 

 When adding new legend entries to the map window, the style used to portray the 
new entry varies based on the presence of a Master Legend and/or Named Styles in 
the GeoWorkspace.  If the items selected in the Add Legend Entries command are 
defined in the Master Legend or if the name of the items selected matches an existing 
Named Style, the existing style definitions are used with the Master Legend definition 
taking precedence.  If there are no matches, a default style is used.  None of these 
style definitions are being updated as cartographic edits occur.  However, the Carto 
Master Legend (CML) is being continually updated as cartographic edits occur.  During 
the cartographic editing process, it may be desirable to add the cartographic edited 
version of the features to an existing or new map window.  To ensure that the 
cartographic edited version of the style definition is used when adding new 
legend entries, set the Master legend definition on the Legends dialog equal to the 
Carto Master Legend (CML) definition specified on the Cartographic Options dialog 
box as follows: 

a. Select Home > Legend > Legends > Legends. 

b. In the Master legend field, select MapWindow1 and click Close. 

13. Select File > Save to save the GeoWorkspace. 

 These tutorials can be done sequentially or by selected subject. For the tutorials that 
follow you can either continue working with the same workspace and accumulate the 
results of the exercises that you perform or, alternately open the workspace for each 
tutorial. Some of the tutorials have dependencies on previous tutorials being completed. 
This dependency is removed by starting each tutorial with the workspace for that particular 
tutorial. 
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 Performing cartographic edits in GeoMedia Map Publisher involves at a minimum 
the use of a GeoWorkspace, a Cartographic Source database, and a Cartographic 
Edits database, all of which should remain in sync with one another during the 
cartographic editing process.  As cartographic edits are performed on the data, the 
results are written to the GeoWorkspace and Cartographic Edits database(s) in real-
time. Edits written to the Cartographic Edits database(s) are saved immediately as the 
edit occurs.  However, edits written to the GeoWorkspace are not saved until the 
operator manually saves the GeoWorkspace.  For this reason, it is recommended that 
the GeoWorkspace be saved periodically to ensure that the cartographic edits 
performed remain in sync between the GeoWorkspace and the Cartographic Edits 
database(s).  There are several scenarios where the GeoWorkspace and the 
Cartographic Edits database(s) could get out of sync with one another during the 
cartographic editing process.  First, an operator could perform several cartographic 
edits and then exit the GeoWorkspace without saving it.  Second, an operator could 
perform several cartographic edits and then experience a power outage that prohibited 
them from saving the GeoWorkspace.  In the event that the GeoWorkspace and the 
Cartographic Edits database(s) get out of sync with one another during the 
cartographic editing process, the operator can easily get them back in sync with one 
another by doing the following: 

a. Start GeoMedia Professional and open the affected GeoWorkspace.  

b. Select Carto > Cartographic Edits > Refresh.  

c. Select File > Save to save the GeoWorkspace.  

 
 

 
 

 

 


