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This Tutorial 
Tutorial Objective 
This tutorial includes multiple sections that address common workflows associated with raster 
data. The first section focuses on the use of Image Footprints – area geometries that represent 
the outline of the images, and illustrates how to create the Image Footprints and Display Selected 
Images that are associated with image outlines. The second section addresses Image 
Registration of an aerial photograph and outputting the registered image to GeoTIFF. 

 
Tutorial Data Set 
The tutorial dataset is primarily for King, County Washington. The data was accessed on public 
government websites from U.S. Census Bureau, U.S. Geological Survey (USGS) and Natural 
Resources Conservation Service, Department of Agriculture (USDA).  

This tutorial relies on the use of Named Locations to navigate to specific areas in the data set. A 
unique locations XML file is included with this tutorial:  

C:\GMTutorial\GeoWorkspaces\KingCounty_locations.xml 

To ensure that this locations XML file is being referenced, toggle the Display Location command 
button on the Home tab. This will invoke the Display Location dockable control, where you can 
click the Display Location Options button and browse for the locations file noted above. 

 

Tutorial Text Conventions 
There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb group, click Ccc. 

 Dialog box names, field names, and button names are depicted using Bolded Text. 

 Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 

 
Tutorial Prerequisites 
The datasets used in this tutorial access native data formats via GeoMedia Data Servers. This 
tutorial covers multiple raster processing utilities including Image Registration, Image Footprints, 
Display Selected Images, and Output to GeoTIFF. Section 1: Image Footprints can be run on all 
tiers. Section 2: Image Registration and Output can only be run on the Professional tier, as the 
Image Registration and Output to GeoTIFF commands are not available at the Essentials or 
Advantage tiers. 
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Image Footprints 

Section Objective 
GeoMedia provides basic image processing capabilities for the display and manipulation of 
assorted image file formats, many of which provide compression techniques that can influence 
display performance. When display performance is critical, the use of Image Footprints can be 
employed to improve performance by defining image outlines that can be selected so images are 
displayed on demand. This section illustrates the Image Footprints concept, where vector area 
geometries depicting the image outline are generated. These vector outlines are then used for 
selection to display only the images that are necessary for your workflow.     

 
Tools Used 
 

Image Footprints 
Create and display image footprint polygons of an image feature class, query, category, or 
reference feature. An image footprint is an area geometry that represents the outline of the image. 

 

Display Selected Images 
Display images from those features in a select set that have image geometries; objects without an 
image geometry are skipped. This command is designed to be used in conjunction with the Image 
Footprints command, which creates image footprint polygons of an image feature class or query, 
although it can also be used in other contexts. 
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 Working with Image Footprints 

Task 1: GeoWorkspace Preparation 

In this task you will open an existing GeoWorkspace, navigate to a specific location on the map, 
and create a new Access warehouse to store the path for your image data. 

1. Launch GeoMedia Desktop, and choose Open an existing GeoWorkspace from the 
Welcome menu. 

2. Click More Files… from the list, and click OK.  

3. For Look in, navigate to C:\GMTutorial\Geoworkspaces. 

4. Select KingCounty.gws, and click Open.  

5. On the Home tab, select Legends… to open the Legends dialog. 

6. Select the legend named Display By Scale and click Replace to change the legend. 

7. Choose Yes on the confirmation dialog. Click Close to dismiss the Legends dialog. 

8. On the Home tab, select Display Location > Locations to open the Locations 
dialog. 

9. Select Seattle South Quad (7.5 Minute) then click Display. Click Close to dismiss 
the Locations dialog. 

 
If the Named Location does not appear in the list, it implies that the 
tutorial Locations file has not been defined. Refer to the Tutorial Data 
Set section on page vii for details. 

10. On the Home tab, select Map Display to open the Display Properties dialog. 

11. Change the value for Display scale to 1:100,000 and click Apply. Click Close to 
dismiss the Display Properties dialog. 
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12. On the Manage Data tab, select Warehouse > New Warehouse. 

13. On the Warehouse Template dialog accept the default of normal.mdt and press 
New. 

 
The Warehouse Template dialog was previously titled ‘New’ in 
GeoMedia 2015 and earlier releases.   

14. The New Warehouse dialog is displayed. For Save in, browse to 
C:\GMTutorial\Warehouses. For File name enter RasterUtilities and press Save. 

 

 

Task 2: Create Image Footprints 

The Image Footprints command lets you create image footprint polygons of an image feature 
class, query, category, or reference feature.  An image footprint is an area geometry that 
represents the outline of the image.  Using image footprints when possible, rather than the raster 
images themselves, greatly speeds display processing (panning, zooming, etc.).   

1. On the Raster tab, select Georeferenced. The Insert Georeferenced Images 
dialog is displayed. 

2. For Georeference mode, select Automatic. For Coordinate system file, leave the 
field blank. 

3. For Folder, browse to C:\GMTutorial\Warehouses.  

4. In the Available files list, scroll down and select SeattleSouthNE.tif, 
SeattleSouthNW.tif, SeattleSouthSE.tif, and SeattleSouthSW.tif.  Use the > arrow 
button to move the files to the Selected files list.  

 
Note that the Georeference mode has been updated to GeoTIFF.   
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5. For Warehouse, select RasterUtilities. For Image feature class with matching 

coordinate system, enter SeattleSouth. 

6. Check the box for Add new legend entry for feature class and click OK. 

 
7. On the Raster tab, select Image Footprints. 

8. For Create image footprints for select the SeattleSouth feature class in the 
RasterUtilities connection. 
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9. Accept the default query name of Image footprints of SeattleSouth and select the box 

for Display footprints in map window. Click OK. 

10. Right click the SeattleSouth legend entry and select Delete to remove it from the 
legend. Click Yes on the confirmation dialog. 

11. You should now see 4 image footprints along with their corresponding labels. 
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Task 3: Display Selected Images 

The Display Selected Images command displays images from those features in a select set that 
have image geometries.  The command loads only those images that have been placed in the 
select set, whether they have been placed by selection of their footprints in a map window, their 
rows in a data window, or some other technique.  To use this command, which has no graphical 
interface, you must have a select set, and an active map window. 

1. In the map window select the image footprint for SeattleSouthNW.tif. On the Raster 
tab, select Display Selected Images. 

2. A legend entry named Selected images of SeattleSouth is added to the map window 
legend and the SeattleSouthNW.tif image is displayed. 

 
3. Right click the Selected images of SeattleSouth legend entry and select Delete to 

remove it from the legend. Click Yes on the confirmation dialog. 

4. Hold down the Ctrl key and click the footprint for SeattleSouthNE.tif and 
SeattleSouthSW.tif to add them both to the select set. 

5. On the Raster tab, select Display Selected Images. 

6. A legend entry named Selected images of SeattleSouth is added to the legend and 
the SeattleSouthNE.tif and SeattleSouthSW.tif images are displayed. 
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7. Exit GeoMedia without saving. 



 

   

Image Registration and 
Output 

Section Objective 
This section illustrates a workflow to register an aerial photograph that does not contain 
georeferenced information to the existing GeoWorkspace Coordinate System, and to generate a 
GeoTIFF file of the registered image that contains the GeoTIFF tags for use in applications that 
support the display of georeferenced image data.  

 
Tools Used 
 

Image Registration 
Register an image that has been inserted into the GeoWorkspace by creating a registration or by 
applying an existing registration. An image can also be re-registered by editing the registration 
originally used to register the image. You can edit a saved registration, save a report of the 
selected image registration to a text file, or delete selected image registrations. 

 

Output to GeoTIFF 
Take a selected TIFF image, and output it to a new GeoTIFF image file containing geographic 
header information (also called GeoTIFF tags). 
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 Image Registration 

Task 1: Image Registration Overview 

Image Registration allows you to register a selected image by creating a new registration or 
applying an existing registration.  Creating a new image registration involves registering an image 
to its real-world coordinates, that is, transforming raster points to map control points.  You can 
enter these points in any order and can collect them by placing data points or by precision keyin. 

To create a new image registration, a single image must be in the select set before you select 
Image Registration.  You must select an image to re-register it, and you must register it 
manually by clicking the Register button; the command does not do it automatically. 

 
You must have at least one map view open during image registration 
and an interactive selection of control-point pairs.  Also, control-point 
icons are displayed in all appropriate open map windows. 

To register an image by creating a new registration: 
• Insert an image into your GeoWorkspace. 

• Place the image you want to register in a select set. 

• In the Raster tab, select Image Registration.  

 
 

• Click New.  
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• Collect control-point pairs using the following available options: 

o Click Add Points; then follow the prompts for adding control-point pairs.  
When complete, double click to fill the grid with control-point pair 
coordinates. 

o Type the coordinates directly into the grid. 

o Click Add Points; then type the coordinate values into the Precision 
Coordinates dockable control. 

o Collect all source points by clicking Edit Source; then add the target 
points by typing them directly into the grid or by clicking Edit Target. 

o Collect all target points by clicking Edit Target; then add the source 
points by typing them directly into the grid or by clicking Edit Source. 

• Check the calculated error in the Residuals field after you have entered at least 
three control-point pairs.  If it is not acceptable, use the Control/Check toggle of 
the Type column to examine the error for individual control-point pairs. 

• Select the Type column in the grid to remove pairs with a high error from the 
calculation; then edit individual control-point pairs using the editing steps that 
follow. 

• Type an appropriate name and an optional description for the registration. 

• Click Register to register the image. 

OR 

Click Save to save the registration without saving the image.  

 

To register an image by applying an existing registration: 
• Select the image you want to register. 

• Select Tools > Image Registration. 

• Select the appropriate registration from the list on the Registrations dialog box. 

• Click Register 
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Task 2: Image Registration Preparation 

1. Launch GeoMedia Desktop, and choose Open an existing GeoWorkspace from the 
Welcome menu. 

2. Click More Files… from the list, and click OK.  

3. For Look in, navigate to C:\GMTutorial\Geoworkspaces. 

4. Select KingCounty.gws, and click Open. 

5. On the Home tab, select Legends… to open the Legends dialog. 

6. Select the legend named Display By Scale and click Replace to change the legend. 

7. Choose Yes on the confirmation dialog. Click Close to dismiss the Legends dialog.  

8. On the Home tab, select Legends > Add Legend Entries.  

9. Expand the USDA – Imagery tree-view, and check NAIP_Color_Mosaic. Click OK.  

10. Right-click the NAIP_Color_Mosaic legend entry and choose Fit by Legend Entry. 

 
11. Close, pin or undock the legend to provide more space for the map window.  

12. Pan in the map window so the image appears on the right side. 
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13. On the Raster tab, select Interactive. The Insert Interactive Image dialog is 

displayed. 

14. For Image Name browse to C:\GMTutorial\Warehouses\AR6295001400125.tif 

15. For Warehouse select USGS Imagery. 

16. For Feature class, enter Interactive and click OK. 

17. To the west of the SeattleSouth image, draw a bounding box similar to the one 
shown below in yellow: 

 
18. The image is placed within the bounding box. 

19. Zoom in so that the detail in the Interactive image is clearly visible. 
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Task 3: Registering an Image 

1. Click the Interactive image placed in the previous task, adding it to the select set. 

2. On the Raster tab, select Image Registration.  

3. On the Registrations dialog, click New.  

4. On the New Image Registration dialog, click Add Points. 

5. Click to add a point to the source image (Interactive). Be sure to choose a location 
that is easily found in both images. Some sample coordinate pairs are shown below: 

 
6. Click to place the corresponding point on the target image (SeattleSouth). You can 

optionally place target points on vector data.  

7. Repeat the process of placing coordinate pairs between the images until you have at 
least 3 pairs of points with adequate distance between them. 

8. Double click to end the process of adding control points. The New Image 
Registration dialog is displayed. 

9. Review the table of created control points and click Register to register the image. 

10. The image is now registered and is moved to its correct geographic location. 
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Class Notes 
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 Output to GeoTIFF 

Task 1: Outputting GeoTIFF Overview 

Output to GeoTIFF takes a selected TIFF image and writes it out to a new GeoTIFF image file 
containing geographic header information.  The selected TIFF image is assumed to display in the 
correct location.  The image could have been inserted with Insert Interactive Image and 
registered with Image Registration, or it could have been placed using the Insert 
Georeferenced Images command.  The output header information (also called GeoTIFF tags) in 
the GeoTIFF file allows the image to be inserted in another GeoWorkspace in the correct 
geographic location automatically with Insert Georeferenced Images or to be used in other 
software packages that accept GeoTIFF-formatted image files. 

You can only select one raster at a time.   Output to GeoTIFF makes a copy of the originally 
selected file to the directory and filename specified.  The original file is not modified in any way. 
Then, the command writes new GeoTIFF tags (overwriting any existing ones) to the header of the 
new image file.  The command takes the coordinate system of the GeoWorkspace and the 
associated raster matrix as input to write these GeoTIFF tags. 

By default, a companion world file is also created for the GeoTIFF file being output.  The world file 
has the same name as the new file, except with a .tfw extension.  Thus, if an application does not 
support GeoTIFF placement, it can use the world file.  A world file is simply the six necessary 
components of an Affine matrix that define the mapping from pixel to world coordinates.  Unlike 
the GeoTIFF tags, the world file does not include any coordinate system information. 

Output to GeoTIFF can only write out to certain projections and datums of coordinate systems. 
Insert Georeferenced Images can, however, read almost any data that is correctly defined within 
the GeoTIFF specification.  You can use any of the GeoMedia product tiers to insert a GeoTIFF 
image with the Insert Georeferenced Images command. However, the Output to GeoTIFF 
command is only available with the Professional tier of GeoMedia Desktop.  
 

Task 2: Output a GeoTIFF Image 

1. Select the Interactive image registered in the previous exercise, adding it to the 
select set. 

2. On the Raster tab, select Output to GeoTIFF. 

3. On the Save as GeoTIFF dialog, navigate to C:\GMTutorial\Warehouses. For File 
name, enter Seattle1975 and click Save. 

4. Click OK to dismiss the confirmation dialog.  
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Task 3: Verify GeoTIFF Output Result  

1. On the Home tab, select Add / Show Windows > New Map Window. 

2. In the New Map Window dialog select Display by Scale for the legend to display, 
and click OK.  

3. On the Home tab, select Display Location > Locations to open the Locations 
dialog. 

4. Select Seattle South Quad (7.5 Minute) then click Display. Click Close to dismiss 
the Locations dialog. 

5. On the Raster tab, select Georeferenced. The Insert Georeferenced Images 
dialog is displayed. 

6. For Georeference mode, select Automatic. For Coordinate system file, leave the 
field blank. 

7. For Folder, browse to C:\GMTutorial\Warehouses. 

8. In the Available files list, select Seattle1975.tif and use the > arrow to move it to the 
Selected files list.  

9. For Warehouse, select USGS Imagery. For Image feature class with matching 
coordinate system enter Seattle1975. 

10. Check the box for Add new legend entry for feature class and click OK. 

11. In the legend right-click the Seattle1975 legend entry and choose Fit by Legend 
Entry. 

 
12. Exit GeoMedia Desktop without saving. 
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