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This Tutorial 

Tutorial Objective 
The objective of this tutorial is to learn how to work with import a small collection of 3D models in 
KMZ format. 

 

Tutorial Overview 
GeoMedia® Desktop allows you to access GIS data through connections.  Connections are links 
that allow the transfer and translation of feature data from the various supported data warehouse 
types.  Warehouses can include both raster feature classes and vector data feature classes. 

Display feature classes, in this context, refers not only to the ability to display any feature within 
the 3D map window, but also to the ability to maintain the connectivity to the feature source (that 
is, to allow you to interact with the geospatial information (namely X, Y, Z) and attribution just like 
you would with GeoMedia Desktop; and in turn, perform geospatial analytics within the 3D 
visualization component). Specifically, feature classes that are rendered in the 3D map window 
can be interacted with in a fashion that is similar to interacting with a displayed feature in a 2D 
map window. 

If you are familiar with GeoMedia Desktop, you should have a working understanding of 
connections, warehouses, and feature classes. In short, connections are the link between 
GeoMedia and a warehouse (that is, you connect GeoMedia to warehouses that contain spatial 
data via a connection). Warehouses are essentially databases (that is, they contain feature data 
that is typically spatial; spatial feature data consist of points, lines, or areas).  Feature classes are 
collections of same-type data (that is, points can represent features such as fire hydrants, lines 
can represent features such as telephone cables, and areas can represent features such as 
buildings). 

 

Tutorial Data Set 
The exercises outlined in the GeoMedia 3D tutorials make use of specific data sets.  Specifically, 
the GeoMedia 3D tutorial data sets include:  vector sources (point, line, and area features), raster 
sources (aerial photographs in GeoTIFF format), and elevation sources in ERDAS Imagine and 
USGS SDTS formats. 

 
Tutorial Text Conventions 
There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb group, click Ccc. 

 Dialog box names, field names, and button names are depicted using Bolded Text. 

 Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 

 

Tutorial Prerequisites 
There are no prerequisites for making use of this tutorial; however, having a basic understanding 
of the GeoMedia Desktop will be helpful in expediting the execution of certain steps within this 
tutorial.  
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Importing a Collection of 3D 
Buildings in KMZ Format 

Section Objective 

GeoMedia 3D can be used to create LOD 1 representations from an area feature class containing 
building footprints while also maintaining connectivity to your GIS data. In this exercise, you will 
learn how to import a collection of LOD 2 3D models representing buildings into GeoMedia 3D. 

The intent of this tutorial is to outline the steps needed to use the Import 3D Objects utility that 
comes bundled with GeoMedia 3D then inturn make use of this output to display building models 
in GeoMedia 3D. 

The Import 3D Objects utility is an optional install component; it is not automatically installed 
during the installation process.  If you did not specifically choose to install this component during 
your initial installation, you need to make use of your original installation disk to add this 
component. In this section you will learn how to: 

 
 Convert a collection of KMZ files into a set of XPL2 files. 

 Use the output feature class that is generated during the conversion process in tandem 
with the XPL2 files and the Replace with 3D Object property to display the models in the 
3D map window. 

 

Tools Used 

The Import 3D Objects utility and GeoMedia styles commands are used in this section. 
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 Using the Import 3D Objects 
Utility 

Objective: 
The objective of this exercise is to learn how to import a collection of 3D models in KMZ format 
into a GeoMedia Warehouse and hence GeoMedia 3D. 

Important Note: 
Before running GeoMedia 3D’s Import 3D Objects utility on a computer with a non-English 
operating system, it is currently necessary to change the regional settings to English (United 
States). After all 3D models have been imported, the regional settings can be reset to the 
appropriate language. 

Task 1: Set Regional Settings to English (United States) 

The sample files for this exercise make use of decimals when denoting numbers and given this, 
the Regional and Language settings may need to be modified. 

More specifically, before running GeoMedia 3D Import 3D Objects utility on a computer with a 
non-English operating system, you must change the regional settings to English (United States). 

1. Go to the Windows > Start menu and select Control Panel. 

2. Click the Clock, Language, and Region option. 

3. Click the Region and Language option. 

4. Use the Format drop-down list to specify English (United States). 

  

5. Click the OK button to apply this setting and to dismiss the dialog. 

Task 2: Launch the GeoMedia 3D Import 3D Objects Utility 

The Import 3D Object utility is used to import a collection of 3D models that contain 
georeferencing information (that is, coordinate information that allows the models to be correctly 
placed on the earth's surface).  
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1. The Import 3D Objects utility can be started using the Windows > Start menu.  Use 
your mouse and Windows desktop controls to select Start > Programs > Hexagon 
GeoMedia 3D > Utilities > Import 3D Objects. 

Task 3: Specify Input Parameters 

1. Click the Input parameters > Folder > Browse button to display the Browse For 
Folder dialog box. 

2. Use the facilities in the Browse For Folder dialog box to specify C:\GeoMedia 3D 
2015 Tutorials\Lesson 1\Input KMZ Files. 

3. Click OK to accept the specified location. This action will populate the Files list using 
a tree view control. 

 

 

 

This sample folder contains 4 individual building models in KMZ 
format.  

4. Click the + symbol beside the top-level folder to display the children of this entry. 

 

You can use this list to selectively check the check box beside one or more folders, or you can 
check the check box beside a parent, which in turn selects every model in every subfolder.  In this 
case, we are going to specify that we want every model in every subfolder to be converted. 

If you were to specify an option in the Files of type field, the list would automatically update to 
display only those folders containing models that match the filter.  

In this case, all of the folders contain a single KMZ model and therefore we do not need to specify 
a Files of type option. 

5. Check the check box beside the top-level folder to specify that you want the contents 
of all sub-folders to be considered during the conversion process. 
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All of the folders will be checked and therefore all of the models within these folders will be 
imported. You will see a control for EPSG code. This control can be used as a fall-back. For 
example, let's assume you have 500 models and 50 of these models for some reason did not 
include any projection information. 

In this particular case, the 450 files with projection information would import using this internal 
projection information, while the remaining 50 files would import using the EPSG code you input. 

If you leave the EPSG code field blank, the 50 files without any projection information would not 
be imported, as the system would not be able to correctly place these models, and these errors 
would then be recorded and output to the log file. 

6. Given that all of the models in the example collection have internal projection 
information, the EPSG code field can be left blank. 

The conversion process needs an input MDB file as the conversion process generates a new 
feature class or appends new records to an existing feature class (that is, a feature class is 
ultimately used to link every output XPL2 file to the appropriate model footprint or feature) so that 
the options in the 3D Settings tab can be used to display the model in a 3D map window. 

Task 4: Specify Output Parameters 

1. Click the Output parameters > Database file > Browse button to display an open 
dialog box. 

2. Use the facilities in this dialog box to specify Use the facilities in the Browse For 
Folder dialog box to specify C:\GeoMedia 3D 2015 Tutorials\Lesson 
1\3DMLFootPrintFeatures.mdb. 

3. Click Open to accept the specified MDB file. This action will populate the Database 
file field. 

 

4. Use the Feature class drop-down list to select an existing feature class or to specify 
a new one. In this example, specify Sample_Building_Footprints. 

 

If you specified an existing feature class, the Append to feature class and Replace feature 
class radio buttons would enable, thereby allowing you control how you want the update to occur. 
In this case, we have specified a new feature class (that is, one that does not already exist within 
the database).  Therefore, these radio buttons do not enable. 

As noted above, the Import 3D Objects utility creates a small collection of XPL2 files for each 
model. These models need to be stored in a location that is accessible to you and or your 
GeoMedia 3D workstation. 

5. Click the Output parameters > 3D object folder > Browse button to display the 
Browse for Folder dialog box. 

6. Use the facilities in this dialog box to navigate to C:\GeoMedia 3D 2015 
Tutorials\Lesson 1\XPL Files. 
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7. Click OK to accept the specified output folder location. This action will populate the 
3D object folder field. 

 

If for some reason one or more models do not import, you can use the log file to determine what 
might have gone wrong during the conversion process. 

This log file is automatically created for each conversion and it is automatically placed in the 3D 
object folder that you specify. The name of this file will be Log.txt. 

8. When everything is set, click the Import button to start the import process. 
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9. The system will process all of the input models. This process can take some time to 
complete. The utility tends to average 45 seconds to 60 seconds to convert one 
model. 

10. During processing, the status bar at the bottom of the Import 3D Objects window 
displays the messages: Translating 3D objects...Generating XPL files…Updating 
output database… 

11. When processing is complete, a dialog box displays Import complete. 

Task 5: Exit the Import 3D Object Utility 

1. Click the X (close icon) in the upper-right corner of the Import 3D Objects dialog to 
exit the utility. 

Task 6: Understanding the Output Feature Class 

In the example provided above, we chose to write out a feature class called 
Sample_Building_Footprints to the MDB file entitled 3DMLFootPrintFeatures.mdb.  If you 
were to review this feature class and its attributes in GeoMedia Desktop, you would notice the 
Import 3D Objects utility created a single footprint for each input model and a small collection of 
attributes. Not all of the attributes are vital to this discussion; however, there are a few attributes 
you need to be aware of. 

 

Name Description 

GM3D_Model Contains the location of the XPL2 file that was generated. 
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Origin_x Contains a value to represent the X location for placing the model (this 
value is used to correctly place the model in the 3D map window). 

Origin_y Contains a value to represent the Y location for placing the model (this 
value is used to correctly place the model in the 3D map window). 

Origin_z Contains a value to represent the Z location (this value is used to 
correctly place the model in the 3D map window). 

These attributes are important as they are used to correctly render and locate each model within 
the 3D map window.  Later in this tutorial, you will see how they are used to display a model in 
the 3D map window. 

Task 7: Understanding the Output Files (XPL2) 

In the example provided above, we chose to store the output files in the folder C:\GeoMedia 
Desktop Training\Whats New in GeoMedia 3D\Lessons\Lesson 1 Importing 3D Models\XPL Files. 

1. Use Window desktop commands to locate and open C:\GeoMedia 3D 2015 
Tutorials\Lesson 1\XPL Files. 

 

2. Notice that a single folder has been created for each input model and that the name 
of each folder reflects the name of the input model. 

3. Use Window desktop commands to open one of the subfolders. Notice a small 
collection of XPL2 files and a collection of texture files in JPEG format. 
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Task 8: Understand the Log File 

The log file is used to report any errors.  You can use the log file to determine whether any 
conversion errors occurred during the conversion process. The log file is a simple text file and 
can be opened in a wide variety of applications such as Notepad, WordPad, or Microsoft® Word. 

Remember, this file is placed in the location defined when specifying the path for the output 
models. Specifically, the path specified in the 3D object folder text box is used. 
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 Using the Output From the 
Import 3D Objects Utility 

Objective: 
The objective of this exercise is to learn how to import make use of the output from the 
GeoMedia 3D Import utility in GeoMedia 3D. More specifically how to display 3D models in XPL2 
format within GeoMedia 3D. 

Task 1: Launch GeoMedia 

Now that you have converted your models to XPL2 format, you are ready to make use of these in 
GeoMedia 3D. Make using of these models is easy and requires only a few steps. 

1. Use your mouse and desktop controls to navigate to Use the facilities in this dialog 
box to navigate to C:\GeoMedia 3D 2015 Tutorials\Lesson 1. 

2. Double-click Lesson 1.gws.  This action will start GeoMedia Desktop and open the 
GeoWorkspace called Lesson 1. 

 

This GeoWorkspace has one legend entry (StreetCasings). This feature is used to provide some 
context to the building 3D models you will be adding.  

Task 2: Insert Legend Entry Containing Footprints for 3D Models 

In this particular example, a GeoMedia warehouse connection has already been made to the 
3DMLFootPrintFeatures.mdb database file on disk for you. Given this, we can make use of this 
connection to display the resulting features from the import process. 

1. On the Home tab, in the Legend panel, click Add Legend Entries to display the 
Add Legend Entries dialog. 

2. Use the facilities within this dialog to place a checkmark beside the feature class 
called Sample_Building_Footprints. 
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3. Click the OK button to dismiss the Add Legend Entries dialog and to display the 
geometries contained within Sample_Building_Footprints feature class into the 
legend and hence the map window. 

. 

4. You should notice four footprint features in the map window – one for each of the 
KMZ files that were specified during the import process. 

Task 3: Toggle to 3D 

You do not have to be in the 3D map window to complete the remainder of the tasks, but the 
results will be more noticeable if you are, as once the styles have been setup correctly, you will 
see the building models displayed in full 3D. 

1. On the 3D tab, in the View panel, click Toggle 3D to convert the current 2D map 
window and contents to a 3D map window. 

 

As you can see, the Sample_Building_Footprints and StreetCasings legend entries were 
automatically placed in the 3D map window.  

Please note, MapWindow1 is pointing to the content file called Default_Internet.fly and therefore 
imagery and terrain are added automatically. 

Also please note, that at this point the 3D models for each footprint are not displayed. These  
need to be stylized first. 

Task 4: Reviewing Attributes 

As noted earlier, the Import 3D Objects utility creates a small collection of attributes for each 
feature. These attributes can be used to drive the display of the 3D models. 
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1. Use the GeoMedia Select Tool to display the Properties dialog box for one of the 
Sample_Building_Footprints  
 
(that is, on the Home tab, in the Selection panel, click Select Tool to enable the 
selection tool, and then double-click one of the Sample_Building_Footprints 
features in the map window). 

 

The Sample_Building_Footprints feature class contains an attribute called GM3D_Model. This 
attribute contains a value indicating the location of the XPL2 file for this record, and this attribute 
is going to be used to display the footprint as a 3D model. 

2. Click OK to close the Properties dialog box. 

In the example below, the process of linking a single feature in the output feature class to an 
XPL2 output file is illustrated. 

 

One model footprint is shown with its associated attributions. The associated attributions 
including a GM3D_Model attribute. This attribute is used to reference an XPL2 file, which in turn 
is used to locate the correct model and display it when in the 3D map window. 

As you can see in the sample provided above, the attribute GM3D_Model points to an XPL2 file 
and the attributes origin_x, origin_y, and origin_z are used to correctly position the XPL2 file 
when viewed in the 3D map window. 
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Specifically, the origin_x, origin_y attributes are used to geo-locate the model, while the 
origin_z attribute is used to place the model relative to the surface at the location specified in the 
origin_x, origin_y attributes. 

The system tries its best to place the model on the surface; however, if the model was not 
designed to take any type of change within a surface into account, the model may appear to 
hover above the surface in some locations. 

 

Notice that the front of the building is hovering above the surface, while the rear of the building is 
just below the surface.  In this case, the model was not designed to reflect the sloping surface.  
You can adjust for this offset using the origin_z attribute. 

You can adjust the value stored in the origin_z attribute accordingly to lower the building into the 
surface (that is, you can override the default value with a negative value that makes sense for the 
building in question) and ideally better position the model relative to the surface. 

 

A value of -5.00 was used to lower the entire model by 10 meters 

With this type of adjustment, the building will lower and the gap between the surface and the 
bottom of the building will be reduced.  Notice that the front of the building now lies on the 
surface, while the rear of the building lies below the surface. 
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Task 5: Stylizing Feature for 3D Model Display 

Features can be stylized in a number of ways to improve their appearance within a map window. 
In this case, we are going to stylize the footprints feature class to display the 3D model for each 
feature  

1. Double-click the  icon of the legend entry Sample_Building_Footprints to 
display the Legend Entry Properties dialog box. 

2. Click the Properties button to display the Style Properties dialog box. 

3. Click the 3D Settings tab to bring this tab to the forefront. 

4. Ensure that you place a check mark in the Boundary options check box. 

5. Ensure that the Replace with 3D object option is enabled. 

6. Use the Replace with 3D object drop-down list to specify the attribute 
GM3D_Model. 

 

7. Click OK to close the Styles Property dialog box. 

8. Click OK to close the Legend Entry Properties dialog box. 

9. Use the navigation controls to review the results. 

 

XPL2 files are optimized for rendering in GeoMedia 3D however, with the release of GeoMedia 
3D 2105, you can now improve rendering through the use of 3D Mesh Layer (3DML) files. 3DML 
files can be used in place of any 3D model layer in GeoMedia 3D. For example, they can be used 
in place of any feature class representing 3D symbols (such as fire hydrants) or 3D models (such 
as buildings).  

Given this, if you have a feature class containing a large collection of relatively static models (i.e. 
models where appearance is not driven through attribute-based symbology); you may want to 
consider creating a 3DML representations of these layers for performance reasons as 3DML files 
are highly optimized for display within the 3D map window. 
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Please note that once a 3DML file is created via Construct 3DML publishing process, it is 
disconnected from the underlying feature class. Hence changes within the source feature classes 
do not percolate through to the 3DML file. Given this, you will want to balance when 3DML files 
are used in place of actual model layers.   
 

Task 6: Exit GeoMedia Desktop 

You have completed this exercise. You can now exit GeoMedia Desktop and begin the next 
exercise. Given that you may want to revisit this exercise, it is recommended you do not save any 
of your changes.  By not saving your changes, you can restart the exercise in the future with a 
clean GeoWorkspace. 

1. Click the Close icon in the upper-right corner of the GeoMedia Desktop application 
window to exit GeoMedia Desktop.  The system displays a warning dialog box. 

2. Click No. 
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