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This Tutorial 

Tutorial Objective 
In this tutorial you will learn how to perform style edits using GeoMedia Map Publisher.  
 

Tutorial Data Set 
The sample data set used in the GeoMedia Map Publisher tutorial exercises represents a typical 
1:50,000 scale map sheet produced by the Danish National Mapping Agency, Kort & 
Matrikelstyrelsen (KMS) – Danish Ministry of the Environment, National Survey and Cadastre.  

It should be noted that the original data set provided by KMS represented a completed 
cartographic product prior to lithographic processing.  However, liberties have been taken within 
the data set in order to illustrate a typical starting point in the cartographic editing process.  The 
exercises provided in this tutorial do not necessarily represent standard workflows employed at 
KMS, nor do the exercises claim to represent the type of cartographic edits performed at KMS.  
The tutorial exercises simply illustrate standard cartographic editing procedures that mapping 
agencies and mapping companies would expect to be available using a cartographic editing 
software application such as GeoMedia Map Publisher.  

The cartographic results produced within this training tutorial reflect the results of standard 
cartographic processes and editing concepts.  The resulting data set should be viewed as a 
representative sample of the type of data modifications that typically occur during the 
cartographic production process, and in no way illustrate the "truth on the ground." 

Hexagon Geospatial would like to extend its appreciation to Kort & Matrikelstyrelsen (KMS) for 
their cooperation in this endeavor. 

 
Tutorial Text Conventions 
There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb group, click Ccc. 

 Dialog box names, field names, and button names are depicted using Bolded Text. 

 Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 

 
Tutorial Prerequisites 
Familiarity with the GeoMedia Desktop. 
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Performing Style Edits Section 1:  

Section Objective 
This section will introduce you to cartographic style editing in GeoMedia Map Publisher. You will 
learn about: 
 

 Viewing and navigation in the carto edit environment 

 Overriding styles 

 Replacing styles 

 Adjusting line styles 

 Flipping patterned lines 

 Moving area patterns 

 

Tools Used 
GeoMedia Professional and GeoMedia Map Publisher. 
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 Viewing and Navigation Exercise 1:

Objective: 
Learn how to view and navigate in the cartographic editing environment for this tutorial 

Task 1: Viewing and Navigation 

The following instructions are designed to set up the viewing and navigation environment for this 
tutorial.  As noted earlier, in this tutorial, Queued Edit is being used solely for the purpose of map 
window navigation.  Queued Edit is not required to use the Map Publisher interactive cartographic 
editing commands.  It is used, however, to portray the results of the Generalize command.  While 
Queued Edit may not be required during interactive cartographic editing, it does provide a 
powerful tool to assist in quality control and quality assurance workflows where map editors need 
to review the results of their cartographer's edits.    

 You can either continue working with the workspace from the previous tutorial or open the 
following workspace: C:\GeoMedia Desktop Training\Introduction to Mapping Manager\GeoMedia 
Map Publisher\Lessons\Lesson 2 Style Edits\Lesson 2 Style Edits.gws 
 

1. Select Home > Properties and Information > Map Display.  Set the Display Scale 
to 1:12,500, and click Apply.  Click Close.   

2. Select Home > Window > Properties.  Select Center at current scale.  Click OK.   

3. Select Analysis > Utilities > Queued Edit, which displays the Queued Edit 
dockable control.  On the Queued Edit dockable control, select the drop-down, 
expand the KMS 50K Carto node, and select the MappubTutorial feature class.   

 

The Queued Edit Map Window and Queued Edit data Window are displayed. 

4. On the Queued Edit dockable control, select the Options button. 

  

The Queuing Options dialog box is displayed.  
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5. Click the General tab.  Make sure the Show description box option is not checked, 
and that the Add item to select set option is not checked. 

 
 
When the Add item to select set option is checked, it automatically loads the current 
queue item into the select set as the user navigates through the queue. This behavior 
can impact the GeoMedia Map Publisher interactive commands when operated in 
Action-Object mode as the item in the queue may not be valid for performing 
cartographic edits. If the Add item to select set option is checked, the user should 
clear the select set before attempting to operate any of the GeoMedia Map Publisher 
interactive commands in Action-Object mode. 

6. Click the View tab.  In the All other map windows group, ensure that Honor setting 
from Map Window Properties during queue navigation is checked. 

 

7. Click the Locator tab.  In the Enable group, ensure that Locator box and Locator 
crosshairs are checked. 

8. In the Display group, ensure that the Queuing map window and All other map 
windows options are checked. 
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9. Set the color to magenta and the width to 2.000. 

 

10. Click OK.  

11. Minimize the Queued Edit Map Window and the Queued Edit Data Window. 

12. Click the Move First button on the Queued Edit dockable control. 

 

The result of these last ten steps establishes the starting point for the Style Edits in this tutorial. 
Queued Edit will be used to navigate the map window from one geographic location to the next, 
centering its crosshairs on the initial feature instance that is to be modified with its respective 
Style Edit command.  As each lesson is completed, the active command will be terminated, and 
the queue will be advanced to the next record in Queued Edit using the Move Next button on the 
Queued Edit dockable control  
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 Override Style Exercise 2:

Objective: 
Overridng style as part of the carto editing process. 

 If you are not satisfied with the result of any your style edits, simply delete the 
cartographic edit (Carto > Cartographic Edits > Remove), and try again. 

 You can also use the GeoMedia Professional Delete command (Home > Edit > Delete) 
to remove cartographic edits.  When cartographic edits are deleted, the feature instance 
automatically reverts back to its non-edited source. 

 

Task 1: Override Style 

 

Override Style changes the style properties of selected feature instances.  The feature instances 
that are selected must all belong to the same feature class and must all be displayed by the same 
legend entry.  Override Style operates on all geometry types except for image.  This lesson is 
record 1 of 14 in the Queued Edit dockable control. 

1. Click the Select Tool  and select the Skov (Woodlands) feature instance 
centered on the Queued Edit crosshairs. 

 

2. Select Carto > Modify Style > Override Style from the ribbon. 

 

The Override Style dialog box displays, portraying the active style properties for the 
feature instance selected. 
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The Override Style dialog box is the same as the GeoMedia Style Properties dialog 
box.  All of the properties on the dialog are candidates for the style override.  The 
contents of the dialog box will vary based on the geometry type (point, line, area, 
compound, text) selected, and active style type (Simple Fill Style, Pattern Fill Style, and 
so on). 

3. Select the Simple Fill Style component in the tree-view.  Click the Color button and 
change the fill color to brown. 

 

4. Click OK on the Color dialog box. 

The style of the selected feature instance has been modified.  The command is still 
active, operating in action-object mode.Select other Skov (Woodlands) feature instances 
to modify. 
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5. Press the ESC key, or click the Select Tool, or select Exit from the right-click menu 
to terminate the command. 

          

6. Click the Move Next button on the Queued Edit dockable control. 
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 Replace Style Exercise 3:

Objective: 
Replacing styles as part of the carto editing process. 

Task 1: Replace Style 

Replace Style replaces the style properties of selected feature instances.  The feature instances 
that are selected can belong to different feature classes and can have different delineation types 
(point, line, area, and so forth).  This lesson is record 2 of 14 in the Queued Edit dockable control. 

1. Click the Select Tool  and select the Skov (Woodlands) feature instance centered on 
the Queued Edit crosshairs. 

 

2. Select Carto > Modify Style > Replace Style from the ribbon. 

 

The Replace Style dialog box displays, portraying the active style properties for the 
feature identified in the Select feature from drop-down list. 

The Replace Style dialog box contains many of the same controls as the GeoMedia 
Legend Entry Properties dialog box.  The functional capabilities of the Replace Style 
command are similar to the Override Style command with the following exceptions: 

 Multi-select across different features independent of geometry type. 

 Multiple processing options available for style replacement:  replace styles for 
selected features, or replace styles for all features using the style in the select 
set. 

 Access existing Named Styles from available workspace styles, or from existing 
carto edited styles. 
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The contents of the dialog box will vary based on the geometry type (point, line, area, and 
so forth) selected, and active style type (Simple Fill Style, Pattern Fill Style, etc).  
Selecting the Properties button on the dialog invokes the Style Properties dialog box, 
where the following workflow is essentially identical to the Override Style workflow. 
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3. In the Named styles group, double click the Styles folder to display the available Named 
Styles available in the GeoWorkspace. 

4. Scroll to the bottom of the list of Named Styles and select Replace Skov. 

5. The Style group is updated to reflect the style properties of the selected style. 

6. Click OK. 

The style of the selected feature instance has been replaced, modified from a Simple Fill 
Style to a Pattern Fill Style. 

 
 
This illustrates the basic Replace Style workflow. 

7. Press the ESC key, or click the Select Tool, or select Exit from the right-click menu to 
terminate the command. 
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8. Select Home > Window > Properties.  Click the View at current scale radio button For 
items in select set.  Click OK. 

9. Click the Select Tool , and select the initial Skov (Woodlands) feature instance 
modified with the Override Style command.  With the feature instance highlighted, press 
the CTRL key and while it is pressed, select the Hoejsp (High Tension Line) feature 
instance. 

 

10. Select Carto > Modify Style > Replace Style from the ribbon. 

 

The Replace Style dialog box displays. 

11. Click the drop-down list for Select feature from. 

 
 

Notice that both features in the select set are listed.  Toggling between Skov and Hoejsp 
changes the contents of the Named styles group and Style group on the dialog to reflect 
the characteristics of each individual feature selected. 
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12. Select Skov in the Select feature from drop-down list. 

 
 

In the Named styles group, the Carto Styles folder contains the Carto Edited Styles sub-
folder, the Styles sub-folder, and Named Styles for the feature instances in the select set; 
in this case, Skov1. 

13. Double-click on the Carto Edited Styles folder in the Named styles group. 

 
 

The Carto Edited Styles folder lists all of the existing style definitions for the Skov legend 
entry:  the default/original style (Skov), the modified style produced with the Replace 
Style command (Replace Skov), and the modified style produced with the Override Style 
command (Skov1). 
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14. Click the All features using this style option. 

15. In the Style group, click on the Fill color button, change the color to pale magenta, and 
click OK. 

 

16. Click Apply. 

Notice that the Named Style Skov1 has been removed and replaced with a new Named Style 
of Skov2.  The same replacement has occurred in the Carto Edited Styles folder.  As style 
edits occur, Map Publisher is ‘cleaning house’ and removing unnecessary style references 
that are no longer being used.  This particular replacement occurred because All features 
using this style was selected during processing. 
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17. Select Hoejsp in the Select features from drop-down list. 

18. In the Named styles group, double click the Styles folder to display the Named Styles 
available in the GeoWorkspace.  

19. Scroll to the bottom of the list of Named Styles and select Replace Hoejsp. 

20. Click the Selected features option. 

21. Click OK. 

 
 

The style of the Skov (Woodlands) feature instances is replaced, modified from a brown fill to 
a magenta fill, and the style of Hoejsp (High Tension Line) is replaced, modifying the point 
symbol used in the linear pattern. 

This illustrates the advanced multi-select Replace Style workflow. 

22. Press the ESC key, or click the Select Tool, or select Exit from the right-click menu to 
terminate the command. 

          

23. Select Home > Window > Properties.  Click Center at current scale. Click OK. 

24. Click the Move Next button on the Queued Edit dockable control. 
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 Adjust Line Style Exercise 4:

Objective: 
Adjusting line styles as part of the carto editing process.  

Task 1: Replace Style 

Adjust Line Style modifies the display pattern of dash-gap sequences for dashed line styles.  
Types of modification include dash offset, dash length, gap length, or dash-gap length.  For 
additional information, see Adjust Line Style in the Help.  This lesson is record 3 of 14 in the 
Queued Edit dockable control. 

1. Click the Select Tool , and select the Sti (Path) feature instance centered on the 
Queued Edit crosshairs. 

 

2. Select Carto > Modify Style > Adjust Line Style from the ribbon. 

 

The Adjust Line Style dockable control is displayed. 

The following picture shows the control in an undocked state. 

 
 

The Adjust Line Style command provides multiple line style adjustment options 
including: 

 Dash Offset – modifies the starting point of the first dash definition in the dash-

gap sequence at the beginning of the line.  
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 Dash Length – modifies the dash length(s) only, retaining the existing gap 

length(s) definition for the dash-gap sequence of the selected feature. 

 Gap Length – modifies the gap length(s) only, retaining the existing dash 

length(s) definition for the dash-gap sequence of the selected feature.  

 Dash-Gap Length – modifies the dash length(s) and the gap length(s) definition 

for the dash-gap sequence of the selected feature. 

The command provides a dynamic view of the adjustment by moving the slider bar.  The 
text boxes on either side of the slider bar define the minimum compression limit of 50% 
and the maximum stretch limit of 200% when adjusting the dash and/or gap length.  In 
the case of Dash Offset adjustments, the minimum/maximum values are preset and 
cannot be modified.  The minimum is defined by the negative dimension of the style's 
entire dash-gap sequence, and the maximum is defined by the positive dimension of the 
style's entire dash-gap sequence.  
 

 GeoMedia style rendering of dashed lines always begins with the first dash definition 
in the sequence.   To begin the dashed line with a gap, select the Dash Offset option 
and simply move the slider in the negative direction. 
All options except Dash Offset provide the option to Adjust dash offset automatically.  
When this option is selected, the Dash Offset distance is automatically set to be 
equivalent to 50% of the length of the first dash in the dash-gap sequence.  The basic 
workflow for the Adjust Line Style command involves invoking the command, selecting 
the adjustment option, and using the slider bar to adjust the selected feature instance.  
When the desired representation is achieved, click in the map window to complete the 
adjustment. 

3. Select Dash-Gap Length as the style property to be adjusted.  

4. Ensure that Adjust dash offset automatically is checked. 

5. Move the slider left or right to achieve the desired cartographic intersection. 

6. Click in the map window.  
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The style of the Sti (Path) feature instance has been modified adjusting the dash-gap 
sequence of the selected feature. 

7. Press the ESC key, or click the Select Tool, or select Exit from the right-click menu to 
terminate the command. 

          

8. Click the Move Next button on the Queued Edit dockable control 
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 Flip Patterned Line  Exercise 5:

Objective: 
Flipping patterned lines as part of the carto editing process. 

Task 1: Flip Patterned Line 

Flip Patterned Line modifies the symbol orientation by rotating the point symbol style of the 
Pattern Line Style by 180 degrees.  This includes linear style and area boundary style definitions, 
and supports Symbol Styles, Font Styles, and Picture Styles.  For additional information, see Flip 
Patterned Line in the Help.  This lesson is record 4 of 14 in the Queued Edit dockable control. 

1. Select Home > Window > Properties.  Click the View at current scale radio button For 
items in select set.  Click OK. 

2. Click the Select Tool , and select the Hoejsp (High Tension Line) feature instance 
centered on the Queued Edit crosshairs.  This is the same feature instance that was 
modified earlier with the Replace Style command. 

 
 

When defining the position and offsets of point symbols along a Pattern Line Style 
definition, the placement is dictated by the direction of the line.  The position of the 
symbols along the line is completely independent of the location of the line itself.  In the 
example above, it is obvious that the transmission tower symbols along the line are 
upside-down.   
 
This is occurring because of the direction that the Hoejsp (High Tension Line) feature 
was digitized.  This can be easily rectified using the GeoMedia Professional command 
Vector > Geometry > Edit > Reverse Direction.  This approach may be suitable for 
some features such as depression contours where direction is not an issue, but may be 
prohibitive with other features where the direction of the line must be maintained.  In 
addition, there is the issue of read-only source warehouse connections where the 
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Reverse Direction command is not an option.   
 
Flip Patterned Line addresses these issues. 
 

3. Select Carto > Modify Style > Flip Pattern from the ribbon. 

 

The orientation of the transmission towers in the Hoejsp (High Tension Line) feature 
instance has been flipped, rotating the symbols to the appropriate orientation. 

4. Press the ESC key, or click the Select Tool, or select Exit from the right-click menu to 
terminate the command. 

          

5. Select Home > Window > Properties.  Click Center at current scale. Click OK. 

6. Click the Move Next button on the Queued Edit dockable control. 
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 Move Area Pattern Exercise 6:

Objective: 
Moving area patterns as part of the carto editing process. 

  

Task 1: Move Area Pattern 

Move Area Pattern enables you to adjust the position of area patterns in both the x and y 
direction within individual polygons.  Symbol Style, Font Style, and Picture Style types used in the 
Pattern Fill Style definition are all supported.  For additional information, see Move Area Pattern 
in the Help.  This lesson is record 5 of 14 in the Queued Edit dockable control. 

1. Click the Select Tool , and select the Skov (Woodlands) feature instance centered 
on the Queued Edit crosshairs.  This is the same feature instance that was modified 
earlier with the Replace Style command. 

 

2. Select Carto > Modify Style > Move Pattern from the ribbon. 

 
When area patterns are rendered, their origin is fixed, referencing an arbitrary origin that 
is relevant to the map window.  In many cases, it may be desirable to adjust the position 
of the pattern fill within the context of an individual polygon.  This is the spirit of the Move 
Area Pattern command:  enabling the individual adjustment of pattern fills within each 
area polygon.  The command provides a dynamic view of the adjustment.  The basic 
workflow involves selecting the pattern fill, adjusting the position, and then clicking in the 
map window to accept the edit. 

3. Click to identify the origin point. 
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4. Drag the cursor to identify the new pattern location, and click in the map window to define 
the final location. 

 

The area pattern has been adjusted. 

5. Press the ESC key or click the Select Tool  to terminate the command. 

6. Click the Move Next button on the Queued Edit dockable control. 

 

7. Select File > Save to save the GeoWorkspace. 

 
 

 

 
 


