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This Tutorial 

Tutorial Objective 
This training tutorial is designed to illustrate the functionality and capabilities provided by 
GeoMedia® Map Publisher.  
 

 

Tutorial Data Set 
The sample data set used in the GeoMedia Map Publisher tutorial exercises represents a typical 
1:50,000 scale map sheet produced by the Danish National Mapping Agency, Kort & 
Matrikelstyrelsen (KMS) – Danish Ministry of the Environment, National Survey and Cadastre.  

It should be noted that the original data set provided by KMS represented a completed 
cartographic product prior to lithographic processing.  However, liberties have been taken within 
the data set in order to illustrate a typical starting point in the cartographic editing process.  The 
exercises provided in this tutorial do not necessarily represent standard workflows employed at 
KMS, nor do the exercises claim to represent the type of cartographic edits performed at KMS.  
The tutorial exercises simply illustrate standard cartographic editing procedures that mapping 
agencies and mapping companies would expect to be available using a cartographic editing 
software application such as GeoMedia Map Publisher.  

The cartographic results produced within this training tutorial reflect the results of standard 
cartographic processes and editing concepts.  The resulting data set should be viewed as a 
representative sample of the type of data modifications that typically occur during the 
cartographic production process, and in no way illustrate the "truth on the ground." 

Hexagon Geospatial would like to extend its appreciation to Kort & Matrikelstyrelsen (KMS) for 
their cooperation in this endeavor. 

 
Tutorial Text Conventions 
There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb group, click Ccc. 

 Dialog box names, field names, and button names are depicted using Bolded Text. 

 Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 

 
Tutorial Prerequisites 
Familiarity with the GeoMedia Desktop. 
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Performing Geometry Section 1:  
Edits 

Section Objective 
This section will introduce you to cartographic geometry editing in GeoMedia Map Publisher. You 
will learn about: 
 

 Creating cartographic features 

 Aggregating areas 

 Extending boundaries 

 Displacing feature segments 

 

Tools Used 
GeoMedia Professional and GeoMedia Map Publisher. 
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 Create Cartographic Feature  Exercise 1:

Objective: 
Creating cartpographic features as part of the carto editing process. 
 

 If you are not satisfied with the result of any your geometry edits, simply delete the 
cartographic edit (Carto > Cartographic Edits > Remove), and try again. 

 You can also use the GeoMedia Professional Delete command (Home > Edit > Delete) 
to remove cartographic edits.  When cartographic edits are deleted, the feature instance 
automatically reverts back to its non-edited source. 

 In the event that you stopped working through the tutorial after the Performing Style Edits 
section, and exited GeoMedia, you will likely need to re-invoke Queued Edit.  Follow the Queued 
Edit instructions in the beginning of the Performing Style Edits tutorial.  

Task 1: Create Cartographic Feature 

Create Cartographic Feature creates a cartographic feature instance for each of the selected 
source feature instances (point, line, area, compound, and text) and stores it in the Cartographic 
Edits database.  The new cartographic features can be edited using GeoMedia editing tools. This 
lesson is record 6 of 14 in the Queued Edit dockable control. 

 You can either continue working with the workspace from the previous tutorial or open the 
following workspace: C:\GeoMedia Desktop Training\Introduction to Mapping Manager\GeoMedia 
Map Publisher\Lessons\Lesson 3 Geometry Edits\Lesson 3 Geometry Edits.gws 

1. Click the Select Tool , and select the Vindmll (Windmill) feature instance centered on 
the Queued Edit crosshairs. 
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2. Select Carto > Modify Geometry > Create Feature from the ribbon. 

 

A cartographic feature has been written to the cartographic edits database for the selected 
feature.  The command is still active, operating in action-object mode. 

3. Click on the surrounding three Vindmll (Windmill) features to create cartographic features. 

4. Press the ESC key, or click the Select Tool, or select Exit from the right-click menu to 
terminate the command. 

          
 
The features can now be edited using standard GeoMedia Edit commands. 

5. Select Vector > Geometry > Move from the menu bar. 

6. Move each of the four Vindmll (Windmill) features upward so the bottom of the Vindmll 
symbol does not overprint the road.  

 
 
New cartographic features have been created and moved to the appropriate location.  The 
Create Cartographic Feature command is only necessary if you want to perform 
cartographic edits using the GeoMedia Edit commands when a cartographic feature does not 
exist.  All of the GeoMedia Map Publisher commands automatically create the cartographic 
features to reflect the cartographic edits made.  If GeoMedia Edit commands are used 
without first creating a cartographic feature, the edit will be performed on the source feature 
instance instead of the cartographic feature instance.  This is the reason why the 
cartographic source warehouse connection in this tutorial is read-only – to prevent 
inadvertent modifications to the source data. 

7. Press ESC or click the Select Tool to terminate the command. 

 

8. Click the Move Next button on the Queued Edit dockable control. 
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 Aggregate Areas  Exercise 2:

Objective: 
Aggregating areas as part of the carto editing process 

Task 1: Aggregate Areas 

Aggregate Areas provides the ability to interactively select multiple input area features and 
combine them collectively into a single output area feature. The features selected for area 
aggregation, both for input and for output, can all belong to the same feature class; or the 
selected input features can span across multiple feature classes and be aggregated into an 
entirely different output feature class.  

 This lesson is record 7 of 14 in the Queued Edit dockable control. 

The basic workflow for the Aggregate Areas command involves invoking the command, 
identifying the area features to be considered for the aggregation, defining and/or modifying the 
aggregation options, and previewing/accepting the aggregated results. The Aggregate Areas 
command operates in two distinct phases; a feature selection phase where operators can add 
and/or remove area features to be considered for the aggregation, and a preview/acceptance 
phase where operators can visualize a dynamic preview of the aggregated results as they modify 
the aggregation options and accept or reject the aggregated results. Moving between these two 
phases is accomplished through the use of the right-click context menu, where the menu items 
available vary based on the current state of the command. 

 Feature Selection phase (Adding features to the Select Set) – Single features 
can be added to the Select Set by hovering the cursor over the desired area 
feature so it highlights and then performing any one of the following:  
 

 Click the left mouse button. 

 Press the ENTER key.  

 Click the right mouse button to invoke the context menu and select Accept highlighted 
feature. 

 Feature Selection phase (Removing features from the Select Set) – Single 
features can be removed from the Select Set by hovering the cursor over a 
previously selected area feature so it highlights and then performing any one 
of the following:  
 

 Click the left mouse button. 

 Press the ENTER key.  

 Click the right mouse button to invoke the context menu and select Remove selected feature. 

 Feature Selection phase (Clearing features from the Select Set) – All features 
in the Select Set can be removed by doing either of the following:  
 

 Press the C key.  
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 Click the right mouse button to invoke the context menu and select Cancel aggregate areas. 

 Switching between the Selection phase and the Preview/Acceptance phase – 
The Aggregate Areas command requires the selection of a minimum of two 
area features for processing. As long as there are at least two area features 
in the Select Set during the feature selection phase, the operator can switch 
over into the preview/acceptance phase by doing either of the following: 
 

 Press the P key. 

 Click the right mouse button to invoke the context menu and select Preview aggregation. 

 Preview/Acceptance phase (Accepting the aggregated results) – Once in the 
preview/acceptance phase, the operator can accept the results of the 
aggregation by doing either of the following: 
 

 Press the ENTER key. 

 Click the right mouse button to invoke the context menu and select Accept aggregated 
results. The result of this action writes the aggregated results to the Cartographic Edits 

database. The command remains active and switches the state of the command to the initial 
selection phase, where operators can identify a new set of area features to aggregate. 

 Preview/Acceptance phase (Rejecting the aggregated results and maintaining 
the contents of the Select Set) – Once in the preview/acceptance phase, the 
operator can reject the results of the aggregation by doing either of the 
following: 
 

 Press the R key. 

 Click the right mouse button to invoke the context menu and select Reject aggregated 
results. The result of this action not only rejects the aggregated results, but also switches the 

state of the command back to the selection phase, where operators can add and/or remove 
area features to be considered for the aggregation. The current area features present in the 
Select Set are maintained for further processing. 

 Preview/Acceptance phase (Rejecting the aggregated results and clearing  
the contents of the Select Set) – Once in the preview/acceptance phase, the 
operator can reject the results of the aggregation by doing either of the 
following: 
 

 Press the C key. 

 Click the right mouse button to invoke the context menu and select Cancel aggregated 
results. The result of this action not only rejects the aggregated results, but also switches the 

state of the command back to the initial selection phase, where all previously selected area 
features are removed from the Select Set.  

 The Aggregate Areas command requires the selection of multiple input area features, 
and operates in object-action mode as well as action-object mode. The multi-select behavior 
in object-action mode varies from the multi-select behavior in action-object mode for this 
command.  In object-action mode, the multi-select behavior is consistent with GeoMedia 
Professional operations where the multiple selections are accomplished by pressing the 
CRTL key as additional features are selected. However in object-action mode, the use of the 
CTRL key is not required for multiple feature selections. As with most GeoMedia editing 
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commands, it is critical to be able to visualize the difference between selected features and 
highlighted features, as illustrated below. 

 

 

1. Select Home > Window > Properties.  Click the View at current scale radio button For 
items in select set.  Click OK. 

2. In the map window legend, scroll down to the Bygning (Buildings) legend entry and 
ensure that its ‘Locatable’ status is turned off. Right-click the Bygning (Buildings) 
legend entry, and select Locatable Off.  

3. In the map window legend, scroll down to Bykerne (Town Center) legend entry. Ensure 
that the ‘Locatable’ status of Bykerne (Town Center), Hoj_bebyg (Tall Buildings), and 
Lav_bebyg (Built-up Area) is turned on. This lesson will aggregate instances from all 
three of these features into the Lav_bebyg (Built-up Area) feature class.  
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4. Click the Select Tool , and select the Bykerne (Town Center) feature instance 
centered on the Queued Edit crosshairs. 

 
 

5. Select Carto > Modify Geometry > Aggregate from the ribbon. 

 
 
The Aggregate Areas dockable control is displayed. 
The following picture shows the control in an undocked state. 
 

 
 
The Aggregate Areas command provides an assortment of options for defining the 
output aggregated feature including: 

 Output feature class – defines the desired output feature class.  

 Z-calculation – specifies how the z value will be determined for each vertex of the output 

aggregated feature. Options include Highest, Lowest, Average, and Original.  

 Distance tolerance – defines the minimum distance between boundaries of area features to 

be considered for the area aggregation. Value is defined in paper units.   

 Eliminate holes smaller than – as holes are produced as a result of the aggregation, this 

option defines the minimum size of holes to retain in the output aggregated feature. A value of 
zero indicates that no holes will be eliminated. Value is defined in paper units.   

 Aggregate orthogonally – specifies that the aggregation will be calculated orthogonally. 

 Boundary smoothing – specifies that the resulting aggregation will minimize the presence 

of jagged edges on the aggregated boundary.  
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This command provides a dynamic preview of the resulting area aggregation. Once 
all of the input area features have been selected for the aggregation, the operator 
can preview the results and modify any of the options on the dockable control prior to 
accepting the aggregated results.  

6. Select the surrounding Hoj_bebyg (Tall Buildings) feature instances – dark gray 
polygons and the surrounding Lav_bebyg (Built-up Area) feature instances – light gray 
polygons. 

 
 

7. On the Aggregate Areas dockable control, define the following: 

 Output feature class – Lav_bebyg (KM 50K Source connection).  

 Z-calculation – Original.  

 Distance tolerance – 0.5 mm.  

 Eliminate holes smaller than – 0.00 mm^2.  

 Aggregate orthogonally – checked.  

 Boundary smoothing – checked.  
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8. Right click to display the right-click menu and select Preview aggregation. 

 
 

9. Modify the aggregation options on the Aggregate Areas dockable control to dynamically 
preview the results of the aggregation. Set the Distance tolerance to 5.0 mm. 
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10. Modify the aggregation options on the Aggregate Areas dockable control to dynamically 
preview the results of the aggregation. Set the Distance tolerance back to 0.5 mm and 
set the Eliminate holes smaller than equal to 2.0 mm^2. 

 
 

11. Right click to display the right-click menu and select Accept aggregated results.  

 Due to the fact that the Aggregate Areas command is creating new feature 
geometries (as opposed to modifying existing feature geometries), the subsequent 
behavior of this command will vary based on the existing GeoMedia GeoWorkspace 
Options defined. When viewing the Placement and Editing tab in GeoMedia 
Professional’s Tools > Options command, there is an option to Display Properties 
dialog for new features. If this option is checked when using the Aggregate Areas 
command, upon accepting the results of the area aggregation, the Properties dialog will 
be displayed to enable the operator to define the available attributes. 

12. Press the ESC key or click the Select Tool to terminate the command. 

 
 This lesson illustrates basic area aggregation capabilities that focus primarily on 

the feature geometry. In some scenarios, additional settings are required to specify how 
the attribute values of the output aggregated feature are calculated based on the input 
attribute values of the selected area features.  

13. Select Home > Window > Properties.  Click Center at current scale. Click OK. 

14. Click the Move Next button on the Queued Edit dockable control. 
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 Extend Boundary Exercise 3:

Objective: 
Extending boundaries as part of the carto editing process. 

Task 1: Extend Boundary  

Extend Boundary provides the ability to interactively extend the boundary of selected area and 
linear features so that their boundary is shared with other selected area and linear features.  The 
boundaries can be extended to a calculated centerline or made to share the same boundary of 
the adjacent feature.  

 This lesson is record 8 of 14 in the Queued Edit dockable control.  

The basic workflow for the Extend Boundary command involves invoking the command, 
identifying the features to be considered to extend (referred to as the FROM features), identifying 
the features to be extended to (referred to as the TO features), defining and/or modifying the 
extend options, and previewing/accepting the extended results. The Extend Boundary command 
operates in two distinct phases:  a feature selection phase where operators can select the FROM 
features and the TO features to be considered for the boundary extend, and a 
preview/acceptance phase where operators can visualize a dynamic preview of the extended 
results.  Moving between these two phases is accomplished through the use of the right-click 
menu, where the menu items available vary based on the current state of the command.  

 Feature Selection phase (Adding FROM features to the Select Set) – Single FROM 
features can be added to the Select Set by hovering over the desired feature so it 
highlights and then performing any one of the following: 
 

 Click the left mouse button.  

 Press the ENTER key.  

 Right click to display the right-click menu, and select Accept highlighted FROM feature. 

 Feature Selection phase (Removing FROM features from the Select Set) – Single 
FROM features can be removed from the Select Set by hovering the cursor over a 
previously selected FROM feature so it highlights and then performing any one of 
the following: 
 

 Click the left mouse button.  

 Press the ENTER key.  

 Right click to display the right-click menu, and select Remove selected feature. 

 Feature Selection phase (Clearing FROM features from the Select Set) – All FROM 
features in the Select Set can be removed by doing the following: 
 

 Press the C key.  

 Right click to display the right-click menu, and select Clear extend FROM features. 
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 Feature Selection phase (Adding TO features to the Select Set) – Single TO features 
can be added to the Select Set by hovering over the desired feature so it highlights 
and then performing any one of the following: 
 

 Hold down the CTRL key and click the left mouse button.  

 Hold down the CTRL key and press the ENTER key.  

 Right click to display the right-click menu, and select Accept highlighted TO feature. 

 Feature Selection phase (Removing TO features from the Select Set) – Single TO 
features can be removed from the Select Set by hovering the cursor over a 
previously selected TO feature so it highlights and then performing any one of the 
following: 
 

 Hold down the CTRL key and click the left mouse button.  

 Hold down the CTRL key and press the ENTER key. 

 Right click to display the right-click menu, and select Remove selected feature. 

 Feature Selection phase (Clearing TO features from the Select Set) – All TO features 
in the Select Set can be removed by doing either of the following: 
 

 Hold down the CTRL key and press the C key.  

 Right click to display the right-click menu, and select Clear extend TO features.  

 Switching between the Selection phase and the Preview/Acceptance phase – The 
Extend Boundary command requires the selection of at least one FROM feature and 
at least one TO feature. As long as there is one FROM feature and one TO feature in 
the Select Set during the selection phase, the operator can switch over into the 
preview/acceptance phase by doing either of the following: 
 

 Press the P key.  

 Right click to display the right-click menu, and select Preview results. 

 Preview/Acceptance phase (Accepting the extended results) – Once in the 
preview/acceptance phase, the operator can accept the results of the extended 
boundary by doing either of the following: 
 

 Press the ENTER key.  

 Right click to display the right-click menu, and select Accept results. The result of this action 

writes the extended results to the Cartographic Edits database. The command remains active 
and switches the state of the command to the initial selection phase, where operators can 
identify new FROM features and TO features to extend. 

 Preview/Acceptance phase (Rejecting the extended results) – Once in the 
preview/acceptance phase, the operator can reject the results of the extended 
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boundary by doing either of the following: 
 

 Press the R key.  

 Right click to display the right-click menu, and select Reject results. The result of this action 

not only rejects the extended results, but also switches the state of the command back to the 
selection phase, where operators can add and/or remove FROM features and TO features to 
the Select Set. The current contents of the Select Set (FROM features and TO features) are 
maintained. 

 The Extend Boundary command is unique among other cartographic editing commands 
because of the content and display of features in the Select Set – FROM features and TO 
features. When selected features are displayed in the map window, a visual distinction is 
necessary to aid operators in determining which selected features are FROM features, and which 
selected features are TO features. This is accomplished using the colors defined on the Map 
Display tab in GeoMedia Professional’s File > Options command. FROM features in the Select 
Set are portrayed using the specified Select color, whereas TO features in the Select Set are 
portrayed using the specified Handles color, as illustrated below. 

 

. 

1. Select Home > Window > Properties.  Click the View at current scale radio button For 
items in select set.  Click OK.  

2. In the map window legend, scroll up to Vej3_6 (Road, Hard Surface 3-6m wide) legend 
entry.  Ensure that the ‘Locatable’ status of Vej3_6 (Road, Hard Surface 3-6m wide), 
and Vej_and (Other Road) is turned on. This lesson will extend the boundaries of Skov 
(Woodlands) feature instances to the Vej3_6 (Road, Hard Surface 3-6m wide), and the 
Vej_and (Other Road) feature classes. 
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3. Click the Select Tool , and select the Skov (Woodlands) feature instance centered 
on the Queued Edit crosshairs. 

 

4. Select Carto > Modify Geometry > Extend from the ribbon. 

 
 
The Extend Boundary dockable control is displayed. 
The following picture shows the control in an undocked state. 
 

 
 
The Extend Boundary command provides an assortment of options for defining the 
output extended features including: 

 Distance tolerance – defines the minimum distance between features to be considered 

for the extended boundary. Value is defined in paper units. 

 Extend to meet at centerline – specifies that the extended boundaries will be applied 

to both the FROM features and the TO features to a calculated centerline. When this 
option is unchecked, the extended boundaries will only occur on the FROM features 
extending them to the TO features.  

 Eliminate gaps smaller than – as gaps are produced as a result of extending 

boundaries, this option defines the minimum size of gaps to retain in the output extended 
feature. A value of zero indicates that no gaps will be eliminated. Value is defined in paper 
units. 

 Extend orthogonally – specifies that the extended boundary will be calculated 

orthogonally. 

This command provides a dynamic preview of the resulting extended boundaries. Once 
all of the FROM features and TO features have been selected for processing, the 
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operator can preview the results and modify any of the options on the dockable control 
prior to accepting the extended results. 

5. Select the surrounding Skov (Woodlands) feature instances; defining them as FROM 
features, by hovering over them and clicking the left mouse button. 

 
 

6. Select the surrounding Vej3_6 (Road, Hard Surface 3-6m wide) and Vej_and (Other 
Road) feature instances; defining them as TO features by hovering over them, holding 
down the CTRL key and clicking the left mouse button. 

 
 

7. On the Extend Boundary dockable control, define the following: 

 Distance tolerance – 0.1 mm.   
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 Extend to meet at centerline – unchecked.  

 Eliminate gaps smaller than – 0.00 mm^2.  

 Extend orthogonally – checked. 

8. Right click to display the right-click menu, and select Preview results. 

 
 

9. Modify the extended options on the Extend Boundary dockable control to dynamically 
preview the results of the extended results. Set the Distance tolerance to 1.0 mm. 

 
 

10. Right click to display the right-click menu, and select Accept results. 
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11. Press the ESC key or click the Select Tool to terminate the command. 

 

12. Select Window > Map Window Properties.  Click Center at current scale. Click OK. 

13. Click the Move Next button on the Queued Edit dockable control. 
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 Displace Feature Segment Exercise 4:

Objective: 
Displacing feature segments as part of the carto editing process. 

Task 1: Displace Feature Segment  

Displace Feature Segment modifies the position of a linear feature or area boundary by 
displacing the segment between user-defined start and end points.  For additional information, 
see Displace Feature Segment in the Help.  This lesson is record 9 of 14 in the Queued Edit 
dockable control. 

1. Click the Select Tool , and select the Vandloeb (Stream) feature instance centered 
on the Queued Edit crosshairs. 

 
 

2. Select Carto > Modify Geometry > Displace from the ribbon. 

 
 
The results achieved using the Displace Feature Segment command can vary widely 
based on several factors, including the current tapering distance (see the Help) and the 
location of the selected start and end points relative to the location of vertices in the 
feature segment. 
The result shown in Step 5 below was achieved by selecting the following start and end 
points: 
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The vertices of the segment have been highlighted above to illustrate their location 
relative to the selected start and end points. 

3. Click to define the start point.  To change the start point, right click and select Redefine 
Point, or press the BACKSPACE key.  

4. Click to define the end point.  To change the end point, right click and select Redefine 
Point, or press the BACKSPACE key. 

5. Drag the segment to the new location and click to place it. 

 
 

The line segment has been displaced. 

 As noted earlier, the results obtained using the Displace Feature Segment 
command can be influenced by the selected start and end points relative to the location 
of the existing vertices of the selected feature segment. In some cases, there are not 
enough vertices present in the selected segment to provide a suitable cartographic result 
when the displacement is initiated. This can be overcome by adding additional vertices to 
the feature segment, using the following workflow: 

a. Select the feature instance to be processed by the Displace Feature Segment 
command. 

b. Select Carto > Modify Geometry > Create Feature. 
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c. Select Vector > Attributes > Update > Update Attributes, and select the feature 
class from the relevant connection listed in the GMMapPublisher Category. 

d. Update the Geometry attribute of the selected feature using the Densify expression.  
Additional vertices will be added to the feature segment based on the ‘Densify’ 
parameters defined in the expression. For example, the original feature processed 
above contained six vertices. After updating the geometry using the following Densify 
expression DENSIFY(Input.Geometry,100), the number of vertices increased from 
six to sixteen 

6. Press ESC or click the Select Tool to terminate the command. 

 

7. Click Move Next on the Queued Edit dockable control. 

 

8. Select File > Save to save the GeoWorkspace. 

 

 

 

 

 

 


