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This Tutorial 
Tutorial Objective 
This tutorial is designed to provide an introduction to GeoMedia Desktop and explores some of 
the basics concepts, processes, and commands used in geospatial workflows. The tutorial will 
review how data is presented in the GeoWorkspace; graphic and tabular. It examines standard 
workflows for accessing and displaying data, which include connecting to Warehouses, reviewing 
Map Display properties, and Style properties of individual map features. There are exercises that 
introduce the user to adding and editing features, as well as creating labels. In addition there is 
an example analytical exercise that demonstrates the generation of Buffer Zones.  

 
Tutorial Data Set 
The first two exercises reference the United States sample dataset delivered with GeoMedia 
Desktop. The remaining exercises reference local and regional datasets from the southeast 
United States. Beginning with Exercise 3, students are instructed to save the GeoWorkspace with 
a name that references the completed exercise, such as GM_Study3.gws. This enables uses to 
complete individual exercise and proceed at their own pace as time permits.  

 
Tutorial Text Conventions 
There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb group, click Ccc. 

 Dialog names, field names, and button names are depicted using Bolded Text. 
 Information to be entered, either by selecting from a list or by typing, is depicted using 

Italicized Text. 

 
Tutorial Prerequisites 
None. The datasets used in this tutorial access native data formats via GeoMedia Data Servers. 
This tutorial can be run on all tiers.  
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Introduction to GeoMedia 
Desktop 

Section Objective 
 

This tutorial is designed to provide an introduction to GeoMedia Desktop and explores some of 
the basics concepts, processes, and commands used in geospatial workflows. 

 
Tools Used 
 

GeoWorkspace The central document where data is viewed and edited. It can 
contain multiple connections to different data sources, and 
multiple ways of viewing the data. 
 

Warehouse A data storage source (e.g., Oracle, Access, WMS, CAD, 
Text File, etc.). All warehouses except Access, File 
Geodatabase, SQL Server, Oracle, and WFS are read-only. 
 

Map Window Provides a graphic portrayal of the data for viewing and editing your 
geographic features. 
 

Data View Allows the viewing and editing of non-graphic attributes (e.g., 
area, length, azimuth, name, address, etc.) of data in a 
warehouse. 
 

Legend Controls which features are currently displayed in the Map 
Window. Also indicates locatable features and style keys for 
displayed features. 
 

PickQuick Allows a specific feature to be selected when multiple 
features are within the tolerance of the cursor locate zone. 
 

Tooltip Displays attribute information about the features in the Map 
Window when the cursor hovers over the feature. 
 

Buffer Zone A user-defined region around or within features. 
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 Viewing Data in the GeoWorkspace 
Objective: 
Examine how to open an existing GeoWorkspace and use assorted GeoMedia commands for 
map navigation, selecting features, and reviewing attributes of selected features.  

Task 1: Opening an Existing GeoWorkspace 

1. Invoke GeoMedia. On the GeoMedia <product tier> dialog, select the Open an 
existing GeoWorkspace option. Select More Files... and click OK. 

 

The Open GeoWorkspace dialog displays all of the .gws files in the default 
GeoWorkspace folder, C:\GeoWorkspaces.  

2. Select USSampleData.gws from the list of GeoWorkspaces and click Open. 
3. On the Home tab, select Legends > Legends.  

4. On the Legends dialog, highlight Scalable Map (1:20,000,000) and click Replace. 
Click Close to dismiss the Legends dialog.  

A GeoWorkspace opens with a legend set to display the continental United States and 
corresponding feature classes. 
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1) Application Tab Access to New, Open, Save, Send, Snapshot, Page 
Setup, Print, Publish, Customize, Options, Help, Exit. 

2) Quick Access Toolbar One-click access to commonly used functions. 
Customizable. 

3) Ribbon Access to GeoMedia functions, collected in tabs and 
groups 

4) Title bar Window Title, Minimize, Maximize, Close     
 5) Window Main Viewing space. Can add multiple windows. Map 
Window, Data Window, Layout Window. 

6) Legend Pane Display and arrange feature classes for each Map 
Window displayed and is not available for Data Windows 
or the Layout Window.   

 

5. Right click in the map window and select Fit All to optimize the data display in the 
map window. 

 

 You can also select Fit to Frame button   in the Extent group on  
the Home tab, or from the Quick Access Toolbar. 

6. A scale bar and north arrow automatically display in the map window. Move them by 
clicking and dragging them to a preferred location in the map window. 

7. On the Toolbox tab, click North Arrow and Scale Bar to remove them from the map 
window. You can add them to the window by activating these buttons at any time. 

 

1 2 
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8. On the Home tab, select Zoom in . Click and drag a rectangle around the state of 
Georgia. The View zooms to the extent of the rectangle fence you created. 

9. Click on the city of Atlanta to magnify the zoom by a power of 2x. 

 

The view zooms in and re-centers on Atlanta. 
 

10. Zoom in a few more times and notice how some features are turned on and off 
based on the display scale. 

11. Look at the Legend and notice the different icons next to the Features. 

 

 
Indicates that the Feature is visible at all display scales. 

 Indicates that the Features is only visible at specific scales.  

Feature labels which are greyed out indicate features which are not 
displayed at the current scale. 

 

12. On the Home tab, select Pan   and click and drag to pan around the dataset. 

13. On the Home tab, select Fit All  to reset the view to include all of the data. 

14. Change to Selection mode by selecting the Select Tool  on the Home tab or 
on the Quick Access Toolbar. 

 
Right clicking in the map window will activate the Select   
command and cancels all active commands. 
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15. Hover the cursor over Colorado. Note that the feature turns cyan. Using the mouse 
wheel, scroll up one small increment. The view zooms in and is centered on 
Colorado. 

16. On the Home tab, select Fit All    to reset the map window to include all of the 
data. 
 

Task 2: Quick Access Toolbar 

Students will customize the Quick Access Toolbar.  

1. Hover over the Quick Access Toolbar and from the right-mouse context menu, 
select Customize Quick Access Toolbar. 

 

 

2. From the Choose Commands From: list, select Home. 

The options in this list represent the Tabs on the GeoMedia Ribbon. Within each 
category you will find individual commands to be added to the Quick Access toolbar. 

3. From the Commands list, highlight Add Legend Entries. 

4. Click the Add>> button to add this item to the Quick Access toolbar. 

5. Repeat these steps to add Styles to the Quick Access toolbar. 

6. Click OK to close the dialog and save the changes to the Quick Access Toolbar. 

You can also add commands to the Quick Access toolbar directly from the Ribbon. 

7. On the Home tab, click the drop down arrow next to Add/Show Windows. 

8. Hover over New Data Window and from the right-mouse context menu, select Add 
to Quick Access Toolbar. The tool is added. 

Next we will remove and rearrange the tools we have added to the Quick Access 
Toolbar. 
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9. Again, hover over the Quick Access Toolbar and from the right-mouse context 
menu, select Customize Quick Access Toolbar. 

10. From the command list on the right, highlight Redo and click Remove. 

11. Select New Data Window from the list. Use the Up Arrow to move this command 
under Save GeoWorkspace. 

12. Click OK to close the Customize dialog and update your changes. 

 

Task 3: Selecting Features 

Feature geometries can be selected directly in the map window. In this task you will experiment 
with several different methods of selecting features within the GeoMedia map window. Once a 
geometry has been selected, it becomes part of the ‘select set’, which can be used as inputs to 
assorted commands. 

1. With the Select Tool  active, hover over a part of Colorado that does not have 
rivers or interstates. The geometry turns cyan to indicate that it is highlighted and if 
clicked, the geometry that will be selected. 

2. Click on the Colorado state graphic (geometry) in the map window. It changes to 
Green, indicating it has been added to the select set. 

 

 
Default colors for Highlight and Select may be changed using the Map 
Display tab on the Options dialog, which can be accessed by selecting 

Options from the Application tab . 

 
 

3. Press and hold the Ctrl key and use the mouse to click on other state geometries. 

Geometries may also be selected by dragging a rectangle (fence) in the map window. 
 

4. Use the mouse to click and drag to create a rectangle (fence) that completely 
encompasses one or more states. 

All locatable geometries completely enclosed within the fence were highlighted and 
placed in the select set. 
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The selection only included those geometries which were completely enclosed because 
the Selection Mode was set to Inside Fence. 

 
 

        Inside Fence             Overlap Fence 
 

 
  Rectangle Fence             Polygonal Selection 

   

5. On the Home tab, select Overlap Fence  to change the selection mode. 

6. Click and drag to draw a small fence. 

All of the locatable geometries inside or overlapping the fence are selected. 

7. On the Home tab, select Unselect All  to remove all the selected geometries 
from the select set. 

8. On the Home tab, select Polygonal Selection . 

9. Click the Select Tool and click to begin digitizing the polygon and to add vertices. 
When finished, double-click to close the polygon. 

10. Click once more to finish the selection. 

 
Note that double-clicking closes the polygon without adding a new 
vertex. 

11. On the Home tab, click the arrow under Fit .  

12. Select Fit Select Set  to zoom to the selected items. 

13. On the Home tab, select Unselect All . to deselect all features. 

14. On the Home tab, select the Default Selection (rectangle)  mode. 
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Task 4: Selecting with Pick Quick 

Many times the cursor is hovering over multiple overlapping or stacked geometries, but you don’t 
want to select all of them. The Pick Quick dialog allows you to specify which of the overlapping 
geometries you want to select. 

1. Make sure that you are in Select mode by clicking the Select Tool   on the Home 
tab, or on the Quick Access Toolbar. 

Note that the GeoMedia Select cursor has a circle at the tip of the arrow.  

This circle indicates the cursor locate zone. Everything underneath this circle is 
selectable. 

2. To change the relative size of the cursor locate zone select Options on the 

Application tab . On the Options dialog, click the Smart Locate tab. 

3. Drag the slider bar to change the size of the Cursor Locate Zone. Note how the size 
of the circle changes. 

4. Return the cursor locate zone size to its original size and click Cancel on the Options 
dialog. 

5. Move the cursor so the locate zone circle overlaps two or more state boundaries. 
Hover it over the same point for a few seconds. 

6. Notice that allowing the cursor to sit still over two or more locatable features will result 
in the cursor changing to an ellipsis (3 small dots) appearing to the lower right of the 
on-screen cursor. 

  
7. When you see the ellipsis (three dots), click the mouse. The Pick Quick dialog is 

displayed. 

The Pick Quick dialog allows you to pick which features should be selected when multiple 
features are found within the tolerance of the cursor locate zone. 

8. Move the cursor over the pick quick numbers and note how the corresponding state 
geometries highlight when you hover over each number in the PickQuick dialog. 

 

 
9. Click one of the PickQuick numbers to select that geometry. 

10. Right click in the map window and select Fit Select Set to fit the selected item(s). 
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Task 5: Automatically Fit to Selected Items 

You can use the Map Window Properties command to setup the map to automatically fit selected 
items. 

1. From the Home tab, click Properties .  

The Map Window Properties dialog is displayed. 

 

 
 

2. In the Map window name field type Regional Index. 

3. Select the Fit and zoom out option. 

4. Set the percent to 150%. 

Now when items are selected, the selected items displayed in the Regional Index map 
window will be automatically fit to the map window. 

5. Click OK on the Map Window Properties dialog. 

6. Click on various features and note how the selected geometry is resized to fit the map 
window. 

 
This option is especially useful when there are multiple map windows 
or data windows for locating items. (Example: an overview map and a 
detailed map view). 

7. On the Home tab, select Fit All    to reset the map window to include all of the 
data. 
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Task 6: Viewing and Editing Feature Attributes 

You may also view and edit feature attributes using the Select Set Properties command. 
Attribute editing requires a read-write connection. 

1. Use the left mouse button to double-click a single state geometry. 

 

Once a geometry is selected, there are several ways to display the 
Select Set Properties. 

1) Select the Select Set Properties command   on the 
Home tab.  

2) Double-click the feature in the View.  

3) Right-click in the View and choose Select Set Properties 
from the Quick View menu. 

 

The States Properties dialog appears. This dialog allows you to view and edit the 
information stored in the attributes of the selected feature in Read-Write connections 
(Access, MS SQL, Oracle, etc.). The properties for Read-Only connections cannot be 
edited. 

 

 
 

2. Add one (person) to the value defined for the POP attribute. 

3. Select the General tab. 
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The feature class and connection name are listed here. The feature geometry type and 
units can also be seen. In this case Area is listed as m^2 (square meters). 
Next we will change the unit of measure. 

4. Click OK on the Properties dialog. (Note: It is suggested that you click Cancel if 
nothing is changed). 

5. On the Home tab, select Coordinate System . 

The GeoWorkspace Coordinate System dialog appears. 
 

 
 

6. Select the Units and Formats tab. 

7. In the Default units and precision specification area, select Area from the Type list. 

8. Select mi^2 from the list of available units in the Unit drop-down list. 

9. Select .12 from the Precision drop-down list. This will display Area accurate to two 
decimal places. 

10. Click OK to save changes to the GeoWorkspace Coordinate System. 

11. Activate the Select Tool and double-click on a state geometry. 

12. Click on the General tab and review the Area. Note that the value is now expressed 
as mi^2 (square miles) with two decimal places. 
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13. Click Cancel on the Properties dialog since we did not make changes to the 
attributes. 

14. Select Close on the Application tab   to close the current GeoWorkspace. Do 
not save the changes. 
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Class Notes 
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 The Data Window 
Objective: 
The data window contains the non-graphic attributes of a feature class or a query. In this lesson 
you will learn how to view, sort, and select data. You will also learn to use the data window to 
modify the attributes in a read-write database. 

Task 1: Open the Data Window and Sort Columns 

1. In GeoMedia, open USSampleData.gws by selecting Open on the Application tab 
. 

2. Using the GeoWorkspace tools in the upper right, minimize all map windows.  

3. On the Home tab, select Add/Show Windows > New Data Window . 

The New Data Window dialog appears. 
 
 

 
 

4. From the USSampleData Set tree-view, select the feature class Cities and click OK to 
create the data window. 
 

 
When a data window is opened in GeoMedia, the Table tab is made 
visible on the Ribbon. Many of the commands on the Table tab are 
also available from the right-mouse context menu when hovering over 
the data window. 
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Feature Class/Query Name Attribute Column Names 

 

Select All Rows 

 
 
 
   Select Row 

 
 
 
 
 
Go to First Row                                   Go to Last Row        Attribute Values 
 

 Previous Row Current Row     Next Row       

          Total Rows     

 
Columns may be selected in order to perform certain tasks, such as sorting the 
records based on a selected column, or even hiding the column(s) from the data 
window. 

5. Use Ctrl-click (or click and drag) on all of the attribute columns that follow POP to 
select them. 

The contents of the columns highlight. 

6. Right click in the data window and select Hide Columns. 

The selected columns are no longer displayed in the data window. The columns and the 
data they contain are intact in the source warehouse, but are hidden from the current 
data window. 

7. Right click in the data window and select Show Columns. 

The Show Columns dialog appears. This dialog may be used to show and hide columns 
in the data window. 

8. Uncheck the ID attribute column to turn off the display of the column. Check the 
SQMILES and STATE_NAME attribute columns to turn on their display. 
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9. Click OK on the Show Columns dialog. 

The columns that are not checked on the dialog are hidden from the data window. 

10. In the data window, select the attribute column POP. 

11. Right click in the data window and select Sort Descending. 

 

 
 

The records are sorted on the data window based on the descending order of the 
attribute values in the POP column. The data in the warehouse is unchanged. 

 

Task 2: Locating Graphics Using the Data Window 

When both the data window and map window reference the same record set (feature class or 
query), any selected records on the data window can be located in the map window. 

1. Restore (unminimize) the USSampleData map window. 

2. On the Home tab, select Arrange Windows Tile Vertically .   

The data window and the map windows will resize. 

3. Click on the top bar of the map window frame for the USSampleData map window to 
make this the active window. 

4. In the Legend, right-click on Cities and select Display On to show the cities in the 
map window. 

5. On the Home tab, select Properties. 
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The Map Window Properties dialog appears. 

 
6. In the section For items in select set, select Fit and zoom out. 
7. Change the zoom percentage to 240. 

8. Check the option to View at current scale only when selecting in this window. 

9. Click OK on the Map Window Properties dialog. 

In the data window, make the record for DALLAS, TX active by clicking on its record 
selector (far-left portion of the record/row). 

10. The selected record has been fit to the map window. 
 

 
11. Hold down the Ctrl key and add SAN ANTONIO, TX to the Select Set. Observe 

where the corresponding map graphic(s) are located. 
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Once one data record is selected the up and down arrow keys can be 
used to cycle through the records. 

12. In the Legend, right-click on Cities and select Display Off. 
 

Task 3: Select Records Using the Map Window 

1. Right-click in the map window and select Fit All to fit the graphics in the 
USSampleData map window. 

2. Zoom in on Colorado until the counties become visible. 

3. Click on the top bar of the data window frame for the Cities data window to make it 
the active window. 

4. Right-click in the data window and select Change Contents. 

 
5. Select Counties from the USSampleData Set tree-view to replace the contents of the 

data window. 

6. Click OK on the Change Data Window Contents dialog. 

7. Select the USSampleData map window. 

8. Click on a county in the map window.  

Notice how the record is highlighted in the data window. 
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9. On the map window, click and drag to define a fence that encloses several of the 
county polygons. 

 
 

The counties in the fence are added to a select set, and the records are highlighted in 
the map window. 

10. Click on the top bar of the data window to make it active. 

11. On the Table tab, select Promote Rows . 

 
 

The selected records are moved to the top of the data window.  

 

When relatively small selections are made you can right-click on the 
data window and copy the records into the paste buffer. The records 
can then be pasted into other applications such as Excel. 

To ensure that the column headers are included when coping from the 

data window, select Options from the Application tab . On the 
General tab, check the option Copy data window column 
headers to clipboard.  

12. Close the data window. Notice the Table tab is no longer displayed on the Ribbon. 

13. On the Application tab , select Close. Do not save your changes. 
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 Warehouse Connections and 
Legends 

Objective: 
Now that you have some experience using the GeoMedia interface and selecting geometries, you 
will learn how to create a warehouse connection. You will also learn how to create a legend to 
display features in the GeoWorkspace. 

Task 1: Creating a GeoWorkspace 

You should have an empty GeoMedia window open. 

First you will create a new GeoWorkspace to store the connections. 

1. On the Application tab , select New. 

 

You can also open the New dialog by selecting New  
GeoWorkspace    from the Quick Access tool bar. 

2. Click on the Look in field to navigate to C:\GeoTrain\GeoWorkspaces\Templates 
folder. 

3. Highlight Sample.gwt and click the New button to create a new GeoWorkspace with 
this template file. 

The new GeoWorkspace document is created with the default settings from Sample.gwt 
and is assigned a temporary name of GeoWorkspace1. 

4. Click the Application tab , and select Save As. 

5. Navigate to C:\GeoTrain\GeoWorkspaces and save the file as GM_Study3.gws. 

6. To review the connections in the GeoWorkspace, go to the Manage Data tab and 

select Warehouse > Warehouse Connections . 
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Notice that using the supplied GeoMedia template established two Access warehouse 
connections, one named Regional Data and the other named USA Sample Data. 

Existing connections defined in GeoWorkspace Templates may not have feature 
caching enabled. Feature caching can significantly improve performance when it is 
enabled.  

7. Highlight the Regional Data connection and click Properties.  

8. Place a check in the box next to Enable feature caching. The Enable Caching 
dialog appears. 

9. Take a moment to read the information on the Enable Caching dialog. Click 
Caching Explained and take a few minutes to read this information. 

10. When finished, close the GeoMedia Help window and click Create/ Refresh Cache. 

11. The warehouse connections Properties dialog contains the Location setting for 
storing the feature cache files; the default location is C:\Warehouses\Caches. 

 
To change the Cache location, click the Browse button and specify the 
preferred location.  

 

 
The initial publishing of cache files may require a significant amount of 
time when dealing with large data volumes. Nevertheless, once this 
publishing is complete, substantial performance improvement can be 
appreciated within the GeoWorkspace. Feature Caching is not 
available for all warehouse connections. Refer to Feature Caching in 
the on-line Help for additional details.  

12. For the Location, click the Browse button and browse to 
C:\GeoTrain\Warehouses\Caches. Click OK on the Browse for Folder dialog. 

13. Click the Refresh Cache button, and click Yes on the warning message to proceed. 

14. When the cache has been refreshed, click OK on the Properties dialog, and Close 
on the Connections dialog. 

Now you will change the default location for the Feature Cache files and Warehouses files 
to point to our training directory. 

15. On the Application tab, select Options. In the Options dialog, select the File 
Locations tab. 
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16. Select the Feature Cache Files entry in the File types list. 

17. Click the Modify button to open the Browse for Folder dialog. Point the location to 
C:\GeoTrain\Warehouses\Caches. Click OK on the Browse for File dialog. 

18. Select the Warehouse Files entry in the File types list. 

19. Click the Modify button to open the Browse for Folder dialog. Point the location to 
C:\GeoTrain\Warehouses. Click OK on the Browse for File dialog. 

20. Verify that Warehouse Files is now pointing to the correct location and click OK on 
the Options dialog. 
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Task 2: Connect to an Access Warehouse 

We will now add a new connection to the GeoWorkspace we just created. 

1. On the Manage Data tab click Warehouses > New Warehouse Connection . 

The New Connection dialog is displayed 
 

 
 

This dialog allows you to connect to any of the connection types supported by GeoMedia. 

 
Oracle connection types may not show if Oracle Clinet software is not 
installed. 

2. Highlight Access as the connection type. 

 
The Access option will create a Read-Write connection. You can make 
a Read-Only connection to an access warehouse using the Access 
Read-Only connection type. 

3. In the Connection name field, type Local Data. 

4. In the Connection description field type Huntsville Alabama. 

5. Click the Browse button. On the Access Database file dialog, select 
C:\GeoTrain\Warehouses\HSVlocal.mdb and click Open. 

6. Place a check in the box next to Enable feature caching.  

7. Click OK on the New Connection dialog.  

When a new connection is established, nothing visible happens but features are now 
available to add to the map window. 
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Task 3: Adding Features 

Features from the warehouse may be displayed in the active map window using a legend. 

1. On the Home tab, select Legends > Add Legend Entries . 

The Add Legend Entries dialog is displayed listing sources for graphic features. 

 
2. Click on the + next to the Regional Data connection to expand the tree-view to list the 

features that are available for the connection. 

3. Click the checkbox corresponding to the top level of the Regional Data connection. 
This selects all of the features in that connection. 

4. Uncheck Urban. This also unchecks top level Regional Data checkbox. 

5. Select OK to display the features. 

 
6. Right-click on the map window and select Fit All. 
7. Right-click on the legend and select Fit Legend to resize the legend pane horizontally 

to fit the legend entries for the map legend. 
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Notice how States is listed twice on the legend. Feature names on the legend can 
appear multiple times whether coming from one or multiple warehouses. 

8. Select States (4) in the legend. 

9. Right-click in the legend and select Fit by Legend Entry.  

This zooms the map window to the extent of the selected legend entries 

  
 

10. Select States (49) in the legend. 

11. Right-click in the legend and select Delete. 

12. Click Yes to confirm the deletion. The selected items are deleted from the legend 
and map window. 

The legend simply controls which features are displayed in the map window. The data 
has NOT been deleted from the warehouse. The features can be re-added to the legend 
at any time. 

 

Task 4: Naming Map Windows and Legends 

Now we will create a new map window to display a second dataset. 

1. On the Home tab, select Add/Show Windows > New Map Window . 

2. For the Map window name enter Downtown Huntsville. Click OK.  

Note that the map window name changes to reflect the new name. 

3. On the Home tab select Legend > Add Legend Entries . 

4. Expand the Local Data connection tree-view. 
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5. Select address_points, Parcels, and street_casing from the list of features and click 

OK. 

All the selected features are displayed with random styles in the map window. We will 
modify the style characteristics for these features in the next exercise. 

6. In the Legend, right-click address_points and select Display Off. 
The map legend can be named so the entries can be used in other map windows or 
recalled for future use. This is especially useful if a map window is inadvertently deleted. 

7. On the Home tab, select Legend > Name Legend . 

8. For Name, type Huntsville AL, and click OK to save the legend. 

The legend name is now saved as part of the GeoWorkspace document (.gws) and can 
be used when creating new map windows. Notice that it does not change the title of the 
map window. 

9. Minimize all map windows except Downtown Huntsville. 

10. On the Home tab, select Arrange Windows > Tile Horizontally. Select Fit.  

11. Click the Save GeoWorkspace icon  on the Quick Access toolbar to save 
GM_Study3.gws. 
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Class Notes 
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 Scaling and ToolTips 
Objective: 
There are two basic modes of style scaling, View Scaling and Paper Scaling. 

When using View scaling, the style characteristics of the legend entry remains the same 
independent of the map window display scale.  As you zoom in and out, the rendered style 
remains the same.  

Paper scaling defines the style characteristics based on a fixed map scale, called the Nominal 
Map Scale. When the map window is displayed at this scale, the legend entries are displayed at 
the size defined in the Style Properties, but get larger or smaller as the map zooms in and out. 

 

Task 1: Paper Scale Styling and Nominal Scale 

The GeoWorkspace, GM_Study3.gws should be open with the Downtown Huntsville map 
window displayed. 

           Display scale = 1:1500                                                               Display scale = 1:3000 

 
 
 

 
Label size remains 
Constant with View 

Style Scaling 

 
 
 
 
 
 
When the legend entry Style Scaling is set to View, the size of the rendered style remains 
constant as the map window display scale changes. 

 

1. Experiment using the Zoom In and Zoom Out commands and observe the size of the 
address text. Notice how the text size stays the same size as the display scale 
changes. 

2. Right-click in the Downtown Huntsville map view and select Fit All. 
3. Hold down the ctrl key and select both of the address point legend entries. 
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4. Right-click on top of the selected legend entries and select Style Scaling > Paper.  
The size of the selected legend entries are scaled so that they are fixed at the current 
Nominal Map Scale (paper scale) setting. However, the Nominal Map Scale makes the 
styling appear even worse than before. 

 

 
 

To fix the label size we must change the Nominal Map Scale to better reflects the 
ideal map scale for this data. 

5. One the Home tab select Map Display        . 

 
To access the Display Properties in the map window right-click in the 
map window and select Display Properties. 

 

The Display Properties dialog appears. 

 

.  

6. Change the Nominal map scale setting to 1 : 1200. 
 
Changing the Nominal Map Scale to a smaller number renders smaller labels for those 
legend entries using the Paper style scaling mode. 
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7. Click the Apply button.  

 

 
 

The Address text and points are resized to be their true size at a 1:1200 map scale. 

8. Click Close to dismiss the Display Properties dialog. 

9. Experiment using the Zoom In and Zoom Out commands and observe the size of 
the address text. 

10. On the Home tab, select Zoom to > Zoom to Nominal Map Scale to display the 
map at its Nominal Map Scale, in this case 1:1200.  

11. Right-click on address_points and select Display On.  
 
To remove the point geometries for the addresses, select address_points in the 
Legend. 

 
Make sure that you select the address_points point geometry and 
not the GDO_Text of address_points. 

12. Right-click and select Delete. Click OK on the Warning dialog. 
 
The Address Point geometries are removed from the map window, making the address 
labels more legible. 

Task 2: Displaying Features by Scale 

As you zoom in and out of the map window some features may no longer be legible. The 
display by scale option can be used to automatically turn the display of features on and off as 
the map display scale changes. 

1. On the Home tab, select Fit  to fit the graphics to the map window. 

2. Zoom In until the text becomes legible. 
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3. Take note of the current map display scale (lower right of the map view). 

 

 
 

4. Write your display scale here:  1:_____________________ 

We now know that any higher display scale value (zooming out) will mean that the text 
will not be legible.  

5. Right-click on the GDO_Text_of_Address_Points legend entry and then select 
Display Scale Range. 

The Scale Range dialog appears.  
 

 
 

6. Set the Maximum scale value a little larger than the value noted above. 

7. Click OK. 

8. Click Yes when prompted to change the legend entry to Display by Scale. 

 
Selecting No will require that you change the Display Option to By 
Scale before your change will be displayed. 

 
 

The Legend icon 
changes,  
indicating that the 
geometry is  
set to Display by 
Scale. 

9. Experiment using the Zoom In and Zoom Out commands and observe how the text 
turns on/off as the display scale changes. 

10. On the Home tab, select Fit  to fit the graphics to the map window. 
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Task 3: Legend Toolt ips 

A Tooltip is a quick and easy way of getting information about a feature without formally 
displaying the attribute information in the data window or for invoking the Select Set Properties 
dialog. 

1. Select Parcels in the Legend. Right-click and select Fit by Legend Entry. 

2. From the Home tab, select Legend > Add Legend Entries to add street_centers 
from the Local Data connection to the Downtown Huntsville map window. 

3. Right-click on street_centers in the Legend. 

4. Select Map Window Tooltip > Attributes > sfeanme from the list of attributes. 

 

 
 

5. To view the tooltips, hover the cursor over different street_centers segments. You 
may need to zoom in to see the street centers in the view. 

 
 

Only one attribute can be selected in this manner. If you want to select multiple 
attributes, i.e., to have the tooltip say ‘CAMBRIDGE ST”, you will have to build an 
Expression.  

6. In the Legend, right-click on street_centers again and select Map Window Tooltip > 
Expression. 

The Map Window Tooltip dialog already has the street name (from the sfeanme). We 
will add the space and the feature type. 
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.  

7. Click in the Expression text box on the dialog and place the cursor at the end of the 
existing expression. 

8. Click on the + button just beneath the Expression text box. 

9. To add the space, you will need to type “ “ using the keyboard. 

10. Click the + button again. 

11. In the Category list, select Text. 
12. In the Functions list, double-click FORMATATTRIBUTE. 
13. Scroll down the list of Attributes and double-click Input.sfeatyp. 

 

Your Expression should look like the following:  

FORMATATTRIBUTE(Input.sfeanme) + " " + FORMATATTRIBUTE(Input.sfeatyp) 

 

14. Click OK and hover your mouse cursor over a street_center segment again. 

 

 
 

The tooltip has been modified to display the street name and street type. 

15. On the Home tab, select Fit  to fit the data to the map window and leave 
GeoMedia open with Downtown Huntsville displayed.  

16. On the Application tab , select Save as, and save the GeoWorkspace as 
GM_Study4.gws in the C:\GeoTrain\GeoWorkspaces folder.  
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 Creating Labels 
Objective: 
Labels can be automatically created using feature class attributes. Dynamic labels will redraw 
as you roam throughout the data area. Rules can be defined to assist in the proper placement 
of labels. 

Task 1: Creating Labels for Area Features 

We will create labels for the parcel layer and establish rules to ensure proper placement within 
the map window. The GeoWorkspace, GM_Study4.gws should still be open and visible. 

1. Highlight GDO_TEXT of address_points in the legend. 

2. Right-click and select Display Off. 

3. On the Home tab, select Map Display  to open the Display Properties. 

4. Set the Nominal Map Scale to 1:2000 and click Apply. Click Close.  

5. Highlight Parcels within the Legend and from the right-mouse context menu, select 
Fit by Legend Entry. 

6. On the Home tab, select Zoom to  > Zoom to Nominal Map Scale . 

7. On the Labeling tab, select Label Manager .   

The Label Manager dialog opens. 
                           
Identifies legend 
entries to be labeled    

Identifies if the feature geometry 
should be considered as an 
obstacle during labeling  

Defines label style and 
attributes used to 
create the labels  

          
 

     

    Defines rules used 
to place label in 
map window 

 
 
 
 
 
 
 

8. Highlight the row containing Parcels and click the Properties button. 

 
The Label Proprties dialog can also be invoked by clicking the Label 
checkbox. If a layer / legend entry is designated for labeling and does 
not have the text definition for the label placement, the Label 
Properties dialog is opened by default. 
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9. In the Text drop down menu, select parcel_num. 

 

 
 

10. Change the font Size to 16.00 pt and click OK. 
11. In the Label Manager dialog place a check mark in the Label column and Obstacle 

column for the Parcels layer / legend entry. 

12. Click OK to exit the Label Manager dialog. 

13. On the Labeling tab, select Toggle Dynamic . 
 

The labels have been generated in the map window. Because of the default rules for 
applying labels, only a few labels can be seen in the map window. Next we will create rules 
to better place the labels in the map window. 

 

 
 
 
 

14. On the Labeling tab, select Label Manager . 

15. Select the Parcels row and click the Rule button. 
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Currently there is only a check mark next to Place Horizontal rule. We will modify this 
to better place the labels on each parcel. 

 

16. Uncheck the box next to Place Horizontal and add a check mark in the box next to 
Place at Dominant Angle. 

17. Add a check mark next to Allow Font Reduction and change the Max No. of Steps to 4. 
18. Finally, place a check mark in the box next to Allow Use of Leader Line. 

19. Click Create on the Rule Properties dialog. 

20. In the Parcels row, place a check mark in the Obstacle column and click OK to the Label 
Manager dialog. 

 
Most Parcels now have an applied label. There may still be a few that do not. This is most 
likely due to interference with obstacles. We will change the preferences to allow a label to 
overlap with an adjacent obstacle. The Obstacle setting is unchecked by default for all 
feature types, except point features. 

 

21. Again, open Label Manager. 
22. In the Parcels row, remove the check mark in the Obstacles column and click OK. 
 
Once again the labels are redrawn to reflect the changes. Look over the changes that 
have been made. Notice that labels with leader lines are now able to overlap other 
features (obstacles) in the map window. 
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Task 2: Creating Labels for Linear Features 

Linear features have a different set of rules to properly place labels along features. We will now 
apply labels to streets. 

 

1. Begin by removing the parcel labels. Open Label Manager and remove the check next 
to Parcels and click OK. 

 

 
 

2. Click OK to the message that appears. The Parcel labels are removed from the map 
window.  

3. Highlight Parcels within the Legend and from the right-mouse context menu, and select 
Fit by Legend Entry. 

4. Click OK to the message that appears.  

 
This message will continue to appear when making changes to the 
map window extent when dynamic labeling is turned on and no labels 
are selected for placement. 

5. Highlight Parcels within the Legend and from the right-mouse context menu, and select 
Display Off. 

6. On the Labeling tab, select Label Manager . 

7. Click on the row containing street_centers to highlight it. 

8. Click Properties to define the attribute used for the label. 

9. In the Text drop down menu, select sfeanme. 

10. Change the Size to 12.00 pt and click OK to the Label Properties dialog. 

11. Place a check mark in the Label and Obstacle columns next to street_centers and 
click OK to the Label Manager dialog. 

12. On the Labeling tab, select Toggle Dynamic . 

 
The labels are added to the map window. Not all streets have been labeled using the 
current Rule definition. We will adjust the Rules to modify how the labels are applied to 
the streets. 
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13. Reopen Label Manager. Ensure the street_centers row is highlighted and click Rule. 

14. Place a check mark next to Allow Labels to Cross Lines and click Create. 
15. Click OK to the Label Manager dialog. 
 
The labels have been redrawn and we now see more street names. There are a few 
other rules that will help ensure all street are properly labeled with a street name. 

16. Open Label Manager. With the street_centers row highlighted, again click Rule. 

17. Place a check mark next to Repeat Labels and change the spacing to 11.00 cm. 

18. Next, place a check mark next to Allow Font Reduction and change the Max No. of 
Steps to 4. 

  
 

19. Click OK to the Rule Properties dialog and OK to the Label Manager dialog. 
The labels are again redrawn. They are now properly placed so all streets have a 
displayed name. 
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Task 3: Creating Labels with Expressions 

Labels can be created using more than one attribute. We will now use the expression builder to 
add the street type to the street label. 

 
1. On the Labeling tab, select Label Manager . 

2. Highlight the street_centers row highlighted, click Properties. 

3. On the Label Properties dialog, click Expression.  

The Expression Builder dialog opens. The current expression used to create the label is 
shown in the edit window. Currently it is set to the attribute defined earlier, sfeanme. We 
will build upon this to add the street type. 

 
 

4. Click in the Expression text box on the dialog and place the cursor at the end of 
sfeanme in the edit window. 

5. Click the space bar to add a space after sfeanme. 

6. From the available Operators, click the ++ button   to add this to the expression. 

7. Next, use the scroll bar in the Fields list to find sfeatyp. Double click on sfeatyp to add it 
to the expression 

 

Your Expression should look like the following:  

sfeanme ++ sfeatyp  

 

8. Click OK to close the Expression Builder dialog. 

9. Click OK on the Label Properties dialog and OK on the Label Manager dialog.  

The Labels have been updated to display the new label based on the expression. 
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Task 4: Creating Labels for Point Features 

Next we will add point labels and explore the rules available for points. 

 
1. On the Home tab, select Legends > Add Legend Entries. 

2. Expand the Local Data tree-view and place a check mark next to Restaurants. Click OK. 

3. On the Labeling tab, select the Label Manager . 

4. Uncheck the Label column in the street_centers row. 

5. Highlight the Restaurants row and click Properties. 

6. In the Text drop down menu, select NAME. 

7. Change the Size to 12.00 pt and click OK to the Label Properties dialog. 

8. In the Restaurants row, place a check mark in the Label Column. 

9. Click Rule. The Rule Properties dialog opens. 

 

   
 

10. Place a check mark next to Allow Labels to Cross Lines. 

11. Place another check mark next to Allow Font Reduction and change the Max 
Number of Steps to 4. 

12. Next, examine the graphic that allows the position priority to be defined. 
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13. Use the Clear All button to remove all of the priority definitions. A red exclamation point 
will flash indicating the need to define at least one position. 

14. Click in the cleared boxes to define the order in which the software will attempt to 
place the labels. Priority will be given on a 1st, 2nd, 3rd, etc. order basis.  

 
 

 
The Default button on the Rules Properties dialog can be used to reset 
the default preferences with this dialog. This will reset ALL of the Rule 
Properties back to their default settings. You must replace the check 
marks in steps 10 and 11 if this button is pressed. 

 

 

15. When finished, click Create to the Rule Properties dialog and OK on the Label 
Manager dialog. 

16. If necessary, on the Label tab select Toggle Dynamic   to display the labels. 

17. View the placement of the labels, noting the positions given based on the defined 
pattern in the Rule Properties.  

18. On the Label tab, select Toggle Dynamic   to turn off the dynamic labels from the 
map window.  

19. On the Application tab , select Save as, and save the GeoWorkspace as 
GM_Study5.gws in the C:\GeoTrain\GeoWorkspaces folder. 
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 Working With Styles 
Objective: 
Styles are named symbology settings which are stored in the GeoWorkspace. Example: You may 
have a style named Major Highway, which is linear, red, and 3mm in thickness. This named style 
can then be used to symbolize any linear graphic legend entry. 

Task 1: Organizing and Creating New Styles 

We used a template (Sample.gwt) to create the current GeoWorkspace. This template contained 
predefined styles. The Styles dialog can be used to manage, create, edit, and delete the styles in 
the GeoWorkspace.  
 

The GeoWorkspace, GM_Study5.gws should still be open and visible. 

1. On the Home tab, select Styles  .  
 

 
 

2. To add a new styles folder click on the New button . and select the Folder option 
from the list. 

3. Name the folder Transportation. 

4. Click on the top-level Styles folder. The styles in the root folder “Styles” are now visible. 

5. In the Show drop-down menu, select Line Styles to filter out everything except line 
styles in the styles Inventory. 

6. Click the View button , and select the Details option. 
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7. Scroll through the list of styles and use the Shift key to highlight all of the line styles from 
Dirt Road to Ramp. With the styles highlighted, use the Ctrl key to unselect the styles that 
are not related to transportation. 
 

 

8. Click the Copy button . 

9. Select the Transportation styles subfolder. 

10. Click Paste   to paste the selected styles into the Transportation subfolder. 

11. Click the View   button and check the Icons option. In the Show drop-down menu, 
select All Styles. 

 

 
 

Now we will create a new style for the Address Text in our Map View. 

12. Click the Units button. 

 
13. Ensure the units for Font size is set to pt. Click OK on the Style Units dialog. 

14. Select the root Styles folder in the Folders list. 
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15. Right-click in the style inventory and select New > Text Style 

 

A ‘New Text Style’ is created at the end of the styles. 

16. Name the new style Address Text. 

17. With the new Address Text style selected, click the Properties button  
 

 
 

18. Set the font Size of the style to 8.000 pt. 

19. Click the Bold button. 

20. Click the Color button and select a dark red color on the color palette. 

21. Check the Display halo option. Change the halo Size to 2.000 pt. 

22. Click OK on the Style Properties dialog. 

23. Click Close on the Styles dialog. 

 
Editing a style does not change any style in the Legend. You still need 
to apply edited styles to the legend entries. 

 

 

 

 

 

 

. 
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Task 2: Apply Text Style to the Map Legend 

In the previous task, we created a new style for the Address Text, but it did not 
automatically apply to the map Legend. 

 

                                   Style Key          Legend Entry Title 

 
 

            Display by Scale 
 

             Locatable                 Geometry count 

 
 

1. In the legend, right click on GDO_TEXT of address_points and select Display On. 

2. Right click on GDO_TEXT of address_points again and select Fit by Legend Entry. 

3. On the Home tab, select Zoom to > Zoom to Nominal Scale. 

4. Double-click on the legend style key for GDO_TEXT of address_points to invoke the 
Legend Entry Properties dialog.  
 

 
Legend entry  
types              

  Style Preview 

                 

 Edit Common 
Style properties 

 

Legend Entry          
 Preview           Edit Advanced 
            Style properties 

                    
                     

 
List of styles which can 
be used for the selected 
legend entry 

 
5. Double-click on the Transportation folder. 
 
The Transportation folder is opened but no styles are listed because only Text Styles may 
be applied to the text legend entry. We only copied Line Styles into the Transportation 
folder. 

6. Click on the Up one level button        . 
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7. Click on various styles and see the Previews. 

8. Scroll through the list of styles and select the Address Text style. 

9. Click Apply and OK on the Legend Entry Properties dialog. 

 

 
 

The dialog is dismissed and the Address Text style is applied to the GDO_TEXT of 
address_points legend entry. 

 

Task 3: Edit Style Collections 

1. In the legend, right click on GDO_TEXT of address_points and select Display On.  

2. Double-click on the legend style key for Parcels. 

 
 

3. Single-click on the Light-Yellow Style. 

4. Click on the Properties button. 
 
The Style Properties dialog for the selected style is displayed. 

Style Key 



48  Introduction to GeoMedia Desktop 

 
 

Area styles are an example of a style which is made up of more than one style type. 
These are called Style Collections. Each individual component of the style collection 
may be edited; in this example Boundary Styles and Fill Styles. 

 

5. Select the Light Yellow component under Fill Styles in the Style component tree-view. 

6. Click on the Color button and use the Color palette to change the color to another light 
color (e.g., Number 72) and click OK. 

7. Set the Translucency value to 25. 
 

Style components can be replaced with other pre-defined styles. 

8. Select the Simple Line Style. Right-click and select Replace. 

The Select Style dialog appears. 

9. Select the National Boundary with Tint style and click OK.  
 

 
 

The simple line style is replaced with a style collection, which is nested into the style 
tree view. 

10. Right-click on the National Boundary with Tint style and use the Replace option to 
replace with the style Wall. 

11. Click OK. 
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12. Right-click on Wall and select Rename. 

13. Rename the style to Parcel Line. 

14. Use the Color button to set the color number to 39. 

15. Set the Translucency to 25. 
 

We will now create a new boundary line that will serve as an interior boundary tint. 
 

. 

16. Right-click on Parcel Line style and select New Style to add a new line style to the 
style collection. 

17. Rename the style Boundary Tint. 

18. Use the Color button to select color 98. 

19. Set the Translucency to 25. 

20. Set the Width to 2.000. 

21. Check the Interior boundary tint option. 

22. Click OK to view the style settings. 

23. In the Legend Entry Properties dialog, click the Name Style button and name the style 
Parcels. 

24. After naming the style click OK on the Legend Entry Properties dialog. 
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Task 4: Editing a Linear Style Collection 

1. Double-click on the legend style key for street_centers to open the Legend Entry 
Properties dialog. 

2. Open the Transportation folder. 

3. Select the Highway style collection. 

4. Click on the Properties button. 

Notice that the style has two style components; a red foreground line that represents the road 
fill and a thicker black background line that represents the road casing. 

 
 

Style Components 

 
 
 
 
 

 
 

Click to Magnify 
the Preview 

 
  Preview 

 
 

5. Click on the Magnify command for the Style preview and select 400%. 

Notice how the ends of each style component have been set to Flat, while the mid-line 
joins have been set to Round. 

6. Click Cancel on the Style Properties dialog. 

7. Click OK on the Legend Entry Properties dialog. 

8. Right-click on the legend entry street_centers and set the Style Scaling method to 
Paper. 

9. Zoom In and examine a street intersection and notice how the flat ended lines overlap at 
the intersections. 
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Because the software is drawing each road segment sequentially, the segments appear 
to stack on top of each other. We can, however, tell the software to draw all of the same 
styles together at the same time, which will clear intersections for linear data. This 
function is called Order by Style (instead of Order by Feature). 

10. Right-click on street_centers legend and select Style Properties. 

11. In the Style Properties dialog, select the top-level style named Highway. 

 
 

 
 

12. Change the Style drawing order to Order by Style. 

13. Click OK on the Style Properties dialog. 

14. Notice now how the intersections are “cleared” of their overlapping styles (caps). 
 

 

15. On the Application tab , select Save as, and save the GeoWorkspace as 
GM_Study6.gws in the C:\GeoTrain\GeoWorkspaces folder.  
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Class Notes  
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 Adding and Editing Features 
Objective: 
Inserting features is the process of digitizing new graphics in the map window. The new graphics 
are stored as new records in the read/write warehouse Feature Class tables. 

Students will learn to insert new features in the Warehouse. You will set the Feature placement 
options, vertex snap options, and digitize linear, polygonal, and point features. 

Task 1: Connect to a Warehouse and Add Legend Entries 

We will now connect to a new Warehouse that contains predefined feature classes. Once 
added to the Legend, we will digitize features into these classes. 

  

The GeoWorkspace, GM_Study6.gws should still be open and visible.  

1. Minimize all map windows.  

2. On the Home tab, select Add / Show Windows > New Map Window. The New Map 
Window dialog is invoked.  

3. For the Window name, key-in INGR Campus. Ensure that the selected legend to 
display is defined as <Empty>. Click OK.  

4. On the Home tab, select Arrange Windows > Tile Horizontally.  

5. On the Manage Data tab, select Warehouse > New Warehouse Connection . The 
New Connection dialog appears. 

 

  
 

6. For the Connection name, key-in INGR Campus.  

 



54  Introduction to GeoMedia Desktop 

7. Click the Browse button. On the Access Database file dialog, navigate to the 
C:\GeoTrain\Warehouses folder. Select Digitizing_Lab.mdb and click Open.  

8. Click OK to the New Connection dialog. 

9. On the Home tab, select Legends > Add Legend Entry . 

10. In the Add Legend Entries dialog, check the top level INGR Campus warehouse to 
add all of the features in that database to the Legend. 

 
11. Click OK in the Add Legend Entries dialog. 

The feature classes from the INGR Campus warehouse are loaded into the legend.  

12. On the Home tab, select Legends > Fit Legend. The Legend pane expands to the 
width of the longest legend entry. 

 

The Fit Legend command can also be accessed through the right-mouse 
context menu when hovering over the Legend pane.  
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Task 2: Set Display and Digitization Options 

1. Right-click on the map view and select Display Properties. 

2. In the Display Properties dialog, set the Nominal map scale to 1:2,400 and check the 
Paper scaling option. 

3. Click Apply and then click Close. 

4. Right-click in the Legend pane and select Properties. 
 

 
 

5. Place a check in the box next to Count of all features. 

6. Click OK on the Legend Properties dialog. 

All of the vector feature classes from the Warehouse have a count of zero. In the next 
several steps we will digitize to add features 

7. Right-click the Images_Ingr_Campus legend entry and select Locatable Off. 
Locatable Off means the cursor will not be able to highlight or select the image and it can 
function as a backdrop when digitizing features. 

8. On the Application tab , select Options. The Options dialog is opened. 

9. Click on the Placement and Editing tab. 

10. Ensure that the Copy attribute values from previous feature option is checked. 

11. Click OK in the Options dialog. 

When inserting (digitizing) new features, there are several Options available on the Vector 
tab that control how the Insert Feature command behaves, such as Maintain Coincidence, 
Use Existing Geometry When Digitizing, Break Linear Features, and Display Properties 
Dialog For New Features. These Options are available as On/Off toggle buttons that can 
be selected at any time while inserting features. 
 
When digitizing features, as the cursor moves within the snap tolerance the cursor display will 
change to one of the shapes below to indicate that it is ready to snap the next ‘snap point’ 
associated with the existing feature. The icons displayed correspond to the SmartSnap 
options defined on the Vector tab.  
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Vector Snap Options 
 

              Intersection Snap - snaps to the indicated intersection. 

              Endpoint Snap – snaps to the nearest endpoint. Endpoint Snap 

              Vertex Snap – snaps to the nearest vertex.  

             On Element Snap – snaps onto the element. 

    Origin Snap – snaps to the origin of the text, point, or symbol.  

               Midpoint Snap – snaps to the midpoint of the element.  

               Tangent Snap – snaps to form a tangent with the element. 

   Perpendicular Snap – snaps to a perpendicular element segment.  

  

Digitizing Options 
 

Maintain Coincidence – inserts a new vertex when snapping to an 
existing feature. Both features will use this new vertex. 

 
Break Linear Features – allows features in the same feature class to 
break an existing line when it snaps. (This can be changed in the 
Placement and Editing tab of the Application tab > Options dialog.) 
 
Display Properties Dialog For New Features – opens the Properties 
dialog when a new feature is created (or when a feature is broken 
while inserting or editing. 
 
Use Existing Geometry When Digitizing – when digitizing a new 
feature, it will share a line/edge with the existing feature. 

 

12. Activate the Vector tab. Locate the SmartSnaps group and ensure that the following 
vector snaps options are enabled: End Point, Vertex, On Element, Origin, and 
Midpoint. 

13. Ensure that the Maintain Coincidence, Break Linear Features, and Display 
Properties Dialog for New Features are enabled in the Options group of the 
Vector tab. 

 



 

    57 

Task 3: Insert Linear Features 

1. On the Vector tab select Insert Feature . 

The Insert Feature dockable control is displayed in the GeoMedia interface. By default, it is 
located at the bottom of the application (under the legend pane & map window). 

 

 
        Feature Selection List   Placement Mode 

 

2. Click in the Feature selection list. Expand the INGR Campus connection tree-view and 
select Rail_Road. 

 

 
          Railroad 

 

3. For the Placement Mode, select Point by Point from the pull-down menu. 

4. Zoom in to the South (bottom) part of the image. If needed, click the right mouse button 
to exit the zoom command. 

 Lake 
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The Insert Feature command remains active during map window 
navigation allowing you to zoom and pan while you are digitizing   
features. 

5. Use the left mouse button to click points to digitize the railroad. 

6. End the line just before the rail split and road intersection by clicking the right mouse 
button and select End Feature on the list of options. The Properties dialog is 
automatically displayed. 

7. Click OK to dismiss the Properties dialog without making any changes to the 
attributes. 

Now we will continue adding the railroad features using the snapping features. 

8. Hover the cursor over the ends of the railroad line and notice the small picture (glyph).  
A snap glyph  appears indicating the type of snap that will occur when a point is 
placed. 

9. With a glyph visible, use the left mouse button to place a vertex to snap to the railroad. 

10. Continue digitizing the railroad features following the same instructions as noted in 
step 5 through step 7 above. 
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Task 4: Inserting Area Features 

First we will digitize a few rectangular buildings. 

 
1. On the Home tab, select Fit, and then select Zoom In so you can see the buildings. 

 

 

                    Digitize this         
        building with         
        a rectangle        and this building 
          with a polygon 

 

 

                                                                                                    

2. On the Vector tab, select Insert Feature. 

3. On the Insert Feature dockable control, click the Feature Selection pull-down menu. 
Expand the INGR Campus tree-view and select Building.  

4. Click the Placement Modes pull-down menu and select Place by rectangle. 

5. Digitize the western (left) building outline by clicking in the northwest corner of the 
building footprint. Notice that the rectangle expands as you move your cursor. 

6. Click in the southeast corner of the building footprint to finalize the rectangle. Click OK 
on the Properties dialog. 

 

Now we will digitize the non-rectangular building. 

 

7. Change the placement mode to Point by point. 
8. Begin digitizing the non-rectangular building to the east of the already digitized 

buildings. 

9. If you make an error while digitizing the feature, you can press the Backspace key while 
digitizing to undo the placement of the previous point. 

10. Continue digitizing the building outline. After placing the last point in the building 
outline, double-click to end the digitizing process. A vertex is not placed where you 
double-click.  

11. Click OK on the Properties dialog. 

12. Press the Esc key to exit the Insert Feature command. 
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Task 5: Editing Existing Features 

Once a feature has been digitized and saved into the Warehouse, it can be edited if necessary. 

Perhaps you made some digitizing errors when you digitized the vertices in the polygonal building 
in the previous steps. 

 
Move these 
vertices to the 
corners 

 
 
 
 
 
 
 
 
 
 

1. Select a building by clicking on one of the line segments. It should change to a green 
color. 

2. On the Vector tab, select Edit > Edit . All of the vertices in the selected feature are 
displayed as black squares. 

3. Click on the vertex you would like to move. It changes to a purple circle to indicate that it 
has been selected. 

4. Drag the vertex to its correct location. 

5. Click on a line segment to add a new vertex. Drag it to its new location. 

6. Press the Delete key to delete the selected vertex. Click Yes on the warning box to 
confirm the deletion. 

 
You can use the Ctrl key to select multiple vertices and the Shift key to 
select all of the vertices. 
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We will now redigitize a portion of the western-most building we created with a 
rectangle to append the covered entryway to the existing feature. 

 
 
 
 

Before 

 

 
 
 
 
 
 
 
                  After 
 
 
 
 
 

7. On the Home tab, select Pan and adjust the view so that the building is visible in the 
map window. 

8. Select the building by clicking on the rectangle. 

9. On the Vector tab, click Edit > Redigitize . 

10. Click to define the start and end points of the portion of the polygon which will be 
redigitized. 

 
 
                        Click here 
 
 
 

    and then here 
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11. Click to add vertices at the corners of the covered carport. 
 

              
 

12. Double-click or press the N key to finish the digitizing. 

Task 6: Insert Point Features 

Now we will digitize the fountain in the middle of the lake as a point feature. 

 
1. On the Home tab, select Pan and adjust the view so it is centered on the lake. 

2. On the Insert Feature dockable control, click the Feature Selection pull-down menu. 
Expand the INGR Campus tree-view and select Misc_Point.  

3. Click the Placement Modes pull-down and observe the available options of placing a 
point feature.  

4. Select Place at angle and then click inside the lake to place a point on the fountain. 

5. In the Misc_Point Properties dialog, click the Value cell for Feature_Type and select 
Water Fountain from the pick-list. 

6. Click OK. 

7. Press the Esc key to exit the Insert Feature command. 

8. On the Application tab , select Save as, and save the GeoWorkspace as 
GM_Study7.gws in the C:\GeoTrain\GeoWorkspaces folder.  
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 Buffer Zones 
Objective: 
In this challenge you will learn how to create and modify buffer zones in GeoMedia. 

Task 1: Creating and Merging Buffer Zones 

We will be performing a buffer analysis of Madison County, AL to determine the Fire Station 
coverage. First, we need to display the Fire Stations.  

The GeoWorkspace, GM_Study7.gws should still be open and visible.  

1. Ensure Downtown Huntsville is the active map window. 

2. On the Home tab, select Legends > Add Legend Entries. 

3. Expand the Local Data tree-view, check Fire_Stations and click OK. Points giving the 
locations of the Fire Stations are placed on the map. 

 
You may want to change the Symbol color of the Fire Stations to 
better stand out against your highways. 

4. On the Home tab, select Fit  

5. On the Analysis tab, select Buffer Zone . 
 

 
 

6. Click the Buffer zone around pull-down menu. Expand the Local Data tree-view and 
select Fire_Stations. 

7. Ensure that the Distance is set to Constant. 
8. Change the buffer distance to 2 and the units to mi. 

9. Click the Style button to display the Select Style dialog. 

10. For the Named style, select the Light Coral (or another style with a solid fill color). 
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11. Change the Translucency to 75%. 

12. Click OK on the Select Style dialog, and click OK on the Buffer Zone dialog. 

The buffer zones are calculated and displayed in the map window. Note that each fire 
station has its own individual buffer zone. 

 
Next we want to edit the buffer zone query, make the buffer radius slightly larger and 
merge all of the overlapping buffer zones a single buffer. 

13. On the Analysis tab select Queries . 

.  

14. Select the Buffer Zones around Fire_Stations query and click the Properties button. 

15. Change the Distance to 3 mi and check the Merge touching buffer zones option. 

16. Click OK to dismiss the Query Properties dialog and click Close to dismiss the 
Queries dialog. 
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The buffer zones are redisplayed in the map window, and any of the overlapping sets of 
buffer features are merged into a single buffer zone in the map window.  

17. On the Application tab , select Save as, and save the GeoWorkspace as 
GM_Study8.gws in the C:\GeoTrain\GeoWorkspaces folder. 

18. Exit GeoMedia.  


	Section 1:   Introduction to GeoMedia Desktop
	Vector Snap Options
	Digitizing Options


