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About Us 
Hexagon Geospatial helps you make sense of the dynamically changing world. Hexagon 
Geospatial provides the software products and platforms to a large variety of customers through 
direct sales, channel partners, and Hexagon businesses, including the underlying geospatial 
technology to drive Intergraph Security, Government & Infrastructure (SG&I) industry solutions. 
Hexagon Geospatial is a division of Intergraph Corporation. 

CUSTOMERS. Globally, a wide variety of organizations rely on our products daily including 
local, state and national mapping agencies, transportation departments, defense organizations, 
engineering and utility companies and businesses serving agriculture and natural resource 
needs.  Our portfolio enables these organizations to holistically understand change and use 
information to make mission and business-critical decisions.   

TECHNOLOGY. Our priority is to deliver products and solutions that make our customers 
successful. Hexagon Geospatial is focused on developing leading-edge technology that is easily 
configurable. Through extensible, scalable and collaborative products, we enable you to 
transform multi-source content into dynamic and actionable information. We are constantly 
re-conceptualizing and improving our products. 

PARTNERS. As an organization, we are partner-focused, working alongside our channel to 
ensure we succeed together.   We provide the right tools, products and support to our business 
partners so that they may successfully deliver sophisticated solutions for their customers.  We 
recognize that we greatly extend our reach and influence by cultivating channel partner 
relationships both inside and outside of Hexagon.   

TEAM. As an employer, we recognize that the success of our business is the result of our highly 
motivated and collaborative staff.  At Hexagon Geospatial, we celebrate a diverse set of people 
and talents; and we respect people for who they are and the wealth of knowledge they bring to 
the table. We retain talent by fostering individual development and ensuring frequent 
opportunities to learn and grow.    

HEXAGON. Hexagon Geospatial plays a key role in Hexagon’s multi-industry focus, leveraging 
the entire portfolio for a wide variety of geospatial needs. Hexagon is a leading global provider of 
design, measurement and visualization technologies.  Synergistic thinking is encouraged 
across all levels and functions at Hexagon companies, so that we all respond better and faster 
to our shared customer’s needs. 

For more information, visit www.hexagongeospatial.com (http://www.hexagongeospatial.com) 
and www.hexagon.com (http://www.hexagon.com). 

http://www.hexagongeospatial.com/
http://www.hexagon.com/
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DEM to Watershed Tutorial 

Delineating Watersheds with Grid Analysis 

According to Wikipedia, a watershed or drainage basin is an extent or an area of land where 
surface water from rain and melting snow or ice converges to a single point, usually the exit of 
the basin, where the waters join another water body, such as a river, lake, reservoir, estuary, 
wetland, sea, or ocean. 

The drainage basin acts as a funnel by collecting all the water within the area covered by the 
basin and channeling it to a single point. Each drainage basin is separated topographically from 
adjacent basins by a geographical barrier, such as a ridge, hill, or mountain. 
 

Tutorial Introduction 

This tutorial demonstrates a typical workflow used for a hydrological analysis of a drainage 
basin. Employing a Digital Elevation Model (DEM) source layer, you will delineate stream 
networks in a basin. Hints on using Grid Analysis commands for other types of hydrological 
analysis are included throughout. 

Topics covered in this tutorial include: 

 Opening a GeoMedia GeoWorkspace 

 Importing a source DEM 

 Delineating a sub-basin 

 Using the Fill Depressions, Downhill Path, and Downhill Accumulation commands 

 Modifying results using the Grid Edit window tools 

 Using the Recode and Segmentation commands 

 Using the Sub-Basin Delineation command 

 Vectorizing results to a feature class 

 

Tutorial Text Conventions 

There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb panel, click Ccc > Ddd. 

 Dialog box names, field names, and button names are depicted using Bolded Text. 

 Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 
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Data Set 

The data set for this tutorial is located in the folder C:\Grid Analysis Tutorials\Introductory 
Tutorials\DEM to Watershed. The data is a DEM of Moontown, Alabama, with a cell resolution of 
30 meters. 

This data was produced by the U.S. Geological Survey (USGS) as part of the National Mapping 
Program.* 

* The provision of U.S. Geological Survey data does not imply sanctioning by the USGS 
and does not constitute an endorsement of Intergraph Corporation or its products. 
 

How This Tutorial Should Be Used 

This tutorial shows how Grid Analysis commands can be used in drainage-basin analysis. To 
use the tutorial most effectively, you should have a good working knowledge of GeoMedia 
Desktop and have completed the Learning to Use Grid Analysis introductory tutorial. 
 

Data Preparation 

Opening a GeoWorkspace 

Grid Analysis is completely integrated with the GeoMedia Desktop and is available when 
GeoMedia Advantage or GeoMedia Professional tiers are used. Grid Analysis commands are 
located on the Grid tab within the GeoMedia Desktop ribbon bar. 

To begin this tutorial: 

1. Launch GeoMedia Desktop, and choose Open existing GeoWorkspace from the Welcome 
menu. 

2. Double click the More Files… option, and browse to \Grid Analysis Tutorials\Introductory 
Tutorials\DEM to Watershed\DEM to Watershed.gws, and click Open. 

3. If a GeoMedia error message requests the name of the database file, browse to \Grid 
Analysis Tutorials\Introductory Tutorials\DEM to Watershed\DEM.mdb, click Open, and click 
OK in the error message box. 

The display will show an empty Map window. This is because the Warehouse does not currently 
contain any vector data. The GeoWorkspace coordinate system has been set to Universal 
Transverse Mercator, North American Datum 1927, which matches that of the DEM that will be 
imported. If desired, the coordinate system can be checked using the Home tab, in the 
Properties and Information panel, Coordinate System entry. 
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Importing a DEM 

Grid Analysis requires an active Study Area. When a grid layer is imported, a new Study Area is 
automatically defined and made active. 

1. On the Grid tab, in the Study Area panel, click Import. 

2. Click Browse, navigate to \Grid Analysis Tutorials\Introductory Tutorials\DEM to 
Watershed\Moon Town\9894CATD.DDF, and click Open. 

3. Click Next > to import the selected file. 

4. A dialog box appears showing the current read-write connection DEMs. 

5. Expand the list hierarchy. 

6. Inside the DEMs connection is a Study Area named by default Study Area 1 containing the 
Moontown, AL – 24000 layer. 

7. Click Next >. 

8. A final dialog box appears with a report giving information about the imported layer and the 
new Study Area. 

9. Click Finish to conclude the import process. 

To display a list showing the new Study Area and grid layer, choose the List entry on the Grid 
tab in the Study Area panel. Notice that the field at the top of the Study Area List window 
shows that the new Study Area Study Area 1 is active. 
 

Displaying a Grid Layer 

Note that the imported grid layer does not appear in the Map window. To display the grid layer: 

1. On the Grid tab, in the Layer panel, click Display. 

2. Select MOONTOWN, AL – 24000 and click OK. 

3. On the Home tab, in the Extent panel, click Fit All to adjust the viewing area of the Map 
window to show the entire grid layer. 

 

Editing a Grid Layer 

The Edit window is used to view a grid layer and its legend. It can also be used to alter cell 
colors and values and to visually group together ranges of zones. 

1. On the Grid tab, in the Layer panel, click Edit. 

2. In the Edit Raster Layer dialog box, select MOONTOWN, AL - 24000. Click Edit to display 
the layer in the Edit window. 

3. Click and drag the Legend window to the side of the layer, and expand it to show three 
columns: the cell colors, cell values, and number of cells in each zone. 
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4. Click the Query Raster Values tool  and move the pointer over the grid layer. Hold 
down the left mouse button to display a 5-by-5 matrix of values under the pointer. Scan 
across the layer. The cell values represent elevation above sea level, in meters. 

 

HINT:  Sometimes DEM grid layers have cells with the value VOID. VOID is a special value 
that usually indicates an absence of data. When there are a significant number of VOID cells 
in a DEM layer, they can be "filled" (given non-VOID values) using one of the interpolation 
commands. The DEM used in this tutorial has very narrow wedges of VOID cells along all 
four sides; these will not adversely affect the grid analysis. 

5. In the Legend window, click on the second legend entry (the one below VOID). Hold down 
the Shift key on the keyboard, scroll the Legend window to the end, and click the last entry. 
All the entries except VOID will be selected and highlighted. 

6. Position the mouse pointer over the Legend window, right click to display the context menu, 
and choose Color Sequence. A different color sequence can allow for better visual 
evaluation of the layer. In particular, a sequence with a lot of contrast will make it easier to 
find "pits" or "holes" in the layer. 

7. Use Color Sequence to assign various color sequences to the grid layer. Experiment with 
different start and end colors, with different path choices, and with different color 
distributions to find a sequence with maximum color contrast. 
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8. Examine the grid layer, and look for discontinuities in the surface. Change the zoom level as 
necessary. 

9. When done, close the Edit window. When prompted to save changes, click No. 

Grid analysis commands will be used to process the DEM data and create a grid layer showing 
the sub-basins, or watershed, in the Study Area. Each grid command will create a new grid 
layer. 
 

Grid Analysis - Sub-Basin Delineation 

Using the Fill Depressions Command to Remove Depressions from the Surface 

The Fill Depressions command removes depressions from a surface layer. This is useful for 
hydrologic modeling, as anomalous depressions (such as those made more visible by applying 
the high-contrast color sequence) can impede modeling of water flow direction. Grid cells 
representing a depression are given a value equal to the lowest value at the edge of the 
depression, creating a smoother surface. 

The Fill Depressions command executes in an iterative fashion, making several logical sweeps 
over the layer surface and filling depressions gradually. The progress bar at the bottom of the 
window tracks the progress of these sweeps. 

1. On the Grid tab, in the Analysis panel, click Surface > Fill Depressions. 

2. For the Source layer, enter MOONTOWN, AL – 24000. 

3. For the Result layer type Filled DEM. 
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4. Clear the Place results in map window check box. 

 

5. Click OK to execute the command and to close the dialog box. This may take a few 
moments. 

6. Notice that the new grid layer now appears in the Study Area List window. 
 

Using the Calculator Command to Locate Differences 

The Calculator is used for Layer or Overlay Math. It allows you to perform mathematical 
operations and functions involving grid layers and constants. The calculator functions are 
performed on the individual cell values of the specified grid layer(s). For example, if a grid layer 
is multiplied by 1000, each cell in the input grid layer is multiplied by 1000. If one grid layer is 
subtracted from another, the operation is performed on all cells common to both layers. 

The layer "Filled DEM" will be subtracted from the original layer "MOONTOWN, AL – 24000," 
creating a new layer that, by showing the difference between the layers, shows the depressions 
that were filled. 

1. On the Grid tab, in the Analysis panel, click Calculator. 

2. Enter the statement: "Filled DEM" - "MOONTOWN, AL – 24000". Enter the layer names by 
double clicking them in the layer list, and enter the subtraction symbol by clicking the 
appropriate calculator button. 

3. Name the Result Layer Comparison. 

4. Clear the Place results in map window check box. 

5. Click OK. 
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6. When the command has executed, display the result layer, Comparison, in the Grid Edit 
window. 

 

7. Use the Query Raster Values tool  to examine the cell values. 

8. In the Legend window, examine the cell values and the number of cells in each zone. 

The cell values in this layer do not represent elevation above sea level, but rather the 
elevation differences between corresponding cells in MOONTOWN, AL – 24000 and Filled 
DEM. The differences range from 0 to 15 meters and show the depth and number of 
depressions filled. 

Note that the DEM used in this tutorial is for demonstration purposes only and therefore has 
a fairly coarse resolution. Higher resolution data would result in significantly fewer 
anomalous depressions. 

9. When done, close the Edit window. When prompted to save changes, click No. 
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Using the Downhill Path Command to Determine Flow Directions 

The Downhill Path command generates a grid layer of downhill flow path directions. Each cell 
value represents the steepest downhill direction from that cell. Multiple downhill directions (ties) 
are possible. 

Downhill Path produces a map layer in which the value of each cell represents the direction of 
the steepest downhill path. When applied to a depressionless DEM, Downhill Path returns one 
of nine values for each cell. Cardinal flow directions are represented by 1=E, 2=SE, 4=S, 8=SW, 
16=W, 32=NW, 64=N, and 128=NE and 0=No Flow. 

1. On the Grid tab, in the Analysis panel, click Surface > Downhill Path. 

2. For the Source layer, enter Filled DEM. 

3. Click the radio button for Hydrological Flow. 

4. Clear the Remove single cell pits and spikes in surface layer check box. 

5. Name the Result layer Flow Direction. 

6. Make sure the Return option Steepest path is selected and that Place results in map 
window is checked. 

 

7. Click OK. Note the change in the Map window. 

8. Display the result layer, Flow Direction, in the Grid Edit window. 

Note the dramatic visual effect of the flow direction layer. To make one specific flow 
direction stand out, change the color of that zone. 

9. In the Legend window, select the value 16 by clicking on it. 

10. Right click on the legend entry to display the context menu, and select Change Color(s). 
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11. Using the Color Picker, select a bright color that will contrast well with the grays of the 
layer. 

12. Click OK. 

13. Use the Query Raster Values tool  to examine the values in the grid layer. Values are 
cardinal flow directions. Flow direction can also be represented graphically. 

 

14. Click the Show/Hide Path Direction Arrows button . Use the Query Raster Values 

tool  again. Path direction arrows will be displayed in place of cardinal values. 
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15. Click the Zoom Ratio  button, and select a zoom ratio of 1:16. Path direction arrows 
can now be viewed for the entire layer. 

 

16. Click the Pan button . The mouse pointer will turn into a hand icon. Click and drag to 
move the layer within the viewing area. 

  Grid editing tools can be used to change the value of individual cells or groups of 
cells. Changing cell values also changes the flow direction for those cells. 

17. Click the Eye Dropper drawing tool . This tool is used to assign the color and value of a 
selected grid layer cell to one of the grid drawing tools. 

18. Click the Eye Dropper tool on a cell with value "16." The value and color of that cell are now 
shown in the Draw Color and Draw Value fields at the top of the Edit window 

. 

19. Click to select the Draw Freehand tool . 

20. Click the tool on a cell with a value that is not "16." The cell color and value will change. 

21. Click the Redraw Raster Layer button  to display the flow direction arrow showing the 
new flow direction resulting from the changed value. 

22. Close the Edit window without saving changes to the grid layer. 
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Although the grid editing tools can be used on any grid layer, in formal analysis it is preferable to 
make any data adjustments in the original DEM layer. 
 

Using the Downhill Accumulation Command to Calculate Flow Accumulations 

The Downhill Accumulation command uses a flow direction grid layer of cardinal flow direction 
values to generate a flow accumulation layer. The command assigns each cell a value equal to 
the number of cells on a direct uphill path from that cell. Cells in the flow direction layer with a 
value of "0" are considered to be stream outlets or sinks. 

The upstream drainage area of a given cell can be calculated by multiplying the cell’s flow 
accumulation value by the cell area. 

1. On the Grid tab, in the Analysis panel, click Surface > Downhill Accumulation. 

2. From the drop-down list, enter Flow Direction as the Source Layer. 

3. Name the Result Layer Downhill Accumulation. 

4. Leave Place results in map window checked. 

 

5. Click OK. 

6. For a closer look, display the result layer, Downhill Accumulation, in the Grid Edit 
window. 

7. Use the Query Raster Values tool  to examine the cell values of the streams and 
surrounding area. 

8. Each cell value is the number of cells draining into that cell. 
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HINT:  Problems in the original DEM often become apparent in a Flow Accumulation layer. 
For example, this tutorial layer contains at least one instance of parallel streams, a 
circumstance that could indicate a potential problem. The parallel streams of interest are 
shown just above the Query Raster Values tool icon in the graphic to the right. 

 

9. Zoom to a ratio of 1:16 and locate the parallel streams. 

10. Use the Query Raster Values tool  to examine the cell values. 

HINT:  The Downhill Accumulation grid layer can be useful for identifying and evaluating 
problem areas. However, any data corrections should be made to the original DEM, and the 
analysis sequence should be re-run in order to avoid creating data issues. 

 

A flow accumulation layer can be used to determine "when a stream becomes a stream". 
Assigning different colors to groups of cell values can make visual analysis easier. 



DEM to Watershed Tutorial 

 

 

19 

 

11. Expand the Legend window to view the cell colors, values, and number of cells in each 
zone. 

Note that the largest zone, with the greatest number of cells, has a value of "0" - no cells 
flow into these cells. These cells represent local topographic highs. The cells with high 
values represent major streams into which many cells flow. 

12. Change the zoom ratio to 1:1. 

13. Using the Query Raster Values tool , examine the cell values near the ends of visible 
streams on the Downhill Accumulation layer. These values should be approximately 2100. 

14. In the Legend window, click the zone with a value of 2101; then scroll down and shift-click 
on the last legend entry. 

15. Right click on the Legend window to open the context menu, and choose Group Selection. 
The selected legend entries will be grouped together as a single legend entry with one color. 
The cell values will be unaffected. 

16. Click on the grouped entry’s color element to show the Color Palette. Select bright yellow. 

 

If the Value column in the legend is not wide enough to display the contents, right click 
inside the Legend window and select Format… for legend formatting options.  Click on the 
Value column name so that the sizing handles appear, and then resize the column as 
needed. 

17. Click on the Value column name so that the sizing handles appear, and then resize the 
column as needed. 

18. Click the Save button  in the Edit window to save this layer and its grouped legend; 
then close the Edit window. 
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  The stream threshold value of "2101" was arbitrarily assigned for this tutorial. In a real 
analysis, ground verification should be used to check that whatever threshold numbers are used 
are an accurate reflection of the drainage patterns in the particular Study Area. 
 

Using the Recode Command to Extract a Drainage Network 

The Recode command has two main functions: explicit value extraction and explicit value 
reassignment. It generates a result layer in which each cell is assigned a specific value based 
on its value in the source layer. This command is often used in layer editing. 

When the legend entries were grouped in the previous section, the underlying cell values were 
unaffected. Recode can be used to create a grid layer with different cell values, in which all 
stream network cells have the value "1" and other cells are "VOID." 

1. On the Grid tab, in the Analysis panel, click Classification > Recode. 

2. From the drop-down menu, select Downhill Accumulation as the Source Layer. 

3. Enter 1 in the first Assigning value field and 2101… in the corresponding To value field. 
Do not forget the ellipsis (three dots) after 2101.This will assign the value "1" to cells having 
value 2101 and greater. 

4. Press Enter to enter the value fields. 

5. Name the Result Layer Drainage Network. 

6. Clear the Place results in map window check box. 

 

7. Click OK. 

8. Use the Grid Edit window to check the result. The Legend should contain only the values 
VOID and 1. 
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9. Close the Edit window without saving. 

 
 

Using the Segmentation Command to Assign Unique Values to Stream Segments 

The Segmentation command assigns a unique value to each segment of a stream network. 
Stream segments are sections of a stream that connect a headwater and a junction, a junction 
to a junction, a junction to an outlet, or a headwater to an outlet. A junction cell is one into which 
two or more cells flow. An outlet cell is one that has no outflow, or which flows either into a VOID 
cell or off the grid layer. A headwater cell is a cell into which no neighbors flow, but which flows 
out into a neighbor. 

Two input grid layers are required: a drainage network layer, and a flow direction layer.  

  Complex watersheds can have a very large number of segments. 

1. On the Grid tab, in the Analysis panel, click Path > Segmentation. 

2. From the drop-down menu, select Drainage Network as the Source Layer. 

3. Select Flow Direction as the Flow Direction Layer. 

4. Name the Result Layer Segmented Network. 

5. Clear the Place results in map window check box. 

 

6. Click OK. 

7. Display the result layer, Segmented Network, in the Grid Edit window. 

View the Legend window and note that each stream segment has been assigned a unique 
identifying value. There should be 41 stream segments in this layer. Each segment is a 
different shade of gray. Assigning different colors to some of the stream segments will make 
them easier to see and distinguish. 



DEM to Watershed Tutorial 

 

 

22 

 
 

8. Using the Query Raster Values tool , examine the Segmented Network layer to 
choose several zones to re-color. 

9. For each stream segment to be re-colored, click the color element of the corresponding 
legend entry, and use the Color Palette to choose a new color. You may also select a range 
of legend values. Right click in the Legend window, select Change Colors, and use the 
Color Picker to color the range. 

10. When finished, save changes to the grid layer, and close the Edit window. 

HINT:  Another way to achieve meaningful visualization of stream segmentation is to select 
groups of legend entries and assign color sequences to each group (select a range of entries, 
right click in the Legend window, and select Color Sequence). The sequences can be chosen 
for contrast or to indicate progressions. 

 
 

Using the Sub-Basin Delineation Command to Create Watersheds 

The Sub-Basin Delineation command defines the watershed (or sub-basin) for each segment 
in a network grid layer by identifying all cells that are directly uphill from the stream segment. 

Two input grid layers are required: a segmented stream network layer and a flow direction layer. 

1. On the Grid tab, in the Analysis panel, click Surface > Sub-Basin Delineation. 

2. From the drop-down menu, select Segmented Network as the Source Layer. 

3. Select Flow Direction as the Flow Direction Layer. 

4. Name the Result Layer Watersheds. 
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5. Leave Place results in map window checked. 

 

6. Click OK. 

The resulting grid layer, which now appears in the Map window, is the end product of the 
sub-basin delineation analysis. 

The Watershed layer shows each sub-basin as a different shade of gray. A color sequence 
with more contrast will improve visualization. 

7. On the Grid tab, in the Layer panel, click Edit, select the layer Watersheds, and click Edit. 

8. Use the Legend window to apply a new color sequence to all the non-VOID values in the 
Watershed layer. Try different combinations of colors and paths to find one that provides 
maximum contrast. 

9. Save the changes made to the grid layer, and close the Edit window. Your work will be 
visible in the Map window. 
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Once the watersheds (basins) have been created, a number of basin parameters can be 
calculated. For example, the area of each sub-basin can be computed or the length of the 
stream segments, either in each sub-basin or in the entire Study Area, can be calculated. 
 

Feature Class Generation 

The Vectorize to Feature Class command converts grid information into a point, line, or area 
feature class, which is stored in the same connection as the current Study Area. Vectorized 
features classes can be styled, edited, and viewed in GeoMedia Desktop, exported to other 
applications, used to update data in the warehouse, or used to build queries. 
 

Using the Vectorize to Feature Class Command to Generate River Features 

1. On the Grid tab, in the Layer panel, click Vectorize to Feature Class. 

2. Select Segmented Network from the Layer name list. 

3. Choose Conversion type: Line. 

4. Accept the default Feature Class Name. 

5. Click OK. 

6. Maximize the GeoWorkspace Map window. Note that the new feature class is not yet 
displayed in the GeoWorkspace legend. 

7. On the Home tab, in the Legend panel, click Add Legend Entries. 

8. In the Add Legend Entries dialog box, select Segmented_Network_V1. 

9. Click OK. The name of the feature class – Segmented_Network_V1 – appears in the Map 
window’s legend, and the new feature class is placed in the Map window. 
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Using the Vectorize to Feature Class Command to Generate Watershed Features 

1. On the Grid tab, in the Layer panel, click Vectorize to Feature Class. 

2. Select Watersheds from the Layer name list. 

3. Choose Conversion type Area. 

4. Choose Output type Non-Partitioned Boundary. 

5. Accept the default Feature Class Name. 

 

6. Click OK. 

7. On the Home tab, in the Legend panel, click Add Legend Entries. 

8. In the Add Legend Entries dialog box, select Watershed_V1. 

9. Click OK. The Watershed_V1 feature class will appear in the Map window’s legend, and 
the new feature class is placed in the Map window. 

 

HINT:  The watershed feature classes can be used to compute a number of basin 
parameters. The area of each sub-basin can be computed, or the length of the stream 
segments either in each sub-basin or in the entire Study Area can be calculated. 

10. To end the tutorial, close GeoMedia Desktop, and click No when prompted to save changes. 
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