
 

 

Learning to Use Grid Analysis 
- A Tutorial: 
Using the Elevation Workbench 

 

Version 16.5 
 

May 2019 
 

 
 

 

 

  

 

 



 

 

Copyright 

© 2006-2019 Intergraph® Corporation and/or its affiliates. Hexagon Geospatial is a part of Intergraph. All Rights Reserved.  

Warning:  This computer program, including software, icons, graphical symbols, file formats, and audio-visual displays; may be 
used only as permitted under the applicable software license agreement; contains confidential and proprietary information of 
Intergraph and/or third parties which is protected by patent, trademark, copyright and/or trade secret law and may not be 
provided or otherwise made available without proper authorization. 

Copyright for the Canadian National Transformation Version 2 Software: ©1995. Her Majesty the Queen in Right of Canada, 
represented by the Minister of Natural Resources. Produced under license from Her Majesty the Queen in Right of Canada, 
represented by the Minister of Natural Resources. Software based on the National Transformation Version 2 developed by 
Geodetic Survey Division, Geomatics Canada. 

Copyright for Dynamap/2000 ©2002-2005 Tele Atlas North America, Inc. This product contains proprietary and confidential 
property of Tele Atlas North America, Inc. Unauthorized use, including copying for other than testing and standard backup 
procedures, of this product is expressly prohibited. 

The labeling engine used by this product is from MapText, Inc. – Copyright © 1997-2014 MapText, Inc. 

Code for doing JPEG software compression and decompression is based in part on the work of the Independent JPEG Group, 
Copyright © 1991-1998, Thomas G. Lane.  

Code for handling GeoTIFF files is based in part on LibTIFF and LibGeoTIFF, Copyright © 1988-1997 Sam Leffler 

Copyright © 1991-1997 Silicon Graphics, Inc. 

Copyright © 1995 Niles D. Ritter 

Code for handling "Deflate" compression in GeoTIFF files is based on zlib, Copyright © 1995-1996 Jean-loup Gailly and Mark 
Adler 

MrSID, MrSID Decompressor, and the MrSID logo are trademarks of LizardTech, Inc. used with permission. Portions of this 
computer program are copyright ©  1995-1998 LizardTech. All rights reserved. MrSID is protected by U.S. Patent No. 
5,710,835. Foreign Patents Pending. Unauthorized use or duplication prohibited. 

Code for doing JPEG 2000 compression and decompression is based on Kakadu software, Copyright © 2001-2008, David 
Taubman, UNSW 

Portions copyright © Microsoft Corporation. All rights reserved. 

Portions copyright © Blue Sky Software Corporation. All rights reserved. 

This product uses libpng version 1.2.12 - June 27, 2006 

Copyright (c) 1998-2002 Glenn Randers-Pehrson 

Copyright (c) 1996-1997 Andreas Dilger 

Copyright (c) 1995-1996 Guy Eric Schalnat, Group 42, Inc.  

No warranty is expressed or implied by the holders of these copyrights. Please contact Intergraph with any problems with our 
implementation of this third party code. The copyright holders are not responsible for problems in our implementation. 

Restricted Rights Legend 

Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) of the Rights in 
Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c) (1) and (2) of Commercial 
Computer Software -- Restricted Rights at 48 CFR 52.227-19, as applicable. 

Unpublished - rights reserved under the copyright laws of the United States. 

Terms of Use 

Use of this software product is subject to the End User License Agreement ("EULA") delivered with this software product unless 
the licensee has a valid signed license for this software product with Intergraph Corporation. If the licensee has a valid signed 
license for this software product with Intergraph Corporation, the valid signed license shall take precedence and govern the use 
of this software product. Subject to the terms contained within the applicable license agreement, Intergraph Corporation gives 
licensee permission to print a reasonable number of copies of the documentation as defined in the applicable license agreement 
and delivered with the software product for licensee's internal, non-commercial use. The documentation may not be printed for 
resale or redistribution. 

Warranties and Disclaimers 

All warranties given by Intergraph Corporation about software are set forth in the EULA provided with the software or with the 
applicable license for the software product signed by Intergraph Corporation, and nothing stated in, or implied by, this document 
or its contents shall be considered or deemed a modification or amendment of such warranties. Intergraph and its suppliers 
believe the information in this publication is accurate as of its publication date. 



 

 

The information and the software discussed in this document are subject to change without notice and are subject to applicable 
technical product descriptions. Intergraph Corporation and its suppliers are not responsible for any error that may appear in this 
document. 

Trademarks 

Intergraph, the Intergraph logo, and GeoMedia are registered trademarks of Intergraph Corporation.  Hexagon and the Hexagon 
logo are registered trademarks of Hexagon AB or its subsidiaries.  Microsoft and Windows are registered trademarks of 
Microsoft Corporation.  Bing is a trademark of Microsoft Corporation. Google Maps is a trademark of Google Incorporated. 
Pictometry Intelligent Images is a registered trademark of Pictometry International Corporation. ERDAS, ERDAS IMAGINE, 
Stereo Analyst, IMAGINE Essentials, IMAGINE Advantage, IMAGINE Professional, IMAGINE VirtualGIS, Mapcomposer, 
Viewfinder, and Imagizer are registered trademarks of Intergraph Corporation. 

Other brands and product names are trademarks of their respective owners.  

 



 

 

Learning to Use Grid Analysis - A Tutorial: Using the Elevation Workbench 4 
 
 

Contents 
Processing a Large Collection of Elevation Files .................................................................................... 5 

Preparing Data for Use with Grid Analysis ............................................................................................. 5 
Tutorial Introduction .......................................................................................................................... 5 
Tutorial Text Conventions ................................................................................................................ 5 
Data Set ............................................................................................................................................ 6 
How This Tutorial Should Be Used .................................................................................................. 6 

Data Preparation ..................................................................................................................................... 6 
Opening a GeoWorkspace ............................................................................................................... 6 
Create Elevation Footprints .............................................................................................................. 7 
Reviewing Attributes ......................................................................................................................... 9 

Creating a Single Unified DEM for a Collection of Elevation Footprints ............................................... 10 
Defining Input Files and Filters ....................................................................................................... 10 
Interpolating Unknown Values ........................................................................................................ 11 
Saving Elevation Workbench Layers to a Study Area .................................................................... 12 
Saving a Workflow .......................................................................................................................... 13 

  



 

 

Learning to Use Grid Analysis - A Tutorial: Using the Elevation Workbench 5 
 

Preparing Data for Use with Grid Analysis 

Tutorial Introduction 
As illustrated in the Import to Mosaic to Project tutorial, Grid Analysis users can use the Import 
File(s) command to prepare elevation files for use with Grid Analysis commands, and, once 
imported, the Mosaic command can then be used to piece together individual input files to 
create one contiguous surface. However, for those users wishing to process large collections of 
elevation data, it is recommended that the Create Elevation Footprints command be used in 
tandem with the Elevation Workbench command. These commands effectively streamline the 
import process and ultimately provide the user with greater flexibility and scalability. 

The aim of this tutorial is to demonstrate how to make use of the Create Elevation Footprints 
and Elevation Workbench commands. Topics covered in this tutorial include: 

▪ Opening a GeoMedia GeoWorkspace  

▪ Creating a collection of footprints from elevation files  

▪ Using the elevation footprints to import, mosaic, process, and save elevation data to a Study 
Area 

  Before using the Elevation Workbench command, it is recommended that you disable 
the warehouse caching option to avoid potentially incorrect results. The warehouse caching 
option is found on the GeoMedia Options command > General tab. Make sure that the Enable 
caching check box is unchecked. 
 

Tutorial Text Conventions 

There are several conventions used throughout the tutorial: 

▪ Ribbon bar items are shown as: On the Aaa tab, in the Bbb panel, click Ccc > Ddd. 

▪ Dialog box names, field names, and button names are depicted using Bolded Text. 

▪ Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 

 

Processing a Large Collection of 
Elevation Files 
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Learning to Use Grid Analysis - A Tutorial: Using the Elevation Workbench 6 
 

Data Set 
The data set for this tutorial is located in the folder \Grid Analysis Tutorials\Introductory 
Tutorials\Elevation Workbench\Huntsville SDTS Files. The data consists of six SDTS DEM 
layers. 

The DEM layers are referenced to Universal Transverse Mercator (UTM) projection, Zone 16 
coordinates, North American Datum of 1983 and have a resolution of 10 meters. Cell values 
give elevation in meters above sea level. The layers represent the USGS map sheets of Triana, 
Farley, New Hope, Madison, Huntsville, and Moontown. These data were produced by the U.S. 
Geological Survey (USGS) as part of the National Mapping Program. 

  The provision of U.S. Geological Survey data does not imply sanctioning by the USGS 
and does not constitute an endorsement of Intergraph Corporation or its products. 
 

How This Tutorial Should Be Used 

This tutorial is intended for those interested in using Grid Analysis commands to tile together 
multiple DEM files into a contiguous DEM. To use the tutorial effectively, you should be familiar 
with GeoMedia Desktop and have worked through the Learning to Use Grid Analysis  
introductory tutorial. 
 

Data Preparation 

Opening a GeoWorkspace 

The Grid Analysis commands are located in the Grid tab in the ribbon bar. 

1. Launch GeoMedia Desktop, and choose Open an existing GeoWorkspace from the 
Welcome menu. 

2. Double click the More Files… option, browse to \Grid Analysis Tutorials\Introductory 
Tutorials\Elevation Workbench\Import.gws, and click Open. 

3. If a GeoMedia error message requests the name of the database file, browse to \Grid 
Analysis Tutorials\Learning Grid Analysis\Elevation Workbench\UrbanArea.mdb, click Open, 
and click OK in the error message box. 

A GeoMedia Map window and its associated legend will open, displaying basic urban features of 
the City of Huntsville. 
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Create Elevation Footprints 
The Create Elevation Footprints command has been developed so that users can create a 
large number of footprints from an existing collection of elevation files. Specifically, the Create 
Elevation Footprints command creates footprint features from the data contained in elevation 
files and inserts them into a GeoMedia feature class. Users can then make use of these footprint 
features inside the Elevation Workbench command and other commands within the GeoMedia 
Desktop suite of products. 

In this tutorial, six SDTS DEMs will be used. SDTS is the acronym for Spatial Data Transfer 
Standard. This standard defines a non-proprietary format for spatial data and associated 
attributes and metadata. It is intended primarily for spatial data product distribution and 
archiving.  

1. On the Grid tab, in the Utilities panel, click Grid > Create Elevation Footprints. 

  The Create Elevation Footprints command allows you to create elevation 
footprints for a collection of elevation files. The created footprint features are placed into a 
new GeoMedia Area feature class. 

2. Click Search to display the Search for Files dialog box. 

3. Click Browse, navigate to \Grid Analysis Tutorials\Introductory Tutorials\Elevation 
Workbench\Huntsville SDTS Files, and click Open. 

4. Use the Files of type drop-down list to select the file filter USGS SDTS (*.catd). 

5. Click Start Search. 

  Once the Start Search button is clicked, the search process will begin. The Start 
Search button text will be changed to Stop Search while a search is in progress. All 
controls on the dialog box will become disabled except for the Stop Search button and the 
Cancel button. 

Any files that are found during the search process will become populated in the Files data 
view. The progress of the search can be viewed in the GeoMedia status bar. In this 
particular case, the system should find six files: 

▪ \Farley\9658CATD.ddf,  

▪ \Huntsville\9658CATD.ddf,  

▪ \Madison\9658CATD.ddf,  

▪ \Moontown\9658CATD.ddf,  

▪ \New Hope\9658CATD.ddf, and 

▪ \Triana\9658CATD.ddf. 
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Once the search has completed, click Check All to specify that you want all six files to be 
included in the footprint creation process. Your dialog box should look similar to the example 
provided below. 

 

1. Click OK. 

  The OK button dismisses the Search for Files dialog box and adds all checked files 
to the Input Files list view on the main dialog box. In this particular case, all of the checked 
files have an internal coordinate system and therefore can be used by the create footprint 
process without having to specify any additional parameters. For further information on how 
to use files that do not carry coordinate information, see the GeoMedia Help Topics. 

2. Use the Connection drop-down list to select Urban Areas. 

3. Type SDTS_10M_Elevation_Footprints into the Feature class text box. 

4. Ensure that Display feature class in map window is checked. 

The Create Elevation Footprints dialog box should look like the example provided below. 

  

5. Once your Create Elevation Footprints dialog box looks like the example above, click OK. 

  Clicking the OK button starts the footprint creation process. This button is initially 
disabled and is only enabled when all required settings have been selected or entered on 
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the dialog box. All files in the Input files grid are processed regardless of whether they are 
selected.   

While the footprint creation process is in progress, the Create Elevation Footprints 
command main dialog box will remain visible, and the cursor representation changes to a 
pointer with an hourglass. This is done so that you can easily select the Cancel button. 
Progress will be indicated in the following three ways.   

One, as each file is being processed, the status column in the Input Files grid is updated with 
one of three icons: 

▪   Shows that this file is currently being processed  

▪   Shows that an error occurred converting this file 

▪   Shows that this file was successfully converted 

Two, the status area (lower-left corner of GeoWorkspace window) is updated to reflect the 
number of records processed. This indicator, unlike the icons and progress bar, reflects the 
overall progress for the entire footprint creation process. Specifically, this indicator contains the 
total record count and a count value to represent how many of the records have been 
processed. This status area uses the format “Creating Footprint XXXXX of XXXXX” and is sent 
an update for every 100 footprints created.   

Three, the progress indicator (middle right of the GeoWorkspace window) provides a graphical 
representation of the footprint creation process. Upon processing all of the files, a summary log 
is presented to the user. 
 

Reviewing Attributes 
As noted above, the Create Elevation Footprints command creates an area-based feature 
class. This feature class contains attribution. 

1. On the Home tab, in the Selection panel, click Select. 

2. Move your cursor over one of the newly imported footprints and double click to display the 
Properties dialog box for the feature. 

  

  The critical piece of information in this case is the FileName because this attribute 
contains a pointer to the location on disk where the source file is located. This information is 
used by the Elevation Workbench command to locate the related file for processing. If you 
change the location of the source file, you will have to re-run the create elevation footprints 
process or update this attribute to reflect the new location. 

3. Click OK. 
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Creating a Single Unified DEM for a Collection of 
Elevation Footprints 

Defining Input Files and Filters 
The Elevation Workbench command is a modeless dialog box; therefore, it works 
independently of the feature selection process. Specifically, you can use the selection tool within 
GeoMedia Desktop to select the footprints in tandem with using the Elevation Workbench 
command.  

The process of defining input for the Elevation Workbench command is as follows:  select the 
footprint or footprints you want to process, activate the Elevation Workbench command, and 
then choose either the Tools > Source Data > Load from the Selected Footprints command 
or the Tools > Source Data > Refresh from the Selected Footprints command. In this section, 
you will learn how to use both the load and refresh options. 

1. On the Grid tab, in the Analysis panel, click Elevation Workbench. 

2. Move the Elevation Workbench dialog box to the upper-left region of your window to 
ensure that it does not cover up any of the elevation footprint features. 

3. On the Home tab, in the Selection panel, click Select. 

4. Use the selection tool to draw a fence around all six elevation footprint features. 

  In this particular case, all of the other features in the GeoMedia Map window have 
been place in the legend with the Location property set to Locatable Off. This condition 
ensures that only the elevation footprint feature get selected while drawing the selection 
fence. 

  The footprint selections do not need to be adjacent to one another nor do they need 
to be contiguous; however, interpolating large open areas is not recommended because 
interpolations of this size (not containing any source data) are not likely to yield quality 
results. If you want to process areas that are not adjacent or contiguous, it is recommended 
that you process each patch using separate processing chains. 

  The order in which the footprint features are selected can change the results of 
processing. The data units of the first elevation file selected are used to normalize elevation 
values of all subsequent elevation files processed. For example, assume that a select set of 
elevation footprints is contained within four files, two of which have data units of feet, and 
two of which have data units of meters. If the first elevation file selected has data units of 
feet, the resulting surface will contain cell values expressed in feet (in other words, the files 
containing meters would be converted to feet to ensure data value consistency across the 
new surface). 

  When using fence selects, be aware that the processing order of features may vary 
depending on whether you have employed the use of the Index Feature Cache (IFC). When 
using a fence select with IFC turned off, the order in which features are processed is the 
same as the order in which they are read from a file or database table. When IFC is turned 
on, the order of the features is adjusted to spatially optimize performance, and this ordering 
is not guaranteed to match that of the features in a file or database table. 

5. Click anywhere within the Elevation Workbench dialog box to enable it. 
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6. Choose Tools > Source Data > Load from Selected Footprints and the Elevation 
Workbench dialog box will update to reflect this step in the process chain. 

  Unlike other steps within a process chain, the Source selection step will always be 
the first step in the chain and therefore it cannot be moved from this position. In this 
example, all six elevation data sources will be considered for processing. 

7. Click Refresh to process the specified data sources and filters. 

  This process may take a few seconds or a few minutes to complete. The processing 
time depends on the number of source points, the cell resolution, and the number of 
processors you have on your system. As the number of source points increases, the time to 
process increases. As the cell resolution value decreases, the time to process increases. As 
the number of processors increases, the time to process decreases. However, given that 
there is a threshold at which files can be read from a disk, you may not experience speed 
improvements beyond four to eight processors. Specifically, processing time may flatten as 
more processors are used.  

Given these factors, a progress indicator has been provided to help you estimate the overall 
processing time. This progress indicator is located in the lower-left corner of the GeoMedia 
Desktop application window. This indicator displays the text "Processing elevation tile XX of 
XX" and can be used to help estimate the time to completion. 

Once the process completes, the results will be displayed in the active map window as a 
temporary Grid Analysis layer. 

8. On the Grid tab, in the Layer panel, click Cell Magnifier. 

9. Move your cursor over one of the outer edges. Notice that there are VOID values. These 
VOID values can be removed using the Elevation Workbench command. 

 

Interpolating Unknown Values 

Interpolation is not a simple process; understanding some principles can help when making 
decisions about what interpolation process to use and which parameters to use. For additional 
information about Interpolation, refer to the Help topics entitled Interpolation Explained. 

When importing multiple adjacent files, you may see seams or linear gaps in the data. Specially, 
the surface contains VOID areas. If you were to examine the Grid Analysis layer in the example 
above, you would notice that the VOID areas are small (typically no larger than one or two cells 
wide). This is a good representation of the data because interpolating VOID patches of one or 
two cells is appropriate given the resolution of this data. In this section, you will use the Inverse 
Distance Weighting commands to interpolate new values for each VOID cell.  

1. Choose Tools > Interpolation > Inverse Distance Weighting to display the Inverse 
Distance Weighting Interpolation dialog box. 
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  For information regarding each Inverse Distance Weighting option, refer to the Help 
topics entitled IWD. 

 

2.  In this particular case, all of the default parameters are appropriate for this data except 
Search radius:. Set the search radius to 15 cells. After modifying the Search radius:, click 
OK to accept the settings and to close the Inverse Distance Weighting Interpolation 
dialog box.  

Once you have clicked OK, the Inverse Distance Weighting Interpolation dialog box will 
close, and the Elevation Workbench dialog box will update to reflect this new step in the 
chain. 

3. Click Refresh to update the active Map window with the final step in the process chain (that 
is, data that includes the interpolation step). 

4. Zoom in on the temporary Grid Analysis layer so that you can better examine the results of 
this two-step process. The surface should no longer contain any VOID values. 

 

Saving Elevation Workbench Layers to a Study Area 
GeoMedia Analysis contains a wide variety of Grid processing commands, and the layers that 
you create using the Elevation Workbench command can be saved to a Study Area so that 
additional processes can be applied to the data. In this section, you will learn how to output all 
layers created by the Elevation Workbench command to a new Study Area. 

1. Choose File > Save to New Study Area to display the Save to New Study Area dialog 
box. 

2. Use the Connection drop-down list to specify the target connection (in this case, choose 
the UrbanArea connection). 

3. Enter DEM into the Name text box. 

4. You can save both layers to the new Study Area or just select the layers you want to persist. 
In this case, select the Inverse Distance Weighting Result layer. 

5. Click Save to save the selected layer to the specified Study Area. 

6. Once the save is complete, on the Grid tab, in the Study Area panel, click List. 

7. You should notice the new Study Area and the new layers. You can now use the contents of 
this Study Area to perform further processing. 
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Saving a Workflow 
Once you have perfected a process, you can save this workflow to disk for use in the future. In 
this section, you will learn how to save a workflow to disk. 

1. Choose File > Save As to display the Save As dialog box. 

2. Use the controls in this dialog box to save the workflow to a preferred name and preferred 
location on disk. 

3. Once a workflow has been saved, it can be reopened using the File > Open command. 

4. Exit the tutorial by closing the Elevation Workbench command and by closing GeoMedia 
Desktop. Do not save any changes. 

 


