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This Tutorial 

Tutorial Objective 
This training tutorial is designed to illustrate the functionality and capabilities provided by 
GeoMedia® Map Publisher.   

 

Tutorial Data Set 
The sample data set used in the GeoMedia Map Publisher tutorial exercises represents a typical 
1:50,000 scale map sheet produced by the Danish National Mapping Agency, Kort & 
Matrikelstyrelsen (KMS) – Danish Ministry of the Environment, National Survey and Cadastre.  

It should be noted that the original data set provided by KMS represented a completed 
cartographic product prior to lithographic processing.  However, liberties have been taken within 
the data set in order to illustrate a typical starting point in the cartographic editing process.  The 
exercises provided in this tutorial do not necessarily represent standard workflows employed at 
KMS, nor do the exercises claim to represent the type of cartographic edits performed at KMS.  
The tutorial exercises simply illustrate standard cartographic editing procedures that mapping 
agencies and mapping companies would expect to be available using a cartographic editing 
software application such as GeoMedia Map Publisher.  

The cartographic results produced within this training tutorial reflect the results of standard 
cartographic processes and editing concepts.  The resulting data set should be viewed as a 
representative sample of the type of data modifications that typically occur during the 
cartographic production process, and in no way illustrate the "truth on the ground." 

Hexagon Geospatial would like to extend its appreciation to Kort & Matrikelstyrelsen (KMS) for 
their cooperation in this endeavor. 

 
Tutorial Text Conventions 
There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb group, click Ccc. 

 Dialog box names, field names, and button names are depicted using Bolded Text. 

 Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 

 
Tutorial Prerequisites 
Familiarity with the GeoMedia Desktop. 
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Generalization Section 1:  

Section Objective 
This section will introduce you to generalization in GeoMedia Map Publisher. You will learn about: 
 

 Managing Generalization Rules  

 Performing Generalization with GeoMedia Map Publisher 

 

Tools Used 
GeoMedia Professional and GeoMedia Map Publisher 
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 Managing Generalization Exercise 1:
Rules  

Objective: 
 
Creating and Managing generalization rules in GeoMedia Map Publisher. 

Task 1: Manage Generalization Rules 

The workflow for performing automated Generalization in GeoMedia Map Publisher spans across 
multiple commands.   

The Manage Generalization Rules command is responsible for the creation and the storage of 
the rules.  

The Generalize command is responsible for executing the rules.   

Storing Rules 
The rules are accessed through a standard GeoMedia warehouse connection, and can be 
included in the Cartographic edits warehouse or kept separately in a rules warehouse, the latter 
being the example used in this tutorial.  Storing the rules in the Cartographic edits database may 
be preferable in production scenarios where the focus is on the generation of a single map sheet 
or map product.  Storing the rules in a separate database may be preferable in series mapping 
scenarios where a common schema is used, enabling the re-use of the rules across multiple map 
sheets or map products.  Rules can also span multiple warehouses.  The only requirement for 
their use is that the appropriate warehouse connection(s) are defined in the GeoWorkspace.  
When selecting rules to process, you must define the rules connection.  If multiple rules 
connections exist, you must run the Generalize command separately for each rules connection. 

Managing Rules 
Generalization rules are managed by selected Subjects – the items to be processed. Each 
Subject has one or more Rules associated with it, and each Rule defines one or more Actions. 
The defined Rules and their Actions are completely configurable.  Rules can optionally be 
organized into Groups; a logical grouping of the defined rules that can be organized by product 
type, by theme, by geometry type, or by processing order.   
 
Conflict Detection and Resolution 
Rules contain two components; a detection condition for defining potential conflicts, and a 
resolution action(s) to apply when conflicts are detected.  When performing the actual 
generalization, you can select the specific rules to process.  As an example, a rules connection 
may contain ten rules, but you may decide to execute only two of them during processing. 
 
During processing, you have the option of automatically resolving the detected conflicts based on 
the rule definition, or of detecting only the conflicts and resolving them interactively.  In either 
case, the Generalize command outputs the result to Queued Edit, where you can cycle through 
the queue to review the results and/or perform any additional manipulations on the data. 

 Some Generalization operations, such as area aggregation may produce an output feature 
that is a different feature class than the selected input feature classes, where the attributes 
defined for the output feature are completely different than the attributes defined for the input 
features. When this occurs, it is possible to define how the generalized feature attributes are 
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automatically calculated during processing.  
 

Manage Generalization Rules provides the interface for defining and managing the 
generalization rules.  For additional information, see Manage Generalization Rules in the Help.  

The basic workflow for Manage Generalization Rules involves invoking the command, defining 
the subjects to process, and defining the rules/actions for each subject defined. Once rules have 
been defined, they can be organized into logical groups.   

 You can either continue working with the workspace from the previous tutorial or open the 
following workspace: C:\GeoMedia Desktop Training\Introduction to Mapping Manager\GeoMedia 
Map Publisher\Lessons\Lesson 7 Generalization\Lesson 7 Generalization.gws 

1. Select Carto > Generalization > Manage Generalization Rules from the ribbon.   

  
The Manage Generalization Rules dialog box displays.  
The first time the Manage Generalization Rules command is invoked, the dialog box is 
empty, requiring the definition of a rules connection.  Once the rules connection has been 
defined, it is saved as a user preference.  
 

 
 

 Even though the rules connection is stored as a user preference, it is subject to 
change, especially when working on different projects that reference a different rules 
connection.  When Manage Generalization Rules is invoked, the rules connection user 
preference is evaluated.  If the available warehouse connections do not match the user 
preference, the dialog box will appear empty as illustrated above, requiring the user to 
choose the appropriate rules connection.  

2. Click the drop-down list for Rules connection. 

 
 
There are two warehouse connections available.  Only read-write connections appear in 
the drop-down list. 
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3. Select KMS 50K Rules.  

If the selected connection does not contain rules tables, the following message is 
displayed. 
 

 
 

4. Click Yes.  

5. Click the Rules tab.  

6. In the Defined Subjects group, click Add. 

The Add dialog box is displayed portraying Subject treeviews for Feature Classes (FC), 
Carto Master Legend (CML), and Geometry Type (GT). 
 

 
 

 In many cases, the content listed in the Feature Classes (FC) treeview and the 
Carto Master Legend (CML) treeview will appear the same. However, there are some 
subtle differences during processing for Subjects selected from the Feature Classes (FC) 
treeview versus their counterpart in the Carto Master Legend (CML) treeview. The 
Subjects listed in the Feature Classes (FC) treeview represent the combined features of 
all available source warehouse connections. Queries are not listed. During processing, 
rules defined with Subjects originating from the Feature Classes (FC) treeview will be 
evaluated, and any legend entry that originates from the defined Subject will be 
considered. This includes queries and legend entries that have been renamed. The 
Subjects listed in the Carto Master Legend (CML) treeview represent the legend entries 
defined in the Carto Master Legend. This includes feature classes and queries. During 
processing, rules defined with Subjects originating from the Carto Master Legend (CML) 
treeview will be considered only if the name defined in the rule is an exact match with the 
name defined in the map window legend. 
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7. Expand the Feature Classes (FC) treeview, and check Telemast. Expand the Carto 
Master Legend (CML) treeview and check Vejo6, Vej3_6, and Lav_bebyg. Click OK. 

 
 
The selected Subjects have been added to the Defined Subjects group. The Type 
column indicates their origin, and will display either FC for Feature Classes, CML for 
Carto Master Legend, or GT for Geometry Type.  

8. In the Defined Subjects group, highlight the individual subjects and use the up-arrow 
and down-arrow to re-order them as follows: 

a. Telemast  

b. Vejo6  

c. Vej3_6  

d. Lav_bebyg  

The order listed here defines the processing order when multiple Subjects / Rules are 
processed from the Subjects tab in the Generalize command.  

 The following rule is designed to detect Telmast symbols that are within a 
minimum distance (1.0 mm) of the Vejo6 and Vej3_6 road features. When this conflict 
is detected, the Telemast symbol will be displaced 1.0 mm from the specified road 
features. 

9. In the Defined Subjects group, highlight Telemast and click New in the Defined Rules 
group. 
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The New Rule for Telemast dialog box displays. The title of the dialog will vary based on 
the name of the selected Subject, in this case Telemast. The syntax for the dialog box 
title is New Rule for <Subject>. 
 

 
 

10. For the Rule name, type Displace from Roads. Press the TAB key. 

 Optional Rule Properties can be defined for the selected Subject, which include an 
attribute filter and/or a spatial query. Attribute filters can be applied only to Subjects that 
originated from the Feature Classes (FC) treeview, but a spatial query can be applied to 
all Subject types (FC and CML). 

11. In the Queue message group, click the Queue Messages button.  

The Add/Modify Queue Messages dialog box is displayed. 

12. For the Name, type Displace Telemast.  
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13. For the Description, type Minimum distance from Road is 1.0mm. 

 
 

14. Click OK. 

15. In the Queue message group, click the Name pull-down and select Displace Telemast.  

16. In the Actions group, click New.  

The New Action dialog box displays. 
 

 
 

17. Click the Displace action so it highlights and click OK.  

The Displace: Telemast dialog box displays. The title of the dialog includes the name of 
the active Subject, in this case Telemast.   

18. Click the Conditions tab.  

19. For By distance of, type 1.0.  

 The available detection conditions (Coalesces, Are Coincident, Are Contained) listed 
in the drop-down menu in the That group vary based on the action selected. The 
Displace action only supports the Coalesces condition.  

20. For By minimum distance of, type 1.0.  

21. Click the With drop-down in the first row and select Motorvej from the Feature Classes 
(FC) treeview. 

 The Subjects listed in the Feature Classes (FC) treeview appear in alphabetical 
order. 
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22. Click the With drop-down in the second row and select Vejo6 from the Feature Classes 
(FC) treeview. 

 Multiple With features can be defined in the table.  The items listed in the With 
column are considered ‘static’ features.  They are used in the detection process, but do 
not have any resolution applied to them.  The resolution is applied to the selected 
Subject. The Filter option is disabled when selecting items from the Cartographic Master 
Legend or Geometry Type treeviews. 
 

 

23. Click OK.  
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The New Rule for Telemast dialog box is populated with the previously defined settings 
for Rule name, Queue message, and Actions. 
 

 
 

 If multiple Rules are defined for the selected Subject, it may be desirable to check the 
Clear dialog when Apply is clicked option before clicking Apply.  

24. Click Apply.  

25. Click Cancel.  
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The New Rule for Telemast dialog box is dismissed. The Manage Generalization 
Rules dialog box is populated with the rule definition. The Displace from Roads rule is 
listed in the Defined Rules group, and the properties and actions defined are listed in the 
Rule Properties and Actions group. 
 

 
 

 The next rule is designed to detect road segments for Vejo6 that are contained within 
the built-up area Lav_bebyg. When this conflict is detected, the segments of the Vejo6 
feature will be replaced with a style that does not contain a road casing representation. 

26. In the Defined Subjects group, highlight Vejo6 and click New in the Defined Rules 
group. 

The New Rule for Vejo6 dialog box displays.  

27. For the Rule name, type Replace Urban Segments. Press the TAB key.  

28. In the Actions group, click New.  

The New Action dialog box displays.  

29. Click the Replace Segment Style action so it highlights and click OK.  

The Replace Segment Style: Vejo6 dialog box displays. 

30. Click the With style name of button.  

The Style Name dialog box displays.  

31. Scroll to the bottom and select the Vejo6 Urban style. Click OK.  

32. Click the That drop-down and select Are Contained.   

33. Click the With drop-down in the first row and select Lav_bebyg from the Carto Master 
Legend (CML) treeview.  

 The Subjects listed in the Carto Master Legend (CML) treeview appear in the 
same order as that of the map window legend.   

34. Click OK.  
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The New Rule for Vejo6  dialog box is populated with the previously defined settings for 
Rule name and Actions. 

 This Rule was defined with a single Action. It is also possible to define multiple 
Actions within a single Rule. In this example, a rule was defined to detect road segments 
that were contained within the built-up area, and replace the style of the conflicting 
segments. An additional Action could also be defined within the same Rule to detect road 
segments that are coincident with the built-up area boundaries, and to replace the style of 
the conflicting segments. 

35. Click Apply.  

36. Click Cancel.  

The New Rule for Vejo6 dialog box is dismissed. The Manage Generalization Rules 
dialog box is populated with the rule definition. The Replace Urban Segments rule is 
listed in the Defined Rules group, and the properties and actions defined are listed in the 
Rule Properties and Actions group. 
 

 
 

 The next rule is designed to detect road segments for Vej3_6 that are contained 
within the built-up area Lav_bebyg. When this conflict is detected, the segments of the 
Vej3_6 feature will be replaced with a style that does not contain a road casing 
representation.    

37. In the Defined Subjects group, highlight Vej3_6 and click New in the Defined Rules 
group. 

The New Rule for Vej3_6 dialog box displays.  

38. For the Rule name, type Replace Urban Segments. Press the TAB key.  

39. In the Actions group, click New.  

The New Action dialog box displays.  

40. Click the Replace Segment Style action so it highlights and click OK.  

The Replace Segment Style: Vej3_6 dialog box displays. 

41. Click the With style name of button.  

The Style Name dialog box displays. 

42. Scroll to the bottom and select the Vej3_6 Urban style. Click OK.  

43. Click the That drop-down and select Are Contained.   



 

    13 

44. Click the With drop-down in the first row and select Lav_bebyg from the Carto Master 
Legend (CML) treeview.  

45. Click OK.  

The New Rule for Vej3_6  dialog box is populated with the previously defined settings for 
Rule name and Actions. 

46. Click Apply.  

47. Click Cancel.  

The New Rule for Vej3_6 dialog box is dismissed. The Manage Generalization Rules 
dialog box is populated with the rule definition. The Replace Urban Segments rule is 
listed in the Defined Rules group, and the properties and actions defined are listed in the 
Rule Properties and Actions group. 
 

 
 

 The next rules are designed to do the following: First, to detect a minimum 
distance (0.5mm) between the urban features Bykerne, Hoj_bebyg, and Lav_bebyg. 
When this conflict is detected, the area features will be aggregated into a single output 
feature. Second, to detect a minimum distance (1.0mm) between the aggregated 
Lav_bebyg feature and several road features (Motorvej, Vejo6, and Vej3_6). When this 
conflict is detected, the Lav_bebyg area boundary will be extended to the specified roads.     

48. In the Defined Subjects group, highlight Lav_bebyg and click New in the Defined 
Rules group. 

The New Rule for Lav_bebyg dialog box displays.  

49. For the Rule name, type Aggregate Urban Features. Press the TAB key.  

50. In the Actions group, click New.  

The New Action dialog box displays. 

51. Click the Aggregate Areas action so it highlights and click OK.  

The Aggregate Areas: Lav_bebyg dialog box displays. 

52. Click the Conditions tab.  

53. For the Distance tolerance, type 0.5.  

54. For the Eliminate holes smaller than, type 2.0.  
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55. For Z-Calculation, select Original.   

56. Check Smooth boundary and check Aggregate orthogonally.  

 The settings defined in Steps 53 through 56 are the same settings defined when 
running the interactive Aggregate Areas command.  

57. Click the With drop-down in the first row and select Bykerne from the Carto Master 
Legend (CML) treeview.  

58. Click the With drop-down in the second row and select Hoj_bebyg from the Carto 
Master Legend (CML) treeview.  

59. Click the With drop-down in the third row and select Lav_bebyg from the Carto Master 
Legend (CML) treeview.  

 When aggregating area features, it is possible that the parameters defined will 
introduce invalid spatial relationships with features that are not being considered in the 
aggregation process. For example, the result of aggregating area building features 
produces a result that overlaps drainage features (rivers, streams, and so forth.) These 
resulting invalid spatial relationships can be eliminated by defining features that prohibit 
the aggregation from occurring if the result produces an invalid spatial relationship. To 
define features that prohibit the area aggregation from occurring, click the Constraints 
tab and select the desired features.    

60. Click OK.  

The New Rule for Lav_bebyg dialog box is populated with the previously defined 
settings for Rule name and Actions. 

61. Click Apply.  

62. Click Cancel.  

The New Rule for Lav_bebyg dialog box is dismissed. The Manage Generalization 
Rules dialog box is populated with the first rule definition. The Aggregate Urban 
Features rule is listed in the Defined Rules group, and the properties and actions 
defined are listed in the Rule Properties and Actions group. 
 

 

63. In the Defined Subjects group, highlight Lav_bebyg and click New in the Defined 
Rules group. 

The New Rule for Lav_bebyg dialog box displays.  

64. For the Rule name, type Extend to Roads. Press the TAB key.  



 

    15 

65. In the Actions group, click New.  

The New Action dialog box displays.  

66. Click the Extend Boundary action so it highlights and click OK.  

The Extend Boundary: Lav_bebyg dialog box displays. 

67. Click the Conditions tab.  

68. For the Distance tolerance, type 1.0.  

69. For the Eliminate gaps smaller than, type 0.0.  

70. Un-check Extend to meet at centerline and check Extend orthogonally.  

 The settings defined in steps 68 through 70 are the same settings defined when 
running the interactive Extend Boundary command. 

71. Click the With drop-down in the first row and select Motorvej from the Carto Master 
Legend (CML) treeview.  

72. Click the With drop-down in the second row and select Vejo6 from the Carto Master 
Legend (CML) treeview.  

73. Click the With drop-down in the third row and select Vej3_6 from the Carto Master 
Legend (CML) treeview.  

 When extending the boundary of features, it is possible that the parameters defined 
will introduce invalid spatial relationships with features that are not being considered in 
the extended-boundary process. For example, the result of extending the boundary of 
area building features produces a result that overlaps drainage features (rivers, streams, 
and so forth.) These resulting invalid spatial relationships can be eliminated by defining 
features that prohibit the extended boundary from occurring if the result produces an 
invalid spatial relationship. To define features that prohibit extending boundaries from 
occurring, click the Constraints tab and select the desired features.    

74. Click OK.  

The New Rule for Lav_bebyg dialog box is populated with the previously defined 
settings for Rule name and Actions. 

75. Click Apply.  

76. Click Cancel.  
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The New Rule for Lav_bebyg dialog box is dismissed. The Manage Generalization 
Rules dialog box is populated with the second rule definition. The Extend to Roads rule 
is listed in the Defined Rules group, and the properties and actions defined are listed in 
the Rule Properties and Actions group. 
 

 

77. Click the Groups tab. 

 

78. In the Defined Groups group, click New. Type in Built-up Areas for the Group name.  

79. In the Defined Groups group, click Add Rules.  

The Add Rules for Built-up Areas dialog box is displayed. The title of the dialog will 
vary based on the name of the selected Group, in this case Built-up Areas. The syntax for 
the dialog box title is Add Rules for <Group>.   
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80. In the Rules group, expand each of the treeviews, and check Vejo6 (CML), Vej3_6 
CML), and Lav_bebyg (CML). Click the Displace from Roads rule so it highlights 

 
 
The information displayed for the Rule Properties and Actions is the same information 
that is displayed for the Rule Properties and Actions on the Manage Generalization 
Rules and Generalize dialog boxes. 

81. Click OK.  

The Add Rules for Built-up Areas dialog box is dismissed, and the Defined Groups 
group on the Manage Generalization Rules dialog box is populated with the selected 
rules.  

82. Click on the ‘+’ (plus signs) for each of the rules listed to expand the treeview.  

83. In the Defined Groups group, select the Aggregate Urban Features rule in the 
Lav_bebyg (CML) treeview so it highlights and click the up arrow. This will ensure that 
the Aggregate Urban Features rule will process before the Extend to Roads Rule 
when processing Lav_bebyg from the Groups tab in the Generalize command.  
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84. In the Defined Groups group, select Lav_bebyg (CML) in the Built-up Areas treeview 
so it highlights and click the up arrow until Lav_bebyg (CML) is the first Subject defined 
in the Built-up Areas Group. This will ensure that the Lav_bebyg (CML) Subject will be 
processed first, followed by the Vejo6 (CML) Subject, and followed by the Vej3_6 (CML) 
Subject. 

 
 

 Selecting any of the rules in their respective Subject treeview in the Defined 
Groups group will populate the Rule Properties and Actions group with the parameters 
defined for the selected rule. This information is the same as that provided in the Rule 
Properties and Actions group on the Rules tab when selecting a rule in the Defined 
Rules group.   

85. Click Close. 
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 Generalize Exercise 2:

Objective: 
Performing generalization with GeoMedia Map Publisher. 

Task 1: Generalize 

Generalize provides the interface for executing the generalization rules established in the 
Manage Generalization Rules command 

1. Select Carto > Generalization > Generalize from the ribbon.  

  
 

 When Generalize is invoked, the command evaluates the open warehouse 
connections to determine a rules connection.  If none of the available connections contain 
valid rules tables, or if the rules warehouse connection is closed, the following warning 
message appears: 
 

 
 
As noted earlier, the rules connection is stored as a user preference.  If there are multiple 
warehouse connections that contain valid rules tables, and one of them matches the user 
preference, the rules connection is displayed with the connection defined in the user 
preference.  If there are multiple warehouse connections that contain valid rules tables, 
and none of them match the user preference, the Generalize dialog box will load the first 
available connection listed in the Rules connection drop-down. 
The Generalize dialog box displays.  
 

2. Click on the Output tab. In the Output results to static queue group, select KMS 50K 
Carto for the Connection. 

3. Click the Subjects tab. 
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4. Make sure the Rules connection is defined as KMS 50K Rules.  
 

 

5. In the Rules to apply group, make sure the Telemast treeview is expanded and check 
Displace from Roads.  Checking the rule indicates that it will be processed when the 
command is executed. 
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6. In the Telemast treeview, highlight the Displace from Roads rule. 

 

 
 
The Legend entries matching Subject list box and the Legend entries matching 
features used by Action list box are populated, and the Rule tab is enabled.  
When a Subject is highlighted in the Rules to apply section, the list boxes for Legend 
entries matching Subject and Legend entries matching features used by Action are 
cleared.  When individual rules are highlighted, the Legend entries matching Subject 
list box displays the legend entries found in the active map window that originated from 
the Subject defined in the rule. The legend entries displayed are those that will be 
considered for resolution when conflicts are detected.  Similarly, the Legend entries 
matching features used by Action list box displays the legend entries in the active map 
window that are being considered for conflict detection for the rule selected.  It is 
important to note that the rule definition can be defined independent of the legend entries 
in the active map window.  The legend entries listed in the Legend entries matching 
Subject list box and the Legend entries matching features used by Action list box 
may not always correspond with the original rules definition.   
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 It is recommended that the rule(s) that you intend to process be highlighted so you 
can determine if there are any issues with the Legend entries in the active map window 
prior to executing the rule. The example noted above represents what is displayed in the 
Legend entries matching Subject list box and Legend entries matching features 
used by Action list box when no issues are encountered. The following example 
illustrates what is listed in the Legend entries matching Subject list box and Legend 
entries matching features used by Action list box when the active map window legend 
does not contain the defined Subject or any of the defined features used by the Action. 
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The next example illustrates what is listed in the Legend entries matching features 
used by Action list box when the defined features used by the Action are present in the 
active map window legend, but contain no records. 
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Finally, the next example illustrates what is listed in the Legend entries matching 
Subject list box and Legend entries matching features used by Action list box when 
the Generalize command is invoked prior to executing the Cartographic Options 
command. 
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7. Click the Rule tab. 

 
 
The information displayed for the Rule Properties and Actions is the same information 
that is displayed for the Rule Properties and Actions on the Manage Generalization 
Rules dialog box. 
In this example, when the rule was defined in Manage Generalization Rules, the Displace 
Action defined feature classes as the With features, denoted by the (FC) suffix on the 
Static Participants as illustrated above.  There are two features defined in the original rule 
that are listed, Motorvej and Vejo6.  In comparison, the Legend entries matching 
features used by Action list box on the Subjects tab lists four legend entries: 
Bro_Motorvej, Bro_Vejo6, Motorvej, and Vejo6.  The reason for this discrepancy is that 
the active map window legend contains duplicate legend entries for the Motorvej and 
Vejo6 feature classes.  The ‘Bro_’ prefix in the legend entry names identifies bridge 
segments for their corresponding roads which are distinguished in the map window 
legend entries through the use of Attribute Based Symbology (ABS).  The rule defined 
Motorvej as a feature class to process, and the process will consider all legend entries 
that originate from the Motorvej feature class; in this case, Bro_Motorvej and Motorvej. 

8. Click the Output tab.   

9. In the Output results to static queue group, make sure KMS 50K Carto is defined for 
the Connection.  

10. In the Output results to static queue group, for the Queue name type 
TelemastSubject.  
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 Defining a Queue name is optional; the default name is GeneralizeQueue. The 
user-defined Queue name cannot contain any spaces. If the Queue name contains a 
space, the following message is displayed. 
 

 

11. In the Output results to static queue group, check Display queue on completion.  

 This option enables users to execute the Generalize command multiple times in 
succession without invoking Queued Edit after the completion of each Generalize task, 
allowing the user to invoke Queued Edit at a later time to display the results of the 
Generalize command. Given this workflow, it is important to be able to identify the static 
Queue names produced when executing the Generalize command.  When rules are 
executed by the Generalize command, the result is written to a static queue in the 
defined Connection. Specifying a static Queue name that already exists in the defined 
Connection will not overwrite the existing queue. Instead, the Generalize command will 
automatically append a numerical value to the end of the Queue name to ensure that its 
name is unique. For example, a static Queue name already exists for GeneralizeQueue1. 
If GeneralizeQueue1 is defined as the Queue name in the Generalize command, the 
Queue name will automatically be appended with a numerical value to ensure a unique 
Queue name, such as GeneralizeQueue11, as illustrated below on the feature drop-down 
list on the Queued Edit dockable control. 
 

 

12. In the Output to log file group, uncheck View log file after processing and uncheck 
Log statistics.  

13. Uncheck On rule failure, do not process any remaining rules.  

14. Check Disable all automatic resolutions.   



 

    27 

 When this option is checked, the Generalize command will only perform the 
conflict detection specified in the rule; no resolution will be applied. This is useful for 
refining the detection parameters in the rule definition. It can also be used as an 
automated tool to detect conflicts that can be resolved interactively with the assistance of 
Queued Edit. 
 

 

15. Click the Subjects tab.  

16. Click OK.   
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Upon completion, Queued Edit is invoked containing the results produced by the 
Generalize command.  The Queued Edit toolbar is displayed along with the Queued Edit 
Map Window, and the Queued Edit Data Window. 
 

 
 
The Queued Edit Data Window lists the following attributes: 
ConflictType – a numeric field that identifies the condition used in the conflict detection.  
Valid values are 0 (no specific detection), 1 (Coalescence), 2 (Coincidence), 4 
(Containment).  
ConflictDescription – a text field that identifies the Rule Name, Action, and Queue 
Message. 
ConflictStatus – a numeric field that identifies the current status.  This field maps to the 
Status Review / Update drop-down list on the Queued Edit dockable control.  Valid 
values are 0 (Unresolved), 1 (Resolved), 2 (Resolved Edited). 
ID1 – numeric field that identifies the Recordset number. 

17. Minimize the Queued Edit Data Window.  

18. On the Queued Edit dockable control, click Options. 
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The Queuing Options dialog box is displayed. 

19. Click the General tab and make sure Show description box is checked. 
 

 

20. Click OK.  

The description box on the Queued Edit dockable control is displayed. 
 

 
 
The information provided in the Queued Edit description box not only contains the Rule 
Name, Action Name, Queue Message, and so forth, but also includes relevant 
information determined by the generalization operation performed. In the case of the 
Aggregate Areas Action, information in the description box includes the amount of the 
total change in area, as well as the percentage change in the area produced by the area 
aggregation.  
 

 Upon enabling Show description box on the Queued Edit control, the description 
box is displayed but may appear blank. To visualize the contents of the description box, 
click in the description box. 
The Queued Edit dockable control contains the following controls: 
 

Queue list  

Move First  

Move Previous  

Current Item 
Number  

Total Number of 
Items  

Move Next  



30  Generalization 

Move Last  

Status Review / 
Update  

Zoom In  

Zoom Out  

Fit current queue 
item  

Options  

Additional 
Commands  

Remove Data 
Window  

Close Queue  

Description Box  

 

 Queued Edit was incorporated into GeoMedia with the 06.01 release.  GeoMedia 
Map Publisher uses Queued Edit with the Generalize command; the contents of some of 
the controls are unique to GeoMedia Map Publisher as follows: 

 Queue list – the queue name specified in the Generalize command is automatically loaded, 

and appears in the Queue drop-down list.  Since this queue is written to a warehouse 
connection (in this case, KMS 50K Carto), it can be accessed in subsequent Queued Edit 
workflows for QA/QC through the Queued Edit command, appearing in the Static Queues 
treeview, as illustrated below. 

 

 Status Review / Update – The status listed here varies based on several conditions.  First, 

if the Disable all automatic resolutions option is checked on the Output tab in the 

Generalize command, the result of the process will produce an ‘Unresolved’ status for all 

conflicts detected.  Second, if Disable all automatic resolutions option is unchecked on 

the Output tab in the Generalize command, the process will attempt to resolve the conflicts 

detected.  When conflicts can be resolved without ambiguity, the status will be defined as 
‘Resolved’.  In cases where there is ambiguity, the status will be defined as ‘Unresolved’.  The 
Generalize command will not produce a ‘Resolved Edited’ status, as this status is defined 
interactively by the user. 

 Description box – The content listed in the Description box is determined automatically by 

the Generalize command and contains: 

 The Rule name (Displace from Roads, in this example).   
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 The Action (Displace, in this example).  

 The Queue Message (if one was defined). 

 Additional information (per queue item) that varies based on the processing Action. 
Information may include statistics or identify that a particular resolution cannot be resolved 
in cases of ambiguity.  

For additional information on Queued Edit, see the Working with Queued Edit chapter in 
the Features and Categories section of the GeoMedia Professional Help. 

21. Select Home > Window > MapWindow1, or click on MapWindow1 to make it the active 
window.  

22. Select Home> Window > Map Window Properties. Click the Center at current scale 
option.  Click OK. 

23. Click the Move First button on the Queued Edit dockable control. 

 
The first item in the queue is centered in MapWindow1. 

24. Select Home > Window > Queued Edit Map Window.  

25. Resize the Queued Edit Map Window so it takes up about one-fourth of the available 
viewing area, and position it in the upper left.  

26. Resize the legend pane on the Queued Edit Map Window so the legend entry names are 
completely in view. Hover the cursor over the legend pane, right click to display the right-
click menu, and select Fit Legend. Three legend entries appear in the Queued Edit Map 
Window: 

 OriginalGeometry of TelemastSubject  

 CDRGeometry of TelemastSubject  

 ConflictGeometry of TelemastSubject  

 The Queued Edit Map Window produced by the Generalize command will always 
contain these three legend entries.  In this case, the common denominator; 
‘TelemastSubject’ denotes the Queue Name. 

27. On the Queued Edit dockable control, click Fit current queue item. 

 



32  Generalization 

28. On the Queued Edit dockable control, click Zoom out two times. 

 
 

 
 

 One of the options available for the Queuing Options is to Add item to select set. 
If this option is selected when the Generalize command is executed, all of the items 
displayed in the Queued Edit Map Window will display in the Select color defined on the 
Map Display tab in File > Options. If all of the graphics displayed in the Queued Edit 
Map Window appear to be in the select set, click in the Queued Edit Map Window to clear 
the select set.  
With the select set cleared, the legend entries in the Queued Edit Map Window clearly 
distinguish the separate components evaluated in the conflict detection process, as 
follows: 

 OriginalGeometry – depicted in orange.  This is the ‘Subject’ identified in the rule. 

 CDRGeometry – depicted in black.  These are the ‘Static Participant’ features identified in 

the rule.  

 ConflictGeometry – depicted in red. This illustrates where the conflicts occur.  

 You may have to change the style settings in the Queued Edit Map Window to get 
the same styles as denoted above. 
 

 While these three legend entries are consistent with each of the rules processed, 
the graphics displayed in the Queued Edit Map Window will vary based on the geometry 
type being processed and the Action being performed.  Coincidence and Containment 
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use the feature’s geometry (point, line, area) when performing the conflict detection.  The 
OriginalGeometry legend entry and the CDRGeometry legend entry will be depicted in 
the Queued Edit Map Window as a point, a line, or an area.  In contrast, Coalescence 
uses the geometry of the feature’s style defined in the map window legend. The 
OriginalGeometry legend entry will be depicted by the outline of the feature’s style, and 
the CDRGeometry legend entry will be depicted as a point, a line, or an area.  In the 
example above, the OriginalGeometry is portrayed as the outline of the Telemast point 
symbol (an upside-down ‘T’).  The CDRGeometry is portrayed as the linear geometry of 
the road feature defined in the rule. 

29. Click Move Next on the Queued Edit dockable control and cycle through each of the 
items in the queue to review the detected conflicts. 

 
 

 
 

 The Queued Edit Map Window provides visual feedback specific to the Generalize 
process.  It is not designed to be used for subsequent interactive editing.  Notice all 
legend entries in the Queued Edit Map Window have their Locatable status turned off.  
Interactive editing of detected conflicts should occur in the originating map window where 
all features are displayed, providing a visual reference to the surrounding features.  

30. On the Queued Edit dockable control, click Close Queue. 

 

31. Select Home > Window > MapWindow1, or click on MapWindow1 to make it the active 
window. 
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32. Select Carto > Generalization > Generalize from the ribbon. 

 

33. Click the Groups tab.  

The Generalize dialog box is displayed with the Groups tab active 
 

 

34. In the Rules to apply group, make sure the Built-up Areas treeview is expanded and 
check Built-up Areas.  Checking the group indicates that all rules contained in the group 
will be processed when the command is executed. 

 Selecting rules for processing can be performed on the Subjects tab or the 
Groups tab. When executing the Generalize command, the rules processed will be 
those specified on the active tab when the command is executed. The processing 
order of the rules can be defined independently for Subjects and Groups in the Manage 
Generalization Rules command. In this example the rules for Lav_bebyg on the Subjects 
tab list Extend to Roads first, and Aggregate Urban Features second. The rules for 
Lav_bebyg on the Groups tab list Aggregate Urban Features first, and Extend to 
Roads second.   

35. Optionally highlight one of the rules to determine if there are any issues with the legend 
entries in the active map window for the defined Subject and any of the defined features 
used by the Action for the selected rule.   

36. Optionally click the Rule tab to review the Rule Properties and Actions of the selected 
rule.  

37. Click the Output tab.  
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38. In the Output results to static queue group, select KMS 50K Carto for the 
Connection.  

39. In the Output results to static queue group, for the Queue name, type 
BuiltUpAreasGroup, ensuring there are no spaces or special characters in the name.  

40. In the Output results to static queue group, check Display queue on completion.  

41. In the Output to log file group, click the Browse button to specify a log file name.  

The Generalize Log Files dialog box displays. 
 

 
 

42.  Select C:\GeoMedia Desktop Training\Introduction to Mapping Manager\GeoMedia Map 
Publisher\Lessons\ Lesson 7 Generalization  in the Save in drop-down list. 

43. For the File name, keep the default name Generalize.log. 

44. Click Save. 

45. In the Output to log file group, check View log file after processing.  

46. In the Output to log file group, check Log statistics.  

47. Check On rule failure, do not process any remaining rules.  

 It is recommended that this option is checked when there are multiple rules 
defined for any given Subject, especially if the rules are dependent on one another. For 
example, during processing the output results of the first rule are used as the input for the 
second rule. If the first rule fails and the second rule is processed, the overall results may 
be significantly different than the overall results produced when both rules complete 
successfully.  
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48. Uncheck Disable all automatic resolutions. 

 

49. Click the Groups tab.  

50. Click OK.   

Upon completion, Queued Edit is invoked containing the results produced by the 
Generalize command.  The Queued Edit dockable control is displayed along with the 
Queued Edit Map Window, and the Queued Edit Data Window. 
The specified log file is also displayed. 

51. After reviewing the log file, close the application (Notepad, Word, and so forth) displaying 
it.  
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52. Minimize the Queued Edit Data Window and the Queued Edit Map Window. 

53. Select Home > Window > MapWindow1, or click on MapWindow1 to make it the active 
window. 

54. Select Home > Window > Properties. Click the Center at current scale option.  Click 
OK. 

55. Click the Move First button on the Queued Edit dockable control. 

 
The first item in the queue is centered in MapWindow1. 

56. Click Move Next on the Queued Edit dockable control and cycle through the items in the 
queue to review the results. 

 

57. On the Queued Edit dockable control, click Close Queue. 

58. Close the Queued Edit Map Window. 

 

 


