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About Us 
Hexagon Geospatial helps you make sense of the dynamically changing world. Hexagon 
Geospatial provides the software products and platforms to a large variety of customers through 
direct sales, channel partners, and Hexagon businesses, including the underlying geospatial 
technology to drive Intergraph Security, Government & Infrastructure (SG&I) industry solutions. 
Hexagon Geospatial is a division of Intergraph Corporation. 

CUSTOMERS. Globally, a wide variety of organizations rely on our products daily including 
local, state and national mapping agencies, transportation departments, defense organizations, 
engineering and utility companies and businesses serving agriculture and natural resource 
needs.  Our portfolio enables these organizations to holistically understand change and use 
information to make mission and business-critical decisions.   

TECHNOLOGY. Our priority is to deliver products and solutions that make our customers 
successful. Hexagon Geospatial is focused on developing leading-edge technology that is easily 
configurable. Through extensible, scalable and collaborative products, we enable you to 
transform multi-source content into dynamic and actionable information. We are constantly 
re-conceptualizing and improving our products. 

PARTNERS. As an organization, we are partner-focused, working alongside our channel to 
ensure we succeed together.   We provide the right tools, products and support to our business 
partners so that they may successfully deliver sophisticated solutions for their customers.  We 
recognize that we greatly extend our reach and influence by cultivating channel partner 
relationships both inside and outside of Hexagon.   

TEAM. As an employer, we recognize that the success of our business is the result of our highly 
motivated and collaborative staff.  At Hexagon Geospatial, we celebrate a diverse set of people 
and talents; and we respect people for who they are and the wealth of knowledge they bring to 
the table. We retain talent by fostering individual development and ensuring frequent 
opportunities to learn and grow.    

HEXAGON. Hexagon Geospatial plays a key role in Hexagon’s multi-industry focus, leveraging 
the entire portfolio for a wide variety of geospatial needs. Hexagon is a leading global provider of 
design, measurement and visualization technologies.  Synergistic thinking is encouraged 
across all levels and functions at Hexagon companies, so that we all respond better and faster 
to our shared customer’s needs. 

For more information, visit www.hexagongeospatial.com (http://www.hexagongeospatial.com) 
and www.hexagon.com (http://www.hexagon.com). 

http://www.hexagongeospatial.com/
http://www.hexagon.com/
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Viewshed Analysis Tutorial 

Performing a Viewshed Analysis Using GeoMedia Analysis 

What Is a Viewshed 

A viewshed is the area that can be "seen" from a given vantage point, in a specified direction. A 
measurement of a viewshed must take into account the surrounding elevation data, the height of 
any obstructions, and the height of the vantage point. 

Viewshed analysis is a fundamental technique in grid-based GIS and has many applications in 
resource development and tourism. For example, resource extraction companies use viewshed 
analysis to limit their development to those areas that cannot be viewed from highways or urban 
areas. 

In the Canadian province of British Columbia, landscape aesthetics are very important to 
tourism. For example, the forestry industry must obey guidelines established to limit the visual 
impact of cutting. "Cut blocks" with minimal visual impact on highways and populated areas 
must be planned and approved. Viewshed calculations are essential to the cut-block planning 
process. 
 

Tutorial Introduction 

This tutorial demonstrates a typical workflow used to perform a viewshed analysis. You will be 
introduced to commands used to create a viewshed scene from a Digital Elevation Model 
(DEM). Hints are provided for extending the use of the Viewshed command.  

Topics covered in this tutorial include: 

 Opening a GeoMedia GeoWorkspace 

 Defining a Study Area by importing files 

 Rasterizing GeoMedia feature classes 

 Using the Information window to set the data units for an Obstruction layer 

 Using the Viewshed command to delineate areas visible from defined viewpoints 

 Using the Local Scan command to fill in small data anomalies 

 



Viewshed Analysis Tutorial 

 

 

8 

 
 

Tutorial Text Conventions 

There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb panel, click Ccc > Ddd. 

 Dialog box names, field names, and button names are depicted using Bolded Text. 

 Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 

 

Tutorial Data Set 

The tutorial dataset was generated from two original information sources. Contour data was 
based on map sheet 082J041 TRIM Information (provided by Province of British Columbia Base 
Mapping & Geomatic Services) and land use information on map sheet 082J041 FC1/FIP 
Information (provided by the Province of British Columbia Terrestrial Information Branch). These 
data sets are located in the folder C:\Grid Analysis Tutorials\Introductory Tutorials\Viewshed 
Analysis. 

  The provision of British Columbia Digital Atlas data does not imply sanctioning by the 
Province of British Columbia and does not constitute an endorsement of Intergraph Corporation 
or its products. 
 

How This Tutorial Should be Used 

This tutorial is ideal for those with an interest in delineating viewsheds. Users of this tutorial 
should have a good working knowledge of GeoMedia Desktop and should ideally have worked 
through the Learning to Use Grid Analysis introductory tutorial. 
 

Data Preparation 

Opening a GeoWorkspace 

Grid Analysis is completely integrated with the GeoMedia Desktop and is available when 
GeoMedia Advantage or GeoMedia Professional tiers are used. The Grid Analysis  commands 
are located in the Grid tab in the ribbon bar. 

To begin this tutorial: 

1. Launch GeoMedia Desktop, and choose Open an existing GeoWorkspace from the 
Welcome menu. 

2. Double click More Files, browse to \Grid Analysis Tutorials\Introductory Tutorials\Viewshed 
Analysis\Viewshed.gws, and click Open. 
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3. If a GeoMedia error message requests the database filename, browse to C:\Grid Analysis 
Tutorials\Introductory Tutorials\Viewshed Analysis\Forestry.mdb, click Open, and click OK 
when prompted. 

Your display will show a GeoMedia Map window containing a contour map of the area under 
study. The legend contains five feature classes: 

 View_Point – Viewing Locations (will be rasterized to become the Source layer for the 
Viewshed command) 

 Hwy – Highways (provides spatial context) 

 F_FC_Area – Forest Cover Polygons (will be rasterized to become the Obstruction layer 
for the  Viewshed command) 

 TWTR_Line – Rivers and Lake Boundaries (provides spatial context) 

 CNTR_Line – Contours (provides terrain context; was used to create a DEM layer) 

HINT:  If desired, the data underlying F_FC_Area Forest Cover Polygons (or any other feature 
class) may be viewed by using the New Data window in GeoMedia Desktop and selecting the 
feature class. Note that the data for F_FC Forest Cover Polygons includes a Stand_Height 
attribute, as well as detailed data on the density of tree species. 
 

Importing Layers to a Study Area 

A Study Area must be defined and active before analysis can take place. One way to define a 
Study Area is to import data. When a grid layer is imported, a Study Area based on the layer’s 
parameters is automatically created and made active. 

1. On the Grid tab, in the Study Area panel, click Import. 

2. Select the Import multiple files option. 

3. To select the files to import, click Browse, navigate to \Grid Analysis Tutorials\Introductory 
Tutorials\Viewshed Analysis, and click OK. 

4. Select GeoMedia Grid (*.mfm) from the Format drop-down list. 

5. Two files, DEM.mfm and Shaded.mfm, appear in the Available files list. 

6. Click the >> button to add the files to the Selected files list. 

7. Click Next. 

Some data file formats do not include coordinate system definition information. In order to 
import these files, a separate GeoMedia Coordinate System File must be supplied. 

8. Click Browse, navigate to \Grid Analysis Tutorials\Introductory Tutorials\Viewshed Analysis, 
select the UTM12N WGS84.csf file, and click Open.   

9. Click OK. 

10. A dialog box appears showing the current read-write connection BC Forestry. 

11. Expand the list hierarchy. 
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12. Inside the BC Forestry connection is a Study Area named by default Study Area 1 
containing the DEM and Shaded layers. 

13. Click Next. 

14. A final dialog box appears with a report giving information about the imported layer and the 
new Study Area. 

15. Click Finish to conclude the import process. 

HINT:  Grid Analysis can be used to prepare a DEM from a vector contour layer. For more 
information, see Introduction to Grid Analysis Mini-Tutorial: Contours to DEM. 

HINT:  Grid Analysis can be used to generate a shaded relief model from a DEM. For more 
information, refer to the on-line help for Grid > Visualization > Shaded Relief. 
 

Viewing Cell Values in a Grid Layer 

The Edit window is used to view a grid layer and its legend. It can also be used to alter cell 
colors and values and to visually group ranges of zones. 

1. On the Grid tab, in the Layer panel, click Edit. 

2. In the Edit Grid Layer dialog box, select DEM, and then click Edit to display the layer in the 
Edit window. 

3. Expand the Legend window to show its three columns: the cell colors, cell values, and 
number of cells in each zone. 

4. Scroll within the Legend window and examine the values. The values in the second column 
of the Legend window represent elevation in meters above sea level, accurate to one tenth 
of a meter. 
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5. Click the Query Raster Values tool , hold the left mouse button down, and move the 
mouse pointer over the grid layer. A 5-by-5 matrix of values is displayed under the pointer. 
Scan across the layer to view the cell values. 

 

6. When finished, close the Edit window. If prompted to save changes, click No. 

HINT: The grid layer named DEM was originally generated from the feature class CNTR_Line 
(vector contours) using the Spline interpolation command. 

 
 

Rasterizing Feature Classes 

Grid Analysis allows you to convert vector data to grid data using the Rasterize Legend Entries 
command. 

1. In the GeoMedia Map window, select the legend entries View_Point and F_FC_Area. 

2. On the Grid tab, in the Layer panel, click Rasterize Legend Entries. This command will 
immediately create two new grid layers. Note that there are no visible results in the Map 
window. 

3. On the Grid tab, in the Study Area panel, click List. The two new grid layers are listed in 
the Viewshed Study Area. 
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Grid Analysis - Generating Viewsheds from a Set of 
Veiwpoints Points 

Grid Analysis includes a powerful suite of Grid Analysis commands. Most Grid Analysis 
commands produce a new grid layer, which belongs to the current Study Area. 
 

Using the Information Window to Set the Data Units of an Obstruction Grid Layer 

When a GeoMedia feature class is rasterized, as in the last section of this tutorial, the data units 
of the resulting grid layer are set to "None" by default. In the present workflow, the grid layer 
F_FC_Area will be used as an "obstruction" layer when creating a viewshed. The viewshed 
calculations will be in meters; therefore, the data units of F_FC_Area must be changed to 
meters. 

The Grid Analysis Information window displays grid layer information such as size, data type, 
extents, cell resolution, and file location. The Information window also contains a facility for 
changing the layer’s assigned data units. 

1. On the Grid tab, in the Layer panel, click Layer > Information. 

2. Select the layer F_FC_Area, and click OK. 

3. Use the drop-down Data Units list to select Meters. 

4. Click OK. 
 

Using the Viewshed Command to Delineate Viewsheds 

The Viewshed command creates a Result layer identifying cells that can be "seen" from 
specified vantage points. This command requires a minimum of two input layers: a Source layer 
representing viewing locations (in this case, a set of two viewer points) and a Surface layer 
representing elevation. An optional Obstruction layer can also be included. 

Note that any non-VOID cell in the Source layer is treated as a viewing location. 

1. On the Grid tab, in the Analysis panel, click Surface > Viewshed. 

2. For Source layer, select View_Point from the drop-down list. This layer contains two 
single-cell viewing locations. 

3. For Surface layer, select DEM. 

4. For Obstruction layer, select F_FC_Area. This layer represents forest stands. 

5. For the Attribute of the Obstruction layer, scroll down the drop-down list and select 
STAND_HEIGHT. This will allow the viewshed calculation to include the height data of the 
local forests (recall that we specified a data units of meters for this layer in a previous step). 

6. Enter a Viewing Distance of 7.5 Kilometers. 

7. Enter a Viewing height of 2.0 Meters. This is the approximate height of a person. Viewing 
height is added to the Surface layer’s elevation values during the calculation. 
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8. Do not change the values in Vertical exposure or View bearing. For more information on 
these options, move the mouse pointer over the options and read the contextual help that 
appears at the bottom of the dialog box. 

9. Name the Result layer Viewshed. 

10. Remove the check from the Place results in map window check box. 

 

11. Click OK. The command will take a few moments to complete. 

HINT:  Occasionally, you may wish to use a Source layer that includes viewing locations of 
varying heights (for example, views from towers and from the air). To create such a Source 
layer, duplicate the original Source layer using Layer > Duplicate, and then use Layer > Edit 
Window to assign the desired heights to each viewing location. Then assign values of 0 to all 
non-viewing cells. Add this new layer to the original Surface layer using Calculator to create a 
new Surface layer. This grid layer will act as the new Source layer. Execute the Viewshed 
command using these new layers as inputs, specifying a viewer height of 0. 

  Make sure that the data units of the Source layer match those of the Surface layer. 
 

Using the Edit Window to Examine the Results of the Viewshed Command 

1. On the Grid tab, in the Layer panel, click Edit. 

2. Select Viewshed from the Edit Grid Layer list, and click Edit. 

3. Examine the legend, and note that this grid layer contains four zones: 
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 -1 (represents the two viewing locations) 

 0 (represents cells that cannot be viewed from either viewing location) 

 1 (represents cells that can be viewed from one viewing location) 

 2 (represents cells that can be viewed from both viewing locations) 

 

  It is possible for the viewshed layer to contain as many zones (+2) as there are 
viewing locations in the Source layer. 

1. Using the Query Raster Values tool , examine the values in the grid layer. Notice that, 
in some areas, there are small, regular "gaps" in the viewshed, represented by "0" values. 
These imperfections are artifacts of the DEM creation process, in which data values have 
been assigned in "stepped" increments. In the next tutorial section, you will remove these 
gaps using the Local Scan command. 

 

2. Close the Edit window. If prompted to save changes, click No. 

  To generate a viewshed layer in which each cell contains information regarding which 
viewing location can see it, use the following workflow:   

1. Create a Source layer for each viewing location. 

2. Ensure that each viewing location is assigned a unique value (that is, five viewing locations 
= five grid layers = five unique values).  

3. Execute the Viewshed command, once for each Source layer.  

4. Execute Implicit Cross Tabulation using all the viewshed Result layers to produce the 
desired final Result layer. The result will be a table of ones and zeros that is assigned a 
unique value for each unique viewshed combination. 
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Using the Local Scan Command to Fill In Small Gaps 

The concept of neighborhood is fundamental to grid-based GIS. Over a mappable surface, the 
value of a measured phenomenon is often dependent on the proximity of nearby values. 

Local Scan is used to characterize boundaries between different zones, calculate local 
statistics, smooth data, remove anomalous values, define transitions from one zone to another, 
and determine local uniformity or density. It functions by characterizing each target cell using 
cell values in a definable radial neighborhood surrounding that cell. The result statistic is stored 
in the target cell. 

In the present workflow, you will use Local Scan to remove small inconsistencies in the data. 
This step is especially important if the data is eventually to be vectorized, as it ensures that the 
resulting polygons will better represent the underlying data (gaps and anomalies fragment the 
data, resulting in the generation of a greater number of polygons). 

1. On the Grid tab, in the Analysis panel, click Statistical Analysis > Local Scan. 

2. From the drop-down list, select Viewshed as the Source layer. 

3. Leave the Window shape as Round, and specify a Window size of 5 Cells. The command, 
when executed, will use a round 5x5 cell scanning window to gather grid layer statistics. 

4. Select a Statistic of Maximum. This option produces a Result layer in which the data values 
represent the maximum (or highest) of the Source layer values that fall within the scanning 
window. 

5. To explore other Statistic options, press F1 and read the help. 

6. Name the Result layer Final Viewshed. 
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7. Accept the defaults for all other options. 

 

8. Click OK. The results will appear in the GeoMedia Map window. 

9. On the Home tab, in the Extent panel, click Fit All and view the layer. Notice that the 
step-like gaps are no longer present. 

 

Using the Edit Window to Color the Results of Local Scan 

1. On the Grid tab, in the Layer panel, click Edit. 

2. Select Final Viewshed from the Edit Grid Layer list, and click Edit. Note that the value "-1" 
(viewing locations) has been removed by the Local Scan command. 

3. In the legend, click on the black color element of the first legend entry to display the color 
palette. 

4. Click Transparent to change the color to "transparent." Note the change to the grid layer in 
the Edit window. The color appears white, but if this layer were draped over another layer, 
the lower layer could be seen through this zone. Recall that the value "0" represents the 
cells that cannot be seen from either viewing location. 

5. Click on the dark gray color element of the second legend entry to produce the color palette. 

6. Click Other in the color palette. 
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7. In the Color Picker, select a light green color by changing the value of Green to 60% and 
the Red and Blue values to 0% (RGB value 0,60,0). This zone represents areas that are 
visible from one viewing location. 

 

8. Click OK, and note the change to the layer in the Edit window. 

9. Use the same process to change the color of the third legend entry to dark green (RGB 
value 0,30,0). This zone represents areas that are visible from both viewing locations 
(southwest corner of the grid layer). 

10. Click the Zoom Ratio button  to change the zoom ratio to 2:1. 

11. Move the Legend window so that the layer zones are visible, and view the layer. 

 

12. Click the Save button , and close the Edit window. 

13. Exit the tutorial by closing GeoMedia Desktop. Do not save any changes. 
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