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S E C T I O N  1  

The City of Hamilton wanted to assess its Natural Heritage System. A healthy Natural Heritage 
System is a collection of interconnected and protected natural areas that can effectively 
maintain biological and geological diversity, natural functions, and sustainable populations of 
native species. 

According to the Toronto & Region Conservation Authority (TRCA), complex ecological 
information is needed for making informed decisions about a Natural Heritage System. 
Currently, land use decisions are made on a site-by-site basis, and they fail to consider 
cumulative impacts. A regional strategy is therefore required to set a context for making 
ecologically sound decisions. 

Given this, the City of Hamilton decided to follow the spatial analysis approaches that were used 
by the TRCA; namely, the City of Hamilton carried out a Landscape Analysis, a Vegetation 
Community Analysis, and a Species Analysis. 

Although each spatial analysis approach or phase was carried out separately, the final scoring 
of the Natural Heritage System incorporated information from all three phases into an overall 
ranking score for the entire system. However, for the purposes of this tutorial, we will focus on 
the first phase (Landscape Analysis) because some of the workflows within this phase relied 
heavily on raster analysis. 

  For details relating to the entire Natural Heritage Project, contact the Planning and 
Development Department at the City of Hamilton. 

The analysis of the Natural Heritage System, when completed, will provide complex ecological 
information that is needed to help direct land use policy, strategic planning, and environmental 
decision making. This information will allow planners to assess the impacts of land-use changes 
or restoration projects on individual natural areas and on the larger landscape. The development 
of the Natural Heritage System will also enable the staff to answer queries, to monitor changes 
in the natural habitat, and to produce custom maps. The City will have the ability to monitor the 
effectiveness of its protection policies for natural areas and to guide policy improvement over 
time. 
 

The Customer 
The City of Hamilton Planning and Development Department is responsible for a wide variety of 
functions associated with planning, land development, property management, and downtown 
renewal. To manage these responsibilities, the department is organized into four main divisions. 
The divisions include: 

▪ Building and Licensing 

▪ Development and Real Estate 

▪ Downtown Renewal 

▪ Long Range Planning 

Introduction 
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The Planning and Development Department operates within the GIS section (Official Plan & 
Information Planning) of the Long Range Planning department at the Stoney Creek City Hall 
office.  Most of the work in which The Planning and Development Department is involved is 
dictated by the overall policies outlined in the Official Plan & Zoning documents of the former 
region and municipalities of Hamilton. 
 

Participants 
The project described in this tutorial was conducted by Cathy Plosz and Richard Paola. Cathy 
has a Bachelor of Science degree in Biology and a Master of Science degree in Rural Planning. 
She worked as a field biologist for five years and then as Natural Heritage Planner for the City of 
Hamilton for the past eight years. 

Richard has a Bachelor’s degree in Geography, with 15 years of GIS/spatial analysis 
experience. The last eight years have been with the City of Hamilton, most recently with the 
Planning and Development Department. 
 

The Study Area 
The Study Area for the purposes of this project encompasses the entire area of the City of 
Hamilton, including the six former municipalities: Hamilton, Stoney Creek, Ancaster, Dundas, 
Glanbrook, and Flamborough. The total area of the City of Hamilton, according to Statistics 
Canada, is 1,117 square kilometers, with an urban area of approximately 22,000 hectares and a 
rural area of approximately 90,000 hectares.  

  Most of the natural features being captured and analyzed in the Natural Heritage project 
are located within the rural part of the Study Area. 
 

The Case Study 
As mentioned earlier, the workflow outlined in this tutorial concentrates on the Landscape 
Analysis phase of the Natural Heritage project. The Landscape Analysis portion of the Natural 
Heritage project consisted of three different spatial analysis techniques to determine an overall 
score for each forest patch; namely, Patch Size, Patch Shape, and Matrix Influence. 

  Patch Size and Patch Shape were determined using Functional Attributes within 
GeoMedia Desktop, while Matrix Influence was determined using Grid Analysis. This tutorial 
therefore outlines the process used to create the Matrix Influence score. 

Patch Size is simply the area of each polygon in hectares. Large habitat patches are preferable 
for biodiversity and maintenance of ecosystem integrity because they: 

▪ can support bigger populations of species, thus promoting their viability, 

▪ have the capacity to support area-sensitive and forest interior species, 

▪ are better buffered from negative external influences, 

▪ likely feature a greater diversity of habitat types, which increases biodiversity, 

▪ are more resilient to external influences, and 

▪ have a greater capacity to maintain and promote a variety of natural ecological 
processes (Forman, 1995; Bennett, 1999). 
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Small wetlands are likely to have more value to wildlife than forest patches of equivalent size, 
and they may also provide greater ecosystem functions per unit area; hence, wetlands were 
given higher weighting. The table below outlines the scores that were used for this portion of the 
Landscape Analysis phase. 

 

Score 

Size (ha) 
Forests, 

Meadows 

Size (ha) 

Wetlands 

1 > 0 < 1 

2 2 1 

3 10 3 

4 50 10 

Patch Shape is based on a simple equation where Shape = (0.282 x Perimeter) / (SqRt Area). 

  Patch Shape is a measure of its exposure to external influences, including the negative 
edge effects resulting from habitat fragmentation. Theoretically, the more convoluted the 
polygon, the longer its edge and the higher will be its exposure to these influences (Forman, 
1995). 

A perfect circle will return a result of 100. On the other end of the spectrum, a severely complex 
shape will be closer to a value of -100. The table below outlines the scores that were used for 
this portion of the Landscape Analysis phase. 

 

Score 

Forest, Meadows, and 
Wetlands Shape (P/A) 

1 500 

2 300 

3 200 

4 125 

5 100 

Matrix Influence is a measure of the positive or negative influence that a patch forest receives 
from its surroundings. Land uses, especially urbanization, adjacent to a patch can exert 
pressure or impacts that can have a profound effect on its biodiversity. 

Conversely, a patch can have a synergistic and beneficial relationship with other natural cover in 
its surrounding area and, to a lesser degree, with agricultural lands. In other words, a patch’s 
score for "Matrix Influence" reflects the degree to which the surrounding land cover and land 
uses threaten or contribute to its biological integrity and diversity. 

The TRCA measures the character of the matrix within a 2-km radius out from the outside edge 
of each habitat patch. The 2-km radius of influence extends beyond the limit of a Study Area 
(region, watershed, or an AOC, for example) if needed. The radius length of 2 km was chosen 
because: 
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1. it is considered to be a reasonable foraging circuit for predatory species associated with 
edge effects, such as raccoons, foxes, feral cats, and cowbirds (negative influence), 

2. it is the distance within which most genetic exchange and species dispersal can be 
expected from most flora and fauna species (positive influence), and 

3. it is a distance that could be considered reasonable for people who regularly visit a natural 
area for recreational purposes by walking, cycling, or driving (negative influence). 

  See Austen et al. 2001; Austen and Bradstreet 1996; Hames et al. 2001; Norris & 
Stutchbury 2001; Haddad 2000; Askins et al. 1987; Robbins et al. 1989. 

In scoring for Matrix Influence, land cover types are calculated as a percentage of the total area 
within 2 km from the edge of each habitat patch. For the purposes of this calculation, there are 
three categories of land cover:  natural, agricultural, and urban, each receiving a base value of 
1, 0, or -1 (respectively) on the gradient of influence. 

Natural cover surrounding a patch is considered to have a positive influence and receives a 
value of +1.  Included in this category are patches of the major habitat types (forest, wetland, 
and meadows), as well as open water in the form of lakes, rivers, and ponds. 

Agricultural lands can have negative impacts, such as pesticide runoff, but they also allow for 
the movement of many species between patches and across the landscape, in particular for 
amphibian movements between forests and wetlands. As a result, they score 0 points as the 
midpoint on a continuum. 

This connectivity function is not provided for many species by urban land uses. In fact, due to 
pollution, refuse, recreational pressures, the presence of dogs and cats, invasive species, and 
so on, urban areas in general can be considered harmful to natural habitats. Therefore they 
receive a base point of -1. 

The percent of each of the land-cover types is measured within the 2-km matrix, and each is 
multiplied by the base point value. From a biodiversity conservation perspective, the perfect 
patch surroundings would be 100 percent natural (for example, wetland within an extensive 
forest patch and measuring at least 2 km out from the wetland edge) and would receive a matrix 
score of 100, while the lowest possible score is minus 100 for a natural habitat patch 
"immersed" within an expanse of urban (residential or industrial) land. 

 

Score 

Forest 

Matrix Influence 

1 -100 to - 60 

2 < -20 

3 -20 to + 20 

4 > +20 

5 +60 to +100 

Each of the total weighted scores for landscape was then translated into individual patch ranks 
(Local Ranks) based on the range of possible total scores from 0 to 15 points. L1 is the highest 
local rank, and L5 is the lowest. 
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Score Rank Patch Color ‘Quality’ Condition 

13-15 L1 Green Excellent 

11-12 L2 Brown Good 

9-10 L3 Beige Fair 

6-8 L4 Blue Poor 

0-5 L5 Red Very Poor 

 
 

Tutorial Text Conventions 
There are several conventions used throughout the tutorial: 

▪ Ribbon bar items are shown as: On the Aaa tab, in the Bbb panel, click Ccc > Ddd. 

▪ Dialog box names, field names, and button names are depicted using Bolded Text. 

▪ Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 
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S E C T I O N  2  

The workflow outlined in this tutorial starts from six area-based feature classes that are stored in 
the Access warehouse entitled Land_Use_Sample.mdb (Agriculture, Urban, Successional, 
Meadow, Forest, Wetlands, and Water). 

Grid Analysis commands are used to merge the six land use categories into one map containing 
three land use categories. The three land use categories comprise the following land uses: Land 
Use 1: Agriculture; Land Use 2: Urban; and Land Use 3: Successional, Meadow, Forest, 
Wetlands, and Water. The process of creating the three-category land use map is presented 
below as a flow chart. 

 
 

Data Preparation 



 Data Preparation 
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Opening the Workspace 
Grid Analysis is completely integrated with the GeoMedia Desktop and is available when the 
GeoMedia Advantage or GeoMedia Professional tiers are used. 

1. Launch GeoMedia Desktop, and select Open an existing GeoWorkspace. 

2. Double click the More Files… option, and browse to \Grid Analysis Tutorials\Customer-
Based Tutorials\A Natural Heritage Study.  

3. Select Natural Heritage.gws, and click Open. 

4. If GeoMedia Desktop requests the name of a database file, browse to \Grid Analysis 
Tutorials\Customer-Based Tutorials\A Natural Heritage Study, and select 
Land_Use_Sample.mdb.  

5. Make sure that the mdb file is correctly referenced before moving on to the next step. The 
GeoMedia Map window will open. 

The Natural Heritage GeoWorkspace has a Microsoft® Access read-write database relating 
to the city of Hamilton in the province of Ontario, Canada. The Land_Use_Sample database 
has the land use information for the area in question. 

The GeoMedia Map window displays seven features classes (FOREST, MEADOW, 
SUCCESSIONAL, AGRICULTURE, URBAN, WATER, and WETLANDS). 

6. Take a moment to look at both the GeoMedia Map window and the legend to identify the 
different feature classes. 

 

Selecting the Study Area 
A Study Area must be defined and/or selected before any analysis can be done. Study areas 
are used to define the geographic location of the grid layers belonging to it and the geographic 
projection, coordinates, and cell resolution shared by all the grid layers used in the analysis. The 
geographic projection and coordinate systems set for the GeoWorkspace will also be used for 
the Study Area defined in that GeoWorkspace. 

If your company or department has a standard projection, you can rasterize all your feature 
classes in that projection. If you have Grid data in different projections, Grid Analysis has 
facilities to reproject your data (for an example of how to Copy/Reproject data between Study 
Areas, refer the Introductory Tutorial that is delivered as part of the GeoMedia Desktop). 

1. On the Grid tab, in the Study Area panel, click List. 

The Study Area List window shows, in tree form, the GeoWorkspace connections, the 
Study Areas defined for each connection, and the grid layers associated with each Study 
Area. The name of the active Study Area is both highlighted and shown in the Current 
Study Area field. 

2. Ensure that the current Study Area is set to Analysis. If this is not the case, click on the text 
Analysis in the Study Area list view tree. 
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Rasterizing Feature Classes 
Rasterizing a feature class converts a feature class (vector) to a grid representation or raster. 

1. In the GeoMedia Legend window, select all seven feature classes (legend entries). 

2. On the Grid tab, in the Layer panel, click Rasterize Legend Entries. 

A progress bar at the bottom of the window tracks the execution of the command. In this case, 
all seven feature classes will be converted to grid files.  

  Some commands are accomplished so quickly that the progress bar is visible for only an 
instant. 

The Study Area List window will now show seven grid layers under the Analysis Study Area 
(you may need to click to expand the tree). 

 
 

Using the Recode Command to Create Land Use 1 
Grid Layer 

The Recode command generates a Result layer in which each cell is assigned a user-specified 
value based on the value of the corresponding cell in the Source layer. 

A small spreadsheet-like table is used to specify what value is to be assigned to what value, 
value list, or value range of the input map layer. In the example below, the value "0" in the new 
map layer will be assigned to the value "18" in the input map layer; the value "1" will be assigned 
to the values "19 through 31, inclusive"; the value "2" will be assigned to all numbers "32 and 
greater"; and the value "3" will be assigned to the values "8", "9", and "12".  

In the second and third cases, the ellipsis (...) is used to indicate a range. It can be used to 
indicate greater or equal, less than or equal, or an inclusive range. Any values in the Source 
layer not explicitly reassigned result in "VOID" in the Result layer. 

 

Creating a grid layer by rasterizing a GeoMedia feature class generates a Primary Key (ID) 
where each raster polygon is identified by the primary key in the database (that is, the key that 
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identifies each record in a feature class). The ID is written to the grid layer and is used to link the 
layer to the database. This allows users to specify an attribute in a Grid command. 

 

In this workflow, all the Agricultural polygons need to have a grid value of one (1). As noted 
above, the grid values in the Agriculture grid layer currently reflect the Database IDs. To 
change these values, use the Recode command. 

1. On the Grid tab, in the Analysis panel, click Classification > Recode. 

2. For the Source layer, use the drop-down list, and choose AGRICULTURE in the Layer 
name field. 

3. The Assigning value and To value fields are used to specify the new values and the zones 
to which they will be assigned. Type 1 in the first Assigning value field. 

4. The new value will be assigned to all the values in the input grid layer. In the first To value 
field, type 0…. Do not forget the ellipsis (three dots) after the 0. This specifies any zones 
with value 0 or greater. 

5. Press the Enter key on the keyboard to enter the value just typed. All the remaining zones 
will be assigned a "VOID" value in the output grid layer unless otherwise specified. This 
results in other zones being "thrown away." 

6. For the Result layer, type LUM1 in the Layer name field. 



 Data Preparation 

 

 

Grid Analysis: A Natural Heritage Study 14 
 

7. Clear the Place results in map window check box. The Recode dialog box should look like 
the following example. 

 

8. When the inputs match those shown above, click OK. 

The grid layer LUM1 can be viewed in the Grid Edit window. This layer will have two zones, one 
with value "VOID" and the other with value 1. The zone with a value of 1 corresponds to areas 
with an agricultural land use. 
 

Using the Recode Command to Create Land Use 2 
Grid Layer 

In this workflow, the City of Hamilton wanted all of the urban polygons to represent the second 
land use layer. As noted above, the grid values in the Urban grid layer currently reflect the 
Database IDs. To change these values, use the Recode command. 

1. On the Grid tab, in the Analysis panel, click Classification > Recode. 

2. For the Source layer, use the drop-down list, and choose URBAN in the Layer name field. 

3. The Assigning value and To value fields are used to specify the new values and the zones 
to which they will be assigned. Type 2 in the first Assigning value field. 

4. The new value will be assigned to all the values in the input grid layer. In the first To Value 
field, type 0…. Do not forget the ellipsis (three dots) after the 0. This specifies any zones 
with value 0 or greater. 

5. Press the Enter key on the keyboard to enter the value just typed. All the remaining zones 
will be assigned a "VOID" value in the output grid layer unless otherwise specified. This 
results in other zones being "thrown away." 

6. For the Result layer, type LUM2 in the Layer name field. 
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7. Clear the Place results in map window check box. The Recode dialog box should look like 
the following example. 

 

8. When the inputs match those shown above, click OK. 

The grid layer LUM2 can be viewed in the Grid Edit window. This layer will have two zones, one 
with value "VOID" and the other with value 2. The zone with a value of 2 corresponds to areas 
with an urban land use. 
 

Using the Overlay and Recode Commands to Create 
Land Use 3 Grid Layer 

The third Land Use map layer needs to reflect a combination of land uses (specifically 
Successional, Meadow, Forest, Wetlands, and Water). To merge these grid layers into a single 
grid layer, use the Overlay command. 

The Overlay command creates a new grid layer by effectively overlaying two to six grid layers. 
The process is analogous to placing maps one on top of another on a light table, aligning them 
to a common coordinate system, and creating a new map from the visible result. Within this 
analogy, cells with data value VOID are "transparent," and all other cells are "opaque." 

  The order in which the layers are specified determines the results. Layers are stacked 
from the bottom of the dialog box to the top of the dialog box (that is, the bottom layer is covered 
by the subsequent layers in turn).  

1. On the Grid tab, in the Analysis panel, click Visualization > Overlay. 

2. For the bottom Source layer, use the drop-down list, and choose SUCCESSIONAL in the 
Layer name field. 

3. For the second Source layer, use the drop-down list, and choose MEADOW in the Layer 
name field. 

4. For the third Source layer, use the drop-down list, and choose FOREST in the Layer name 
field. 
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5. For the fourth Source layer, use the drop-down list, and choose WETLANDS in the Layer 
name field. 

6. For the fifth Source layer, use the drop-down list, and choose WATER in the Layer name 
field. 

7. Leave the Overlay without mosaic option checked. Since all the layers spatially 
correspond with each other, the mosaic option is not required. This option is typically used 
when the input layers do not coincide with one another (that is, when the Overlay without 
mosaic option is checked, the extents of the Result layer will be equal to the intersection of 
the extents of the Source layers. When Overlay without mosaic is unchecked, the extents 
of the Result layer will be the union, or the mosaic, of the extents of the Source layers). 

8. For the Result layer, type LUM3_Temp in the Layer name field. 

9. Clear the Place results in map window check box. The Overlay dialog box should look 
like the following example. 

 

10. When the inputs match those shown above, click OK. 

To conceptualize how the Overlay command works, think of map layers as stacks of 
transparencies. When viewed from above, all of the information on the top layer is visible – as 
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well as anything from the lower maps that shows through the transparent areas of the upper 
maps. 

 

When the Overlay command is used, cells that have VOID values are transparent, and cells 
with any other values are opaque. Overlay can be used to superimpose any number of maps. 
The maps that result from this operation show all of the information from the map and from the 
information from lower maps that occur in the VOID areas of the top map. 

  If the same data value appears in two or more Source layers, this value will be merged 
into a single zone (single color) in the Result layer, and the text from the topmost Source layer is 
used. To avoid this, ensure that the Source layers do not have data values in common. This can 
be accomplished by using the Recode command to preprocess the Source layers. 

The grid layer LUM3_Temp can be viewed in the Grid Edit window. This layer will contain many 
zones because this grid layer contains the ID values from a number of grid layers. To change 
these values, use the Recode command. 

1. On the Grid tab, in the Analysis panel, click Classification > Recode. 

2. For the Source layer, use the drop-down list, and choose LUM3_Temp in the Layer name 
field. 

3. The Assigning value and To value fields are used to specify the new values and the zones 
to which they will be assigned. Type 3 in the first Assigning value field. 

4. The new value will be assigned to all the values in the input grid layer. In the first To Value 
field, type 0…. Do not forget the ellipsis (three dots) after the 0. This specifies any zones 
with value 0 or greater. 

5. Press the Enter key on the keyboard to enter the value just typed. All the remaining zones 
will be assigned a "VOID" value in the output grid layer unless otherwise specified. This 
results in other zones being "thrown away." 

6. For the Result layer, type LUM3 in the Layer name field. 
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7. Clear the Place results in map window check box. The Recode dialog box should look like 
the following example. 

 

8. When the inputs match those shown above, click OK. 

The grid layer LUM3 can be viewed in the Grid Edit window. This layer will have two zones, one 
with value "VOID" and the other with value 3. The zone with a value of 3 corresponds to areas 
with a Successional, Meadow, Forest, Wetlands, and Water land use. 
 

Using the Overlay Command to Superimpose Land 
Use Grid Layers 

The Score command could now be used to calculate the percentage of each Land Use type that 
falls within 2 kilometers of each forest patch; however, the Score command would have to be 
run three times (or one time for each of the land use maps – LUM1, LUM2, and LUM3). To 
streamline the process, the three Land Use grid layers will be merged into a single grid layer 
using the Overlay command. 

1. On the Grid tab, in the Analysis panel, click Visualization > Overlay. 

2. For the bottom Source layer, use the drop-down list, and choose LUM1 in the Layer name 
field. 

3. For the second Source layer, use the drop-down list, and choose LUM2 in the Layer name 
field. 

4. For the third Source layer, use the drop-down list, and choose LUM3 in the Layer name 
field. 

5. For the Result layer, type LUM123 in the Layer name field. 
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6. Clear the Place results in map window check box. The Overlay dialog box should look 
like the following example. 

 

7. When the inputs match those shown above, click OK. 
 

Using the Fill Gaps Command to Remove Slivers 
The final step in the data preparation is to remove any slivers from the final input map. Slivers 
can occur when individual feature classes are rasterized at a low resolution and then combined 
into a single grid layer. The Fill Gaps command takes care of this by filling VOID areas between 
area features with values that match the values of each source feature. 

The Source layer typically has groups of cells that comprise an area-based phenomenon, such 
as deposits of glacial till, parcels of land, or the area of fields of various crop types, with gaps 
between adjacent area features. 

The Result layer will be similar to the Source layer, but with the gaps between area features 
filled with the values of the area features that bound them. This command does not interpolate 
any new values: the Result layer will contain the same number of zones as the Source layer 
minus the VOID zone because all void values are replaced. 

1. On the Grid tab, in the Analysis panel, click Zone > Fill Gaps. 

2. For the Source layer, use the drop-down list, and choose LUM123 in the Layer name field. 

3. For the Result layer, type Land Use Map in the Layer name field. 
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4. Select the Place results in map window check box. The Fill Gaps dialog box should look 
like the following example. 

 

5. When the inputs match those shown above, click OK. 

The Final Land Use Map grid layer contains three zones (namely, 1 through 3) because all of 
the VOID cells were removed during the fill gaps process. The data is now ready to feed into the 
Matrix Influence process. 

1. Use the GeoMedia Legend window to set the display of all the feature classes except Land 
Use Map to off.  

2. Click the GeoMedia Fit All button to fit the contents of the Land Use Map legend entry to 
the GeoMedia Map window. 

 

  The City of Hamilton applied a 2-KM buffer zone around the city limits to ensure that 
those forest patches close to the city limits were not adversely affected by not having the data 
needed to perform matrix scoring. 
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S E C T I O N  3  

The process of creating this map layer required six individual commands to produce the desired 
results. In this instance, the Final Land Use map only needed to be created once; however, 
given that this tutorial is also about automation, a command has been included with this tutorial 
that illustrates how this workflow can be combined into a single command. 

For those who are interested, the files needed to explore and test this command are located in 
the \Grid Analysis Tutorials\Customer-Based Tutorials\A Natural Heritage Study\Custom 
Commands\LandUseGenerator folder. This folder contains the source code and the related 
project files needed to modify and compile the command, but it does not contain the compiled 
version of the command. The source files can be found in the folder entitled 
LandUseGenerator\src. Compiling this solution will cause the compiled files to be written in the 
folder called LandUseGenerator\bin. This must be done prior to installing the Land Use 
Generator command as described below. You can use the project to learn how this command 
was created. Feel free to copy this code. 

 If you downloaded the tutorial data set from the internet, you should right click on the zip 
file, select Properties, check the Unblock option and click Apply before unzipping the contents. 
Failure to do this may prevent you from compiling the source code. 

  If you are interested in creating your own Grid Analysis commands, also refer to the 
Create a Custom Command Tutorial, which outlines how you can create new, empty Grid 
Analysis custom commands. 
 

Installing the Land Use Generator Command 
All commands must be installed before they can be used within GeoMedia Desktop. GeoMedia 
Desktop provides a command line utility, InstallAppCmd, for installing one or more application 
commands.  For ease of use, we have provided simple batch scripts that run the 
InstallAppCmd utility for each of the commands we deliver with this tutorial, and we will use this 
approach to install the commands.  

A full description of the syntax and use of the InstallAppCmd utility can be found in the Install 
Application Command Tool section of the GeoMedia Command Wizard Help document. 

1. Exit GeoMedia Desktop. 

2. Save any changes. 

3. Browse to \Grid Analysis Tutorials\Customer-Based Tutorials\A Natural Heritage 
Study\Custom Commands\LandUseGenerator\bin.  

4. Double click on the InstallCommand.bat file.  

  This step requires that you have administrator privileges. If the command installs 
correctly, you should see a message box letting you know that the command successful 
loaded. 

Automating the Data Preparation 
Workflow 
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  If you want to un-install this command, simply double click on the 
UninstallCommand.bat file. 

 

Testing the Land Use Generator Command 
Once a custom command has been installed, it will be automatically added to the My Workflow 
tab on the GeoMedia Desktop ribbon bar. 

1. Launch GeoMedia Desktop, and select Open an existing GeoWorkspace. 

2. Double click the More Files… option, and browse to \Grid Analysis Tutorials\Customer-
Based Tutorials\A Natural Heritage Study.  

3. Select Natural Heritage.gws, and click Open. 

4. On the My Workflow tab, click Land Use Generator. 

5. Use the mouse to set the Agricultural Land Use layer to AGRICULTURE. 

6. Use the mouse to set the Urban Land Use layer to URBAN. 

7. Use the mouse to set the Natural Land Use layer to FOREST, MEADOW, 
SUCCESSIONAL, WATER, and WETLANDS. Use the Control key ("Ctrl") when selecting 
multiple entries within this dialog box. 

8. Use the Color controls to set a desired color for each of the land use types. 

9. Accept the default Result layer name, and leave the Place results in Map window option 
checked. 

 

10. Once the dialog box look similar to the example presented above, click OK to execute the 
command. 

This command automates the data preparation phase of this project that you carried out earlier 
in this tutorial. In short, it takes the contents of the AGRICULTURE and URBAN layers and 
assigns them a value of 1 and 2, respectively; it then takes the contents of the FOREST, 
MEADOW, SUCCESSIONAL, WATER, and WETLANDS layers and combines them into a 
single layer with a value of 3; the command then combines all three land use maps together into 
a single layer. 
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Since the custom command mimics the workflow that you did earlier in this tutorial, the contents 
of the new grid Result layer (Land Use) should match those of the grid layer called Land Use 
Map. To determine if these maps are identical, you can make use of the Relational/Boolean 
operators in the Calculator command. 

The Calculator creates a new grid layer by applying mathematical and/or relational operations 
to one or more input grid layers. The operations are applied to the values of the cells of the input 
grid layer(s) in a process known as "layer math" or "overlay math." This command is very 
powerful and can be used to perform complex overlay analysis. 

1. On the Grid tab, in the Analysis panel, click Calculator to display the Calculator 
command. 

2. When the calculator opens, click on the Scientific radio button to open the full calculator 
window. 

3. Double click the layer named Land Use Map from the Available layers list. 

4. Click the button  to place == after the layer name. This button indicates that you 
want to make use of the relational operator "equal." 

  The relational operators (<, <=, >, >=, ==, and !=) and the logical operators (AND, OR, 
NOT, &, |, !) return fixed-point results (1 or 0, where 1 = True and 0 = False). 

1. Double click the layer named Land Use from the Available layers list. 

2. The statement should look like this: Land Use Map == Land Use. 

3. Rename the Result layer to Validity Check. 

4. Check the Place results in map window check box. 

 

5. Once your Calculator dialog looks like the example presented above, click OK. 

  The resulting map should be entirely black. Use the Cell Magnifier  to examine the 
results. The entire map should be filled with a single value (that is, 1); this condition indicates 
that every cell at every location in the two input layers match (that is, their condition is true). 

If your map has even a single 0 in it, a mistake was made along the way because this condition 
indicates that not all the values in the two input map layers match (that is, their condition is 
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false). If this is the case, do not worry as you will be making use of the grid layer named Land 
Use from this point forward. 
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S E C T I O N  4  

As mentioned earlier, Matrix Influence is a measure of the positive or negative influence that a 
patch forest receives from its surroundings. Land uses, especially urbanization, adjacent to a 
patch can exert pressure or impacts that can have a profound effect on its biodiversity.   

Conversely, a patch can have a synergistic and beneficial relationship with other natural cover in 
its surrounding area and, to a lesser degree, with agricultural lands. In other words, a patch’s 
score for "Matrix Influence" reflects the degree to which the surrounding land cover and land 
uses threaten or contribute to its biological integrity and diversity. 

To compute a matrix score, the Recode command is used to extract a forest polygon to 
process. The Buffer command is then used to create a 2000 meter buffer around the extracted 
forest patch. The Explicit Cross Tabulation command is then used to determine the 
proportions for each land use category that fall within 2000 meters of the forest patch. The 
following flow chart outlines the process in graphical form. 

 

Determining a matrix score for an individual forest patch requires two input layers, namely, Land 
Use and Forest grid layers. 

The Land Use map contains three zones (1 = Forest, 2 = Urban, and 3 = Natural Areas). This 
map was created earlier using the Urban, Forest, Meadow, Successional, Urban, Waters, and 
Wetlands feature classes. 

Each feature class was rasterized using the Rasterize Legend Entries command, after which a 
combination of Grid Analysis commands were used to create a single Land Use grid layer on 
which Agriculture polygons were assigned a value of 1, Urban polygons were assigned a value 
of 2, and Forest/Meadow/Successional/Water/Wetlands were combined and assigned a value of 
3. 

Determining a Matrix Score for a Forest 
Patch 
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Database Connectivity Explained 
Earlier in this tutorial, you created the Forest grid layer by making use of the Rasterize Legend 
Entries command, which converts a vector feature class into a grid representation and, in doing 
so, carries the value in the database field that has been designated as the primary key from the 
database through to the resulting grid layer, thereby maintaining database connectivity. 

In this tutorial, the database field ID1 is defined as the primary key, and as a result, this 
information was written to the resulting Forest grid layer. 

 

This connectivity is very useful because it allows numeric attributes to be used in the grid 
analysis or, in this case, to update the FOREST table with the matrix values MATRIX_SCORE, 
PREC_AGRICULTURE, PREC_URBAN, and PREC_NATURAL. 

1. On the Home tab, in the Window panel, click Add/Show Window > New Data Window to 
display the New Data Window dialog box. 
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2. Select the FOREST entry, and click OK to display the data window for the FOREST table. 

 

Notice that this table has five fields. With the exception of ID1, these fields are empty. You 
are going to use Grid Analysis to manually update the empty fields for ID1 = 14. 

3. Click Close to close the data window. 
 

Using the Recode Command to Extract a Forest Patch 
The Recode command generates a Result layer in which each cell is assigned a user-specified 
value based on the value of the corresponding cell in the Source layer. 

1. Use the GeoMedia Legend window to set the display of all the feature classes except Land 
Use to off. 

2. On the Grid tab, in the Analysis panel, click Classification > Recode. 

3. For the Source layer, use the drop-down list, and choose FOREST in the Layer name field. 

4. Click in the Attribute drop-down list. Notice that the ID1, PERC_*, and MATRIX_SCORE 
fields are listed. These fields can therefore be used as part of your grid analysis. This 
example illustrates the database connectivity that is maintained when you make use of the 
Rasterize Legend Entries command. 

 

5. Select ID1 in the Attribute drop-down list. 

6. The Assigning value and To value fields are used to specify the new values and the zones 
to which they will be assigned. Type 1 in the first Assigning value field. 

7. The new value of 1 will be assigned to the forest patch that has a value of 14. In the first To 
value field, type 14. 

8. Press the Enter key on the keyboard to enter the value just typed. 

9. For the Result layer, type Forest Patch 14 in the Layer name field. 
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10. Select the Place results in map window check box. The Recode dialog box should look 
like the sample found below. 

 

11. When the inputs match those shown, click OK. 

The operations will take a few seconds to process. Once the command completes, a new grid 
layer named Forest Patch 14 will be added to the GeoMedia Map window. 

 

The new grid layer will only contain two zones (VOID and 1). The zone with a value of 1 
represents the forest patch that is about to be analyzed. As can be seen in the graphic 
presented above, the forest patch is located approximately in the center of the map. 
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Using the Buffer and Recode Commands to Create a 
2000 Meter Buffer Zone 

The Buffer command defines a distance or cost buffer from a source location to a specified 
distance or cost. The Buffer command's options can be used independently or in combination, 
allowing a wide variety of input and results. Buffer is a very powerful tool for data creation, 
spatial analysis, terrain analysis, and surface propagation modeling. 

The Buffer command generates both standard Euclidean distance buffers and non-Euclidean 
distance buffers that take into account elevation change, uphill and/or downhill directions, and 
friction/cost values that represent surface characteristics. The non-Euclidean buffers are 
modified by the shape and character of the terrain over which they are being measured. In this 
example, we want to create a 2000 meter buffer around forest patch 14. 

1. On the Grid tab, in the Analysis panel, click Zone > Buffer. 

2. For the Source layer, use the drop-down list, and choose Forest Patch 14 in the Layer 
name field. 

3. Set the Maximum extent – Value field to 2000 Meters. 

4. For the Result layer, type 2000M Buffer in the Layer name field. 

5. Leave the rest of the options alone. The Buffer dialog box should look like the sample found 
below. 

 

6. When the inputs match those shown, click OK. 
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The operations will take a few seconds to process. Once the command completes, a new grid 
layer named 2000M Buffer will be added to the GeoMedia Map window. 

 

When the distance/cost is chosen, the Result layer values give distance or cost from the source 
points, lines, and/or areas. The distances or costs are measured incrementally. The value for 
each cell in the Result layer is the distance from one cell to the next plus the distance already 
accumulated to the cell. The new grid layer will contain 1983 zones ranging in value from 0 to 
2000, where 0 represents the original forest patch, and the rest of the values represent the cell’s 
distance in meters away from the original forest patch. 

In the example below, the zone with a value of 0 (that is, the original forest patch) was assigned 
a dark gray; and the zones with the values 1 to 2000 were assigned a Red, through Yellow, 
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through Blue color sequence. To further illustrate the results of the Buffer command, the Cell 
Magnifier tool was used to display the values in a portion of the buffer. 

 

In the example above, the Cell Magnifier tool was positioned 696 meters from the edge of the 
original forest polygon. If you were to move the Cell Magnifier tool to the outer edge of the 
buffer, the values would read either close to 2000 or exactly 2000. If you are interested in 
exploring the results more closely, take some time to experiment with different color sequences 
and to test the Cell Magnifier tool. 

Transparency and a layered effect can be achieved using the Grid > Visualization > Blending 
command. This command allows user experimentation with different color sequences, with 
blending modes, and with the merging of multiple themes (grid layers) into a single view. 
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In the example below, the 2000 meter buffer zone map was grouped into 500 increments, and a 
black-through-gray color ramp was applied. This map was then merged with the Land Use map 
using the Blending command. 

 

This example effectively shows the land uses that fall within 2000 meters of forest patch 14. 
 

Using the Explicit Cross Tabulation Command to 
Determine Land Use Proportions within Buffer Zone 

The Explicit Cross Tabulation command answers the question, "Where do phenomena in grid 
layer 1 coincide with phenomena in grid layer 2?" (and grid layer 3? and grid layer 4?...) The 
command cross-tabulates unlimited combinations of values, in up to six Source layers, cell by 
cell, producing a Result layer of designated values. 

Explicit Cross Tabulation assigns values based on user-specified combinations of values in 
the Source layers. In the example below, the Result layer will have exactly three data values. 
Those cells that coincide spatially with cells having value "30" in the Roads layer, "4" in the 
Hydrology layer, and "500" in the Urban layer will have value "1." Those cells that coincide 
spatially with cells having value "30" in the Roads layer, "VOID" in the Hydrology layer, and 
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"500" in the Urban layer will have value "2." All other cells in the Result layer will have value 
"VOID." Use the Arrow Keys to navigate the Grid. 

 

Value combinations not specified in the dialog box are assigned the value "VOID." The legend 
texts of the Source layers are combined and represented in the legend of the Result layer. 

In this example, we want to find out the total amount of each land use that falls within the 2000 
meter buffer zone. Given this, we need to determine where: 

▪ Zone 1 – (Agriculture) in Land Use coincides with the zones 1 through 2000 in 2000M 
Buffer, 

▪ Zone 2 – (Urban) in Land Use coincides with the zones 1 through 2000 in 2000M Buffer, 

▪ Zone 3 – (Natural) in Land Use coincides with the zones 1 through 2000 in 2000M Buffer, 

 

The Explicit Cross Tabulation command is excellent for performing this type of overlay 
analysis. 

1. On the Grid tab, in the Analysis panel, click Classification > Explicit Cross Tabulation. 

2. For the Source layers, use the To layer drop-down list, and choose Land Use. 



 Determining a Matrix Score for a Forest Patch 

 

 

Grid Analysis: A Natural Heritage Study 34 
 

3. For the Source layers, use the first With layer drop-down list, and choose 2000M Buffer. 

4. Working down the first Assigning Value column, set the values to 1, 1, and 1…2000. 

5. Working down the second Assigning Value column, set the values to 2, 2, and 1…2000. 

6. Working down the third Assigning Value column, set the values to 3, 3, and 1…2000. 

7. For the Result layer, type Answer in the Layer name field. 

8. Leave the rest of the options alone. The Explicit Cross Tabulation dialog box should look 
like the sample found below. 

 

9. When the inputs match those shown, click OK. 

The operations will take a few seconds to process. Once the command completes, a new grid 
layer named Answer will be added to the GeoMedia Map window. 

 

The black areas, or zone 1, represent those areas where land use 1 (Agriculture) falls within the 
1-2000 meter buffer zone; the lighter gray areas, or zone 2, represent those areas where land 
use 2 (Urban) falls within the 1-2000 meter buffer zone; and the lightest gray areas, or zone 3, 
represent those areas where land use 3 (Natural) falls within the 1-2000 meter buffer zone. 
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Keep in mind that Matrix Influence is a measure of the positive or negative influence that a patch 
forest receives from its surroundings. We now have a graphic representation of these influences 
for forest patch 14. The next step involves using the legend for this grid layer to calculate a 
percentage influence for each land use and then using these values to determine an overall 
score for the forest patch. 

1. On the Grid tab, in the Layer panel, click Layer > View Legend. 

2. For the Source layer, use the drop-down list, and choose Answer in the Layer name field. 

 

The View Legends command opens the View Legends window, which is used to select and 
display the legend information associated with any of the grid layers in the currently active Study 
Area. Standard legend editing tools are available in the View Legends window. Changes made 
in the View Legends window can be viewed and discarded or saved when the window is 
closed. 

Notice that the default legend contains the Color, Value, Area, and Text elements. The Area 
element defaults to cells (that is, the number of cells that make up the zone). This value and the 
entire format of the legend can be changed using the context-sensitive menu that is associated 
with the legend. To access this facility, right click in the legend, and choose Format. 

For now, the cell count is fine for our purposes. To calculate the percentage coverage for each 
land use, the calculation is: 

Zone 1 or PREC_AGRICULTURE = (335248 / (335248 + 88451 + 197666)) * 

100) *0 = 0 

Zone 2 or PREC_URBAN = (88451 / (335248 + 88451 + 197666)) * 100)* -1 = 

-14.23 

Zone 3 or PREC_NATURAL = (197666 / (335248 + 88451 + 197666)) * 100) = 

31.81 

To calculate the overall matrix score for forest patch 14, the calculation is: 

MATRIX_SCORE = (0) + (-14.23) + (31.81) = 17.58 

You have now calculated the matrix score for forest patch 14. However, the Study Area included 
the former municipalities of Hamilton, Stoney Creek, Ancaster, Dundas, Glanbrook, and 
Flamborough. The total area of the City of Hamilton is 1,117 square kilometers, and when one 
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includes all major natural covers (forest, wetlands, and meadows), the area contains more than 
4000 contiguous patches. 

Herein lies the problem. As illustrated, Grid Analysis contains the command necessary to 
determine a matrix score for each forest patch; however, each forest patch would have to be 
analyzed manually. Given that the manual process would require approximately 7 minutes per 
forest patch, this route was not a viable option because the time needed to process the entire 
Study Area would not warrant the investment. 
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S E C T I O N  5  

As illustrated earlier in this tutorial, Grid Analysis workflows can be automated. For those who 
are interested, the files needed to explore and test this command are located in the \Grid 
Analysis Tutorials\Customer-Based Tutorials\A Natural Heritage Study\Custom 
Commands\MatrixScoreCalculator folder. This folder contains the source code and the related 
project files needed to modify and compile the command, but it does not contain the compiled 
version of the command. The source files can be found in the folder entitled 
MatrixScoreCalculator \src. Compiling this solution will cause the compiled files to be written in 
the folder called MatrixScoreCalculator \bin. This must be done prior to installing the Matrix 
Score Calculator command as described below.. 

Below is pseudo code that outlines the entire process needed to perform the analysis on each 
forest patch.  

For I = FirstPatch to LastPatch in ForestPatchMap 

 A = Recode ForestPatchMap Assigning 1 to I 

 B = Buffer A to 2000 Meters 

 C = Explicit Cross Tabulation B With LandUseMap 

  Assigning 1 to 1..., 1 

  Assigning 2 to 1..., 2 

  Assigning 3 to 1..., 3 

 T1 = Count Zone Value 1 in Legend C 

 T2 = Count Zone Value 2 in Legend C 

 T3 = Count Zone Value 3 in Legend C 

 

 CalculateScores (T1, T2, T3) 

Next I 

 

CalculateScores (T1, T2, T3) 

 Total = T1 + T2 + T3 

 P1 = ((Total/T1) * 100) * 0 

 P2 = ((Total/T2) * 100) * -1 

 P3 = ((Total/T3) * 100) * 1 

 Answer = (P1) + (P2) + (P3) 

 

 Write P1 to Database as AGRICULTURAL_SCORE 

 Write P2 to Database as URBAN_SCORE 

 Write P3 to Database as NATURAL_SCORE 

 Write Answer to Database as MATRIX_SCORE 

End CalculateScores  

As can be seen from the pseudo code provided above, the analysis process included three Grid 
Analysis commands (Recode, Buffer, and Explicit Cross Tabulation), four mathematical 
calculations, and a database update. This is an excellent example of a good workflow to 
automate. 
 

Automating the Matrix Scoring Workflow 
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Installing the Matrix Score Calculator Command 
As noted earlier in this tutorial, all commands must be installed in GeoMedia Desktop.   

1. Exit GeoMedia Desktop. 

2. Save any changes. 

3. Browse to \Grid Analysis Tutorials\Customer-Based Tutorials\A Natural Heritage 
Study\Custom Commands\MatrixScoreCalculator\bin.  

4. Double click on the InstallCommand.bat file.  

  This step requires that you have administrator privileges. If the command installs 
correctly, you should see a message box letting you know that the command successful loaded. 

  If you want to un-install this command, simply double click on the UninstallCommand.bat 
file. 

 
 

Testing the Matrix Score Calculator 
Once a custom command has been installed, it will be added to the My Workflow tab on the 
GeoMedia Desktop ribbon bar. 

1. Launch GeoMedia Desktop, and select Open an existing GeoWorkspace. 

2. Double click the More Files… option, and browse to \Grid Analysis Tutorials\Customer-
Based Tutorials\A Natural Heritage Study.  

3. Select Natural Heritage.gws, and click Open. 

4. On the My Workflow tab, click Matrix Score Calculator. 

5. Use the mouse to set the Forest layer to FOREST. 

6. Use the mouse to set the Land Use layer to Land Use. 

7. Enter 10 into the From patch text box. 

8. Enter 15 into the To patch text box. These text boxes are used to specify which forest 
patches are to be processed (in this case, forest patches 10 to 15 will be processed). 

 

9. Once the dialog box looks similar to the example presented above, click OK to execute the 
command.  

  This command does not return any grid layers; it simply updates the FOREST table 
based upon the forest patch range that was specified. 
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This command may take a few minutes to process because, in this case, the command is 
processing five forest patches and updating the database with the appropriate matrix 
scores. 

10. Once the command has completed processing, on the Home tab, in the Window panel, 
click Add/Show Window > New Data Window to display the New Data Window dialog 
box. 

 

11. Select the FOREST entry, and click OK to display the data window for the FOREST table. 

 

Notice that the records for ID1 = 12, 14, and 15 now have values in the MATRIX_SCORE, 
PERC_AGRICULTURE, PERC_URBAN, AND PERC_NATURAL fields. Remember we only 
requested that forest polygon 10 through 15 be processed, and in this case, the Study Area 
that was defined for this tutorial did not include the entire area. As a result, the Study Area 
Forest map only contained polygons for ID1 = 12, 14, and 15. 

If you would like to experiment with the entire data set, you could create a new Study Area 
(that is, one that encompasses the entire set of forest polygons) and run the Land Use 
Calculator command again. Note that once the command completes, the data can be used 
to map thematically in GeoMedia Desktop or for use in further grid analysis. Remember, 
because of database connectivity, you have access to all the numeric attributes in a feature 
class. 

12. Click the X icon to close the data window. 

13. Save any changes and exit GeoMedia Desktop. 

 


