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This Tutorial 
Tutorial Objective 
This tutorial will examine GeoMedia’s assortment of customization options, including the Quick 
Access Toolbar, My Workflow tab, and the Customize Ribbon command. Each of these can be 
used to design a custom interface to rearrange and/or customize the GeoMedia ribbon interface 
to suit your own specific needs.  

 
Tutorial Data Set 
The exercises in this tutorial primarily use blank GeoWorkspaces, but in some cases may 
reference the United States sample dataset delivered with GeoMedia Desktop.  

 
Tutorial Text Conventions 
There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb group, click Ccc. 

 Dialog box names, field names, and button names are depicted using Bolded Text. 

 Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 

 
Tutorial Prerequisites 
None. The datasets used in this tutorial access native data formats via GeoMedia Data Servers. 
This tutorial can be run on all tiers.  
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Ribbon Customization 

Section Objective 
GeoMedia Desktop provides a wide variety of commands, but when you have a specific workflow to 
accomplish, streamlining the ribbon interface can save a lot of time and effort. Rearranging the 
existing commands you need into functional groups and hiding functions which may not apply to 
your current objective can significantly improve your efficiency, and the addition of custom user 
commands can be vital to the productivity of GeoMedia. In this tutorial, we will examine GeoMedia’s 
assortment of customization options, including the Quick Access Toolbar, My Workflow tab, and the 
Customize Ribbon command. Each of these can be used to design a custom interface that 
rearrange and customize the GeoMedia ribbon interface to your own specific needs. 

 

 
Tools Used 

Customize Ribbon Command 

The Customize Ribbon command lets you add and remove custom tabs and groups, rename 
custom tabs and groups, hide any tab, change tab order, import/export capability, and reset the 
ribbon interface to default settings. 

My Workflow Command(s) 

The My Workflow set of commands allow you to customize the GeoMedia ribbon by creating your 
own workflow tab so that you have easy access to the specific commands you frequently use. You 
can quickly add and remove selected ribbon items from this tab and then save the tab as an XML 
file for reuse and for sharing the workflow with others. 

Quick Access Toolbar (QAT) Command 

You can improve the performance of your workflows by using the Quick Access Toolbar. This 
toolbar allows you to add the commands that you most frequently use from the various ribbon tabs 
and then to remove commands and add others as your workflow changes. 
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 Customize Ribbon Command 
Objective: 
The GeoMedia Desktop provides a default Ribbon layout that is designed to provide a standard 
configuration for the base functionality for each of the product tiers; Essentials, Advantage and 
Professional. While the default Ribbon layout cannot be modified, users do have the capability to 
customize the Ribbon interface to accommodate their specific workflows. The objective of this 
exercise is for users to get familiar with the new Customize Ribbon command. Basic Ribbon 
customization workflows will be evaluated for building custom Ribbons, exporting and importing 
them and reconfiguring the Ribbon interface back to its default state. 

Task 1: Adding Custom Tabs, Custom Groups, and Commands 

The Customize Ribbon command provides the ability to create a user-defined Ribbon interface. 
This task demonstrates the basic workflow for establishing the foundation for a customized Ribbon 
user interface. 

1. Invoke GeoMedia and open a blank GeoWorkspace. 

2. On the Application tab , select Customize > Customize Ribbon. 

 
 

 
You can also right-click on the Ribbon and select Customize Ribbon 
from the context menu to invoke the command. 
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3. In the right tree-view, select the Grid tab.  Click New Tab. In the right tree-view, select 
the New Tab node, and click Rename. Rename the new tab Lesson 1. Select the New 
Group node, and click Rename. Rename the new group Home. 

4. In Choose commands from, select Home. 

5. In the left list-view, select Select Tool (the 2nd in the list), press Add>>.  

6. In the left list-view, select Display Properties, press Add>>.  

7. In the left list-view, select GeoWorkspace Coordinate System, press Add>>.  

8. In the left list-view, select Legends (the 2nd in the list), press Add>>.  

9. Click OK, and review the results.  

 

 
This illustrates the basic workflow for adding a custom tab, and adding 
existing commands to custom tabs. 

10. Invoke the Customize Ribbon command.  

11. In the right tree-view, expand the Lesson 1 tab and select the Home group. Click New 
Group. Rename the new group Manage Data.   

12. In Choose commands from, select Manage Data.  

13. In the left list-view, select Warehouse Connections (the 2nd in the list), press Add>>. 

 
Many of the commands in the left list-view are listed two times. 
Commands that include a triangle to the right of the command name 
indicate a menu collection. Selecting this option will include the 
command selected plus all of the commands included within the menu 
collection. 

14. In the left list-view, select Feature Class Definition, press Add>>.  

15. In the left list-view, select Images, press Add>>.  

16. Click New Group. Rename the new group Analysis.  

17. In Choose commands from, select Analysis.  

18. In the left list-view, select Queries, press Add>>.  

19. In the left list-view, select Attribute Query, press Add>>.  

20. In the left list-view, select Analyze Geometry, press Add>>.  

21. Click New Group. Rename the new group Labeling.  

22. In Choose commands from, select Labeling.  
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23. In the left list-view, select Label Manager (the 2nd in the list), press Add>>.  

24. In the left list-view, select Toggle Dynamic Labeling, press Add>>.  

25. In the left list-view, select Generate Static Labels, press Add>>.  

 
26. Click OK, and review the results. 

 

 
You are able to combine Map Window and Data Window commands 
that are delivered across multiple tabs into user-defined Groups and 
Tabs that best suit your workflow needs. 

27. Invoke the Customize Ribbon command.  

28. Uncheck the Main Tabs checkbox and click OK.  

 
Notice that you are not allowed to hide all of the tabs. At least one tab 
must be visible. 
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29. Check the Lesson 1 tab to ensure it is the only tab that is selected for display.  

 
You will notice that there may be some tabs that appear to be missing 
from the list. The tabs listed will depend on the Product Tier that is 
currently configured. There are some tabs that cannot be hidden such 
as the Table, Cadastral, and Advanced tab so they do not appear in 
the right tree-view. These tabs cannot be hidden because they have 
conditional requirements for their display. For example, the Table tab 
automatically turns on/off based on the presence of a Data Window. 

30. Click OK, and review the results.  

 

 
Once the custom tabs have been defined, the tabs that are not 
required for production can be turned off to reduce clutter in the 
Ribbon interface. 
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Task 2: Exporting and Importing Ribbon Customizations 

The benefit of sharing resources across the enterprise should not be underestimated, and this 
includes Ribbon customization definitions. This task demonstrates the workflows for exporting and 
importing user-defined Ribbon customizations. 

1. Invoke the Customize Ribbon command.  

2. Select Export and save the customization as Lesson1.xml in your My Documents 
folder.  

3. Click OK to dismiss the Customize Ribbon dialog.  

4. Exit GeoMedia and do not save the GeoWorkspace.  

5. Invoke GeoMedia and open a blank GeoWorkspace.  

 
The current state of the Ribbon interface is persisted as a User 
Preference when exiting the GeoWorkspace, independent of whether 
or not the GeoWorspace is saved when you exit. While exported 
Ribbon customizations are useful for back-ups and sharing across the 
enterprise, it is important to note that the active Ribbon customization 
is independent of its exported counterpart.. 

6. Invoke the Customize Ribbon command.  

7. Select Reset All to revert back to the default Ribbon configuration.  

8. Select Import and choose Lesson1.xml in your My Documents folder. 

9. Click OK, and review the results. 

 

 
While Ribbon XML files can be shared by different users across the 
enterprise, it is strongly recommended that the exported files stay 
within the same product tier. The Ribbon configurations can vary 
considerably from one product tier to the next in terms of the available 
tabs and commands. 

 

 
Some of the Customize Ribbon actions such as Import and Reset All, 
are immediate and are irreversible. To minimize this risk, it is 
advisable to export a backup of the current Ribbon configuration 
before these types of changes. 
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Task 3: Re-ordering, Removing, and Resetting Ribbon 
Customizations 

Once the Ribbon customization has been initially defined, it may require an adjustment. This task 
demonstrates the workflow for resolving assorted modifications. 

1. Invoke the Customize Ribbon command. 

2. Select New Tab. Expand the Lesson 1 tree-view and select the Manage Data group in 
the Lesson 1 tab.  

3. Click the down-arrow until the Manage Data group appears in New Tab. 

 
Groups can be re-ordered within Custom Tabs and across Custom 
Tabs. They cannot be moved onto existing Tabs such as the Home 
tab, or the Raster tab. 

4. Expand the Manage Data group in the New Tab tab and select Features.  

5. Click the up-arrow until Features appears in the Home group in the Lesson 1 tab.  

 
Commands can only be re-ordered within Custom groups. They 
cannot be moved into groups that are resident on existing tabs such 
as the Home tab or Raster tab. 

6. Click OK, and review the results.  

 

 
Lesson 1 no longer contains the Manage Data Group, and the Home 
Group now contains the Features command (which was previously in 
the Manage Data Group). 

 

 
New Tab now contains the Manage Data Group, minus the Features 
command. New Group was added, but no commands were added – 
this is an interim editing phase. 



 

    9 

7. Invoke the Customize Ribbon command. 

8. Select the New Tab tab, press <<Remove.  

9. Expand the Lesson 1 tree-view and select the Labeling group in the Lesson 1 tab, 
press <<Remove.  

10. Expand the Home tree-view and select Features, press <<Remove.  

11. Click OK, and review the results. 

 

 
Unnecessary Groups and Tabs are removed to produce the required 
Ribbon interface required for the workflow. 

12. Exit GeoMedia. Do not save changes when you exit. 
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Class Notes 
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 Adding Custom Commands 
Objective: 
Adding custom GeoMedia commands is essentially the same for the Ribbon interface as it was for 
menus and toolbars. There are some variations in the workflow due to the characteristics of the 
Ribbon interface. This exercise will evaluate the files used when adding custom commands to the 
Ribbon and review potential GUI variations that can occur as the result of the XML settings defined. 
Finally once custom commands have been installed, how they are incorporated into the Ribbon 
interface will be reviewed. 

Task 1: The Install Custom Application Command 

The Install Application Command Tool allows you to register one or more commands on the 
GeoMedia Desktop Ribbon. This exercise provides the necessary files for three custom commands 
–  Color Schemes Manager, Locate Feature, and Select Set Statistics. At a minimum when 
installing custom commands, each command will require a DLL and XML file. Optionally, users may 
provide bitmap files for the command buttons. If bitmaps are not provided, a default bitmap is used. 

1. Open Windows Explorer and navigate to C:\GMTutorial\Other 
Materials\Ribbon\CustomCommands. 

2. Select LocateFeature.xml, and select Open from the right-mouse context menu.  

The XML file entries that influence the Ribbon display include: 

• BitmapRootFileName – Two files should be provided; a large 32x32 and a small 
16x16 bitmap. It is no longer necessary to provide monochrome bitmap files.  

• Description – This is the Ribbon caption and may be an abbreviated form of the full 
command name. 

• Tooltip – This is the extended tooltip and can provided detailed description of 
functionality. All tooltips should be appended with \nCommand Name. This 
provides the underline and bolded text for the command name. Command names 
should match the dialog titles they invoke 

3. Select CMDLINE.txt, and select Open from the right-mouse context menu. 

 
This file provides the cut/paste opportunities for the lesson.  

4. (Optional) – The start of this lesson assumes the successful completion of Exercise 1 – 
Customize Ribbon Command where the starting Ribbon contains a single tab – Lesson 
1. If this is not the case, invoke GeoMedia, run the Customize Ribbon command, 
import  

C:\GMTutorial\Other Materials\Ribbon\CompletedLessons\Lesson1.xml. Exit 
GeoMedia. 

5. From the Start menu, select All Programs > Accessories > Command Prompt, and 
from the right-mouse context menu, select Run as Administrator. 

6. In the Command Prompt Window, key in (or equivalent): 
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cd “C:\Program Files (x86)\Hexagon\GeoMedia Professional\Program” 

7. In the Command Prompt Window, key in: 

InstallAppCmd /r /prod "GeoMedia Professional" /cmdset LocateFeature /loc 
"C:\GMTutorial\Other Materials\Ribbon\CustomCommands" /dll "C:\GMTutorial\Other 
Materials\Ribbon\CustomCommands" 

Successful completion of the InstallAppCmd should present the following dialog: 

 
8. Click OK to dismiss the dialog.  

 
The /prod switch in the command line is optional, and is not required. 
This is used to define the product tier. It must be “GeoMedia 
Essentials”, “GeoMedia Advantage”, or “GeoMedia Professional”. If 
this switch is not specified, it will default to the product tier that is 
currently configured.  

For additional information on the Install Application Command Tool, 
refer to the GeoMedia Command Wizard Help in the Developer 
Documentation in the GeoMedia Desktop Help. 

9. Invoke GeoMedia and open a blank GeoWorkspace. 

10. Select the My Workflow tab and review the results.  

 

 
All of the Custom Application Commands that are registered are  
placed on the ‘My Workflow’ tab in the Custom Group by default. Once 
they have been placed on the Ribbon, you can use the other custom 
tools to refine their placement to other custom tabs or to the Quick 
Access Toolbar (QAT). 
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There are a couple things to point out here; the difference in bitmap formats and the 
difference in command captions/command names displayed on the Ribbon. All of the 
icons used on the Ribbon interface that is delivered with GeoMedia Desktop are 32bit 
(24bit plus an alpha channel) and appear similar as the default icon used in the Color 
Schemes Manager command. Unfortunately, the InstallAppCmd does not currently 
support 32bit bitmaps, so when they are referenced by the XML, the alpha channel 
appears black as illustrated in the Locate Feature command. 24bit bitmaps will display the 
background color of the icon design, so you can attempt to match the color of the 
GeoMedia Desktop Ribbon based on the theme defined your personalized desktop. 
Secondly, command captions are abbreviated variations of the command names. In these 
three examples, two of the three commands have identical command names and 
command captions. That may not always be desirable if the command name is very long. 
In this example, the Select Set Statistics command uses ‘Select Set’ as the command 
caption, and then uses the full name in the extended tooltip. Similarly, the WMS Get 
Feature Info command use ‘WMS Info’ as the command caption and uses the full name for 
the extended tooltip. There is limited amount of space on the Ribbon, so minimizing the 
text can be beneficial. 

 
Hover over each of the commands to review the extended tooltips for 
specific information about the bitmap used for the command. 

11. From the Start menu, select Control Panel > Personalization, and select one of the 
High Contrast Themes. 

12. Hover the mouse over the command icons to review the difference. 

13. Select the Windows 7 Basic Theme, and exit Control Panel. 

  



14  Ribbon Customization 

Task 2: Adding Custom Commands to Custom Tabs 

The Customize Ribbon command provides the ability to incorporate custom user commands. This 
task demonstrates the workflow for adding custom commands into the custom Ribbon user 
interface.  

1. Invoke the Customize Ribbon command.  

 
2. In Choose commands from, select My Workflow. 

3. In the right tree-view, expand the Lesson 1 tab and expand the Home group. Select the 
Legends command.  

4. In the left tree-view, select Color Schemes Manager and press Add>>.   

5. In the left tree-view, select Locate Feature and press Add>>.  

6. In the left tree-view, select Set Statistics and press Add>>.   

7. In the right tree-view, un-check the My Workflow tab. 

8. Click OK, and review the results. 
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When working with custom commands, the My Workflow tab is 
generated on-the-fly at runtime based the commands that are 
registered for the current product tier. If these commands are un-
installed and there are no other commands in the My Workflow tab, 
the My Workflow tab will no longer display. 

9. Exit GeoMedia. Do not save changes when you exit.  

 
Unregister the custom commands for the next exercise. Step 10 and 
step 11 may not be required if the Command Prompt Window is still 
open from the previous task. 

10. From the Start menu, select All Programs > Accessories > Command Prompt, and 
from the right-mouse context menu, select Run as Administrator. 

11. In the Command Prompt Window, key in (or equivalent): 

cd “C:\Program Files (x86)\Hexagon\GeoMedia Professional\Program” 

12. In the Command Prompt Window, key in: 

InstallAppCmd /r /prod "GeoMedia Professional" /cmdset LocateFeature /loc 
"C:\GMTutorial\Other Materials\Ribbon\CustomCommands" /dll "C:\GMTutorial\Other 
Materials\Ribbon\CustomCommands" /u 

Successful completion of the InstallAppCmd should present the following dialog: 
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Class Notes 
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 Using My Workflow 
Objective: 
The My Workflow approach to Ribbon customization was the predecessor to the Customize Ribbon 
command. This explains some of the overlap in functionality. There is however some unique 
functionality available with the My Workflow implementation. My Workflow enables the ability to 
copy to entire Groups from the originating tab, whereas the Customize Ribbon command copies 
one command at a time. In addition, the My Workflow tab serves as the temporary ‘holding area’ for 
custom commands in the Ribbon customization design. The objective of this exercise is for users to 
get familiar with the ‘My Workflow’ set of commands. Basic workflows will be evaluated for creating 
the ‘My Workflow’ tab, whether it be the result of the computer registry or a User Preference XML, 
and how these two interact with one another. 

Task 1: Adding and Removing Groups and Commands  

The My Workflow approach to Ribbon customization provides the ability to add and remove Groups 
and Commands to the My Workflow tab. This task demonstrates the basic workflow for establishing 
a My Workflow tab on the Ribbon user interface. 

1. Invoke GeoMedia and open a blank GeoWorkspace. 

2. On the Application tab , select Customize > Customize Ribbon.  

 
You can also right-click on the Ribbon and select Customize Ribbon 
from the context menu to invoke the command. 

3. Select Reset All to ensure that any existing Ribbon customization is reverted back to 
the default Ribbon configuration. 

4. Click OK to exit the Customize Ribbon dialog. 

5. On the Manage Data tab, hover over the Warehouse Connections command and 
select Add to My Workflow from the right mouse context menu.  

 
This action creates a My Workflow tab if one does not exist. A review 
of the content of the My Workflow tab reveals that the command has 
been copied allong with its parent Group. If the parent Group already 
exists on the My Workflow tab, the copied command will be placed in 
its appropriate parent Group.  

6. On the Home tab, hover over the Properties and Information group and select Add 
to My Workflow from the right mouse context menu.  
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Unlike the Customize Ribbon command, this workflow provides the 
ability to copy entire Groups and all of their commands as a collection 
from one tab to another tab in a single step. In this example the Group 
can be selected by hovering over the Group title.  

7. On the Home tab, hover over the Legend group and select Add to My Workflow from 
the right mouse context menu. 

 
My Workflow is limited to add and remove operations. There is not the 
ability to re-order the commands after they have been added. 
Therefore it is important to add Commands and/or Groups in the order 
that you want them to appear on the Ribbon interface.  

8. On the Vector tab, hover over the Feature group and select Add to My Workflow 
from the right mouse context menu. 

9. On the Vector tab, hover over the Geometry group and select Add to My Workflow 
from the right mouse context menu. 

10. On the Home tab, hover over the Window group and select Add to My Workflow 
from the right mouse context menu. 

11. Invoke the Customize Ribbon command. 

12. Check the My Workflow tab to ensure it is the only tab that is selected for display.  

13. Click OK, and review the results. 

 

 
The My Workflow customization is saved as a User Preference, which 
is written to an XML file on disk. This preference is aware of product 
tiers, product versions, and configured language packs. The XML file 
is written to: %LocalAppData%\Intergraph\<Product 
Tier>\<Version>\<Language Code>\MyWorkflow.xml                                                      
For example, this may appear as 
C:\Users\<user>\AppData\Local\Intergraph\GeoMedia 
Professional\15.00\0009\MyWorkflow.xml  

14. On the My Workflow tab, hover over the Styles command and select Remove from 
My Workflow from the right mouse context menu.  

 
If the original Groups contained Separators, the removal of commands 
does not automatically remove them. The My Workflow interface does 
not provide a command to remove Separators from the My Workflow 
tab.  
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The commands added to the My Workflow tab have predefined enabling conditions that 
determine available customization options. Access to menu commands may vary.    

15. On the My Workflow tab, click the Delete Geometry command or the Edit command 
to access commands in their respective sub-menu. These commands are enabled. 
The Trim and Extend command is disabled. Therefore, the commands in its sub-
menu cannot be accessed.   

 
Each of these commands are menu buttons that contain several 
commands in their respective menus. All commands have their own 
enabling and disabling conditions. The exposure of these commands 
in the Ribbon interface are dependendent on many factors, such as 
R/W warehouse connections. In this particular scenario, the Trim and 
Extend sub-menu is not exposed due to the blank GeoWorkspace, 
and lack of any warehouse connections. Therefore, individual 
commands in the menu cannot be removed. If a R/W warehouse 
connection were present, these commands would be accessible to the 
My Workflow commands.  

16. On the My Workflow tab, hover over the Trim and Extend command and select 
Remove from My Workflow from the right mouse context menu.  

 
This illustrates the Ribbon response to the removal of large icons. 
These large icons on the Ribbon can represent any combination of 
Command buttons, Menu buttons, Split buttons, or Toggle buttons.  

17. Hover over the Properties command and select Remove from My Workflow from 
the right mouse context menu. 

18. Hover over the Move Geometry command and select Remove from My Workflow 
from the right mouse context menu. 

19. Hover over the Spin Geometry command and select Remove from My Workflow 
from the right mouse context menu. 

20. Hover over the Rotate Geometry command and select Remove from My Workflow 
from the right mouse context menu. 

 

 
Once the MyWorkflow.xml has been written to disk, the My Workflow tab 
will continue to display as part of the Ribbon customization. To ensure 
that the the My Workflow tab does not display, remove the 
MyWorkflow.xml from the users profile. 
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Task 2: Exporting and Importing My Workflow Customizations 

This task demonstrates the workflows for exporting and importing My Workflow customizations. 

1. On the My Workflow tab, hover over the Ribbon and select Save My Workflow from 
the right mouse context menu. Save it as MyWorkflowRibbon.xml in your My 
Documents folder.  

 
There are now two versions of the MyWorkflow.xml file; the User 
Preference version that is being stored in %LocalAppData%, and the 
recently exported version that is stored for the purpose of this exercise 
in the users My Documents folder.  

2. On the My Workflow tab, hover over the Window Group and select Remove from My 
Workflow from the right mouse context menu. 

3. Hover over the Geometry Group and select Remove from My Workflow from the 
right mouse context menu.  

4. Hover over the Feature Group and select Remove from My Workflow from the right 
mouse context menu. 

5. Exit GeoMedia. Do not save changes when you exit. 

6. Invoke GeoMedia and open a blank GeoWorkspace. 

 

 
This illustrates your current Ribbon User Preference for the My 
Workflow tab.  

7. On the My Workflow tab, hover over the Ribbon and select Load My Workflow from 
the right mouse context menu. Select MyWorkflowRibbon.xml in your My Documents 
folder.  

 

 
This illustrates a variation of the My Workflow tab that has been saved 
for re-use.  
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8. Invoke the Customize Ribbon command. 

9. In the right tree-view, un-check and then check the Main Tabs check box to ensure 
that all tabs are selected for display. Click OK to exit the dialog. 

10. Exit GeoMedia. Do not save changes when you exit. 

Task 3: Interacting with Customize Ribbon Command Workflows  

The My Workflow tab supports multiple workflows associated with Ribbon customization; many of 
which may be independent of one another. This task demonstrates how these associated workflows 
operate together.  

1. Open Windows Explorer and navigate to the folder that contains your MyWorkflow.xml. 

 
The XML file is written to: %LocalAppData%\Intergraph\<Product 
Tier>\<Version>\<Language Code>\MyWorkflow.xml                                                      
For example, this may appear as 
C:\Users\<user>\AppData\Local\Intergraph\GeoMedia 
Professional\15.00\0009\MyWorkflow.xml  

2. Delete MyWorkflow.xml.  

 
Re-install the custom commands. Step 3 and step 4 may not be 
required if the Command Prompt Window is still open from the 
previous exercise.   

3. From the Start menu, select All Programs > Accessories > Command Prompt, and 
from the right-mouse context menu, select Run as Administrator. 

4. In the Command Prompt Window, key in (or equivalent): 

cd “C:\Program Files (x86)\Hexagon\GeoMedia Professional\Program” 

5. In the Command Prompt Window, key in: 

InstallAppCmd /r /prod "GeoMedia Professional" /cmdset LocateFeature /loc 
"C:\GMTutorial\Other Materials\Ribbon\CustomCommands" /dll "C:\GMTutorial\Other 
Materials\Ribbon\CustomCommands"  

Successful completion of the InstallAppCmd should present the following dialog: 

 
6. Invoke GeoMedia and open a blank GeoWorkspace. 
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7.  Select the My Workflow tab. 

 

 
The contents of this My Workflow tab is derived from the computers 
registry.   

8. On the Vector tab, hover over the Geometry group and select Add to My Workflow 
from the right mouse context menu. 

 

 
The contents of this My Workflow tab is derived from the computers 
registry plus the User Preference XML file in%LocalAppData%.   

9. Invoke the Customize Ribbon command.  
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Contents of the My Workflow tab cannot be manipulated with the 
Customize Ribbon command. The My Workflow tab is treated the 
same as pre-configured tabs, such as the Home and Vector tabs. 
Commands cannot be added, removed, re-ordered or renamed.   

10. In the right tree-view, select the My Workflow tab.  Select New Tab. Rename the new 
tab Lesson 3 and rename the new group Mixed Group.  

11. In Choose commands from, select My Workflow. 

12.  In the left list-view, select Locate Feature, press Add>>.   

13. In the left list-view, select Delete, press Add>>.  

14. In the left list-view, select Select Set Statistics, press Add>>.  

15. In the left list-view, select Edit Geometry (the 2nd in the list), press Add>>.  

16. In the right tree-view, ensure that only the My Workflow and Lesson 3 tabs are 
selected for display. Click OK to exit the dialog. 

17. Click OK, and review the results. 

 

 
All of the My Workflow tab content is valid input when creating custom 
tabs using the Customize Ribbon command.   

18. On the My Workflow tab, hover over the Edit Geometry command and select 
Remove from My Workflow from the right mouse context menu.  

19. Hover over the Locate Feature command and select Remove from My Workflow 
from the right mouse context menu. Notice the Remove from My Workflow 
command is disabled when selecting any of the commands in the Custom Group. 

 
The Remove from My Workflow command is respnsible for editing the 
User Preference XML file, not for updating the computer registry.   

20. Exit GeoMedia. Do not save changes when you exit. 

 
Unregister the custom commands for the next exercise. Step 21 and 
step 22 may not be required if the Command Prompt Window is still 
open from the previous task.   
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21. From the Start menu, select All Programs > Accessories > Command Prompt, and 
from the right-mouse context menu, select Run as Administrator. 

22. In the Command Prompt Window, key in (or equivalent): 

cd “C:\Program Files (x86)\Hexagon\GeoMedia Professional\Program” 

23. In the Command Prompt Window, key in: 

InstallAppCmd /r /prod "GeoMedia Professional" /cmdset LocateFeature /loc 
"C:\GMTutorial\Other Materials\Ribbon\CustomCommands" /dll "C:\GMTutorial\Other 
Materials\Ribbon\CustomCommands" /u 

24. Successful completion of the InstallAppCmd should present the following dialog: 
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 Quick Access Toolbar Command 
Objective: 
The Quick Access Toolbar is similar to Customize Ribbon and My Workflow in that it provides a 
customization capability that enables the user to organize their commands into logical groupings 
based on some user-defined criteria. What separates the Quick Access Toolbar from the others is 
that it is independent of tab displays. Map navigation commands for example are good candidates 
for the Quick Access Toolbar because they are used often, regardless of the active tab. The 
objective of this exercise is for users to get familiar with the functionality associated with the Quick 
Access Toolbar, including assigning keyboard shortcuts and defining assorted display options. 

Task 1: Adding Commands to the Quick Access (QAT) Toolbar 

The Quick Access Toolbar provides the capability to combine commands onto a toolbar and make 
them available regardless of what tab that is currently displayed. This task demonstrates the basic 
workflow for adding commands to the Quick Access Toolbar. 

1. Invoke GeoMedia. On the Welcome dialog, select More Files… and open 
USSampleData.gws. Minimize the Map Window, and collapse the Layout Window if it is 
open. 

2. On the Application tab , select Customize > Customize Ribbon. 

 
You can also right-click on the Ribbon and select Customize Ribbon 
from the context menu to invoke the command. 

3. Select Reset All to ensure that any existing Ribbon customization is reverted back to 
the default Ribbon configuration. 

4. Click OK to exit the Customize Ribbon dialog. 

5. Click the pull-down arrow for the Quick Access Toolbar menu, and select More 
Commands. 

 

 
You can also right-click on the Ribbon and select Customize Quick 
Access Toolbar from the context menu to invoke the command. 

6. In Choose commands from, select Home. 

7. In the left list-view, select Unselect All, press Add>>.  

8. In the left list-view, select <Separator>, press Add>>.  



26  Ribbon Customization 

 
Separators can be used to indicate logical groupings of commands.   

9. In the left list-view, select Add Legend Entries, press Add>>.  

10. In the left list-view, select Add Thematic Legend Entry, press Add>>.  

11. In the left list-view, select Styles, press Add>>.  

12. In the left list-view, select New Map Window, press Add>>.  

13. In the left list-view, select New Data Window, press Add>>.  

 
14. Click OK to exit the Customize dialog.  

 
You can add almost any command to the toolbar by right clicking on 
the icon on the Ribbon and select Add to Quick Access Toolbar. 
Similarly, once a command has been placed on the toolbar, you can 
right click on the icon and select Remove from Quick Access 
Toolbar. 

15. On the Quick Access Toolbar, click the New Map Window command. Select the 
<Empty> legend to display, and click OK. 

16. On the Quick Access Toolbar, click the Add Legend Entries command. Expand the 
USSampleData tree-view. Select Interstates, Rivers, and States. Click OK.  

 
This verifies that the commands on the Quick Access Toolbar are 
working.   

17. Collapse the Map Window that was just created in Step #15. 
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Task 2: Customizing Keyboard Shortcuts 

Keyboard shortcuts can have a dramatic effect on productivity. This task demonstrates the basic 
workflow for assigning keyboard shortcuts to GeoMedia commands. 

1. Invoke the Customize Quick Access Toolbar command.  

2. For Keyboard shortcuts, click Customize.  

3. In the Categories list-view, select Home.  

4. In the Commands list-view, select Delete Feature.  

 
The current shortcut key is defined as Ctrl+D. Some of GeoMedia 
commands, such as Delete Feature are delivered with keyboard 
shortcuts pre-defined. When this is the case, the keyboard shortcuts 
are generally defined in the extended tooltip.   

5. In the Commands list-view, select Unselect All. For Press new shortcut key, click in 
the text box below and select the Ctrl key and the U key on your keyboard. 

 
This will automatically populate the text box on the dialog with Ctrl+U. 
You should not attempt to type in these characters.   

6. Click Assign. 
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The Customize Keyboard dialog does not have an OK button. The 
Assign operation is required to set the keyboard shorcut definition for 
the command. If the Current Keys list box is empty, there is a good 
possibility that the Assign operation has not been completed. 

7. In the Commands list-view, select New Map Window. For Press new shortcut key, 
click in the text box below and select the Ctrl key and the W key on your keyboard. 
Click Assign.  

8. In the Commands list-view, select New Data Window. For Press new shortcut key, 
click in the text box below and select the Ctrl key and the T key on your keyboard. 
Click Assign. 

9. In the Commands list-view, select Add Legend Entries. For Press new shortcut key, 
click in the text box below and select the Ctrl key and the L key on your keyboard. 
Click Assign. 

10. Click Close to exit the Customize Keyboard dialog.  

11. Click OK to exit the Customize dialog.  

12. On the keyboard, select the Ctrl + W keys to invoke the New Map Window dialog. 
Select the <Empty> legend to display, and click OK. 

13. On the keyboard, select the Ctrl + L keys to invoke the Add Legend Entries dialog. 
Expand the USSampleData tree-view. Select Interstates, Rivers, and States. Click 
OK. 

14. Using the Select Tool, make a rectangular selection that illustrates multiple features 
are included in the select set. 

15. On the keyboard, select the Ctrl + U keys to invoke the Unselect All command. 

 
This illustrates several examples of how shortcut keys can be 
implemented for GeoMedia commands.   

  

Task 3: Ribbon Display Options  

The Ribbon interface provides several display options. New users may prefer the complete Ribbon 
is exposed in order to enable feature exploration, while experienced users may prefer a reduced 
Ribbon footprint and focus more on Map Window real estate. This task demonstrates several 
alternatives that are available. 

1. The default Ribbon interface display appears as follows.  

 
2. Click the pull-down arrow for the Quick Access Toolbar menu, and select Minimize the 

Ribbon. 
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The display of the Ribbon can be minimized when it is not being used.   

3. Click on Vector or one of the other tabs listed. 

 
The tab is temporarily displayed to provide access to the commands, 
and then minimized when not being used.   

4. Click the pull-down arrow for the Quick Access Toolbar menu, and select Show Below 
the Ribbon. 

 

 

 
The position of the Quick Access Toolbar can be adjusted, even when 
the Ribbon is not minimized.   

5. Exit GeoMedia. Do not save changes when you exit. 
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