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This Tutorial 
Tutorial Objective 
This tutorial is designed to provide an introduction to the assorted window types available in 
GeoMedia and explores the common workflows that occur in production environments. The 
tutorial will review the characteristics of the individual window types, as well as the relationships 
between them.    

 
Tutorial Data Set 
The exercises in this tutorial reference the United States sample dataset delivered with GeoMedia 
Desktop.   

 
Tutorial Text Conventions 
There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb group, click Ccc. 

 Dialog box names, field names, and button names are depicted using Bolded Text. 

 Information to be entered, either by selecting from a list or by typing, is depicted using 
Italicized Text. 

 
Tutorial Prerequisites 
None. The datasets used in this tutorial access native data formats via GeoMedia Data Servers. 
This tutorial can be run on all tiers.  
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Exploring Window Types 

Section Objective 
This section is intended to provide an introduction to the assorted window types in GeoMedia 
Desktop. The GeoMedia GeoWorkspace can contain one or more windows - map windows, data 
windows, a layout window, and an overview window. These windows provide you with different 
ways of visualizing your data. The map window shows a graphic display of the geographic data 
(features, images, and so forth). The data window shows the same features in tabular form, 
displaying the attributes associated with the geographic data. Thus, if a feature is displayed in 
multiple map and data windows, it highlights in all windows when selected. The layout window 
allows you to design and to plot a map layout. Map graphics in the layout window are linked their 
originating map window to reflect any changes made to the data, or they can optionally be placed 
as a static snapshot reflecting the characteristics of the map window at the time of placement. 
The overview window displays a high-level map containing reference polygons that depict the 
location and coverage of all open map windows in your current session. The overview window 
thus provides you with a unified view of all open map windows with relevant context of their 
spatial relationships to each other and their associated data content. In other words, if you have 
several map windows, the overview window provides the context for each map window. This 
allows you to quickly select the proper map window to do your work given the geographic area of 
that map window. 

 

Tools Used 
 

Add / Show Windows 

Provides the ability to add new map windows and data windows, as well as the ability to show / 
hide the layout window and overview window.  

  

Arrange Windows 

Provides assorted methods for choosing how to display the open windows displayed in the 
application. Options include Cascade, Tile Horizontally, and Tile Vertically.  

  

Window Properties  

Displays the active window properties and provides the ability to modify their respective settings, 
which includes the window name, viewing behavior, selection behavior, etc.  

  

Window List 

Provides the ability to identify the active window (Map, Data, Layout) from a list of open windows. 
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 Working With the Map Window 
Objective: 
This exercise illustrates some basic workflows for the adding map windows, arranging windows 
when multiple map windows exist during a session, and defining window display options when 
features are selected in a multiple map window environment.  

 

 

 

Each map window contains the following marginalia items: a 
legend, a north arrow, and a scale bar. You can select or deselect 
each of them in the View group on the Toolbox tab to turn them on 
or off. Whatever the active parameters are for these marginalia 
items in the map window, the same parameters are used to render 
these items in the layout window. 

For the most part you define the content and design of each map 
window through its legend. While a traditional legend simply 
reflects what is displayed on a map, you use the GeoMedia 
Desktop legend to control what is displayed in the map window and 
how it looks. 

The following is a representative workflow for displaying 
geographic data and map objects in a map window: 

1. In an open GeoWorkspace, connect to the warehouse(s) 
containing the data you want to display. 

2. Display the legend in the active map window. 

3. Add entries to the legend. 

4. Customize the look of your map by using the legend to 
change the display characteristics of the geographic data. 

5. Turn on the north arrow and change its appearance. 

6. Turn on the scale bar and change its appearance. 

7. Customize the appearance of the legend. 

8. Add new map and/or data windows to the GeoWorkspace 
to show different views of your map and/or data. 

On the Map Display tab of the Options dialog box, you can 
specify with the When resizing map windows options that the 
contents of a map window be fit automatically when the window is 
resized, or that the map scale be preserved. 
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Task 1: Adding a New Map Window 

1. Launch GeoMedia Desktop, and choose Open existing GeoWorkspace from the 
Welcome menu. 

2. Double click the More Files… option and browse to 
C:\Geoworkspaces\USSampleData.gws, and click Open. 

3. On the Home tab, in the Window group, select Add / Show Windows > New Map 
Window. 

 
The Add / Show Windows button is a Split button, which is a 
combination of a Command button and a Menu button. The Split 
button itself is divided in half (by a horizontal line on large buttons and 
a vertical line on small buttons) to either start a command or to display 
a command menu.When clicking the left half of this button – the 
Command half, the New Map Window command is invoked. When 
clicking the right half of this button – the Menu half, the button display 
a menu with available window commands.  

4. On the New Map Window dialog change the window name to Asian Population and 
select the Asian Population legend from the list. 

 
5. Press OK to add the new map window. 

6. On the Home tab, in the Legend group, select Legends > Position Legend Left. 
Select Legends > Fit Legend. 
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Task 2: Arranging Windows 

1. On the Home tab, in the Window group, select Arrange Windows > Cascade. 

2. If the layout window is open, close it. You should have two map windows visible. 

3. On the Home tab, in the Window group, select Arrange Windows > Tile Vertically. 

4. Select the USSampleData map window and select Fit to fit the feature data to the 
map window. 

5. Select the Asian Population map window and select Fit to fit the feature data to the 
map window. 

 
6. On the Home tab, in the Window group, select Arrange Windows > Tile 

Horizontally. 

7. Select each map window and select Fit to fit the feature data to their map windows. 
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Task 3: Changing Map Window Properties 

When you set map window properties, you can specify the title that appears in the map window 
as well as the way the map window displays features you select in the window.  Because the 
windows in a GeoWorkspace are linked, features you select in one map or data window always 
highlight in the other map or data windows.  Moreover, you can set certain properties in a map 
window to have its view change when you select a feature in another window. 

 

The following properties determine the display in the map view when a feature is selected in 
another window: 

• View at current scale - Features in the select set are highlighted, but the map window 
does not shift or change scale. 

• Center at current scale - Features in the select set are highlighted and centered in the 
map view, but the map window does not change scale. 

• Fit and zoom out - Features in the select set are fit to the map view, and the view zooms 
out according to the percentage you specify.  The default setting is 105%. 

If you set the properties in MapWindow1, for example, to Center at current scale or Fit and 
zoom out, selecting features in any other window changes the zoom scale or window location in 
MapWindow1.  You probably do not want this to happen when selecting features in MapWindow1 
itself, only when selecting features in other windows.  To override this behavior in MapWindow1, 
you can select the View at current scale option. 

1. Select the USSampleData map window. 

2. On the Home tab, in the Window group, select Map Window Properties. 

3. For the Map window name type in Sample. 

4. Select the Fit and zoom out option. Set value for this option to 105%. 

5. Click OK. 

6. In the Asian population map window, select a State feature. 
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7. Note how the corresponding feature is selected, centered, and fit in the Sample map 
window. 

 
8. Now select a State feature in the Sample map window.  

9. Note how the corresponding feature is selected in the Asian Population map window. 

10. Close the Sample map window. Click Yes on the message dialog. 

11. On the Home tab, select Unselect All to unselect any selected features.  
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Class Notes 



 
 

    9 

 Working With the Data Window 
Objective: 
This exercise illustrates some basic workflows for the adding data windows, arranging windows 
when multiple map and data windows exist during a session, and selecting features in a in an 
environment that displays map windows and data windows at the same time. 

Task 1: Adding a New Data Window 

Data windows display the nongraphic attributes of a specific feature class or query. Data windows 
do not display geometry columns and spatial index columns. 

The GeoWorkspace, USSampleData.gws should still be open and visible. 

1. On the Home tab, in the Window group, select Add / Show Windows > New Data 
Window. 

2. In the Features to display treeview, expand USSampleData Set and select the 
States feature class. 

3. Press OK to add the new data window. 

4. Maximize the Data Window. 

5. In the Window List pull-down menu, select Asian Population. 

  
6. On the Home tab, select Fit to fit the feature data to the map window. 

7. In the Window List pull-down menu, select DataWindow1. 
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Task 2: Arranging Windows 

1. On the Home tab, in the Window group, select Arrange Windows > Cascade. 

2. On the Home tab, in the Window group, select Arrange Windows > Tile 
Horizontally. 

3. Select the Asian Population map window and on the Home tab, select Fit to fit the 
feature data to the map window. 

4. On the Home tab, in the Window group, select Arrange Windows > Tile Vertically. 

5. Select the Asian Population map window and on the Home tab, select Fit to fit the 
feature data to the map window. 

 

Task 3: Changing Data Window Properties 

Unlike map window properties, you can only specify the title that appears in the data window. 

1. Select the Data Window. On the Table tab,select Data Window Properties. 

2. For the Data window name, type in States Data. 

 
3. Click OK.  
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Task 4: Selecting Data Window Content 

1. In the Asian Population map window, select a State feature. Note how the 
corresponding feature is selected in the States Data window. 

 
2. Select the Asian Population map window. 

3. On the Home tab, in the Window group, select Map Window Properties. 

4. Select the Fit and zoom out option. Set value for this option to 105%. 

5. Click OK. 

6. In the States Data window, select a row in the table to identify a State feature. Note 
how the corresponding feature is selected, centered, and fit in the map window. 

 
7. Close the States Data window.  

8. On the Home tab, select Unselect All to unselect any selected features. 
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Each data window contains the nongraphic attributes of a single feature 
class or query. This equates to a feature table, with each column 
representing an attribute and each row representing an instance - a 
feature - of the feature class. The data in each cell is called a value or 
attribute value. Data windows display area, linear, point, image, 
compound, graphics text, and nongraphic feature classes, but do not 
display geometry or spatial index key attributes. 

In a read-write warehouse, you can review and edit the features and 
values in a data window, and any changes you make will be reflected in 
the map window. So, if you delete a row in a data window, the 
corresponding feature is also deleted from the map. 

The data window displays descriptions for attributes with PickLists 
defined. For editing such an attribute, a drop-down list box is displayed in 
the cell. This list contains all the available descriptions for the attribute 
values as well as a blank entry (available only if the attribute is not 
required). You can insert a value of NULL for this attribute by selecting 
the blank value. You can edit an attribute only by selecting a description 
from the list. 
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 Working With the Layout 
Window 

Objective: 
This exercise illustrates the basic workflow for accessing the layout window, working in a layout 
window environment and defining the properties associated with sheet layouts and their individual 
page setup. 

Task 1: Showing the Layout Window 

The layout window always exists, with a minimum of one layout sheet. Unlike the map window and 
data window, the layout window only supports a single instance; it is either open or closed. 

However, multiple layout sheets can exist in the layout window, exposed as pages or sheets in the 
same manner as Microsoft Excel. 

The GeoWorkspace, USSampleData.gws should still be open and visible. 

1. On the Home tab, in the Window group, select Add / Show Windows > Show 
Layout Window.  

Note that the ribbon updates to show only the Layout and Drawing tabs while the layout 
window is active. 

 

 
When the layout window is active, the command button on the Layout 
tab changes from Add / Show Windows to Add / Hide Windows, 
and the menu content chages from Show Layout Window to Hide 
Layout Window. The respective buttons on the Home tab and Table 
tab do not change when the layout window is open. 

 

  



14  Exploring Window Types 
 

Task 2: Arranging Windows 

1. On the Home tab, in the Window group, select Arrange Windows > Tile Vertically.  

2. Select the Asian Population map window and on the Home tab, select Fit to fit the 
feature data to the map window.  

3. Select the Layout Window and on the Layout tab, select Fit to fit the layout sheet. 

4. Alternate between selecting the map window and layout window. Note the changes 
to the ribbon as each window type is selected. 

Task 3: Setting Layout Window Properties 

1. Select the layout window. 

2. On the Layout tab, in the Sheets and Layers group, select Sheets > Insert Sheet 
to insert a new layout sheet into the layout window. 

3. On the Layout tab, select Properties to invoke the Layout Window Properties 
dialog. 

The Layout Window Properties dialog box contains a list of all the layout sheets 
currently stored in the layout window. The information available for each layout sheet 
includes the name, # (sheet number), description, and visible property, which are 
defined on the Layout Window Page Setup dialog box. 

 

 
The Name and Description fields are not editable on this dialog, but 
the Visible field can be toggled on/off. All of these fields (except #) can 
be defined on the Layout Window Page Setup dialog. 

4. Click in the cell containing the Sheet1 name then double click in the same cell to 
open the Layout Window Page Setup dialog. 

 
The Layout Window Page Setup dialog can also be access from the 
right-mouse context menu when hovering over a Sheet tab in the 
layout window, and selecting Page Setup. 
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The Layout Window Page Setup dialog box lets you define a unique page setup for 
each layout sheet in the layout window and set a default page setup. 

 
5. Optionally change the sheet name. Add a description and uncheck the Visible option. 

 
The Size pull-down menu provides a pre-defined list of common page 
layouts. When one of these layouts are selected the Width, Height, 
and Units appear as read-only fields. When Custom is selected, 
therse fields are enabled for you to define the custom sheet size.  

6. Review the remaining options and click OK to apply changes and close the Layout 
Window Page Setup dialog box. 

 
The page setup for the first sheet in the layout window is based on 
parameters defined for the layout sheet in normal.glt. However, this is 
not automatically so for subsequent sheets. The page setup 
parameters for each new sheet are based on the active sheet when 
this command is started. Thus, if the first sheet is a C Size Sheet and 
is the active sheet when the command is started, then the new sheet 
inserted will also be a C Size Sheet. But if you then create a D Size 
Sheet, and it is active when you start the command, then the new 
sheet inserter will be a D Size Sheet, not the initial default C Size 
Sheet. 
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7. Review the updates to the Layout Window Properties dialog and click OK. 

 
8. On the Layout tab, in the Window group, select Add / Hide Windows > Hide 

Layout Window. 

9. Maximize the Asian Population map window and select Fit to fit the feature data to 
the map window. 

 
The Layout tab on the Options dialog box (Application tab > Options) 
lets you set various controls for the appearance of the layout window 
and the behavior of some of the graphics commands. Refer to the 
Layout tab link on the Optons Dialog Box section in Help for details. 

 

 

 



 
 

    17 

 Working With the Overview 
Window 

Objective: 
This exercise illustrates the basic workflow involved with the Overview Window, which displays a 
high-level map containing reference polygons that depict the location and coverage of all open 
map windows in your current session. 

Task 1: Showing the Overview Window 

The overview window provides you with a unified view of all open map windows with relevant 
context of their spatial relationships to each other and their associated data content. 

The GeoWorkspace, USSampleData.gws should still be open and visible. 

1. On the Home tab, in the Window group, select Add / Show Windows > Show 
Overview Window.  

 
The Overview Window dynamically updates as the display scale 
changes in one or more map views. It is not linked to standard map 
view commands. The window can be moved outside the GeoMedia 
GeoWorkspace framework for placement anywhere on the desktop or 
on a secondary monitor. There is only one instance of an Overview 
Window within the system at any given time, and it is also read-only. 

 

Task 2: Displaying Data in the Overview Window 

1. On the Home tab, in the Window group, select Add / Show Windows > New Map 
Window. 

2. On the New Map Window Dialog change the window name to White Population and 
select the White Population legend from the list. 

3. Press OK to add the new map window. 

4. Select the White Population map window and Zoom In to the northeastern portion 
of the United States. 

5. Select the Asian Population map window and Zoom In to the southwestern portion 
of the United States. 
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6. Right click inside the overview window and review the context menu options: 

 
The navigation options (Zoom In, Zoom Out, Fit, and Pan) each behave the same 
as their respective command in the map window. The Display Map Window Name 
Label option provides a toggle selection to display the map window name labels. The 
Legend option displays all legends in the Overview Window and corresponds to the 
Legend of the map window. The Select Named Legend option displays all named 
legends and corresponds to the Named Legend of the map window. 

7. Hover over the overview window, and from the right-mouse context menu choose 
Select Named Legend. 

8. On the Select Named Legend dialog, select Scalable Map (1:20,000,000) and click 
OK. 

9. Hover over the overview window, and from the right-mouse context menu select Fit. 

10. Hover over the overview window, and from the right-mouse context menu select 
Display Map Window Name Label. 
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11. Observe the overview window and note the relationship between the two active map 
windows. 

 

 
The display of each map window polygon within the read-only 
overview window is optional, and the display is automatically updated 
when the extents of the associated map window are modified. The 
overview window is resizable and its view stays centered on its data 
and maintains the current view range whenever its window extents are 
modified. The map window polygons optionally contain an associated 
text label displaying the window title. 

When you first start this command, the overview window is fit to the 
spatial extents of the background data and the included map window 
polygons. This user-specified background data content provides 
context for each map window‘s display. The overview window displays 
background reference features, which are defined by individual legend 
entries and/or named legend selections, and polygons that represent 
the extent and location of each open map window. Additionally, the 
styles of the map window polygons and the background data features 
default to a standard initial configuration (polygons to solid line, 
translucent fill, and the background features based on a named 
legend) through selection of a named legend. 

12. Change the extent of one or both of your map windows and observe the changes 
reflected in the overview window. 

13. Close the overview window and exit GeoMedia Desktop without saving your 
changes. 
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