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Links and Help Files 

For additional information on how to use Incident Analyst, please use the resources provided below: 

Help Topics (Client Side)  

Start > Hexagon Incident Analyst 2016 > Incident Analyst Help Topics 

Help Topics (Server Side)  

Start > Hexagon Incident Analyst Server 2016 > Incident Analyst Server Help Topics 

Installation (Client Side) 

Start > Hexagon Incident Analyst 2016 > Incident Analyst Installation Guide 

Installation (Server Side) 

Start > Hexagon Incident Analyst Server 2016 > Incident Analyst Server Installation Guide 

 



 

   
Copyright 2016 Hexagon Geospatial  xi 

The Training Data Set 

Software Requirements 

In order to run the training you will need to have GeoMedia Desktop and Incident Analyst installed on 
your machine. GeoMedia must be configured and licensed for either the Advantage or Professional tier. 

Introduction 

The training data should be unzipped to C:\Incident Analyst Training Data. 

 

Training.gws 

GeoWorkspace (*.gws) files are created in GeoMedia. These files are saved to disk with objects specific to 
GeoMedia and are used to start GeoMedia and hence Incident Analyst. 

Ancillary Files 

GeoMedia can store spatial data in a number of formats including Microsoft Access, ArcView, GeoMedia 
SmartStore etc. The Training makes use of two Microsoft Access files (namely BaseMapData.mdb, and 
TrainingData.mdb) and one GeoMedia SmartStore file (namely Dauphin_SS.cdt). 
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Incident Analyst: An Overview 

Incident Analyst provides an intuitive, user-friendly environment for analyzing incident locations. All 
incidents have a positional characteristic; and Incident Analyst can use this information to spot trends in 
frequency, based on geography. The resultant analysis allows decision makers to target areas to 
effectively deploy resources and create intelligence products that detect spatial patterns to aid tactical 
analysis.  

The distribution of incidents across geography is not random, and the ability to delineate areas of 
abnormal frequency is extremely valuable. Incident Analyst offers tools to assist in identifying these areas. 
Understanding where incidents occur and comparing locations with other factors – time, relative location to 
other geographic features, offense statistics – assist in defining areas of concern. Incident Analyst allows 
easy access to incident details and simple techniques to perform this type of analysis. 

Incident mapping can help agencies better service their citizens. Incident Analyst can display data as both 
simple and complex maps. Simple maps display the locations of individual incidents, and can be used to 
direct resources to places they are needed most. Complex maps can be used by policy makers to observe 
trends and track action on areas of high incident frequency. Complex maps can delineate areas of high 
incidents, animate change in an area over time, and determine journey distance between incidents. 

Features 

Data Connectivity – Provides seamless Web Service access to the Intergraph CAD and RMS databases, 
and extensibility to other incident data sources. 

Pin Mapping – Allows users to dynamically create color-coded pin maps based upon database attributes 
such as incident date, time, location, and offence type. 

Incident Count Mapping – Allow users to create a map that uses color to represent different values 
among defined geographic areas such as police precincts, city voting districts, or census tracts. 

Journey to Incident Mapping – Supports two types of analysis: “distance to incident” analysis (for 
example, measuring serial offenders average and maximum distances traveled to commit a crime), and 
“distance to recovery” analysis (for example, linking stolen and recovered property or vehicles to identify 
routes taken after a crime).  

Repeat Incident Mapping – Uses graduated point symbols to represent the number of incidents at a 
location, allowing you to quickly make comparisons among repeat places and the number of incidents 

Hotspot Mapping – Provides both a simple and an advanced command for extracting hotspots from a 
plot of incidents, helping determine where actions are needed most.  

Change-Over-Time Mapping – Provides an intuitive set of mapping tools to visualize change over time, 
allowing decision makers to assess the impact of incident reduction initiatives to determine their 
effectiveness and identify emerging hot areas.  

Temporal Reporting – Allows users to create incident/time-of-day histograms, giving them the latest 
information on trends and patterns in their locality. 

Benefits 

Strategic Assessment – Identifies priority neighborhoods and the conditions experienced within them.  

Tactical Assessment – Locates where tactics have been deployed and displays their impact. 

Target Profiling – Profiles areas where offenders reside and the areas where they focus their activities. 

Pattern Analysis – Identifies emerging hot spots. 

Risk Analysis – Identifies areas that are at a higher risk.  
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Tutorial: Text Conventions 

The tutorial has been compiled in a fashion to allow readers to efficiently work through it. 

Action Items 

Items that require the reader to perform a task or action are numbered and key words are bolded. 

1. Click the  Zoom In icon. 

2. Move your cursor over the map in the area where you want to zoom in and click the left mouse 
button. The map will zoom in and center on your selected location. 

3. Click the left mouse button again. The map will continue to zoom in with each mouse click.  

4. Continue to zoom in until you are satisfied with the level of zoom. 

Additional Information 

Items that are not required reading are bulleted and shaded so that if need be they can be skipped. 

1. Use the Date/time attribute drop-down list to set this option to DATE_OCCU. 

❖ The Interval drop-down list will default to per day. Note: The drop-down list will always attempt to group the 
data into 12 groups. For example, if the user were to select a query that started on January 1 1996 through 
to December 1, 1996 then the Interval drop-down list would default to per month. 

 

2. Set the Frame Interval time drop-down to per day. 

 

3. Set the Frame duration to 1. 

 

❖ The Frame duration in the seconds field sets the cadence of the animation (i.e. how fast the animation will 
cycle between groups. In this case there will be 5 one for each week day in interval in the query. 

❖ The Style button can be used to set the style for the point symbols in the animation.  
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Exercise 1: Pin Mapping 

Overview 

The Incident Query command is the foundation of Incident Analyst. The Incident Query command provides 
a mechanism for mining data from a database or databases.  This powerful yet very flexible command lets 
users create complex queries without having to know Structured Query Language (SQL).  

Note: The Incident Query command supports assorted user configurations that are beyond the scope of 
this tutorial. The input data used in the assorted exercises of this tutorial will not be referencing results 
produced from the Incident Query command. Instead, a training database (TrainingData.mdb) is provided 
that contains feature classes that replicate the results of the Incident Query command.  

 

Skills Covered in this Exercise 

In this exercise you will learn how to: 

❖ Start GeoMedia and hence start Incident Analyst. 

❖ Zoom the map view in and zoom the map view out. 

❖ Pan across the map display. 

❖ Display a Feature Class using the Add Legend Entries command. 

❖ View Attributes Associated with a Pin Map. 

❖ Create a Thematic Pin Map. 

❖ Color a Thematic Pin Map. 

❖ Label legend entries. 

❖ Perform a query using the Attribute Query command. 

❖ Change Pin Map symbology. 

❖ Animate a Pin Map. 

❖ Remove legend entries from a map window. 

❖ Save changes to a GeoWorkspace. 
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Starting GeoMedia 

GeoMedia and hence Incident Analyst can be launched just like any other Windows application. In this 
particular case, GeoMedia will be launched using the GeoWorkspace that has been provided as part of 
this tutorial. 

1. In Windows Explorer, navigate to C:\Incident Analyst Training Data. 

 

2. Double-click on Training.gws. This action will launch GeoMedia and open the selected 
GeoWorkspace. 
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Zooming In, Zooming Out, and Panning 

GeoMedia provides access to many commonly used commands by way of the Quick Access Toolbar in 
the top left corner. In this particular case, we are going to concentrate on a sub-set of commands on the 
toolbar, namely the Zoom In, Zoom Out, Fit All, and Pan commands. These commands are also available 
on the Home tab in the Extents group. 

 

Zoom In, Zoom Out, Fit All, and Pan 

To select a command, simply click on the desired command icon.  

Map Zooming In 

1. Click the  Zoom In icon. 

2. Move your cursor over the map in the area where you want to zoom in and click the left mouse 
button. The map will zoom in and center on your selected location. 

3. Click the left mouse button again. The map will continue to zoom in with each mouse click. Note: You 
can also click and drag the mouse to zoom into a specific area quickly. You may notice that as you 
zoom in, more and more map information becomes visible. Continue to zoom in until you are satisfied 
with the level of zoom. 

Map Panning 

Panning allows you to move in any direction from a specific point in a map window to see other areas of 
the map. 

1. Click the  Pan icon. 

2. Move your cursor over the map in the area where you want to start the map pan process. 

3. Press and hold the left mouse button in the view of the map window in which you want to pan. 

4. Drag the mouse to pan the view. 

5. To exit Pan, press ESC, click the right mouse button, or choose another command. 

Map Zooming Out 

1. Click the  Zoom Out icon. 

2. Move your cursor over the map in the area where you want to zoom out and click the left mouse 
button. The map will zoom out and center on your selected location. 

3. Click the left mouse button again. The map will continue to zoom out with each mouse click. 

Map Zooming To Extents 

Zooming a map to its full extent quickly allows you to see the map in its entirety (i.e. zoom the map out to 
the farthest extents). 

1. Click the  Fit All icon. 
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Adding a Feature to the Map Window  

The Add Legend Entries command is used to add one or more sets of features (queries/feature classes) 
to the active map window legend.   

1. On the Home tab, select Legends > Add Legend Entries to display the Add Legend Entries dialog 
box. 

 

2. Click the  plus symbol to the left of the label entitled Dauphin Training Data to expand the tree 
view. 

 

3. Once the tree view expands to show all of the features in the Dauphin Training Data connection, 

click on the  check box beside EX1_PinMap. 
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4. With EX1_PinMap checked, click the OK button to display the selected feature in the map window. 

5. Right-click on the EX1_PinMap legend entry and select Style Scaling > View. 

 

6. This is a Pin Map. As you can see from this specific Pin Map there are several dots and patterns that 
are not easily discernible. We are going to learn how to extract information from this map. 

 

Viewing Attributes  

The Incident Query command in Incident Analyst can be configured to return any combination of attributes 
from a data source. In this case, the data source of the Pin Map is a CAD database.  Viewing these 
attributes is easy. 

1. On the Home tab, select Add / Show Windows > New Data Window to display the New Data 
Window dialog box. 
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2. Click the  plus symbol to the left of the label entitled Dauphin Training Data. 

 

3. Once the tree view expands to show all of the features in the Dauphin Training Data connection, 
click on the feature called EX1_PinMap. 

 

4. With EX1_PinMap checked, click the OK button to place the selected feature in the data window. 

 

5. Information from the data window can be viewed similar to a spreadsheet. Use the scroll bars to 
familiarize yourself with the attributes associated with the Pin Map. Note: Information can be extracted 
from this view using simple cut and paste techniques. Also, if you select a record in this window the 
corresponding point in the map will highlight so that you can quickly see its location relative to others in 
the map window. 
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6. Close the data window by clicking on the Close button in the upper right corner of the data window. 

7. Click the  Zoom In icon and zoom in on the map so that individual points can be easily delimited. 

 

8. Once you are at a zoom level that allows you to easily see the individual points, click on the  Select 
Tool to enable it. 

9. Hover the cursor over one of the points in the map window and double-click on it to display the 
Properties dialog box for the selected point. 

 

10. The Properties dialog box contains the attributes for a given point.  

11. Once you have viewed the contents of the Properties dialog box, click the OK button to close the 
Properties dialog box. 

12. Click the  Fit All icon. 
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Creating a Thematic Pin Map  

Thematic Pin Maps are essentially pin maps but the pins are color coded based upon an underlying 
attribute. These maps allow the map reader to better understand the dispersal of points. 

1. Right-click on the EX1_PinMap legend entry and select Legend Entry Properties to display the 
Legend Entry Properties dialog box. 

 

2. There are a number of ways to create thematic maps, but for now we will concentrate on Unique 
Value Thematic. Click on Unique Value Thematic in the Type list to highlight it. Notice that the right 
portion of dialog box updates to reflect this selection 

 

3. Click on the Attribute for classification drop-down list and select the attribute entitled DOW (short 
for Day of Week). Note: This drop-down list contains all of the attributes associated with the feature 
class (i.e. all of the attributes that you saw in the Properties dialog box earlier in this exercise). 
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4. Click the Classify button. 

 

❖ There will be seven classes (one for each day of the week where 1 equals Monday and 7 equals 
Sunday). Note: The labels can be changed here or in the legend. We will change these later using 
the legend. 

❖ The Legend Properties dialog box can be used to manipulate color and symbol types and sizes in 
a multitude of ways. However, given the time constraints of the course, we will only explore one of 
these workflows.  

5. Select a color ramp from the Assign colors drop-down list.  

 

6. Once your Legend Entry Properties dialog box looks similar to the example below, click the OK 
button to apply your selections to the map window. 
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7. The Legend entry entitled EX1_PinMap will have updated to reflect a state of Thematic legend entry 
(i.e. the icon will have changed to  and a   plus symbol will be located to the left of the text label. 

  

8. Click on the   plus symbol to expand the contents of the legend entry. 

  

9. Note that the sub-legend entries reflect the attribute name (i.e. values 1 through 7). Labels can be 
changed to better reflect the contents of the map window. Click on the text 1 to select it, then click 
again to select the sub-legend entry text. 

  

10. Once the text is selected use the keyboard and type in Monday. 

  

11. Make the changes to the remaining entries so that each entry reflects the day of the week. 
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Turning Off the Display of a Legend Entry  

Once a legend entry has been added, the display can be turned off or the legend entry can be deleted. In 
this case, we are going to turn the display off. 

1. Highlight the EX1_PinMap legend entry.  

 

2. Once the legend entry is highlighted, right click to display the context menu. The context menu 
contains many options. 

 

3. Select the Display Off option in the menu. This action turns off the display of the selected legend entry 
and the text in the legend entry will dim to indicate that legend entry is not in a displayed state. 
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Performing an Attribute Query 

The Attribute Query command allows you to define and save new attribute queries that contain a subset 
of features based on an attribute filter applied to input features, which may be a feature class in a 
warehouse or another query in the active GeoWorkspace.  

1. On the Analysis tab, select Attribute Query to display the Attribute Query dialog box.  

 

❖ In this example, we are going to use the Attribute Query command to depict all of the incidents 
that occurred on a Monday.    

2. Click on the Select features in drop-down list and select the feature entitled EX1_PinMap from the 
Dauphin Training Data connection. 

 

 

❖ Remember that this data came from a CAD data source and it has attributes representing when 
the call was logged. 
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3. Click the Filter button to display the Filter dialog box.  

 

4. This dialog box is very powerful and it lets you create complex queries at the click of a mouse. Select 
DOW from the Attributes list. 

 

5.  Click the  down arrow button to place the selected attribute (DOW) in the Filter text box.   

 

6. Click the  equal button to place an = symbol in the Filter text box. 

 

7. Click the Show Values button to show all of the DOW values in the feature class. 

 

8. Click on the value 1,  
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9. Click the  down arrow button to place the selected value in the Filter text box. Your Filter text box 
should contains the text DOW = ‘1’ as in the example provided below. 

 

10. Once the filter is correct (same as the filter dialog box below), click the OK button to set the filter.  

 

11. In this case, the filter is looking for all incidents where the day of the week is Monday (i.e. DOW = ‘1’). 
Note that you have been returned to the Attribute Query dialog box. 

 

12. Make sure the Display query in map window is checked as we want the results to be displayed in 
the map. 

 

13. Use the Query name text box to input a name for this query (type in Monday Calls). 
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14. Make sure the Display query in data window is unchecked as we do not need a data window at this 
point. 

 

15. Once your Attribute Query dialog box looks similar to the example provided below, click the OK 
button to run the query and create your legend entry. 

 

16. As soon as the command completes, a new legend entry entitled Monday Calls will be added to your 
map window. 

17. Right-click on the Monday Calls legend entry and select Style Scaling > View. 
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Changing a Point Symbol 

As noted before, point symbol manipulation is easy and there are a number of different workflows 
associated with this task. In this section you will change the point symbol look and size for the new legend 
entry you just created. 

1. Right-click on the Monday Calls legend entry and select Legend Entry Properties to display the 
Legend Entry Properties dialog box. 

 

2. Click the Properties button to display the Style Properties dialog box. 

 

3. Again there are lots of options to choose from. Select Star Filled from the Name drop-down list. 

 

4. Set the Size field to 14.000. 

 

5. Set the Translucency field to 50. 
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6. Click the color button beside the Define override color  to display the color picker 
dialog box. 

 

7. Choose a color then click the OK button. 

8. Click the OK button to close the Style Properties dialog box. 

9. Click OK button to close the Legend Entry Properties dialog box and apply your style settings to the 
map window. 

10. Zoom in on the map to have a better view of your results. 

 

❖ You may notice that not all of the stars are the same color (i.e. some are darker than others). This 
variation is due to the fact that there are locations where one or more incidents have occurred. 
These locations are referred to as Repeat Locations (or Repeat Victimization). In the next exercise 
you will learn how to map these types of locations effectively. 

11. Right-click on the Monday Calls legend entry and select Display Off.  
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12. Click the  Fit All icon. 

 

 

 

Animating a Pin Map 

Incident Analyst lets you extract point data from a CAD and/or RMS system.  This data is usually related to 
incidents that have information about the time that the incidents occurred.  It is helpful to interactively view 
multiple incident themes over a period of time in an animated fashion.  The Change Over Time command 
includes playback options (play, pause, rewind, fast forward, and interactive slider controls).  These 
controls let you visualize change over time, assess the impact of reduction initiatives to determine their 
effectiveness, and identify emerging areas of concern. 

For example, users may use the Incident Query command to extract car crashes for an entire year. They 
can use this query as input into the Change Over Time command, where the time interval is set to one 
month. Incident Analyst performs queries on the fly against the in-memory query to produce 12 queries, 
then, in turn, display these in sequence as an animation. 

 

Features and Benefits 

❖ Allows users to interactively view multiple incident themes in an animated fashion  

❖ Visualize change over time 

❖ Assess the impact of reduction initiatives to determine their effectiveness  

❖ Identify emerging areas of concern 
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1. On the Incident Analyst tab, select Change Over Time to display the Change Over Time dialog box. 

2. There are two tabs in this dialog, a Legend entries tab and a Chronological feature tab. Select the 
Chronological feature tab.  

 

3. We are going to use the EX1_Animation feature class to illustrate the Change Over Time command. 
This feature class contains one week of calls from a CAD system. Use the Feature drop-down list to 
select the feature class named EX1_Animation. This feature is located in the Dauphin Training Data 
connection.  

 

4. Use the Date/time attribute drop-down list to set this option to DATE_OCCU. 

❖ The Interval drop-down list will default to per day. Note: The drop-down list will always attempt to group the 
data into 12 groups. For example, if the user were to select a query that started on January 1, 1996 through 
to December 1, 1996 then the Interval drop-down list would default to per month. 

 

5. Set the Frame Interval time drop-down list to per day. 

 

6. Set the Frame duration to 1. 

 

❖ The Frame duration in the seconds field sets the cadence of the animation (i.e. how fast the animation will 
cycle between groups). In this case the animation will advance 1 day per second. 

❖ The Style button can be used to set the style for the point symbols in the animation.  

7. Ensure the Accumulate data check box his checked. 

 

❖ If the Ensure the Accumulate check box is checked the display of the animated data is accumulated from 
one time-frame interval to the next. If the Ensure the Accumulate check box is uncheck the data in a single 
time frame interval is displayed at a time during animation. 
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8. Now that all of the options are set for the animation, reduce the Change Over Time dialog using the 
gripper handle in the lower right corner as illustrated below. 

9. Move the dialog into the Ribbon area so you can see the map in the map window. 

 

10. Click the Play  button to start the animation. 

❖ The animation will cycle one day at a time at 1 second intervals. Notice a couple of things as the animation 
cycles through from start to end. 

❖ The Current frame time field will update to reflect what date range is being displayed in the map window. 

 

❖ The Legend will also update to reflect the date just like the Status field however, the legend will also display 
a count for each date range (in the example the count is 36). 

    

11. You can also manually cycle through the animation using the slider bar. Select the slider bar and slide 
the indicator left or right to advance or rewind the animation. 

 

12. Expand the dialog and uncheck the Accumulate data check box and re-run the animation. Notice the 
difference in the playback animation behavior.  

13. Click Close box to dismiss the Change Over Time dialog. 
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Deleting Legend Entries and Saving Changes to a Workspace 

Before moving on to the next exercise, we need to clean up the workspace and then save it. To do this we 
are going to delete all of the legend entries we created in this exercise and then save the changes to the 
workspace. 

1. Select the Monday Calls legend entry. 

 

2. With the legend entry highlighted, depress the Delete key on the keyboard. 

 

3. When the confirmation dialog box appears, click the Yes button to confirm the delete. Note: The 
feature class is not deleted only the legend entry is deleted. 

4. Delete the EX1_PinMap legend entry. 

5. Select the File > Save GeoWorkspace command to save the changes to the GeoWorkspace. 

6. Your GeoWorkspace is now cleaned up and saved to disk. You are ready to move on to Exercise 2: 
Repeat Incident Mapping. 

 

 



 

   
Copyright 2016 Hexagon Geospatial  23 

Exercise 2: Repeat Incident Mapping 

Overview 

Incident Analyst includes a repeat incident mapping command. Repeat incidents maps allow users to 
display locations where incidents occur more than once. These maps use symbol size and color to identify 
reoccurrence of incidents in the same location.  

 

Features and Benefits 

❖ Effectively depicts repeat and non-repeat places on the same map.  

❖ Allows the map reader to quickly make comparisons among repeat places and the number of 
incidents. 

❖ Quickly find concentrations of hot places (i.e. an area that contains several repeat calls for 
service). 

In basic terms, repeat incidents indicate a type of pattern. By most definitions, repeat incidents occur when 
the same type of incident is experienced by the same – or virtually the same – victim or target within a 
specific period of time such as a year. Repeat incidents refer to the total number of incidents experienced 
by a victim or target including the initial and subsequent incidents (e.g. a person's house may be 
burglarized twice in a year or 10 times and both examples are considered repeats or several crashes have 
occurred virtually at the same location within one year). 

 

Skills Covered in this Exercise 

In this exercise you will learn how to: 

❖ Display a Feature Class using the Add Legend Entries command. 

❖ Create a Repeat Incident map using the Repeat Incidents command. 

❖ Color a Repeat Incident map. 

❖ Change the symbol size within a Repeat Incident map. 

❖ Create a Top 20 % Repeat Incident map using the Repeat Incidents command. 

❖ Remove legend entries from a map window. 

❖ Save changes to a GeoWorkspace. 

 

Adding a Feature to the Map Window  

The Add Legend Entries command is used to add one or more sets of features (queries/feature classes) 
to a legend to display in the map window.  

1. On the Home tab, select the Legends > Add Legend Entries command to display the Add Legend 
Entries dialog box. 

2. Click the  plus symbol to the left of the label entitled Dauphin Training Data. 
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3. Once the tree view expands to show all of the features in the Dauphin Training Data connection, 

click on the  check box beside EX2_PinMap. 

 

4. With EX2_PinMap checked, click the OK button to place the selected feature in the map window. 

5. Right-click on the EX2_PinMap legend entry and select Style Scaling > View. 

 

❖ As you can see from this specific Pin Map there are several dots and patterns that are not easily 
discernable. We are going to learn how to extract meaningful information from this map using the 
Repeat Incidents command in Incident Analyst. 

6. Delete the legend entry EX2_PinMap as it is no longer needed. 
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Creating a Repeat Incident Map 

The Repeat Incidents command is used to create repeat incident maps. The Repeat Incidents command 
takes one input (a point feature class) and generates one output (a point feature class that is displayed 
thematically). 

  

Input: Point Features Class 

  

Output: Point Feature Class (Thematically Display) 

1. On the Incident Analyst tab, select Repeat Incidents to display the Repeat Incidents dialog box. 

 

2. Use the Repeat incidents in drop-down list to select the feature class called EX2_PinMap. 
Remember this feature class is stored in the connection called Dauphin Training Data. Note: As soon 
as this action is complete, all the options will enable and the OK button will enable.  

 

❖ All commands in Incident Analyst work in this fashion (i.e. as soon as the required inputs are defined by the 
user) each command automatically sets the remaining options for the user and the OK button enables. With 
this approach, the user can typically run a command with only one or two clicks of the mouse.  

❖ There are two Rank by options (Location and Attribute). 

❖ The default is Location. In this case, any incidents that fall spatially in the same location are grouped (i.e. if 
three incidents fall spatially on top of one another they are counted as three repeat incidents.) 

❖ The Attribute option groups incidents by a user specified attribute. In this case, a map is not created but the 
result of this grouping can be shown in a data window. For example, you could use this option to group the 
results by incident type. 
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3. Ensure the Location option is selected.  

 

❖ The Display frame contains three radio buttons (Top groups, Top % of groups, and All repeating 
incidents) and a check box (Include non-repeating incidents). 

❖ Selecting Top groups will extract the user defined number of records based upon a ranking (i.e. input data is 
sorted, then ranked based upon the total number of repeat counts at each location). For example, assume 
there are 10 records in the input query, and after a sorting and ranking has taken place, the top user defined 
number of groups will be extracted. 

❖ Selecting Top % of groups will extract the user defined percent of records based upon a ranking (i.e. input 
data is sorted, then ranked based upon the total number of repeat counts at each location). For example, 
assume there are 10 records in the input query, and after a sorting and ranking has taken place, the top user 
defined percentage of groups will be extracted. 

❖ All repeating incidents will extract all of the repeating records in the record set. 

❖ Include non-repeating incident will extract all of the records in the record set 

4. Ensure the All repeating incidents option is selected. This is the default and is automatically enabled. 

 

5. For the Query name, type in Repeat Incidents in the text box.  

 

6. Leave the Description field blank. This facility allows users to attach ancillary data to a query. This 
information is used to describe the query so that when a query is viewed in the future, the ancillary 
information can be used to determine its history. 

7. We want the results to be displayed in the map window, therefore ensure that the Display query in a 
map window check box is checked. 

 

8. The Display query in data window option allows the user to display the result in a data window (i.e. a 
table view). In this case, we only want the results to be displayed in the map window, so ensure that 
the Display query in a data window is unchecked. 
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9. Your dialog box should look similar to the sample below. Once it does, click the OK button. 

 

❖ After the command completes the results will be placed in the map window and a new legend entry 
called Repeat Incidents will be visible. 

 

10. Right-click on the Repeat Incidents legend entry and select Style Scaling > View. 

 

11. Click on the  plus symbol beside the legend entry called Repeat Incidents. 

 

❖ This will expand the legend entry so that the user can see the thematic classification of this legend 
entry. 
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Viewing Attributes  

The Repeat Incidents command like other commands in Incident Analyst create functional attributes. 
Functional attributes are additional attributes that are used to help describe the results of the command. 
These attributes are added to the attributes returned from the Incident Query command (i.e. they are 
appended to each record). These attributes can be viewed in a data window or on an individual feature. 

1. Click the  Zoom In icon to zoom in on an area within the map. 

 

❖ Note that the size of the points change to reflect the number of repeat incidents at each location. 

2. Use the Select Tool  to view the attributes that are returned. After selecting the Select Tool  
icon, double-click one of the largest points. This action will display a properties dialog box for the 
selected incident point. 
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❖ Notice the new attribute called RepeatIncidentCount. This attribute was created by the Repeat 
Incidents command (i.e. it aggregated all of the points spatially and then counted the aggregated 
points and placed the resulting count into this attribute). 

3. Click the Cancel button to close the Repeat Incidents Properties dialog box. 

Changing the Color and Symbol Sizes Associated with a Repeat Incident Map 

A default symbol size and color is always applied by the Repeat Incidents command. This default may not 
meet your specific requirements; therefore you can change the results at any time. 

1. If your Repeat Incidents legend entry is not already expanded, click on the  plus symbol beside the 
Repeat Incidents legend entry.  

 

❖ This will expand the legend entry so that the user can see the thematic classification. 

 

2. To change the style of this legend entry or any legend entry, double-click the  icon beside the 
Repeat Incident legend entry. This action will display the Legend Entry Properties dialog box. The 
contents of this dialog box will change depending on the type of legend entry that is clicked, but for all 
intent and purposes, it will look very similar in all instances and it provides common controls for altering 
the style of a legend entry. 

 

❖ Notice that the Attribute for classification is set to RepeatIncidentCount. This is a functional 
attribute that was created by the Repeat Incidents command. This attribute contains the number of 
repeat incidents at each location. 

3. For information regarding all of the functionality in this dialog box use the F1 Key. For now we are 
going to change the size and color range of the selected legend entry.  
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4. Use the Assign colors drop-down list to assign a blue to dark red color sequence for the selected 
legend entry. 

 

5. Use the Assign sizes drop-down list to assign a size range of 6.00 to 14.00 pt. 

 

6. Your dialog box should look similar to the sample below. Once it does, click the OK button. 

 

❖ After the command completes, the result will be placed in the map window and a legend entry 
called Repeat Incidents is modified to match your settings. 

 

❖ The Repeat Incidents command is very good at locating hot areas where there are many repeat 
incidents, but if a user wants to look for hot areas within all of the incidents, the Simple Hotspot or 
the Advanced Hotspot command can be applied. You will learn more about hotspots in Exercise 5 
Hotspot Mapping. 

7. Delete the legend entry entitled Repeat Incidents as it is no longer needed. 

8. Click the  Fit All icon. 
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Creating a Top 20 Percent Repeat Incident Map 

As illustrated in the previous section, the Repeat Incidents command can quickly create meaningful 
depictions of a Pin Map. However, the Repeat Incidents command has a number of options for extracting 
meaningful information from a Pin Map. For example, you can use this command to extract the top 20 
percent of repeating incidents from a Pin Map. 

1. On the Incident Analyst tab, select Repeat Incidents to display the Repeat Incidents dialog box. 

 

2. Use the Repeat incidents in drop-down list to select the feature class called EX2_PinMap. 
Remember this feature class is stored in the connection called Dauphin Training Data. Note: As soon 
as this action is complete, all the options will enable and the OK button will enable.  

 

3. Ensure the Location option is selected.  

 

4. Ensure the Top % of groups option is selected. Once the option is enabled, type 20 into the text field. 

 

5. For the Query name type in Top 20 Percent in the text box.  

 

6. Leave the Description field blank. This facility allows users to attach ancillary data to a query. This 
information is used to describe the query so that when a query is viewed in the future, the ancillary 
information can be used to determine its history. 
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7. We want the results to be displayed in the map window, therefore ensure that the Display query in a 
map window check box is checked. 

 

8. The Display query in data window allows the user to display the result in a data window (i.e. a table 
view). In this case, we only want the results to be displayed in the map window, so ensure that the 
Display query in a data window is unchecked. 

 

9. Your dialog box should look similar to the sample below. Once it does, use your mouse and click the 
OK button. 

 

❖ After the command completes, the results will be placed in the map window and a new legend 
entry called Repeat Incidents will be visible. 

 

10. Right-click on the Repeat Incidents legend entry and select Style Scaling > View. 
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11. Click on the  plus symbol beside the legend entry called Repeat Incidents. 

 

❖ This will expand the legend entry so that the user can see the thematic classification of this legend 
entry. 

 

❖ This legend entry represents the top 20 percent of repeating incident locations. 

12. Delete the legend entry Top 20 Percent as it is no longer needed. 

13. Click the  Fit All icon. 

14. Select the File > Save GeoWorkspace command to save the changes to the GeoWorkspace to disk. 
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Exercise 3: Boundary Mapping 

Overview 

Boundary maps are maps of thematic displays of polygons that count the incidents that fall within it. These 
maps use color to represent different values among land units, such as police precincts, city voting 
districts, or census tracts. They can be expressed as simple counts (e.g. number of incidents in a defined 
boundary) or as density values (e.g. number of incidents per square mile). Incident count maps offer map 
users a broader perspective of where incidents occur without having to interpret a large number of 
individual locations. 

Boundary mapping is a popular technique for representing any spatial distribution as geographic boundary 
thematic mapping. These geographic boundaries usually are defined as administrative or political areas 
such as beats, census blocks, polling districts, wards, or borough boundaries.  

Incident events mapped as points can be aggregated to these geographic region or areas. These counts 
of events by their geographic areas can then be thematically mapped to display the spatial pattern of 
incidents across jurisdiction.  

 

Features and Benefits 

❖ Flexible boundary selection (any area that is connected) 

❖ Automatic labeling 

❖ Simple counts or density (incidents /square mile) 

❖ Offers a broader perspective of where incidents occur without having to interpret a large number of 
individual locations 

 

Skills Covered in this Exercise 

In this exercise you will learn how to: 

❖ Display a Feature Class using the Add Legend Entries command. 

❖ Create a Boundary map using the Incident Count command. 

❖ Classify and color a Boundary map. 

❖ Modify the Statistical method associated with an Incident Count command.  

❖ Remove legend entries from a map window. 

❖ Save changes to a GeoWorkspace. 

 

Adding a Feature to the Map Window  

The Add Legend Entries command is used to add one or more sets of features (queries/feature classes) 
to a legend to display in the map window.  

1. On the Home tab, select Legends > Add Legend Entries to display the Add Legend Entries dialog 
box. 

2. Click the  plus symbol to the left of the label entitled Dauphin Training Data. 
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3. Once the tree view expands to show all of the features in the Dauphin Training Data connection, 

click on the  check box beside EX3_PinMap. 

 

4. With EX3_PinMap checked, click the OK button to place the selected feature in the map window. 

5. Right-click on the EX3_PinMap legend entry and select Style Scaling > View. 

 

❖ As you can see from this specific Pin Map there are several dots and patterns that are not easily 
discernable. We are going to learn how to extract meaningful information from this map using the 
Incident Count command in Incident Analyst. 

6. Delete the legend entry EX3_PinMap as it is no longer needed. 
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Creating a Boundary Map 

The Incident Count command takes two inputs (a point feature class to represent the incident locations 
and an area feature class to aggregate the incidents) and generates two outputs (a label feature class and 
an area feature class that is displayed thematically). 

  

Input 1: Point Features Class 
  

Output 1: Area Feature Class 

   

Input 2: Area Features Class 
   

Output: 2 Label Feature Class 

1. On the Incident Analyst tab, select Incident Count to display the Incident Count dialog box. 

 

❖ The Count incidents in drop-down list allows the user to specify the incident events (or the values that will 
be used to compute the boundary counts). In this example, we are interested in characterizing police beats 
by the total number of incidents in the feature class called EX3_PinMap. 

2. For Count incidents in, select the feature class EX3_PinMap from the drop-down list. Remember this 
feature class is stored in the connection Dauphin Training Data.  
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3. For That touch boundaries in, select the feature class Beat_Boundary from the drop-down list.  
Note: This feature class is stored in the connection called Dauphin Access. 

 

❖ The That touch boundaries in allows the user to select any area based feature class or query (it defines 
the geographical areas within which the counts are computed). In this case we are going to make use of the 
Police Beats. 

❖ The Count type frame contains two radio buttons namely, Simple and Density. These radio buttons control 
the count computation.  
 
If Simple is selected, then the command simply determines the total number of incidents that fall within each 
boundary (i.e. if 50 incidents fell in boundary 1 then boundary 1 would be assigned a value of 50).  
 
If Density is selected, then the command calculates a density value for each boundary based upon the user 
specified area measurement (i.e. if 50 incidents fell in boundary 1 and boundary 1 was 12.5 Acres then 
boundary 1 would be assigned a value of 0.25 (or 0.25 Incident per Acre). The Density option include a drop 
down list and it includes the following options: 

❖ Acre, Hectare, cm^2, in^2, ft^2, km^2, m^2, mi^2, mm^2, yd^2 

4. Ensure that the Simple radio button is selected. 

 

5. For the Query name, type in Simple Count. 

 

❖ The Count label frame contains options for adding labels to the map. 

❖ The Prefix and Suffix radio buttons work in unison with any text that is added within the Static text box and 
the Boundary attribute drop-down list. 
 
For example, if the Prefix radio button is enabled and the text “Census Track: ” is entered into the Static 
text box and an ID attribute is selected, the map labels will appear similar to the example provided below: 

❖ Census Track: 1498a - 12 

❖ Where Census Track: is the static text, 1498a is the census track number (Boundary attribute – user defined) 
for the selected area and the - 12 represents the total number of incident that fell with the census track. 

6. Ensure that the Prefix radio button is selected.  
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7. For the Static text, type in Beat: 

 

8. For the Boundary attribute, select Beat from the drop-down list. 

 

9. Make sure Display query in map window is checked. 

 

10. Make sure the Display query in a data window is unchecked.  

 

11. Your Incident Count dialog box should look similar to the example provided below. Once it does, 
click the OK button to execute the command. 

 

12. Once the command completes, the map window will update to reflect the result. Notice that there are 
two additional items in the legend; namely a thematic legend entry called Simple Count and a label 
legend entry called Labels for Simple Count. Note: Text can be scaled within GeoMedia to create a 
cartographically appealing map. 

13. Right-click on the Labels of Simple Count legend entry and select Style Scaling > View. 

14. Right-click on the Simple Count legend entry and select Style Scaling > View. 
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15. Use the  Zoom In icon to zoom in on an area within the map. 

 

❖ Notice the light red to dark red color ramp and the text labels. The text labels in this instance are 
too large for the map. These can be modified and will be in the next section of this tutorial. 

16. Before changing the label size, let’s examine the results of the Incident Count command. For the 

legend entry Simple Count, click the  plus symbol to the left to expand the sub-legend entries. 

 

❖ Notice that there are 4 sub-legend entries. Each entry contains a class boundary definition (i.e. a 
set of values used to determine a value range). The first sub-legend entry in this case has class 
boundary setting of 0 to 33 and therefore depicts those areas where the incident count falls 
between 0 and 33.  

Changing the Size of Labels  

1. Right-click on the Labels of Simple Count legend entry and select Legend Entry Properties. 
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2. For the Size set the font size to 5. 

 

3. Click the OK button to close the Legend Entry Properties dialog box and apply your style settings to 
the map window.  

4. Notice that the labels update to reflect the specified size. Note: When plotting these maps, you will 
want to explore Style Scaling options (namely Paper and View) for text (i.e. if you intent to create 
hard copy maps you will want to make use of the Paper setting).  

 

5. Delete the legend entry Labels of Simple Count as it is no longer needed. 

6. Click the  Fit All icon. 
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Creating a Boundary Map Using Density 

The Incident Count command includes Density options. This option calculates a density value for each 
boundary based on the area dimension that you specify using the adjacent drop-down list.  

For example, if 50 incidents fell in Boundary1, and Boundary1 was 12.5 acres, Boundary1 would be 
assigned a value of 0.25 (or 0.25 Incidents per Acre).  The area dimensions in the Density drop-down list 
are the same as those specified for area on the Units and Formats tab of the View GeoWorkspace 
Coordinate System dialog box. 

Using a density calculation verses a simple count calculation can yield substantially different results. In the 
example provided below, the same input was used in both cases however, the simple count calculation 
was used to create the map on the left (Incident Per Police Beat) and the density calculation was used to 
create the map on the right (Density of Incidents Per Police Beat).  

As can be seen from the figure below, the results are very different. The map on the right effectively 
depicts those areas where the density of calls is high, not just the sheer number of calls. Each map has its 
advantages however; typically Density maps better depict the actual conditions with a boundary. 

 

1. Existing query results can be modified using the Queries command. In this example you are going to 
modify the existing Simple Count query to reflect a density calculation. On the Analysis tab, select 
Queries to display the Queries dialog box. 
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2. This dialog box contains all of the queries (i.e. Incident analyst Commands) you have run to date. 
Select the query called Simple Count. 

 

3. Click on the Properties button to display the Properties dialog box for the selected query. 

  

4. Ensure that the Density radio button is selected and that the drop-down list contains mi^2. This will 
calculate incident per square mile. 

 

❖ If the Per options is selected, the command calculates the total number of incidents per some numerical 
classification that falls within each boundary. The numerical classification value is defined by a constant 
value (that you type into the text field), divided by a value defined by an attribute in the boundary feature. The 
default value in the text field is 1000. The drop-down list displays numeric attributes for the selected 
boundary feature. For example: Incidents Per 1000 residents Counties, where residents is the population of 
persons per County feature. 
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5. Once your Query Property dialog box looks similar to the example below, click the OK button to 
update the query to reflect the current settings. 

 

6. Your map will update and you will be returned to the Queries dialog box. 

 

7. Click the Close button to dismiss the Queries dialog box. Your Boundary Map will update to reflect 
the density setting. 

8. Use the  Zoom In icon to zoom in on an area within the map. 

 

❖ As can be seen, your map will look very different, as it now reflects a density calculation. However, 
the class boundary definition needs to be updated to reflect the new values. 
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Changing the Color and Class Boundary Settings within a Boundary Map 

1. Double-click on the  symbol for the Simple Count legend entry to display the Legend Entry 
Properties dialog box. 

 

2. Click the Classify… button to display the Classify dialog box. 

 

❖ The Classify dialog box allows you to specify information about the classifications for a Range Thematic 
legend entry where: 

❖ Equal Count: Distributes the same number of records into each range. 

❖ Equal Range: Divides the ranges up equally and distributes the values into each range.  This is the default 
selection.  Selection of this method enables the Begin value and End value text boxes.  The ranges created 
will be limited within these values. 

❖ Standard Deviation: Computes the standard deviation of all values and applies it to the number of ranges. 

3. For the Classification technique, select Equal Range. 

4. For the Number of Ranges, select 6.  

❖ Allows you to type or select the number of ranges you want to use to create the thematic display.  The 
default number of ranges is four, and the minimum number of ranges is two.  The drop-down list contains 
numbers from 2-20.  Numbers exceeding 20 must be typed in. 
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5. When your Classify dialog box looks similar to the one presented below, click the OK button to apply 
the settings. 

 

6. You will be returned to the Legend Entry Properties dialog box. Notice the color ramp has changed 
to the default setting and that the values in the Begin Value, End Value, Label, and Count columns 
have changed to reflect the new values (i.e. Density values). 

 

7. Use the Assign colors drop-down list to assign a light red to dark red color sequence to the selected 
legend entry. 
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8. You can also edit values (labels) in the Label column so that they are easier to read (i.e. reduce the 
level of precision from 16 to 2). Remember that these values represent incident per square mile. Edit 
your labels accordingly. 

        

9. Your Legend Entry Properties dialog box should look similar to the sample below. Once it does, click 
the OK button. 

 

10. After the command completes, the results will be placed in the map window and a legend entry called 
Simple Count will be modified to match your settings. 

 

Incident Count (Density) – Notice that the smaller beats reflect a higher count. 
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Incident Count (Simple) – Notice the color does not relate to size of boundary. 

11. Delete the legend entry Simple Count as it is no longer needed. 

12. Click the  Fit All icon. 

13. Select File > Save GeoWorkspace to save the changes to the GeoWorkspace to disk. 
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Exercise 4: Grid Boundary Mapping 

Overview 

Grid Boundary maps are maps of thematic displays of grid polygons that count the incidents that fall within 
it. These maps use color to represent different values among pre-defined land units. These land units are 
typically square and range in size from 200 meters by 200 meters to 4 kilometres by 4 kilometres. The size 
depends on the area being analyzed. Smaller areas are typically used in urban areas. 

Note: This exercise is similar to Exercise 3 and therefore it is optional. Depending on time this exercise 
may be skipped. 

 

Skills Covered in this Exercise 

In this exercise you will learn how to: 

❖ Display a Feature Class using the Add Legend Entries command. 

❖ Create a Boundary map using the Incident Count command. 

❖ Classify and color a Grid Boundary map. 

❖ Remove legend entries from a map window. 

❖ Save changes to a GeoWorkspace. 

 

Adding a Feature to the Map Window  

The Add Legend Entries command is used to add one or more sets of features (queries/feature classes) 
to a legend and display it in the map window.  

1. On the Home tab, select the Legend > Add Legend Entries command. 

2. Click the  plus symbol to the left of the label entitled Dauphin Training Data. 

3. Once the tree view expands to show all of the features in the Dauphin Training Data connection, 

click on the  check box beside EX4_GridBoundaries and EX4_PinMap. 
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4. With EX4_GridBoundaries and EX4_PinMap checked, click the OK button to place the selected 
feature in the map window. 

5. Right-click on the EX4_PinMap legend entry and select Style Scaling > View. 

6. Right-click on the EX4_GridBoundaries legend entry and select Style Scaling > View. 

 

7. EX4_GridBoundaries was created using the Grid Analysis capabilities in GeoMedia Desktop. This 
feature class contains 2 kilometers by 2 kilometers grid polygons. 

8. Turn off the display of the legend entries EX4_GridBoundaries and EX4_PinMap. 
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Creating a Grid Boundary Map 

1. On the Incident Analyst tab, select Incident Count to display the Incident Count dialog box. 

 

2. For Count incidents in, select the feature class EX4_PinMap from the drop-down list to. Remember 
this feature class is stored in the connection Dauphin Training Data.  

 

3. For That touch boundaries in, select the feature class EX4_GridBoundaries from the drop-down 
list. Note: This feature class is stored in the connection called Dauphin Training Data. 

 

4. Ensure that the Simple radio button is selected.  

 

5. For Query name, type in Grid Boundary Map. 
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6. Ensure that the Prefix radio button is selected.  

 

7. Leave the Static text area blank. 

 

8. For the Boundary attribute, select <None> from the drop-down list. 

 

9. Make sure Display query in map window is checked. 

 

10. Make sure the Display query in a data window is unchecked.  

 

11. Your Incident Count dialog box should look similar to the example provided below. Once it does, 
click the OK button to execute the command. 

 

12. Once the command completes, the map window will update to reflect the result. Notice that there are 
two additional items in the legend; namely a thematic legend entry called Grid Boundary Map and a 
label legend entry called Labels for Grid Boundary Map.  

13. Right-click on the Labels of Grid Boundary Map legend entry and select Style Scaling > View. 

14. Right-click on the Grid Boundary Map legend entry and select Style Scaling > View. 
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15. Use the  Zoom In icon to zoom in on an area within the map. 

 

❖ Notice the color ramp and the text labels.  This map is pretty good but it can be improved from a 
cartographic perspective. 

 

Changing the Color within a Boundary Map  

A default color ramp is always applied by the Incident Count command. This default may not meet your 
specific needs; therefore you can change the results at any time. 

1. Delete the legend entry entitled Labels of Grid Boundary Map as it is no longer needed. 

2. Click the  Fit All icon. 
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3. Double-click on the  symbol for the Grid Boundary Map legend entry to display the Legend 
Entry Properties dialog box. 

 

4. Click the Classify… button to display the Classify dialog box. 

5. For the Classification technique, select Equal Range. 

6. For the Number of Ranges, select 6.  

7. When your Classify dialog box looks similar to the one presented below, click the OK button to apply 
the settings. 
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8. You will be returned to the Legend Entry Properties dialog box. Notice the color ramp has changed 
to the default setting. 

 

9. Click the Base style button to display the Select Style dialog box. 

 

❖ This dialog box provides a list of existing styles and a preview of the selected styles, and it permits you to 
adjust the definition of the selected style before using it. You can also make a new named style from the 
selected style you have adjusted 

10. For the Width, select 0.250. 
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11. Click the Properties button to display the Style Properties dialog box. 

 

❖ The Style Properties dialog box allows you to adjust an existing style definition.  This can be something as 
simple as adjusting style properties (i.e. changing color) or something as powerful as changing the basic 
style type (i.e. changing from a symbol to a picture) or altering the style composition (i.e. expanding a simple 
style structure to a collection style structure, for example).  The dialog box also allows you to replace the 
style definition with a named style using the Select Style dialog box. 

12. Uncheck Simple Line Style. In this case we do not want any Boundary Style lines to appear in the 
map.  

 

13. Click the OK button to apply these settings and close the Style Properties dialog box and return you 
to the Select Style dialog box. 
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14. Click the OK button to apply these settings and close the Select Style dialog box and return you to 
the Legend Entry Properties dialog box. 

15. Use the Assign colors drop-down list to assign a light green to light red color sequence to the 
selected legend entry. 

 

16. In this particular case, the first legend entry 0 to 34 contains essentially no data (i.e. the majority of 
these grid polygons have an incident count of 0 and therefore we are going to hide this legend entry 
from view. Uncheck this legend entry.  

 

17. Your dialog box should look similar to the sample below. Once it does, click the OK button. 
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18. After the command completes the result will be placed in the map window and a legend entry called 
Grid Boundary Map is modified to match your settings. 

 

19. Click on the  plus symbol to the left of the legend entry entitled Grid Boundary Map to display the 
sub-legend entries. 

 

20. Notice that the 0 to 34 legend entry is hidden from view. 

21. Delete the legend entries entitled Grid Boundary Map, EX4_PinMap, and EX4_GridBoundaries as 
they are no longer needed. 

22. Click the  Fit All icon. 

23. Select File > Save GeoWorkspace command to save the changes to the GeoWorkspace to disk. 
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Exercise 5: Hotspot Mapping 

Overview 

Hotspot maps are the backbone of any incident analysis effort. Incident Analyst provides a number of 
commands for extracting hotspots from a plot of incidents, helping managers direct resources where they 
are needed most. Incident Analyst presents a simplified hotspot map interface, allowing novice users to 
quickly create a variety of hotspot maps from a set of sparse incident points.  

More advanced users can make use of the Advanced Hotspot command. Information about this command 
can be found later in this document. 

 

Features and Benefits 

❖ Extract areas where the concentration of incidents is high 

❖ Identify clusters in geographic space 

❖ Simple one click generation 

❖ Distills complex information into a simple picture  

❖ Effective communication products for public education 

❖ Helps direct assets where they are most needed 

This command is ideally suited for extracting geographic concentrations or hotspots from sparse data sets. 
For example, this command can be used to locate hotspots within data sets that contain Epidemiological 
(e.g. pandemic events), Law Enforcement (crime events), or Transportation (accident events).  

Specifically, Hotspot simplifies complex spatial point patterns by creating a surface of density values in 
which the density at each location reflects the concentration of points in the surrounding area. With this 
representation, analysts are able to see how incident densities vary within a geographic area. 

Note: Hotspots can also be used to analyze change over time. For example, multiple layers of car crash 
densities can be used as input into correlation analysis or time series analysis. The correlation analysis 
can be performed either by comparing two or more consecutive time periods (i.e., one week, to the next, 
to the next) or by comparing one time period to a similar one (i.e., July of the current year to July of the 
previous year). Note: This capability is presented later in this document. 

 

Skills Covered in this Exercise 

In this exercise you will learn how to: 

❖ Display a Feature Class using the Add Legend Entries command. 

❖ Create a Hotspot map using the Simple Hotspot command. 

❖ Manipulate the results of a Hotspot map. 

❖ Create a Repeat Incident map using the Repeat Incidents command. 

❖ Create an Advanced Hotspot map using the Advanced Hotspot command. 

❖ Remove legend entries from a map window. 

❖ Save changes to a GeoWorkspace. 
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Adding a Feature to the Map Window  

The Add Legend Entries command is used to add one or more sets of features (queries/feature classes) 
to a legend and display it in the map window.  

1. On the Home tab, select the Legends > Add Legend Entries command. 

2. Click the  plus symbol to the left of the label entitled Dauphin Training Data. 

3. Once the tree view expands to show all of the features in the Dauphin Training Data connection, 

click on the  check box beside EX5_PinMap. 

 

4. With EX5_PinMap checked, click the OK button to place the selected feature in the map window. 

5. Right-click on the EX5_PinMap checked legend entry and select Style Scaling > View. 
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Creating a Hotspot Map 

The Simple Hotspot command takes one input (a point feature class) and generates one output (an area 
feature class that is displayed thematically). 

  

Input: Point Features Class 

  

Output: Point Feature Class (Thematically Display) 

1. On the Incident Analyst tab, select Simple Hotspot to display the Simple Hotspot dialog box. 

 

2. For From incidents in, select the feature class called Ex5_PinMap from the drop-down list to. 
Remember this feature class is stored in the connection called Dauphin Training Data. 

 

❖ The Using intensity attribute drop-down list populates when the user selects a feature class for From 
incidents in (the default value in this drop-down list is <None>). This drop-down list only contains attribute 
names that have a data type of numeric. This drop-down list allows the user to select an Intensity value for 
the Point feature. For example, if the From incidents in drop-down list contains earthquake locations, then 
the Using intensity attribute drop-down list could be used to set a magnitude value to each location.  Or, if 
the From incidents in drop-down list contains car crash locations, then the Using intensity attribute drop-
down list could be used to set the number of injuries that occurs at each location to each location.  
 
Note: Negative values are excluded from the calculation (i.e. given a weight of 0) as these values can de-
normalize the resulting surface making a probability surface impossible. 
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❖ Use target area of interest can be used to restrict the hotspot analysis to a specific geographic area or 
areas. To specify a target area the user needs to select a feature area-based feature class that bounds the 
target area. For example, the user may want to limit the hotspot analysis command to the downtown core 
only, if this is the case, they would need to have an area-based feature class that represents this area. 

❖ The Multiple of mean drop-down list is to define a hotspot threshold. The default value for this is 3 (or 3 
means). This value is the accepted standard value for determining significant values within a surface. With 
this option selected the command will return a set of discrete hotspot areas ramping from the lowest density 
grouping (in this case from 3 means to 4 means) through to the highest density grouping (this group is data 
dependent and will therefore vary). 

  

Simple Hotspot Example x1 Mean Option (9 Discrete Density Areas) 

❖ The Nearest neighbors text is to define a K value for the calculation. The number of nearest neighbors 
affects the size of the bandwidth of the kernel which influences the values within the kernel and, therefore, 
the characteristics of the curve. The default value for this option is 8. Valid values are integers greater than 
zero. 

3. For Query name, type in Simple Hotspots. 

 

4. Leave the Description field blank. This facility allows users to attach ancillary data to a query. This 
information is used to describe the query so that when a query is viewed in the future, the ancillary 
information can be used to determine its history. 

5. Make sure the Display query in a map window check box is checked. 

 

6. Make sure the Display query in a data window is unchecked. 
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7. Your dialog box should look similar to the sample below. Once it does, click the OK button. 

 

❖ After the command completes, the result will be placed in the map window and a new legend entry called 
Simple Hotspots will be visible. 

8. Right-click on the Simple Hotspots legend entry and select Style Scaling > View. 

9. Click the  Zoom In icon and zoom in on some hotspot areas. 
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10. Just as with any legend entry the Simple Hotspots legend entry too can be modified. In this case 
however, we are going to change individual elements (classes) within the legend entry. Click on the  
plus symbol beside the legend entry called Simple Hotspots. 

 

❖ This will expand the legend entry so that the user can see all of the contents for this legend entry. 

 

❖ In the example provided above there are: 

❖ 27 areas where the absolute density is 0.021763 (3 Means – 4 Means),  

❖ 17 areas where the absolute density is 0.029017 (4 Means – 5 Means), 

❖ 12 areas where the absolute density is 0.036271 (5 Means – 6 Means), 

❖ 9 areas where the absolute density is 0.043525 (6 Means – 7 Means), 

❖ 5 areas where the absolute density is 0.050779 (7 Means – 8 Means), 

❖ 2 areas where the absolute density is 0.058033 (8 Means – 9 Means),  

❖ 2 areas where the absolute density is 0.065287 (9 Means – 10 Means), 

❖ 1 area where the absolute density is 0.072541 (10 Means – 11 Means), 

❖ 1 area where the absolute density is 0.079795 (11 Means – 12 Means). 

11. Click on the first legend entry of the Simple Hotspots thematic legend entry. 

 

12. Right-click to display the context menu, and select Display Off. 
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❖ This will turn the selected sub-legend entry off and update the map window to reflect this change. 

 

❖ The map window now shows only thematic hotspots where: 

❖ 17 areas with an absolute density is 0.029017 (4 Means – 5 Means), 

❖ 12 areas with an absolute density is 0.036271 (5 Means – 6 Means), 

❖ 9 areas with an absolute density is 0.043525 (6 Means – 7 Means), 

❖ 5 areas with an absolute density is 0.050779 (7 Means – 8 Means), 

❖ 2 areas with an absolute density is 0.058033 (8 Means – 9 Means),  

❖ 2 areas with an absolute density is 0.065287 (9 Means – 10 Means), 

❖ 1 area with an absolute density is 0.072541 (10 Means – 11 Means), 

❖ 1 area with an absolute density is 0.079795 (11 Means – 12 Means). 

13. Use the technique described above to redisplay the first legend entry using Display On instead. Your 
map window should look similar to the one provided below. 

 

❖ Note that the Simple Hotspot command did a nice job of locating where incidents have occurred 
but there are a number of hotspot that appear in locations where there “appears” to be only a few 
incidents that occurred. 

❖ However, it is important to note that Hotspot analysis takes into account all incidents, even those 
incidents that fall in the same location (i.e. repeat incidents). To better understand the hotspot 
results we will create a repeat incident count map.  
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Creating a Repeat Incident Map 

1. On the Incident Analyst tab, select Repeat Incidents to display the Repeat Incidents dialog box. 

2. Ensure that the Include non-repeating incidents option is checked. 

3. Replicate the options illustrated on the Repeat Incidents dialog box below: 

 

4. Once your Repeat Incidents dialog box looks like the example provided above, click the OK button to 
create the new legend entry. 

5. Click the  plus symbol to the left of the legend entry entitled Repeat Count of EX5_PinMap. There 
are seven sub-legend entries ranging in value from 1 repeat incident to 9 repeat incidents. 

 

6. Right-click on the Repeat Count of EX5_PinMap legend entry and select Style Scaling > View. 

7. When this repeat incident legend entry is view in context with the hotspot legend entry, the hotspot 
results make more sense (i.e. once the location of the repeat incidents are understood, the hotspot 
seem to better reflect the input data). 
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Creating an Advanced Hotspot Map 

As noted above, Hotspot maps are the backbone of any incident analysis effort. Incident Analyst presents 
a simplified hotspot map interface, allowing novice users to quickly create a variety of hotspot maps from a 
set of sparse incident points. However, more advanced users can make use of the Advanced Hotspot 
command. The Advanced Hotspot command allows users to experiment as it exposes all of the variables 
to the user that can affect the results of the command.  

The Advanced Hotspot command takes one input (a point feature class) and generates up to three outputs 
(an area feature class, an area feature class that is displayed thematically, and a linear feature class). 

  

Input: Point Features Class 

  

Output 1: Area Feature Class 

 

  

Output: 2 Area Feature Class 

 

  

Output 3: Linear Feature Class 

1. Delete the legend entry entitled EX5_PinMap as it is no longer needed. 

2. Click the  Fit All icon. 

3. Select File > Save GeoWorkspace command to save the changes to the GeoWorkspace to disk. 
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4. On the Incident Analyst tab, select Advanced Hotspot to display the Advanced Hotspot dialog box.  

 

5. For From incidents in, select the feature class Ex5_PinMap from the drop-down list. Remember this 
feature class is stored in the connection called Dauphin Training Data. 

 

❖ The Using intensity attribute drop-down list populates when the user selects a feature class for Incident 

query (the default value in this drop-down list is <None>). This drop-down list only contains attribute names 
that have a data type of numeric. This drop-down list allows the user to select an Intensity value for the Point 
feature. For example, if the From incidents in drop-down list contains earthquake locations, then the Using 
intensity attribute drop-down list could be used to set a magnitude value to each location.  Or, if the From 
incidents in drop-down list contains car crash location, then the Using intensity attribute drop-down list could 
be used to set the number of injuries that occurs at each location to each location.  
 
Note: Negative values are excluded from the calculation (i.e. given a weight of 0) as these values can de-
normalize the resulting surface making a probability surface impossible. 

❖ The Using weight attribute drop-down list populates when the user selects an Incident query (the default 
setting for this option is <None>). This drop-down list only contains attributes names that have a data type of 
numeric. This drop-down list allows the user to select an attribute that contains the Weight value for the 
Incident query. This value works in unison with the Using intensity attribute value.  

❖ For example, if the From incidents in drop-down list contains crime locations and the Using intensity 
attribute drop-down list contains the number of crimes at a location, a Weight attribute could be used to 
assign a higher weight to the crimes that take place in a specific part of town (i.e. downtown incidents could 
be assigned a weight of two thereby doubling its intensity at these locations).  
 
Note: Negative values are excluded from the calculation (i.e. given a weight of 0) as these values can de-
normalize the resulting surface making a probability surface impossible. 

❖ Weight type can be used to assign different weighting values to each incident type. For example, the user 
may want to weight incidents that occur within the downtown higher than those that occur in the suburbs. If 
this is the case, an attribute can be assigned to each incident location to represent intensity or weighting 
value. 

❖ Use target area of interest area can be used to restrict the hotspot analysis to a specific geographic area or 
areas. To specify a target area the user needs to select a feature area-based feature class that bounds the 
target area.  
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❖ For example, the user may want to limit the hotspot analysis command to the downtown core only, if this is 
the case, they would need to have an area-based feature class that represents this area. 

❖ The user can choose to output any one, two, or three of these options. Note: each has it advantage from a 
map esthetics perspective. 

❖ The Multiple of mean drop-down lists are used to define the threshold variable for each of the output types. 
The default value for this is x3 (or 3 means). This value is the accepted standard value for determining 
significant values within a surface. With this option selected the command will return all areas that equal 3 
means and greater.  

6. Check the Hotpot option. 

7. Set the Multiple of mean for Hotspot to 5 (or 5 means). 

 

❖ The Normalization drop-down list allows the user to specify the preferred normalization. This drop-down list 
contains two options specifically Probability and Density. The default is Density. 

8. Set the Normalization drop-down to Density.  

❖ When the Density option is selected the results returned by the command will represent the number of 
Incidents per the unit of measure specified in the Output density unit drop-down list. 

❖ When the Probability option is selected the results returned by the command represent the probability of 
Incidents per the area. 

❖ The Area units drop-down list contains the output options for the command. This drop-down list contains 
Hectares, cm^2, m^2, km^2, in^2, ft^2, mi^2, and Acres. 

9. Set the Area units drop-down to Cell. 

 

10. Set the Kernel drop-off shape to Quartic.  

 

❖ The Kernel drop-off shape drop-down list allows the user to specify the preferred drop-off shape. The goal 
of this drop down list is to allow the user to select a preferred drop-off shape for the kernel. This drop-down 
list contains four options; Quartic (Gaussian), Uniform (flat), Triangular (conic), and Exponential 
(Gaussian). The default is Quartic. 

❖ The Adaptive bandwidth tab allows the user to modify the input parameters that influence the size and 
therefore the shape of the kernel.  

❖ The Using approximate number of nearest neighbors text box allows the user to specify the number of 
nearest neighbors or k. The default value for this option is 10.  

❖ Note: Bandwidth selection is a critical variable in the interpolation process. Many kernel density interpolation 
approaches described in the literature calculate bandwidth using only the geographic extent of the points and 
thereby do not reflect the geographic distribution of the point within the area of interest. This approach to 
kernel density estimation can result in misleading density values and maps that are either too smooth or too 
spiky. GeoMedia Grid can employ an Adaptive bandwidth approach to overcome these limitations. The 
Adaptive bandwidth approach analyzes each point within the input layer to determine an appropriate 
bandwidth value for each point in the map layer (i.e. the bandwidth adapts to match the local conditions).  
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❖ For example: if k = 10, the algorithm analyzes each point to determine its bandwidth based upon its ten 
nearest neighbors (i.e. for every point location in the layer the algorithm searches for the ten closest points, 
then determines the local bandwidth, then applies a kernel estimation using the calculated bandwidth value). 
With this approach, the “local” spatial relationships within the points are taken into account, thereby, 
effectively reflecting the degree of local clustering within the data. 

❖ The Fixed bandwidth tab allows the user to modify the input parameters that influence the size and 
therefore the shape of the kernel.  

❖ The k-nearest neighbors text box allows the user to specify the number of nearest neighbors or k. The 
default value for this option is 8.  

❖ The Calculated bandwidth radio button uses the bandwidth that is automatically for the user. This button 
makes use of the value in the k= text box to determine a bandwidth that reflects the overall degree of 
clustering present in the map layer selected by the user. 

❖ Note: As noted earlier, bandwidth selection is a critical variable in the interpolation process. Guessing a 
bandwidth can result in misleading density values and maps that are either too smooth or too spiky. The 
Calculate button reduces the potential for this, as it uses all of the points in the input layer to determine the 
overall degree of clustering for the input map layer. For example: if k = 10 the hotspot command analyzes 
each point in the input layer to determine the average distance to each of its ten nearest neighbors, then 
once an average has been calculated for each point in the input layer, an overall average is calculated for 
the entire layer and this values is then used to populate the Size text box. With this approach, the user does 
not have to guess at a bandwidth value. 

❖ The Size text box allows the user to override the calculated bandwidth value. 

❖ If the user changes any one of the three inputs the bandwidth is automatically recomputed.  

❖ If the user wants to override this value, they can do so by modifying the value in the field. 

11. Click on the Adaptive bandwidth tab to enable it. 

12. For Approximate number of k-nearest neighbors, type in 10. 

 

13. For the Query name, type in Advanced Hotspot of EX5_PinMap. 

14. Leave the Description field blank. This facility allows users to attach ancillary data to a query. This 
information is used to describe the query so that when a query is viewed in the future, the ancillary 
information can be used to determine its history. 
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15. Make sure that the Display query in a map window check box is checked. 

 

16. Make sure that the Display query in a data window is unchecked. 

 

17. Your dialog box should look similar to the sample below. Once it does, use your mouse and click the 
OK button. 

 

❖ After the command completes, the result will be placed in the map window and a new legend entry called 
Advanced Hotspots of EX5_PinMap (Hotspots) will be visible. 

❖ The number of legend entries is dictated by the command (i.e. one legend entry is generated for each output 
check mark). For example, if the user elects to check Generate hotspots, Generate thematic, and Generate 
isolines then three new legend entries will be generated by the command. Note: the name of the legend 
entry is based upon the text in the Query name field. For example, it the user checks all three output 
options, and the name specified in the Query name is James Dean then the command will output the 
following three legend entries: 

❖ James Dean (Isolines) 

❖ James Dean (Thematic Hotspots) 

❖ James Dean (Hotspots) 

18. Right-click on the Advanced Hotspot of EX5_PinMap legend entry and select Style Scaling > View. 
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19. Click the  Zoom In icon and zoom in on some hotspot areas. 

 

❖ Notice how the hotspots closely hug the points. 

20. Delete the legend entries entitled Advanced Hotspot of EX5_PinMap, Repeat Count of 
EX5_PinMap, and Simple Hotspots as they are no longer needed. 

21. Click the  Fit All icon. 

22. Select File > Save GeoWorkspace command to save the changes to the GeoWorkspace to disk. 
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Exercise 6: Journey to Incident Mapping 

Overview 

This command enables users to display the location of an incident in comparison to the perpetrator of the 
incident, or an incident’s location in comparison to where the incident elements (cars, bikes, TVs, etc.) 
were recovered. The output is symbolized according to the location and offender or location and recovery. 
Incident Analyst displays a straight line symbolized with direction between the location and offender or 
location and recovery. 

Many studies have shown that the journey to crime is consistently very short - offenders generally commit 
offences within 1 or 2 miles of their residence. For example, Andy Brumwell, a crime analyst with the West 
Midlands Police completed an analysis of 258,074 crime trips made over a 2-year period. He found the 
following: 

❖ About half the journeys were less than a mile. (In most U.S. studies the journeys might be a little 
longer because of lower population densities and greater access to vehicles).  

❖ Distance traveled varied with the offense. For example, shoplifters tended to travel further than 
many other kinds of offenders.  

❖ Females traveled further than males, possibly because many committed shopliftings.  

❖ Individual offenders varied considerably in crime trips. Some usually committed crimes in their local 
neighborhoods. Others traveled further, particularly when working with co-offenders.  

❖ The youngest offenders committed crime very close to home, while those in their 20s traveled the 
furthest.  

 

Features and Benefits 

❖ Travel to incident (e.g. measuring serial offenders average and maximum distances traveled to 
commit a crime) 

❖ Travel from incident (e.g. linking stolen and recovered property or vehicles to identify routes taken 
after a crime) 

❖ Quickly identify the spatial relationship between incident locations 

 

Skills Covered in this Exercise 

In this exercise you will learn how to: 

❖ Display a Feature Class using the Add Legend Entries command. 

❖ Create a Journey to Incident map using the Journey to Incidents command. 

❖ Create Havens based upon Distance to Incidents. 

❖ Remove legend entries from a map window. 

❖ Save changes to a GeoWorkspace. 



 

   
Copyright 2016 Hexagon Geospatial  73 

Adding a Feature to the Map Window  

The Add Legend Entries is used to add one or more sets of features (queries/feature classes) to a 
legend and display it in the map window.  

1. On the Home tab, select the Legends > Add Legend Entries command to display the Add Legend 
Entries dialog box. 

2. Click the  plus symbol to the left of the label entitled Dauphin Training Data. 

3. Once the tree view expands to show all of the features in the Dauphin Training Data connection, 

click on the  check boxes beside EX6_Offender Locations and EX6_Offense Locations. 

 

4. With these two feature classes checked, click the OK button to places the selected features in the 
map window.  

❖ Note: This data was pulled from an RMS database. RMS databases typically contain offenders locations and 
links to offense records (i.e. you can use an RMS database to find out which offenders committed which 
crimes).  

❖ To create this map the Incident Query command was used to pull two offenders from the database who 
have been convicted of a particular crime and then the command plotted their location on the map (this 
location typically represents home location). 

❖ The Incident Query command was then used to pull incidents of similar crime type from the RMS database. 
These are plotted based upon the location of the offense.  

5. Right-click on the EX6_Offender Locations legend entry and select Style Scaling > View. 
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6. Right-click on the EX6_Offense Locations legend entry and select Style Scaling > View. 

 

7. Click the  Zoom In icon and zoom in on areas containing these points.  

8. You can use the legend tools to change the point symbols. In the example provided below the 
Offender locations were assigned a pin symbol while the Offense locations were assigned a black 
square. 
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Creating a Journey to Incident Map 

The Journey to Incident command takes two inputs (a point feature class representing start locations and 
a point feature class representing end locations) and generates one output (a linear feature class that 
displays the connectivity between start and end points). 

  

Input 1: Point Features Class (Start) 
  

Output 1: Linear Feature Class 

  

Input 2: Point Features Class (End) 

 

1. On the Incident Analyst tab, select Journey to Incidents to display the Journey to Incidents dialog 
box.  

 

2. For From locations in, select the feature class EX6_OffenderLocations. Note: This feature class is 
stored in the connection called Dauphin Training Data. 

 

3. For Using join attribute, select LWMAINID, from the drop-down list.  

 



 

   
Copyright 2016 Hexagon Geospatial  76 

4. For At locations in, select the feature class EX6_OffenseLocations. Note: This feature class is 
stored in the connection called Dauphin Training Data. 

 

5. For Using join attribute, select LWMAINID, from the drop-down list. 

 

6. For the Display query in map window style, click the Style button to display the Select Style dialog box. 

 

❖ Use the Select Style dialog box to browse the named styles in the GeoWorkspace and to select one.  The 
dialog box provides a list of existing styles and a preview of the selected styles, and it permits you to adjust 
the definition of the selected style before using it.  You can also make a new named style from the selected 
style you have adjusted. 

7. Click on the line style entitled JourneyToIncident.  

8. Once your Select Style dialog box looks similar to the example below, click the OK button to set the 
line style. 

❖ Note: You can use or define any line style you wish, however the JourneyToIncident line style is packaged 
with Incident Analyst and yields nice cartographic results. 
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9. Make sure Display query in map window is checked. 

 

10. For Query name, type in Journey to Incident. 

 

11. Make sure the Display query in a data window is unchecked.  

 

12. Your Journey to Incidents dialog box should look similar to the example provided below, once it does 
click the OK button to execute the command. 

 

13. Once the command completes the map window will update to reflect the result. Notice that there is an 
additional item in the legend; namely a legend entry called Journey to Incident.  

14. Right-click on the Journey to Incident legend entry and select Style Scaling > View. 
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15. Use the  Zoom In icon to zoom in on an area within the map where the points are most prevalent. 

 

❖ The new legend entry depicts Offender Locations to some of the Offense Locations. 

❖ This new legend entry can be used to determine the distance that was traveled. 

16. Press the Esc key or invoke the Select Tool command. 
Double-click on one of the Journey to Incident lines in 
the map window to display the Properties dialog box for 
this feature. 

❖ This linear feature contains useful distance information, 
namely it links the offender information to the offense 
information and presents it in an easy to read format and it 
also contains Straight Line Distance and a Right Angle 
Distance. 

❖ StraightLineDistance is an as the crow flies distance (i.e. 
straight line distance between two points). 

❖ RightAngleDistance draws a horizontal line from the source 
point until it intersects with a vertical line from the destination 
point. These two new lines are measured and a total 
distance is returned. This distance method calculation 
attempts to reflect the grid pattern of a city and thereby 
better reflect the actual distance traveled. 

❖ Note: The distance information is always expressed in the 
units of the GeoWorkspace. 
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Creating Havens Based on Distance to Incident (Optional) 

Havens delineate how far someone is prepared to travel to commit a specific incident. In this particular 
case we have two individuals who have committed several crimes. We know what distances they have 
traveled to commit these crimes therefore we can determine a haven. The following workflow makes use 
of some of the analytical tools found in GeoMedia. 

GeoMedia includes a rich set of spatial analytical tools. In this section of the tutorial we are going to make 
use of the Analytical Merge, Functional Attributes, and Buffer Zone commands to create a new legend 
entry. This new legend entry will create a haven feature for each of the two offenders. This haven feature 
will reflect the average distance each individual traveled to commit their crimes. 

Using the Analytical Merge Command to Create Functional Attributes 

1. Delete the legend entry entitled EX6_OffenderLocations as it is no longer needed. 

2. On the Analysis tab, select Analytical Merge command to display the Analytical Merge dialog box. 

❖ Analytical Merge is used to merge features from a feature class or query, as well as to aggregate attributes 
for those features into a single output feature. 

 

3. For Merge features in, select Journey to Incident from the drop-down list. Note: This feature is 
stored in the Queries tree-view. 

 

4. Ensure that the By attribute radio button is selected for the Merge criteria.   

 

5. For Attributes, select OffenderId (i.e. make sure the OffenderId attribute is checked). 
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6. In the Output functional attributes list box, select LineGeometry. 

 

7. Click the Properties button to display Functional Attribute dialog box.  

❖ The Functional Attribute dialog box (in some cases called the Expression dialog box), which is accessed 
from the Functional Attribute dialog box, allows you to create and edit the name and expression for a 
functional attribute. This dialog box functions as a calculator that you can use to provide calculated 
information for queries. This calculator provides a simple Excel-like interface with standard operators plus 
syntax information. This dialog box is also accessed from the Aggregation, Update Attributes, and Analytical 
Merge commands. 

8. This dialog box has many interactive methods for building expression statements. However, for this 
tutorial we will simply use our keyboard to type in the text into the Expression text field: 
MERGE(STARTPOINT(Input.LineGeometry)). 

  

9. If the above expression is typed in correctly the Output type read only field should toggle from Line 
Geometry to Point Geometry. 

 

10. For the Functional attribute name, type in MergedStartPoints. This will be the name of the new 
functional attribute you are about to create. 

 

11. Once your Functional Attribute dialog box reflects the example provided below, click the OK button 
to confirm the settings for this functional attribute. Note: In this case you are aggregating all of the start 
points in the Journey to Incident feature class by OffenderId.  
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12. Upon clicking the OK button you will be returned to the Analytical Merge dialog box. 

 

❖ We need one more functional attribute before we can proceed to the Buffer Zone command. In this case, we 
want to use a new functional attribute to reflect the average straight line distance for each offender. With this 
information the buffer command can create a feature that reflects this value and in turn display it in the map 
window.  

13. Click the New… button to display the Functional Attribute dialog box.  

14. Again, this dialog box has many interactive methods for building statements. However, for this tutorial 
simply use your keyboard to type in the text into the Expression text field: 
AVG(Input.StraightLineDistance). 

  

❖ In this particular case, the functional attribute is going to calculate the average distance based upon the 

straight line distance that was created during the execution of the Journey to Incident command.  

❖ As noted earlier in this tutorial, the Journey to Incident command generates two attributes, namely 
StraightLineDistance and RightAngleDistance.  

❖ Given this, we could easily calculate the average distance for the RightAngleDistance simply by modifying 
the expression to read AVG(Input.RightAngleDistance). 

❖ Furthermore, you could also change the function to calculate other distances; such as the maximum distance 
or the minimum distance. To do this the expression would need to be changed to 
MAX(Input.RightAngleDistance) or MIN(Input.RightAngleDistance) respectively. 

15. For the Functional attribute name, type in AverageDistanceToIncident. This will be the name of the 
new functional attribute you are about to create. 
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16. Once your Functional Attribute dialog box reflects the example provided below, click the Add button 
to confirm the settings for this functional attribute. 

 

17. Upon clicking the Add button the Functional attribute dialog box will update so that new functional 
attributes can be created. In this case, there are no more functional attributes required, therefore click 
the Close button to close the Functional Attribute dialog box and return to the Analytical Merge 
dialog box. 

 

18. Once your Analytical Merge dialog box reflects the example provided above, click the OK button to 
create the new legend entry. 
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19. After the command completes, a new legend entry called Merge of Journey to Incident will be visible 
in the map window. 

20. Right-click on the Merge of Journey to Incident legend entry and select Style Scaling > View. 

 

21. Double-click on one of the new points (this will display the Properties dialog box for the selected 
point). 

 

❖ Notice the two attributes. These attributes are based upon the Analytical Merge command. The key 

attribute is AverageDistanceToIncident as it contains the average distance to all of the incidents for a 
specific offender. This attribute will be used to create a buffer and thereby delineate the haven for each 
offender. 
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Using the Buffer Command to Create Havens  

1. On the Analysis tab, select the Buffer Zone command to display the Buffer Zone dialog box.  

 

❖ Buffer Zone allows users to select the feature class or the query to be used to create the buffer 
zones. 

2. For Buffer zone around, select Merge of Journey to Incidents from the drop-down list. Note: This 
feature is stored in the Queries tree-view. 

 

3. Ensure that the Variable radio button is selected and that the Distance drop-down list is set to 
AverageDistanceToIncident and ft respectively. 

 

4. For Query name, type in Havens. 

 

5. Make sure Display buffer zones in map window is checked. 

 

6. Make sure the Display buffer zones a data window is unchecked.  
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7. Your Buffer Zone dialog box should look similar to the example provided below. Once it does, click 
the OK button to execute the command 

 

8. After the command completes, a new legend entry called Havens will be visible in the map window. 

9. Right-click on the Havens legend entry and select Style Scaling > View. 

 

10. You can use the legend tools to change the Style Properties of this new legend entry. In the example 
illustrated below the Havens legend entry was assigned a black line color for the Boundary Style and a 
dark green fill color for the Fill Style with a translucency setting defined as 80%. 
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❖ As can be seen by this map there are unsolved offenses that clearly fall within a specific haven 
while others fall in both. For those falling within a specific haven a hypothesis about who committed 
the crime can be made and action to determine this can follow this analysis. 

11. Delete the legend entries entitled Havens, Merge of Journey to Incident, Journey to Incident and 
EX6_OffenseLocations as they are no longer needed. 

12. Click the  Fit All icon. 

13. Select the File > Save GeoWorkspace command to save the changes to the GeoWorkspace to disk. 
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Exercise 7: Temporal Reporting 

Overview 

The Temporal Reporting command provides a simple interface for creating histograms and line diagrams 
using data from the Incident Query command.   

 

Features and Benefits 

❖ Allows users to interactively view multiple temporal reports at the simple click of a button  

❖ Visualize change over time 

❖ Assess the impact of reduction initiatives to determine their effectiveness  

❖ Identify emerging areas of concern 

 

Skills Covered in this Exercise 

In this exercise you will learn how to: 

❖ Display a Feature Class using the Add Legend Entries command. 

❖ Create a Simple Reports using the Temporal Reporting command. 

❖ Classify and color a Boundary map. 

❖ Modify the Statistical method associated with an Incident Count command.  

❖ Save changes to a GeoWorkspace. 

 

Adding a Feature to the Map Window  

The Add Legend Entries command is used to add one or more sets of features (queries/feature classes) 
to a legend and display it in the map window.  

1. On the Home tab, select Legends > Add Legend Entries to display the Add Legend Entries dialog 
box. 

2. Click the  plus symbol to the left of the label entitled Dauphin Training Data. 
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3. Once the tree view expands to show all of the features in the Dauphin Training Data connection, 

click on the  check boxes beside EX7_PinMap. 

 

4. With this feature classes checked, click the OK button to places the selected feature in the map 
window.  

❖ Note: This data was pulled from a CAD database. It represents a full year of data and contains approximately 
32,000 records. 

5. Right-click on the EX7_PinMap legend entry and select Style Scaling > View. 

 

6. Delete the legend entries entitled Ex7_PinMap as it is no longer needed.  
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Creating a Temporal Report 

1. On the Incident Analyst tab, select the Temporal Reporting command to display the Temporal 
Reporting dialog box.  

 

2. For Report of features in, select the feature class EX7_PinMap from the drop-down list. Note: This 
feature class is stored in the connection called Dauphin Training Data. 

3. There are several classification methods for displaying the data (Time of Day, Day of Week, and 
Month of Year)  

a. The Time of Day method groups the data into hourly groups. This view allows the user to 
determine at what time of day the incident in the query occurred. 

b. The Day of week method groups the data into 24 hour periods (i.e. days). This view allows the 
user to determine at what day of the week the incident in the query are occurred.  

c. The Week of Month method groups the data into monthly groups. This view allows the user to 
determine at what month of the year the incident in the query are occurred. 

4. For Group by, select Day of Week from the drop-down list. 

 

5. Notice the distribution. In this particular case, the data is evenly distributes across the week.   
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6. For Group by, select Time of Day from the drop-down list. 

 

❖ Notice the distribution. In this particular case, the data does show a trend (i.e. the majority of calls 
came in between 5 PM and 9 PM and the least amount of calls came in between 3 AM and 6 AM). 

❖ There are a number of options in this command however given the time constraints of this course 
only a few of the features will be outlined. 

7. For the Chart configuration, click the Options tab.  

 

8. Ensure that the Display Legend check box is checked. As soon as this option is selected, a legend 
will appear to the right of the bar chart. 
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9. For Contents, select Right percent from the drop-down list. For Alignment, select Bottom from the 
drop-down list. 

 

 

❖ With this information we can see that the greatest percentage of calls (6.14 Percent) came in around 7 PM. 

❖ It should be noted that a picture of this chart and or the data that comprises it can easily be transferred to 
other products (such as Microsoft Excel) using the Chart to clipboard, Data to clipboard, Chart to file, or Data 
to file. Where:  

❖ Chart to clipboard – Copies the current chart image to the clipboard. 

❖ Data to clipboard – Copies the data inside the chart, and outputs that data to the clipboard in 3 columns.  
The first column includes the title of the chart and the labels for the X-axis.  The second column is a unique 
identifier for each element in the series.  The third column contains the data of each element in the series.  
This data can be pasted into various applications such as Microsoft Excel or Microsoft Word. 

❖ Chart to file – Outputs a 24-bit Bitmap (BMP) image of the chart.  You can specify the location and file name 
for the .bmp file.  The default location is the GeoWorkspaces folder. 

❖ Data to file – Outputs an XML file that contains the data inside the chart.  You can specify the location and 
file name for the .xml file.  The default location is the GeoWorkspaces folder.  The file contains the series 
title, type, color, count, text (Day of Week, Month of Year, or Time of Day), a unique increment, and a bar 
value. 

10. Click Close to dismiss the Temporal Reporting dialog box. 

11. Select File > Save GeoWorkspace command to save the changes to the GeoWorkspace to disk. 

12. Exit GeoMedia.  

 


