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ISDG TO ISAE WORKFLOW 

TUTORIAL INTRODUCTION 

ImageStation DTM for GeoMedia (ISDG) is a set of tools working in the GeoMedia 

environment and with ImageStation Stereo for GeoMedia (ISSG) to collect and edit 

terrain data to generate surface files for photogrammetric mapping and engineering 

workflows. Having an accurate and up-to-date elevation data layer is critical for many 

applications including orthophoto creation, topographic mapping, engineering design 

and analysis, transportation planning, flood hazard mapping, terrain analysis for vehicle 

mobility, viewshed analysis, flight planning and simulation, precision farming, soil 

analysis, change detection, and many others. Together with GeoMedia and ISSG, ISDG 

provides an alternative to CAD-based workflows for feature and DTM collection and 

editing that works in a GIS environment. Working in a GIS environment provides 

additional tools and capabilities such as spatial filtering, custom queries, spatial analysis, 

data validation, and more. 

TOPICS 

This tutorial presents a workflow depicting the extraction of geomorphic data from a GIS 

using ISDG, feeding the data into the ImageStation Automatic Elevations (ISAE) DTM 

image correlation process, and then ingesting the DTM point data back into the GIS 

environment again using ISDG. 

Topics covered in this tutorial include: 

 Opening a GeoMedia workspace 

 Creating an ISDG DTM project 

 Generating a DTM surface containing geomorphs from the GIS data 

 Running ISAE using the DTM surface as input for defining the geomorphs 

 Loading the resulting surfaces from ISAE into ISDG 

 Point editing and surface updating 

 Viewing triangles and contours 
 

TUTORIAL TEXT CONVENTIONS 

There are several conventions used throughout the tutorial: 
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 Ribbon bar items are shown as: On the Aaa tab, in the Bbb panel, click Ccc > 

Ddd. 

 Dialog box names, field names, and button names are depicted using bolded 

text. 

 Information to be entered, either by selecting from a list or by typing, is 

depicted using italicized text. 
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TUTORIAL DATA SET 

The tutorial data set consists of a small ImageStation aerial photogrammetric project, 

and a GeoMedia GeoWorkspace with an attached warehouse containing stereo 

compiled features. Create a folder named C:\Training\ImageStation and unzip the data 

set to this folder. (The resulting full path to the data set should be 

C:\Training\ImageStation\ISDG-ISAE Workflow.) 

 

TUTORIAL PREREQUISITES 

You should have the following products installed: 

 GeoMedia Advantage or Professional 

 ImageStation Automatic Elevations 

 ImageStation DTM for GeoMedia 

This tutorial assumes you have an existing SQL Server database created and 

configured for use with GeoMedia. If you do not have this, see Appendix A for 

instructions on how to do this. 

  



 ImageStation DTM for GeoMedia Workflow 

 

9 

 

 

EXTRACTING GEOMORPHS FROM A GIS 

CONNECTING TO WAREHOUSES 

1. In Windows Explorer, double-click on C:\Training\ImageStation\ ISDG-ISAE 

Workflow\Wichita.gws to open the GeoWorkspace in GeoMedia. 

The GeoWorkspace opens and displays the data set that is contained in an Access 

warehouse to the map window. For ImageStation customers, this data would typically 

come from a GeoWorkspace/warehouse created with ISSG. 

2. In the Manage Data tab, in the Warehouses panel, click Warehouse > New 

Warehouse Connection. 

3. On the New Warehouse Connection dialog box that appears, select SQL Server 

Read-Write from the Connection type list. 

4. In the Server field, key in the machine name\instance name, for example, 

IS2005\SQLEXPRESS. 

5. Click the Database: down arrow and select the SQL Server database that was 

created for ISDG.  
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6. Click OK to create the connection to where the ISDG project data will be stored. 

 
 

CREATING THE ISDG DTM PROJECT 

1. On the ISDG tab, in the Project panel, click New DTM Project. 

2. On the New DTM Project dialog box that appears, use the Connection drop 

down list to select SQL Server Read-Write Connection 1. 

3. Key in a Name for the DTM project (such as "Training"). 

4. Leave the Coordinate system set to Use current GeoMedia GeoWorkspace 

coordinate system. 
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5. Click Ok to create the project and dismiss the dialog box. 

 
 

DEFINING THE ISDG DTM CATEGORY FEATURES 

1. On the Manage Data tab, in the Feature Data panel, click Categories. 

2. On the Categories dialog box that appears, expand Categories and expand 

ISDG DTM Input Features. 

3. Click on Breakline Features, then click Add Features... 
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4. Expand Access Connection 1 then select all features except Level_10 and 

Surface_Area, and then click OK. 

 

5. Click on Obscure Area Features, then click Add Features... 
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6. Select feature Level_10 and then click OK. 

 

7. Click Close to dismiss the Categories dialog box. 
 

CREATING A SURFACE FROM THE GIS 

1. On the Vector tab, in the Feature panel, click Insert Feature > Insert Feature. 

2. In the lower left corner of the GeoMedia main window frame, click the down arrow 

on the Insert Feature dockable control, expand Access Connection 1, and select 

the Surface_Area feature. 

3. Just to the right, change the placement mode from Point by point to Place by 

rectangle. 
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4. Left-click with your cursor at one corner of the project area, move the cursor to 

the opposite corner and left-click again to place a Surface_Area feature around 

the entire project area. Note that any GeoMedia polygon feature can be used to 

define an area for creating surfaces from the GIS. 
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5. After placing the Surface_Area feature a Properties dialog will appear. Enter a 

name for the Surface_ID such as ISAE_Input_Surface then click OK. 

 

6. On the ISDG tab, in the Surface panel, click Generate Surfaces from GIS. 

7. On the Generate Surfaces from GIS dialog box that appears, select the Input 

feature by expanding Access Connection 1 and then clicking on the 

Surface_Area feature. 
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8. Set the Surface names to Use feature attribute > Surface_ID. 

 

9. Click Ok to create the surface in the ISDG project and dismiss the dialog box. 

10. On the ISDG tab, in the Project panel, click DTM Project Status to open the 

DTM Project Status dialog box. Note that at this point the surface is only a 

placeholder held in the ISDG DTM Project and has not yet been written to disk 

(there is no path to the Filename). Move the dialog to the right side of the screen 

and keep it open. 

11. On the ISDG tab, in the Manage panel, click Update Surfaces. 

12. On the Update Surfaces dialog that appears, click on ISAE_Input_Surface to 

select it.  



 ImageStation DTM for GeoMedia Workflow 

 

17 

 

13. Use the Output folder file browser to select the tutorial project folder: 

C:\Training\ImageStation\ISDG-ISAE Workflow. This is where the surface file will 

be written to on disk. Click Select Folder to save the location and dismiss the 

dialog box. 

14. Uncheck the Triangulate surfaces option. We simply want to use this file to feed 

geomorphs into the ISAE matching process later, so having triangles in the file is 

not necessary. 

 

15. Click Ok. ISDG will scan for features within the Surface_Area feature to locate 

Breakline and Obscure Area features as defined earlier, and then write them out 

to the ISAE_Input_Surface file. Notice that the DTM Project Status dialog box 

has been updated to reflect the surface file now has a location on disk. At this 

point you can open the tutorial folder with Windows Explorer to verify the surface 

file exists. 

Prior to continuing to the next section, select File > Save to save the GeoWorkspace 

and collapse GeoMedia’s main window to get it out of the way for now. 
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AUTOMATED DTM EXTRACTION 

DEFINING THE INPUT 

1. Start ImageStation Automatic Elevations from the Windows Start menu. 

2. Use the Project: browser to locate the ImageStation project file of the tutorial 

data set: C:\Training\ImageStation\ISDG-ISAE Workflow\project. 

3. Check the Autogenerate Collection Boundaries option. 

4. Click the Add All --> button to add all models to the Selected Models list. 

5. Highlight all models, right-click on them, and select Properties to open the 

Selected Model Properties dialog box. 
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6. Use the Morphs file: browser button to locate the ISAE_Input_Surface.dtm file 

that was created in the previous step: C:\Training\ImageStation\ISDG-ISAE 

Workflow\ISAE_Input_Surface.dtm then click Open to dismiss the dialog box. 

7. Use the CSF file: browser to locate the project.csf file from the CSF subfolder of 

the tutorial data set: C:\Training\ImageStation\ISDG-ISAE Workflow\csf\project.csf 

then click Open to dismiss the dialog box. 

8. Leave Output DGN file set to None. 

 

9. Click OK to save the settings and return to the Project and Models tab. 
 

DEFINING ELEVATION COLLECTION PARAMETERS 

1. Click the Elevation Collection Parameters tab. 

2. In the Terrain Type and Matching group box, change the Terrain Type: to Flat. 

3. In the Geomorphic Information group box: 

 Check Use Breaklines: 

 Check Use Obscured Areas: 
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 Set Suppression Distance to 10 

 Set Expansion Distance to 20 

 
 



 ImageStation DTM for GeoMedia Workflow 

 

21 

 

DEFINING OUTPUT PARAMETERS 

1. Click the Output Parameters tab. 

2. Uncheck the Output Surface Data to Output Dgn Files and Output 

Geomorphic Data to Output Dgn Files options. NOTE: These two fields are 

disabled if MicroStation is not installed on the system. 

3. In the Output Surfaces group box, check the Create DTM Files in Dir: option. 

4. Then check the Breaklines, Obscured Areas, and Collection Boundary 

options from the Include from Input Morphs: options. 
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DEFINING AND SUBMITTING THE JOBS 

1. Click the Job Processing tab. 

2. Optional: Click the Show Interactive Status option to cause a separate 

Elevation Collection Status dialog box to appear for every mode that gets 

processed. 

 

3. Click the <<Add Jobs button. 
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4. Click OK to submit the jobs for processing and dismiss the ISAE main dialog box. 

At this point ISAE will dismiss the main dialog box and begin point matching on the 

models. Progress will be logged to a local command window. After each model is 

processed ISAE will create triangulated surface files in the project's isdc\dtm 

subfolder structure. This whole process should take about 5 minutes. 
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REVIEWING THE RESULTS 

ADDING SURFACES TO ISDG 

1. Restore the GeoMedia main window. 

2. On the ISDG tab, in the Surface panel, click Remove Surfaces. 

3. Click on the Input_ISAE_Surface then click Ok to remove the surface from the 

project and dismiss the dialog box. This surface was created for input to ISAE 

and is no longer needed. 

 

4. On the ISDG tab, in the Surface panel, click Add Surfaces. 

5. On the Add Surfaces dialog box that appears, click Add Folder... and browse to 

the tutorial data set folder: C:\Training\ImageStation\ISDG-ISAE Workflow. Drill 

down to the isdc\dtm subfolder and click Select Folder. Note that this is a folder 

browser so you will not see the contents of the folder until you click Select Folder 

and return to the Add Surfaces dialog box. 

6. Check the option to Load exterior boundaries. 
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7. Click Ok to have the surfaces added to the ISDG DTM Project. The model 

footprints will appear in the map window as ISDG exterior boundaries features. 
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VIEWING CONTOURS 

1. On the ISDG tab, in the Display panel, click View Contours. 

2. On the View Contours dialog box that appears, select the 4th surface in the list: 

1212038_1212039. 

 

3. Define the Contours and Labels options as shown above then click Ok to add 

the ISDG contours and ISDG contour labels features to the map window and 

dismiss the dialog box. 

4. Use the GeoMedia commands to zoom about and analyze the results. Notice that 

there are contours on the canal where the image correlation got lost in the water.  
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LOADING AND EDITING DTM DATA 

1. On the ISDG tab, in the Manage panel, click Load DTM Data. 

2. On the Load DTM Data dialog box that appears, select the 4th surface in the list: 

1212038_1212039. 

3. Under Features to load, check the Points option and uncheck the Breaklines and 

Obscure Areas options. 

 

4. Click Ok to dismiss the dialog box and have the points from the surface file added 

to the map window. 

5. In the legend, set Locatable On for feature ISDG points, and set Locatable Off 

for all the other features. You can tell if a feature is locatable or not based on 

whether the arrow symbol is shown next to the feature. 
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6. Use the GeoMedia Select by Polygonal Fence tool to digitize a polygon around 

all the points in the canal area. It is OK if you go outside the canal area a bit. Use 

double-click to finish placing the fence. 

 

7. On the Vector tab, in the Feature panel, click Delete and then confirm the 

deletion of the points. 
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NOTE: Normally this workflow would be completed in a stereo environment using 

ISSG which has new Custom Edit commands specifically designed for this type 

of DTM point editing operation. 

8. On the ISDG tab, in the Manage panel, click Update Surfaces. 

9. On the Update Surfaces dialog box that appears:  

a. Select the 4th surface in the list: 1212038_1212039. 

b. Use the Output folder browser to locate folder 

C:\Training\ImageStation\ISDG-ISAE Workflow\isdc\dtm and click Select 

Folder. 

c. Check the Triangulate surfaces option. 

d. Set Max triangle length and Max segment length to 0. 

e. Uncheck the Ignore obscure areas option. 
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f. Click Ok to dismiss the dialog box and regenerate the surface. Click 

Continue when prompted to overwrite the existing file. 

10. Run View Contours again for surface Name 1212038_1212039. ISDG will 

automatically remove the old contours and replace them with new ones that 

reflect the changes made to the surface. Notice that the contours are now gone 

from the canal area. 

 A different way to have run this workflow would have been when defining the ISDG 

DTM Input Features categories earlier, not only add Level_23 to the Breakline Features 

category, but also add it to the Obscure Area Features category. That way ISAE would 

not have placed any points within the water area. 

 Contour features are written to the GeoWorkspace using a custom data pipe for 

efficiency purposes. It is intended that the features be used for help with analyzing the 

surfaces and are not intended to be permanent or edited in any way. However, when 

contours are generated with ISDG, a GeoMedia "query" is automatically created that 

references these features. If you would like to write the contours and/or contour labels to 

your warehouse as permanent features for editing or printing purposes, you can click the 

Manage Data tab, in the Outputs and Exports panel, then click the Output to Feature 

Classes command. Simply expand the Queries list, check the ISDG_MajorContours, 

ISDG_MinorContours, and ISDG_ContourLabels entries, select a Target connection, 

and then click OK. You can also change the names of the output features by clicking on 

the Advanced tab and editing the Target Feature Class name(s) before clicking OK. 

 When creating surface files for orthorectification, we want to Triangulate surfaces 

so the orthorectification process can directly probe the surface for elevations, and not 

have to triangulate on-the-fly; and we also want to Ignore obscure areas, since we 

want the surface to represent a ‘bare earth’ terrain model for orthorectification. 

 

ONE MORE ANALYSIS… 

1. On the ISDG tab, in the Display panel, click View Clear. 

2. On the View Clear dialog box that appears, select the surface then click Ok to 

clear the contours from the map window. 

3. On the ISDG tab, in the Display panel, click View Triangles. 

4. On the View Triangles dialog box that appears, select one or more surface files 

then click Ok to display the triangles in the map window and dismiss the dialog 

box. (Selecting all surfaces takes about 30 seconds to display.) 
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 Click one surface then press Ctrl-A on your keyboard to select all surfaces. 

 

5. Use the GeoMedia commands to zoom in and analyze the results. 

6. On the ISDG tab, in the Display panel, click View Clear. 

7. On the View Clear dialog box that appears, select all surfaces then click Ok to 

clear the triangles from the map window. 

APPENDIX A: CREATING A SQL SERVER DATABASE 

Objective: 

ISDG supports SQL Server and SQL Server Express 2012 or 2104 x64. In this exercise 

we will install SQL Server Express x64 on your local machine, create a database for 

ISDG to use, and configure that database for use with GeoMedia. 

Task 1: Install SQL Server Express 

In this task we will install SQL Server Express 2014 x64. 

1. Locate your SQL Server Express 2014 x64 delivery folder. 

2. Right-click on 

en_sql_server_2014_express_with_tools_x64_exe_3941421.exe and 

select Run as administrator. 

The Choose Directory For Extracted Files dialog box appears. 
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3. Select Ok 
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4. Select New SQL Server stand-alone installation or add features to an 

existing installation: 
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5. Check I accept the license terms and hit Next: 
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6. Accept defaults for Feature Selection and hit Next: 
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7. Accept defaults for Instance Configuration and hit Next. Make a note of the 

instance name “SQLExpress” as this will be used later when connecting 

to the database in GeoMedia. 
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8. Accept defaults for Server Configuration and hit Next: 
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9. Accept defaults for Database Engine Configuration and hit Next: 

 

 

The installation will proceed and notify the user when complete. 

Task 2: Create Database for ISDG to Use 

In this task we will create a database for ISDG to use. 

1. From the Windows Start menu select Microsoft SQL Server 2014 > SQL Server 

2014 Management Studio. 

The Connect to Server dialog box appears. 
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2. From the Server type drop down list select Database Engine. 

3. From the Server name drop down list select the machine name\instance name, 

for example, IS2005\SQLEXPRESS. The instance name is the name that was 

specified in Task 1, step 7 when SQL Server was installed. 

4. From the Authentication drop down list select Windows Authentication. 

5. Click Connect. 

6. From the Object Explorer tree view, right-click on Databases then select New 

Database. 

The New Database dialog box appears. 
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7. In the Database name field key in the name for your new database, such as 

ISDG. 

8. Click OK to create the database and dismiss the New Database dialog box. 

The person who creates a database is automatically given the proper access 

settings to the database for use with GeoMedia. 

9. Click File > Exit to exit Microsoft SQL Server Management Studio 

Task 3: Configure Database for Use with GeoMedia 

In this task we will configure the database for use with GeoMedia. 

1. From the Windows Start menu, select Hexagon GeoMedia Desktop > Utilities 

> Database Utilities. 

2. From the Database type drop down list select SQL Server. 

Note: ISDG also supports SQL Server Spatial database type. 

The Database Connection dialog box appears. 
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3. From the Server drop down list, key in the machine name\instance id, for 

example, is2005\SQLEXPRESS. The instance name is the name that was 

specified in Task 1, step 7 when SQL Server was installed. 

4. Select Use Windows authentication. 

5. From the Database drop down list select the database that you just created, such 

as ISDG. 

6. Click OK. 

7. The Database Utilities dialog box appears. 
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8. Click Create Metadata Tables. 

9. Dismiss the completion notification text box that appears and then click Close to 

dismiss the Database Utilities dialog box. 

 


