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MERGING LAS AND BREAKLINE TUTORIAL 

TUTORIAL INTRODUCTION 

ImageStation DTMQue (ISDQ) is a collection of command line utilities used primarily for 

converting surface data to the ImageStation DTM format and for making changes to 

DTM format surface data. The DTM format is the preferred surface format for use in the 

ImageStation photogrammetry applications for accuracy and efficiency and is used by 

products such as ImageStation OrthoPro. Wrapped around ISDQ’s various command 

line utilities is a powerful interface that you can use to create, edit, and save workflows 

that can either process a single input source file or an entire directory of input source 

files. In addition, ISDQ delivers basic utilities for making changes to DTM surfaces such 

as clip, tile, triangulate, transform, thin, merge, and several more. 

TOPICS 

This tutorial presents a workflow using ISDQ for combining LIDAR point cloud data with 

breakline data from a MicroStation design file. The resulting merged DTM files can be 

used as input DTM data to OrthoPro. 

Topics covered in this tutorial include: 

 Creating a new ISDQ workflow file 

 Scanning folders for input files 

 Converting ASCII and DGN format files to DTM format 

 Merging surface files 

 Clipping surface files to a smaller area 

 Triangulating surface files 

 Displaying surface files 
 

TUTORIAL TEXT CONVENTIONS 

There are several conventions used throughout the tutorial: 

 Ribbon bar items are shown as: On the Aaa tab, in the Bbb panel, click Ccc > 

Ddd. 
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 Dialog box names, field names, and button names are depicted using bolded 

text. 

 Information to be entered, either by selecting from a list or by typing, is 

depicted using italicized text. 
 

 

TUTORIAL DATA SET 

The tutorial data set consists of three LIDAR point cloud files in ASCII format (.ASC), a 

MicroStation design file (.DGN) containing breakline features, a coordinate system file 

that describes the map projection being used (project.csf), and an ASCII file containing 

polygon coordinates for clipping the surface area (clip.txt). Create a folder named 

C:\Training\ImageStation and unzip the data set to this folder. (The resulting full path to 

the data set should be C:\Training\ImageStation\ISDQ-Merging Data.) 

 

TUTORIAL PREREQUISITES 

You should have ImageStation DTMQue installed. 
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DEFINING THE ISDQ WORKFLOW 

CREATING A NEW WORKFLOW FILE 

Let's get started... 

1. Launch ImageStation DTMQue from the Windows Start menu. 

The ImageStation DTMQue main dialog opens with an "unsaved workflow." 

2. Click File > Save As and enter a name for your new workflow file. Save the 

workflow file in the same folder where the tutorial data reside: 

C:\Training\ImageStation\ISDQ-Merging Data. 

At this point you should see something like the screenshot below. 

 

 
 

SCANNING FOR MULTIPLE SURFACE FILES 

1. Click Input > From Folder. 

A DtmScanner process module is added to the Workflow process tree in the left 

pane and its associated parameters are displayed in the right pane. 

2. Use the directory file browser to locate the folder where the tutorial project data 

are located: C:\Training\ImageStation\ISDQ-Merging Data. 
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3. Note that the input-mask is already set to "*.asc." For other workflows this can be 

changed to scan for any other input files you may have, such as *.las, *.xyz, *.txt, 

etc. 

4. Uncheck the recursive checkbox. This is used for scanning subfolders for 

similarly named input files. 

 
 

CONVERTING ASCII TO DTM FORMAT 

1. Click on the DtmScanner process in the left pane to give it focus, then click 

Format > Ascii. 

An Asc2Dtm process module is added to the Workflow process tree under 

DtmScanner in the left pane and its parameters are displayed in the right pane. 

2. Leave the input-field set to ${input} to indicate that this module will take the files 

located by DtmScanner as input for processing. 

3. Use the input-csf file browser to select project.csf from the project folder which 

defines the coordinate system for the surface data and click Open. 

4. Leave the output-field set to [file rootname ${input}].dtm to indicate that the 

newly created surface files will be named the same as the input files but will have 

a .dtm file extension. 

5. Leave the point-format field set to E N Hgt to indicate the format of the ASCII 

input files. Feel free to click the down arrow to see which other formats are 

supported. 
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6. Leave the skip-lines field set to 0 lines to indicate that there are no header lines 

in the input files that need to be skipped. 

 
 

CONVERTING DGN TO DTM FORMAT 

1. Click Format > DGN. 

A Dgn2Dtm process module is added to the Workflow process tree in the left pane 

below Asc2Dtm and its parameters are displayed in the right pane. 
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2. Right-click on Dgn2Dtm and click Uplevel to move the process to the main 

Workflow process tree (i.e. move it out from under the DtmScanner sub-tree). 

 

3. Use the input file browser to select breaklines.dgn from the project folder and 

click Open. 

4. Leave output set to [file rootname ${input}].dtm to indicate that the output surface 

file will be named the same as the input file but will have a .dtm file extension. 

5. Leave output-csf set to [file rootname ${input}].csf to indicate that the input-csf 

file from the previous process step will be copied to the same name as the output 

surface file with a .csf file extension.  

6. Click the filter browse button, then click Edit Filter. 

 For your own workflows, if you have a DTM Symbology .INI file that you use for 

ISDC and/or ISAE work you can use the file browser to locate that file and use it to 

define the geomorphic features of the input DGN file. 

7. On the DGN Definition dialog box, click New. 

8. Under Class, click on REG and change it to BRK. 

9. Under Level Name, click in the empty field and key in 705, which is the name of 

the level in the design file that contains the geomorphic features. 
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10. Click OK to return to the main dialog. 

 
 

MERGING THE DTM FILES 

1. Click on Operate > Merge. 

A DtmMerge operation module is added to the Workflow process tree in the left pane 

and its parameters are displayed in the right pane. 

2. Use the input file browser to specify the project folder you are working in: 

C:\Training\ImageStation\ISDQ-Merging Data. 

3. Change the input-mask to *.dtm. 

4. Uncheck the recursive checkbox option. 

5. Leave input-csf set to ${input-csf} to indicate that the process will use the CSF 

from the previous process step. 

6. Leave output set to ${input}/merged.dtm to indicate that the results will be stored 

in merged.dtm file in the working directory. 
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7. Make sure points and breaklines options are checked and all others are 

unchecked. 
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DISPLAYING THE RESULTS 

1. Click Display > Show. 

A DtmShow process module is added to the Workflow process tree and its 

parameters are displayed on the right pane. 

2. No changes are necessary in this step. This process step will cause ISDQ to 

display the results of the merged surface files from the previous step. Having the 

async option enabled allows the rest of the processes that get added to the 

Workflow process tree to continue while the surface remains displayed in the 3D 

DTM Viewer. 
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CLIPPING THE MERGED DTM 

1. Click Operate > Clip. 

A DtmClip process module is added to the Workflow process tree in the left pane 

and its parameters are displayed in the right pane. 

2. Leave input and input-csf set to their default values to indicate that it will use the 

output files from the previous step. 

3. Edit the output file by adding "_clipped" to the file name as shown below. 

4. In the clip-polygon field key in the file name, clip.txt, that contains the 

coordinates of the polygon used for clipping. Note that if this file is located 

somewhere other than the folder where the workflow file (*.wf) resides then the 

full path to the file would also have to be included. 

5. Leave inside checked to specify that all points inside the polygon are written to 

the new file.  
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TRIANGULATING THE MERGED DTM 

1. Click Operate > Triangulate. 

A DtmTriangulate process module is added to the Workflow process tree in the left 

pane and its parameters are displayed in the right pane. 

2. No changes to the fields are necessary for this step. The process will read in the 

clipped DTM and its associated CSF from the previous step, triangulate it, and 

write the results back to the same file.  
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DISPLAYING THE NEW RESULTS 

1. Click Display > Show. 

Another DtmShow process module is added to the Workflow process tree in the left 

pane and its parameters are displayed in the right pane. 

2. No changes are needed here. This will cause ISDQ to display the results of the 

triangulated clipped surface in the 3D DTM Viewer. 

 
 

PROCESSING AND ANALYSIS 

SAVE THE WORKFLOW 

At this point we are just about ready to submit the workflow for processing, but before 

doing so, click File > Save to save your work. 
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EXECUTING THE WORKFLOW 

1. Click on the Output tab to display a blank window. Results from the workflow 

processes will be displayed here as the workflow progresses. 

2. Click Execute > Run to process the entire workflow. The whole workflow should 

take less than a minute to complete. The processing is complete when you see 

this line at the bottom of the Output tab: 

Command-line : C:\Program Files\Hexagon\ImageStation DTMQue 

2016\Program\DtmShow.exe … 

The blue progress bar at the bottom right corner of the ISDQ main dialog box will 

continue to scroll until you close the 3D DTM Viewers. 
 

Note: You can use Tools > Max. Parallel Commands to process multiple jobs 

concurrently. The default is 1 and while increasing this number will allow more jobs to 

run concurrently, processing large surface files can cause the system to become disk 

I/O bound or memory bound, so you will likely want to experiment with different settings 

depending on your system capacity and the job at hand. Each job attempts to check out 

a license. Do not set Max. Parallel Commands to a number higher than the number of 

ISDQ licenses currently available to you or the jobs will error off due to insufficient 

licenses. 

COMPARING THE RESULTS 

After the workflow completes there will be two instances of the 3D DTM Viewer 

displayed on top of each other. Use your cursor to drag one off the other and then use 

your mouse to zoom in and rotate the 3D view.  
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Use your mouse to dynamically rotate, pan, and zoom the display:  

 Hold the left mouse button down in the view and drag it to apply Roll, Pitch 

and Yaw.  

 Hold the right mouse button down in the view and drag it to pan the display.  

 Scroll the mouse wheel to zoom in and out. 
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Zoom into the LIDAR data in the upper left area of the merged.dtm file. Notice the 

difference in the display between this and that of the merged_clipped.dtm surface file 

which has been triangulated. The former represents the raw point cloud and breakline 

data whereas the latter has been triangulated and provides a shaded relief look to it. 

You should also notice that the merged.dtm surface does not yield a Z coordinate 

readout as you move your cursor across the surface whereas the merged_clipped.dtm 

surface does. This is because surfaces cannot be probed for elevations until they have 

been triangulated. 
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To summarize what we have just done, we have created and executed a new ISDQ 

workflow file which scanned the input folder for input files, converted ASCII and DGN 

format files to DTM format, merged the DTM files, clipped the merged DTM file to a 

smaller area, triangulated the clipped DTM file, and displayed the intermediate and final 

DTM files. 


