Copyright
© 2016 Intergraph® Corporation and/or its affiliates. Hexagon Geospatial is a Division of Intergraph. All Rights Reserved.

Product Documentation Terms of Use

PLEASE READ THESE TERMS CAREFULLY BEFORE USING HEXAGON GEOSPATIAL’S DOCUMENTATION ("DOCUMENT"). USE OF THIS DOCUMENT INDICATES ACCEPTANCE OF THIS AGREEMENT WITHOUT MODIFICATION. IF YOU DO NOT AGREE TO THE TERMS HEREOF ("TERMS"), DO NOT USE THIS DOCUMENT.

Use Of This Document

All materials in this Document are copyrighted and any unauthorized use may violate worldwide copyright, trademark, and other laws. Subject to the terms of this Agreement, Hexagon Geospatial (a Division of Intergraph Corporation) and Intergraph’s subsidiaries ("Intergraph") hereby authorize you to reproduce this Document solely for your personal, non-commercial use. In consideration of this authorization, you agree to retain all copyright and other proprietary notices contained therein. You may not modify the Materials in any way or reproduce or publicly display, perform, or distribute or otherwise use them for any public or commercial purpose, except as specifically authorized in a separate agreement with Hexagon Geospatial.

The foregoing authorization specifically excludes content or material bearing a copyright notice or attribution of rights of a third party. Except as expressly provided above, nothing contained herein shall be construed as conferring by implication, estoppel or otherwise any license or right under any copyright, patent or trademark of Hexagon Geospatial or Intergraph or any third party.

If you breach any of these Terms, your authorization to use this Document automatically terminates. Upon termination, you will immediately destroy any downloaded or printed Materials in your possession or control.

Disclaimers

ALL MATERIALS SUPPLIED HEREUNDER ARE PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. Hexagon Geospatial does not warrant that the content of this Document will be error-free, that defects will be corrected, or that any Hexagon Geospatial Website or the services that make Materials available are free of viruses or other harmful components.

Hexagon Geospatial does not warrant the accuracy and completeness of this Document. Hexagon Geospatial may make changes to this Document at any time without notice.

Limitation Of Liability

IN NO EVENT SHALL HEXAGON GEOSPATIAL BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES, OR DAMAGES FOR LOSS OF PROFITS, REVENUE, DATA OR USE, INCURRED BY YOU OR ANY THIRD PARTY, WHETHER IN AN ACTION IN CONTRACT OR TORT, ARISING FROM YOUR ACCESS TO, OR USE OF, THIS DOCUMENT.

Indemnification

You agree to defend, indemnify, and hold harmless Hexagon Geospatial, its officers, directors, employees, and agents from and against any and all claims, liabilities, damages, losses or expense, including reasonable attorney’s fees and costs, arising out of or in any way connected with your access to or use of this Document.

Use Of Software

Use of software described in this Document is subject to the terms of the end user license agreement that accompanies the software, if any. You may not download or install any software that is accompanied by or includes an end user license agreement unless you have read and accepted the terms of such license agreement. Any such software is the copyrighted work of Hexagon Geospatial, Intergraph or its licensors.

Links To Third Party Websites

This Document may provide links to third party websites for your convenience and information. Third party websites will be governed by their own terms and conditions. Hexagon Geospatial does not endorse companies or products to which it links.

Third party websites are owned and operated by independent parties over which Hexagon Geospatial has no control. Hexagon Geospatial shall not have any liability resulting from your use of the third party website. Any link you make to or from the third party website will be at your own risk and any information you share with the third party website will be subject to the terms of the third party website, including those relating to confidentiality, data privacy, and security.

Trademarks

The trademarks, logos and service marks ("Marks") displayed in this Document are the property of Hexagon Geospatial, Intergraph or other third parties. Users are not permitted to use Marks without the prior written consent of Hexagon Geospatial, Intergraph or the third party that owns the Mark. "Intergraph" is a registered trademark of Intergraph Corporation in the United States and in other countries. Other brands and product names are trademarks of their respective owners.
Procedure For Making Claims Of Copyright Infringement

Notifications of claimed copyright infringement should be sent to Hexagon Geospatial by mail at the following address: Intergraph Corporation, Attn: Intergraph Legal Department, P.O. Box 240000, Huntsville, Alabama 35824.

U.S. Government Restricted Right

Materials are provided with “RESTRICTED RIGHTS.” Use, duplication, or disclosure of Materials by the U.S. Government is subject to restrictions as set forth in FAR 52.227-14 and DFARS 252.227-7013 et seq. or successor provisions thereto. Use of Materials by the Government constitutes acknowledgement of Hexagon Geospatial or Intergraph’s proprietary rights therein.

International Use

You may not use or export Materials in violation of U.S. export laws and regulations. Hexagon Geospatial makes no representation that Materials are appropriate or available for use in every country, and access to them from territories where their content is illegal is prohibited.

Hexagon Geospatial provides access to Hexagon Geospatial international data and, therefore, may contain references or cross references to Hexagon Geospatial products, programs and services that are not announced in your country. These references do not imply that Hexagon Geospatial intends to announce such products, programs or services in your country.

The Materials are subject to U.S. export control and economic sanctions laws and regulations and you agree to comply strictly with all such laws and regulations. In addition, you represent and warrant that you are not a national of, or otherwise located within, a country subject to U.S. economic sanctions (including without limitation Iran, Syria, Sudan, Cuba, and North Korea) and that you are not otherwise prohibited from receiving or accessing the Materials under U.S. export control and economic sanctions laws and regulations. Hexagon Geospatial makes no representation that the Materials are appropriate or available for use in every country, and access to them from territories where their content is illegal is prohibited. All rights to use the Materials are granted on condition that such rights are forfeited if you fail to comply with the terms of this agreement.

Revisions

Hexagon Geospatial reserves the right to revise these Terms at any time. You are responsible for regularly reviewing these Terms. Your continued use of this Document after the effective date of such changes constitutes your acceptance of and agreement to such changes.

Applicable Law

This Document is created and controlled by Hexagon Geospatial in the State of Alabama. As such, the laws of the State of Alabama will govern these Terms, without giving effect to any principles of conflicts of law. You hereby irrevocably and unconditionally consent to submit to the exclusive jurisdiction of the United States District Court for the Northern District of Alabama, Northeastern Division, or the Circuit Court for Madison County, Alabama for any litigation arising out of or relating to use of this Document (and agree not to commence any litigation relating thereto except in such courts), waive any objection to the laying of venue of any such litigation in such Courts and agree not to plead or claim in any such Courts that such litigation brought therein has been brought in an inconvenient forum. Some jurisdictions do not allow the exclusions or limitations set forth in these Terms. Such exclusions or limitations shall apply in all jurisdictions to the maximum extent allowed by applicable law.

Questions

Contact us with any questions regarding these Terms.
# CONTENTS

**PixelQue Ortho Editing and Enhancement** .......................................................... 6
  Tutorial Introduction .................................................................................................. 6
  Topics .......................................................................................................................... 6
  Tutorial Text Conventions ......................................................................................... 7
  Tutorial Data Set ......................................................................................................... 7
  Tutorial Prerequisites ............................................................................................... 7
  Inspection and Editing ............................................................................................... 7
    Creating the PixelQue Warehouse ............................................................................. 7
  Image Inspection ......................................................................................................... 10
  Review and Edit ......................................................................................................... 13
  Image Enhancement .................................................................................................... 17
    Creating a LUT ........................................................................................................ 17
    Reviewing the LUT ................................................................................................. 18
    Applying the LUT ................................................................................................. 20
PIXELQUE ORTHO EDITING AND ENHANCEMENT

TUTORIAL INTRODUCTION

ImageStation PixelQue (ISPQ) is designed to provide tools for checking and enhancing the quality of orthophotos and mosaics. It allows users to systematically review and mark up errors, to fix errors, and also to do image enhancements on an individual or project basis. PixelQue is part of an orthophoto production solution which includes ImageStation OrthoPro (ISOP). PixelQue and OrthoPro are intended to address the needs of producers of large volumes of orthophotos. Together they address the user requirements to increase the throughput and efficiency of orthophoto production by high degree of automation and efficient, semi-automatic Quality Assurance/Quality Control (QA/QC) review and edit, thus reducing the time and cost factors of a project. Key features include:

- Structured review and edit capability to QA/QC images, orthophotos, or mosaics
- Find and correct problems created in the production process
- General image clean-up and enhancement tools including Look-Up Table (LUT) definition

TOPICS

This tutorial presents a workflow depicting the inspection, editing, and enhancement of Products created by OrthoPro.

Topics covered in this tutorial include:

- Opening a GeoMedia workspace
- Creating a PixelQue warehouse from an OrthoPro project
- Inspecting images and placing problem markers
- Reviewing the problem markers and making spatial edits to the imagery
- Performing image enhancement and creating a LUT
- Applying the LUT to the Product images
TUTORIAL TEXT CONVENTIONS

There are several conventions used throughout the tutorial:

- Ribbon bar items are shown as: On the Aaa tab, in the Bbb panel, click Ccc > Ddd.
- Dialog box names, field names, and button names are depicted using bolded text.
- Information to be entered, either by selecting from a list or by typing, is depicted using italicized text.

TUTORIAL DATA SET

The tutorial data set consists of a small ImageStation aerial photogrammetric project that was orthorectified and then mosaicked using OrthoPro. Create a folder named C:\Training\ImageStation and unzip the data set to this folder. (The resulting full path to the data set should be C:\Training\ImageStation\ISPQ-Ortho Editing.)

TUTORIAL PREREQUISITES

You should have the following products installed:

- GeoMedia Essentials, Advantage, or Professional
- ImageStation PixelQue

INSPECTION AND EDITING

CREATING THE PIXELQUE WAREHOUSE

1. Start Hexagon GeoMedia Desktop from the Windows Start menu.
2. Select Blank GeoWorkspace and then click OK. The workspace opens and displays an empty map window.
3. On the PixelQue tab, in the Warehouse panel, click Warehouse > New PixelQue Warehouse.
4. On the New PixelQue Warehouse dialog box that appears, use the PixelQue warehouse filename: browser to create a new warehouse in the C:\Training\ImageStation\ISPQ-Ortho Editing folder such as ISPQ_Training.
5. Check the **Use OrthoPro/ISPM project to define coordinate system and image list** option.

6. Uncheck **Convert filenames to UNC if possible** option.

   **TIP** Using UNC paths for the images enables multiple users from other systems to access the PixelQue database and its associated images so that they can perform inspection and editing on the same project simultaneously.

7. Use the **OrthoPro/ISPM project filename** browser to select the *Training.opj* file from the `C:\Training\ImageStation\ISPQ-Ortho Editing` folder then click **OK**.

8. Verify that **Use seamlines, Display strip-wise, Add non-products as aux images**, and **Products** are already checked.

9. Under **Type of images to use from OrthoPro/ISPM project**, **Products** should already be checked. These are the final mosaicked products coming from the OrthoPro project that we will be editing.

10. Under **Type of images to use from OrthoPro/ISPM project**, check the **Rectified** option. These are the original orthos that were used to create the mosaicked products. Because they are “non-products” they will be treated as “auxiliary” images, which means they can be used as input for editing operations but the edits will not be applied to these files.
11. Click **OK** to create the PixelQue warehouse and add the PixelQue features to the legend.

12. Maximize the GeoMedia main window to your monitor, then maximize **MapWindow1**, and then use GeoMedia **Fit All** to display the project area.
13. Right-click on *ISPQImageList* in the legend and select **Display On** to view the mosaicked Products that will be edited.

14. Right-click on *ISPQAuxImageFootprints* and *ISPQAuxImageCenters* and select **Display Off**. Notice that the *ISPQImageFootprints*, which represent the footprints on the mosaicked Products, overlap by 300 meters.

15. Right-click on *ISPQImageList* in the legend and select **Display Off**.

16. Right-click on *ISPQAuxImageList* in the legend and select **Display On**. These are the original Rectified orthos that were used to make the mosaicked Products. As “Auxiliary” images they are read-only and will be used to clone fixes into the Products.

17. Right-click on *ISPQAuxImageList* and select **Display Off**.

**IMAGE INSPECTION**

1. On the PixelQue tab, in the Q/A panel, click **Inspection > Inspect Images**.
2. Move the **Inspect Images** dialog down so it is not covering the Overview window.
3. On the **Inspect Images** dialog that appears, set **Image zoom**: to 1:4 then click **Start Inspection**.
4. Analyze the area within the dashed lines of the first tile displayed in the **Inspection Window** on the left. Look for solid blue seamlines that intersect buildings. There shouldn’t be any problems seen in the first inspection area.

5. **Optional:** When you started the inspection process, the **PixelQue Queued Edit Control** was displayed in the lower left corner. Feel free to click on the edge of the control and drag it off the bottom if you like.

6. On the **PixelQue Queued Edit Control**, click the **Move Next** right arrow to advance to the number 2 of 16 inspection tile.

   Note: The number of inspection tiles may differ from this value as it is calculated based on your screen size and resolution.

   ![PixelQue Queued Edit Control](image)

7. Again analyze the image content within the dashed lines, focusing on where the blue seamlines might cross through buildings. As you advance through the tiles, notice that the tiles in the **Overview** window are tinted to indicate that they have been inspected.

8. Keep advancing through the tiles until you get to the last tile of the first row. Notice that a seamline runs through the middle of a building towards the bottom center of the tile.
9. On the **Place Problem Marker** dialog box, use the pick list to change the **Type** to **Building**.

   *Note that there are many problem marker types to choose from, and you can even add comments prior to placing the problem markers. Later, during the Review problem Markers process, users can pick which problem marker types they want to queue up for editing.*

10. Click and drag a problem marker around the building.

11. Continue traversing through tiles 5 – 16 of this Product and place problem markers wherever you see seamlines running through buildings.

   **TIP** If you are inspecting images without intending to perform edits you can minimize the **Auxiliary Inspection Window**. This will speed the time that it takes to traverse the displays from one tile to another.

   **TIP** PixelQue tracks the amount of time spent during the Inspection process and the Review Problem Markers process. A report of this information can be had by clicking **Report > PixelQue Warehouse Report** from the PixelQue ribbon menu. If you are interested in tracking this time accurately, you can at any time click the
Pause button on the PixelQue Queued Edit Control so that the clock doesn’t continue to run when taking a break or some other interruption occurs. This information is tabulated on a per user basis and can be helpful when estimating future jobs.

12. When you click Move Next at tile 16 PixelQue will automatically advance to the next Product (0_1.tif) for inspection. Notice that the first tile contains the same building that we placed first problem marker around on the previous Product. Go ahead and place another problem marker around it for this Product so that we can revisit it after the editing process.

13. Continue inspecting the second Product, placing problem markers as needed. When you get to the last tile click the Close Queue button on the far right of the PixelQue Queued Edit Control.

14. Click Close on the Inspect Images dialog box to end the inspection process.

REVIEW AND EDIT

1. On the PixelQue tab, in the Q/A panel, click Inspection > Review Problem Markers.
2. Move the **Review Problem Markers** dialog down so it is not covering the **Overview** window.

3. Note that there is a count for each problem marker type you placed in the **Problem summary**: section.

4. Under **Problem markers to queue**: check **Building**, or simply click **All** to activate all of them.

5. Click **Start Review** to begin the reviewing process and be automatically driven to the first problem marker that was placed during the inspection process.

6. The **Review Window** on the left is where the edits to the Product will be performed. The **Auxiliary Review Window** on the right is where we will pick which Rectified image to use to clone into the Product image on the left.

7. In the legend of the **Auxiliary Review Window**, click and drag the 3rd ortho image (ortho images start with “O”) above the first ortho image in the list and pay attention to the lean of the building.
8. Repeat this process so that image OAa_5cm_dx_01-0057_rgb.tif is now at the top of the list. Notice that the left half matches the Product image and the right half leans toward the east. We’ll use this image to clone into the product image.


10. On the Pixel Clone toolbar, set the Diameter: to 75 pixels, Feather to 20%, Opacity to 100%, and check the Sync option.

<table>
<thead>
<tr>
<th>Pixel Clone</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brush: Circular</td>
</tr>
</tbody>
</table>

11. Click on the image in the Auxiliary Review Window. When the PickQuick dialog appears, select feature 1 to indicate that you want to use the top-most image for the clone operation.

![PickQuick](C:\Training\ImageStation\ISPQ-Ortho Editing\OAa_5cm_dx_6_01-0057_rgb.tif)

12. Move your cursor over to the Review Window. Hold your left mouse button down and drag it over the right half of the building to perform the edit. When you let go to complete the edit a dialog box will appear indicating that the edit will be performed on all overlapping images. Check the Don’t prompt this message again option and then click Yes. This causes the edit to not only be applied to Product 0_0.tif, but also to 0_1.tif at the same time.

![Warning](The edit is about to be applied to all the overlapped images. Do you want to edit the overlapped images? Check Don’t prompt this message again)

13. Once the edit is complete, change the status for the problem marker on the PixelQue Queued Edit Control to Resolved. The program will automatically proceed to the next problem marker for editing.
Note that there is a **Save all images when resolved** option in the lower left corner of the control. This is on by default and causes PixelQue to immediately write out the edits to the image files on disk. You might also notice that these save operations are nearly instantaneous. PixelQue updates only the image tiles that have been touched and also propagates these changes to the overviews in the imagery. All georeferencing is maintained and the edits are made to all bands within the imagery. PixelQue editing also supports images with greater than 8-bits per band such as 16-bit aerial and satellite imagery.

14. When you get to the next problem marker, repeat the edit process:
   a. Re-order the images in the **Auxiliary Review Window** to find the best candidate to clone from.
   b. Start **Pixel Clone**. Double-check that **Sync** is still checked on the **Pixel Clone** toolbar.
   c. Click on image in **Auxiliary Review Window** and select feature 1.
   d. Click and drag in the **Review Window** to perform the edit.

   - **TIP** The clone operation can be performed with multiple strokes. If you make a mistake press the Backspace key to undo the previous stroke. This can be done for as many strokes you made during the current clone operation.

   - **TIP** While cloning, you can right-click anywhere on the image to cause the **Pixel Clone** toolbar to relocate to your current cursor position.

   - **TIP** While cloning, you can press and hold the Spacebar to temporarily suspend the clone operation and then click and drag in the window to pan the view.

15. Continue visiting problem markers and editing them. When you complete the last problem marker for Product 0_0.tif you will automatically be advanced to the first problem marker for Product 0_1.tif. Notice that the building has the proper lean in both halves, which indicates that the first edit that was done previously was carried over into the overlapping Product.

16. On the **PixelQue Queued Edit Control** click **Close Queue**, and then click **Close** on the **Review Problem Markers** dialog box to end the review process.
Note that there are many other editing options available in PixelQue such as **Local Warp**, **Raster Splice**, **Raster Fill**, and **Raster Enhance**. There are also undo/redo commands such as **Raster Undo**, **Raster Redo**, **Raster Undo Brush**, and **Image Revert**. If time allows, feel free to experiment.

**IMAGE ENHANCEMENT**

**CREATING A LUT**

1. Maximize **MapWindow1** to see all features.
2. In the **MapWindow1** legend select all features, right-click, and then click **Display Off**.
3. Right-click on the **ISPQImageCenters** and **ISPQImageList** and click **Display On**.
4. On the **PixelQue** tab, in the **Select** panel, click **Select Images**, then drag a box around any one of the photo center point features to select that image.

5. On the **PixelQue** tab, in the **LUT** panel, click **Global Enhance** to open the image in the ImageStation Digital Image Analyst (ISDIA) program that is included with PixelQue.
6. If you have room on your monitor, arrange the windows so that you can see the images in the GeoMedia window as you work in the ISDIA window.

7. From the pull-down menu click View > Fit (or press F7, or click the Fit Image button on the ISDIA toolbar) to fit the image to the display.

   Note that there are many, many ways to edit the radiometry of an image but we’re going to do a simple histogram adjustment just to show how the workflow operates.

8. From the pull-down menu click Image > Adjust Histogram…

9. On the Adjust Histogram dialog box that appears, move the Weight: slider to the right to about 0.35 and click OK. Notice that the image in the ISDIA window has changed but the same image in the GeoMedia map window has not.

10. From the pull-down menu click Image > LUT(Gamma) Generator…

11. On the LUT Generator dialog box that appears, click Save Separate LUT. Notice that the image in the GeoMedia MapWindow1 now matches the image in the ISDIA window.

12. Click OK to close the LUT Generator dialog box.

13. Close ISDIA by clicking File > Exit or clicking the X in the upper right corner.

REVIEWING THE LUT

   1. On the PixelQue tab, in the Select panel, click Select Images and drag a box around all ISPQImageCenters point features in the map window to select all the Product images.
2. On the **PixelQue** tab, in the **LUT** panel, click **Load LUT** to open the **Load LUT** dialog box.

3. Click the **Load Single LUT** option.

4. Use the **File name:** browser to locate and open `C:\Training\ImageStation\ISPO-Ortho Editing\ISPQ-Ortho Editing\0_0.lut` then click **Open** to dismiss the dialog box. The LUT file name may differ depending on which image you selected in the **CREATING A LUT** section above.

5. Click **OK** to cause the LUT to be loaded to the display for all Product images. This enhancement is only temporary within the session.

6. Dismiss the **Loading Image LUTs** progress bar if it does not disappear automatically.

7. On the **PixelQue** tab, in the **LUT** panel, click **Reset LUT** and click **Yes** to the **Reset selected Image(s) LUT to identity LUT?** prompt. Notice the images all return to their original state.

8. Dismiss the **Resetting image LUTs** progress bar if it does not disappear automatically.
APPLYING THE LUT

1. On the **PixelQue** tab, in the **Warehouse** panel, click **Remove Images**.
2. On the **Remove Image** dialog box that appears, click **Remove all** under the **Auxiliary images** list, confirm the removal, and then click **Close**.
3. On the **PixelQue** tab, in the **LUT** panel, click **Apply LUT** to make new images with the LUT permanently applied.
4. On the **Apply LUT** main dialog that appears, click **Edit > Select All**, then click **Edit > Properties** on the pull-down menu (or press  *Ctrl-A* and then *Alt+Enter*).
5. On the **Apply LUT Properties** dialog that appears, click **Use Single LUT**.
6. Use the **LUT Filename**: browser to select *C:\Training\ImageStation\ISPQ-Ortho Editing\0_0.lut* then click **Open** to dismiss the dialog box. The LUT file name may differ depending on which image you selected in the **CREATING A LUT** section above.
7. Check the **Use Existing Overviews** option.
8. Set the **Output Path** to *C:\Training\ImageStation\ISPQ-Ortho Editing\*. **Tip**: You can also set the output file properties such as format, tiling, compression, and overviews.

```
9. Click **OK** to save the changes and return to the **Apply LUT** main dialog.
10. From the pull-down menu click **Tools > Options** and then click the **Resource Utilization** tab.
11. Set **Concurrent Jobs** to 1 and click **OK** to save the changes and return to the **Apply LUT** main dialog.
```
You can try different numbers for **Concurrent Jobs** to determine the optimum number for your system based on CPU, memory, disk speed, and network speed. For large projects you may want to scale your production by way of distributed processing. ImageStation customers that have ISPM, OrthoPro, and **PixelQue** are provided 4 **ImageStation Distributed Processing (ISDP)** licenses per product. Customers can then use **ImageStation Image Formatter (ISIF)** to apply these same LUTs to images using HTCondor distributed processing, which is available in the ImageStation product delivery under **Supporting Software > HTCondor for Hexagon Geospatial**.

12. From the pull-down menu, click **Apply > Apply LUT** to process the images.
13. When the processing completes, close the **Apply LUT** main dialog by clicking **File > Exit** or clicking the X in the upper right corner.
14. To review the new images, on the **PixelQue** tab, in the **Warehouse** panel, click **Add Images**.
15. On the **Add Images** dialog that appears, check the **Add as auxiliary images** option and uncheck the other two options.
16. Click **Add…**
17. Use Ctrl+click to select the *_app.tif* files that were just created and then click **Open**.
18. Click **OK** on the **Add Images** dialog.
19. In the **MapWindow1** legend, right-click on **ISPQAuxImageList** and click **Display On**.
20. Drag the **ISPQAuxImageList** legend entry above the **ISPQImageList** feature to view the new images on top of the original ones.
To summarize what we have done in this tutorial, we have inspected a set of Product images, identified several problems, and then corrected those problems using one of the editing commands. We have also enhanced the Product images, saved the enhancement, and applied the enhancement to create a new set of Product files.