GEOMEDIA DESKTOP

Real World Applications of GeoMedia Analysis
The information contained in this document (the "Work") is the exclusive property of Intergraph Corporation ("Intergraph"). The Work is protected under United States copyright law and other international copyright treaties and conventions, to include the Berne and Geneva Phonograms Conventions, the WIPO Copyright Treaty, and the World Trade Organization.

No part of the Work may be reproduced, stored, or transmitted in any form or by any means, electronic or mechanical, including photocopying and recording, or by any information storage or retrieval system, except as expressly permitted in writing by Intergraph. All such requests should be sent to the attention of Manager of Customer Education of the Hexagon Geospatial Division of Intergraph ("Hexagon Geospatial") at the following address:

Hexagon Geospatial
5051 Peachtree Corners Circle
Norcross, Georgia 30092-2500 USA

Phone: 770 / 776-3651
Fax: 770 / 776-3694

Support Services: 800 / 953-6643
Customer Education: 800 / 373-2713
Web: www.hexagongeospatial.com

Warning

The Work, and the software that is the subject of the Work, including icons, graphical symbols, file formats, and audio-visual displays, may be used only as permitted under license from Intergraph; contain confidential and proprietary information of Intergraph and/or third parties which is protected by patent, trademark, copyright and/or trade secret law; and may not be provided or otherwise made available without proper authorization. The Work may not be reproduced in any manner, including for resale or redistribution, without the prior written permission of Intergraph. Use of the software during the training course shall be in accordance with the End User License Agreement ("EULA") delivered with the software. Neither the software nor the software documentation may be reproduced in any manner, without the prior written permission of Intergraph.

About This Manual

The Work is an instructional document designed to be an integral part of the training course offered by Hexagon Geospatial. Hexagon Geospatial believes the information in the Work is accurate as of its publication date. Any specifications cited in the Work are subject to change without notice. The information and the software discussed in the Work are subject to change without notice. Intergraph is not responsible for any errors that may appear in the Work.

Intergraph, the Intergraph logo, ERDAS, ERDAS IMAGINE, IMAGINE Essentials, IMAGINE Advantage, IMAGINE Professional, IMAGINE VirtualGIS, GeoMedia, ImageStation, Video Analyst, Stereo Analyst, TopoMouse, Hexagon Smart M.App, and Power Portfolio are trademarks of Intergaph Corporation. Hexagon and the Hexagon logo are registered trademarks of Hexagon AB or its subsidiaries. Other brands and product names are trademarks of their respective owners.

Acknowledgments

Some of the data provided for the Gulf of Mexico Gas and Oil Production Analysis are courtesy of the Bureau of Ocean Energy Management http://www.boem.gov. The data provided for the Corridor Analysis are courtesy of the City of Des Moines https://maps.dmgov.org.
This Tutorial

Tutorial Objective
This tutorial explores assorted workflow scenarios to illustrate the analytical capabilities available in GeoMedia. The first example summarizes gas and oil production data for wells located in the Gulf of Mexico to determine the largest producers and owners of the wells. It also calculates the distance from each gulf platform to its nearest port. The tools used include Analytical Merge, Join, and Aggregation. The second example evaluates a proposed right of way widening study which demonstrate how to isolate the data, delineate the zone of interest or study area, locate and isolate items in the study area, identify items within the study area for reporting purposes, and summarizing the data in the study area. The tools used include Attribute Query, Buffer Zone, Spatial Query, Spatial Intersection, Aggregation, and Analytical Merge.

Tutorial Data Set
This tutorial dataset contains two sets of data; Gulf of Mexico, and Des Moines, Iowa. Some of the data provided for the Gulf of Mexico Gas and Oil Production Analysis are courtesy of the Bureau of Ocean Energy Management http://www.boem.gov. The data provided for the Corridor Analysis are courtesy of the City of Des Moines https://maps.dmgov.org.

Tutorial Text Conventions
There are several conventions used throughout the tutorial:

- Ribbon bar items are shown as: On the Aaa tab, in the Bbb group, click Ccc.
- Dialog box names, field names, and button names are depicted using Bolded Text.
- Information to be entered, either by selecting from a list or by typing, is depicted using Italicized Text.

Tutorial Prerequisites
None. The datasets used in this tutorial access native data formats via GeoMedia Data Servers. This tutorial can be run on all tiers.
Section 1: Gulf of Mexico Gas & Oil Production Analysis

Section Objective

This section uses a hypothetical problem where it is desirable to summarize gas and oil production data for wells located in the Gulf of Mexico. We need to understand which wells are the largest producers and who are the owners in our final result. We are also interested in knowing the distance from each gulf platform to its nearest port. An overview of our workflow will be to:

- Use Analytical Merge to summarize non-graphic, monthly production reports to obtain yearly output for each well.
- Join the summarized results to graphic well point geometry.
- Use Attribute Based Symbology and Thematic legend entries to visualize the result.
- Use Aggregation to obtain the nearest port name for each platform.

Tools Used

Analytical Merge

Takes a single table (record set) as input, forms groupings of records and for each grouping a single output record is created with any user defined expressions. Any expression built here must return a single result for the entire group, for example the SUM (input.oil_production) might return the total amount of oil produced whereas MAX (input.Date) might return the last reported date for each grouping.

Join

Allows one table or record set to be related to another based on matching related attribute field (columns).

Aggregation

Used to relate one table (a detail feature) to another table (summary feature); the main goal is to summarize information from the detail features to the summary features. Think of the detail items as being organized into groupings according to which summary feature they are related (spatially and/or by attribute). For each grouping a summarization can be made to summarize to the summary feature.
Exercise 1: Using Analytical Merge to Visualize Yearly Gas & Oil Production

Objective:
In this section, we will look at monthly gas and oil production data for the Gulf of Mexico. We will use GeoMedia to summarize the production data to see where high producing wells can be found in the gulf. We also interested in knowing what companies are operating the wells.

By completing this exercise you should understand the how to use GeoMedia analysis tools:
- Analytical Merge command to group records by attributes for summarization.
- Join command to related summarized tabular data to graphic spatial data.

Task 1: Reviewing the Warehouse Connections

1. Use GeoMedia to open C:\Analysis\GeoWorkspaces\Gulf_Gas_and_Oil.gws.
2. Select the Manage Data tab.
3. Use the Warehouse fly-out icon to select the Warehouse Connections command (see graphic below).

The Connections dialog appears listing various warehouse connections.
4. Notice how the source data is referenced in different types of warehouses.

5. Notice how some of the connection types are “Text File”.

The bulk of our analysis is based on delimited or fixed width text files. GeoMedia Text File connections support displaying not only tabular (non-graphic) data but also graphic geometry served directly from the text file.
6. Select the row selector for the Wells connection (see graphic below).

7. Select the **Properties** button.

   *The Properties for the Wells connection is displayed.*

   ![Properties dialog](image)

---

**Note:** Prior to GeoMedia Desktop 2015 the Feature Caching options were not included in the Warehouse Connection Properties dialog, as portrayed above.

8. After reviewing the Wells connection properties, close both the Properties dialog and the Warehouse Connections dialog.

9. Leave the GeoWorkspace open for use in the next task.
Task 2: Review the Graphic Well Data

*The GeoWorkspace, Gulf_Gas_And_Oil.gws should still be open and visible.*

1. Right-click in a blank area of the map legend and select the **Add…** option. *The Add Legend Entries dialog appears.*

2. Expand the **Wells** connection and select ✓ the **Wells** feature class (see graphic below).

3. Select **OK** to add the Wells to the legend & map window.

4. Use the Select Tool ✓ to double-click one of the graphic well points in the map view. *The Wells Properties dialog appears (see graphic below).*
5. After reviewing the properties, **Close** the Wells Properties dialog.
6. Leave the GeoWorkspace open for use in the next task.

---

**Task 3: Reviewing the Non-Graphic Well Production Data**

_The GeoWorkspace, Gulf_Gas_And_Oil.gws should still be open and visible._

1. Select the **Home** tab and use the **Add / Show Windows** option to select the **New Data Window** option (see graphic below).

![Add / Show Windows](image)

2. Expand the Well Production Data connection and highlight / select the **ogor2013dd** feature class (see graphic below).

![New Data Window](image)

3. Select **OK** to create the data window for ogor2013dd (2013 well production data).
4. Use the horizontal scroll bar along the bottom of the data window to locate the **API_Well_Num** column / attribute field.
5. Click on the column header for the **API_Well_Num**.
6. With the API_Well_Num column highlighted, right-click on the data window and select the **Sort Ascending** option (see graphic below).

7. After sorting the records, notice how the Production_Date (6 columns to the left) shows that each record represents monthly output for each well. Thus each well can have up to 12 associated records.

In the graphic below we can see records for January through May production for a specific well API number owned by Exxon Mobile Corporation.

8. Notice the record count along the bottom of the data window shows there are nearly 130,000 records.

9. After reviewing the production data, close the data window.

10. Leave the GeoWorkspace open for use in the next task.
Task 4: Summarizing Attributes Using Analytical Merge

The Analytical Merge command takes as input a single table; it then organizes the records of the table into groupings based on user defined attribute(s); for each grouping we can build summarizing expressions.

In the following example, we can use the Analytical Merge command to organize the records of the well production data by the well number, then summarize the production for each well.

The GeoWorkspace, Gulf_Gas_And_Oil.gws should still be open and visible.

1. Select the Analysis > Analytical Merge command.

2. Click on the Merge features in drop-down list to expand the Well Production Data connection and highlight / select the ogor2013dd feature class.

3. In the Attributes section, select the attribute for API_Well_Num.
4. Right-click in a blank section of the Output functional attributes section and select **New > SUM > Multiple Attributes**… (See graphic below).

All numeric attributes which are valid for direct use with the SUM function are displayed.

5. Select all of the attributes with the exception of the GTFPrimaryKey field (see graphic below).

6. Select **OK** on the Multiple Attributes for SUM dialog.

7. Click on the **New...** option.
The Functional Attribute dialog appears.

8. Set the Functional attribute name as: Daily_oil_bbls.

9. Scroll through the Attributes section (lower right) and locate the Output attributes.


11. Key-in or select the / operator


The Expression field should now look like: `Output.SumOfMonthly_oil_volume / Output.SumOfDays_on_production`

13. Validate that the Output type field is populated and click the Add option to save the expression.

The Functional Attributes dialog reappears ready to aid in building more expressions.
If we assume that each well is owned by a single owner then we could use a simple FIRST() function to select the first owner name in each set of records for each well.

14. Key in Owner in the Functional attribute name field.

15. In the Categories section (lower left) select the Misc category

16. In the Functions section (lower center), double-click FIRST to add FIRST() to the Expression dialog.

17. In the Attributes section (lower right), double-click Input.Operator_Name

The Expression field should now look like: FIRST(Input.Operator_Name)

18. Validate that an Output type is assigned and click Add.


The main Analytical Merge dialog is redisplayed.

20. Set the output Query name as Q1 Merge of Production Data.

21. Enable the option display in the results in the data window.

22. Select the OK option to perform the merge.

The Data Window for Q1 Merge of Production Data is displayed.

23. Click on the column header for Daily_oil_bbls.

The column is highlighted.
24. Right-click over the column and select **Sort Descending**.

Now we can easily see the largest daily oil producers reported in units of bbls (barrels) ~42 gallons or 159 liters.

25. After reviewing the summarized production data, close the data window.

26. Leave the GeoWorkspace open for use in the next task.

---

**Task 5: Relating Tables Using GeoMedia Join**

The Join command can be used to relate the non-graphic well production data to the graphic representation of the well point features.

*The GeoWorkspace, Gulf_Gas_And_Oil.gws should still be open and visible.*

1. Delete the Wells legend entry from the legend (highlight the entry and press `<delete>` key.

2. Select the **Analysis > Join**.

3. Set the *Left side of join* field to **Wells**.

4. Set the *Right side of join* to the **Q1 Merge of Production Data** which can be found in the **Queries**.
5. Highlight **API_Well_Number** and **API_Well_Num** then add the related attribute pair down to the **Selected attribute pairs** field.

6. Set the **Type of join** to **Left outer**.

Left outer join ensures all records from the left side table are returned in addition to any matching attributes from the right side table.

7. Set the Output query name to: **Q2 Well Production**.

8. Select the option to display in the map window.

9. Uncheck the option to display the data window.
Task 6: Visualization of Attribution

Advanced style settings support the use of Attribute Based Symbology (ABS) which can be thought of as instance based styles. An attribute and/or an expression can be used to control style properties for each instance / record.

In the following example, we can use barrels of oil attribute as a size property so each well will be individually sized according to its oil production value.

*The GeoWorkspace, Gulf_Gas_And_Oil.gws should still be open and visible.*

1. Right-click on the legend entry for Q2 Well Production and select **Style Properties** from the list of options.

*The Style Properties dialog appears.*

2. Click on the **Advanced** tab.

3. Notice how moving the on screen cursor over the style properties names displays a data type.
The data type tool tip is important as it indicates the data type that is expected if selecting attributes or building an expression for the style property.

4. Click into the Attribute Based field for Size.

5. Click the drop down to examine the list of available attributes.


7. Select OK on the Style Properties dialog.

Notice how the larger Daily_oil_bbls attributes causes the point symbols to fill the screen.

8. Right-click on the Q2 Well Production legend entry and select the Style Scaling > Paper option.

9. Right-click in the map view and select Display Properties.

10. Set the Nominal Map Scale to 200,000.
The wells which are set to paper style scaling are resized according to the Nominal Map Scale setting.

11. Right click on the Q2 Well Production legend entry and select Legend Entry Properties.

The Legend Entry Properties dialog is displayed.

12. Set the Type to Range Thematic (see graphic below).

13. Set the Attribute for classification as Water_Depth.

14. Enable the Assign colors option and select a desired color scheme.

15. Disable the Assign sizes option.

17. Click on the Classify button.

The Classify dialog appears.
18. Ensure the *Classification technique* is set to **Equal Range**.

![Classification window]

19. Click **OK** on the Classify dialog.

*Values should now be classified into 4 equal ranges.*

![Classification result]

20. Optionally use the Classify option to experiment with other classification techniques. Begin and End values can also be manually edited in the classification grid but the ranges cannot overlap.

21. Click **OK** to review the results.

Notice how the wells symbolized by attribute based symbology (ABS) for size according to daily oil production as well as color for water depth.

22. Use the **Home > Legends > Name Legend** command to name the legend Oil Production Thematic.

![Legend naming window]

23. This may be a good time to use the **File > Save** to save the work you’ve done so far.

24. Leave the GeoWorkspace open for use in the next exercise.
Exercise 2: Using Aggregation For Nearest Attribute Calculations

Objective:
In this section, we will use GeoMedia aggregation command with its Accumulate Nearest option to obtain the name of the nearest port for each oil platform. Optionally, we can also create a functional expression that calculates the distance or even draw a line from each platform to its nearest port.

By completing this exercise you should understand how to use:
- Aggregation command to spatially relate 2 features to determine nearest attribute

Task 1: Getting Started

*The GeoWorkspace, Gulf_Gas_and_Oil.gws should still be open and visible.*

1. Select the Home > Legends > Legends command.

*The Legends dialog appears.*

2. Select the Manned Platforms named legend and click Replace.

3. Click Yes to replace the active map legend.


*The Manned Platforms map legend is displayed.*
Notice that the legend has 2 platform related entries.

- Qa is Join query which relates platform attribute information to related platforms.
- Qb is an attribute query of the Qa join to locate platforms which are manned by either 8 or 24 hour shifts and is not abandoned.

5. Optionally, use the Analysis > Queries command to review the properties of the Qa and Qb queries.

6. Optionally, review the attribute properties of one or more of the platforms.

7. Leave the GeoWorkspace open for use in the next task.

**Task 2: Obtaining Nearest Related Attribute**

Recall our goal: For every oil platform, we need to know the nearest port.

Similar to the join command, the Aggregation command can be used to relate one table to another. Aggregation however, provides powerful spatial operators that relate tables spatially in addition to attribute relationships. Aggregation works by relating information from a detail feature class and summarizing information to a summary feature class. The output of Aggregation is the summary feature class with all of its original attributes plus any calculated attributes which are typically summarized from the related detail features.

In the following example we will use Aggregation’s Accumulate Nearest spatial operator. The Accumulate nearest spatial operator ensures that each summary feature (Manned Platforms) is associated with its nearest detail feature (Ports). Only one detail feature will be associated to each summary feature. A single detail feature (Port) can be associated to 1 or more summary features, some detail items may not be assigned as the nearest for any summary feature.

*The GeoWorkspace, Gulf_Gas_And_Oil.gws should still be open and visible.*

1. Select Analysis > Aggregation.

2. Select drop down for the Aggregate to summary features list, expand the Queries and select the Qb Manned Platforms query.

3. Click in the From detail features drop down list, expand the Gulf States connection and select Ports.
4. Set the spatial operator to the **accumulate nearest** option (see graphic below).

![Spatial Aggregation](image)

Each summary feature is assigned a single detail feature.

5. Click on the **Output** tab.

6. Right-click in the Output functional attributes section and select **New > First > Main_Port_Name** (see graphic below).

![Output Functional Attributes](image)

*FirstOfMain_port_name is added to the Output functional attributes section.*

7. Set the output Query name as **Qc Agg Platforms for Nearest Port**.
8. Click **OK** to run the Aggregation and view the results in the map view.

9. Leave the GeoWorkspace open for use in the next task.

---

**Task 3: Visualizing Results Using Unique Value Thematic**

The legend entry for the aggregation can be set to a Unique Thematic mapping to better visualize the results. See steps below.

*The GeoWorkspace, Gulf_Gas_And_Oil.gws should still be open and visible.*

1. Use right-click action to turn off the display (Display Off) of the legend entries for **Qa Platforms** and **Qb Manned Platforms**.

2. Right click on the **Qc Agg Platforms for Nearest Port** legend entry and select **Legend Entry Properties**.

*The Legend Entry Properties dialog appears.*

3. Use the following graphic as guide to create a Unique Value Thematic (see graphic below).
4. Ensure that the Style Scaling for the new thematic legend entry is set to View.

5. After reviewing the results, optionally use the Home > Legends > Name Legend command to name the legend appropriately (see graphic below).
6. Exit and Save the GeoWorkspace OR if time allows, try the following challenge section.
Challenge 1: Calculating Distance and Creating Polylines

Objective:
In this challenge section we can modify the existing Aggregation query to add more functional calculations.

Task 1: Calculating Distance

The Distance function is useful for calculating the distance between geometries. The syntax for the function can vary slightly as the expression can be used in scalar style query output or more commonly in aggregating style query output.

Example Syntax for scalar distance calculation: If a feature has 2 geometry fields, functional attributes command could be used to calculate the distance between the 2 geometry fields.

\[ \text{DISTANCE (Input.Geometry1, Input.Geometry2, ProjectedMeas, Meter)} \]

An example for aggregating style distance calculation is where detail features are related to summary features in aggregation command where for example it might be desirable to obtain the AVG or MAX distance between each summary feature and it’s set of related (spatially and/or attribute relation) detail features:

\[ \text{AVG (DISTANCE(Input.Geometry, Detail.Geometry, ProjectedMeas, Meter))} \]

In special cases when using the Accumulate Nearest or Are Nearest To spatial operators in Aggregation, the syntax for the DISTANCE expression can use the FIRST(detail.geometry) as in the following example lab below:

The GeoWorkspace, Gulf_Gas_And_Oil.gws should still be open and visible.

1. Select Analysis > Queries.
2. Highlight Qc Agg Platforms for Nearest Port and select Properties.
3. Select the Output tab, and use the New button to build a function to calculate the distance:

Example:

\[ \text{DISTANCE (FIRST(Detail.CoordGeocodePoint), Input Geometry, TrueMeas, Mile)} \]

Optionally a line could be created between each port and platform using a CREATEPOLYLINE statement. See the task below.
Task 2: Creating Line to Nearest Related Feature

Similar to the DISTANCE function, the CREATEPOLYLINE can be used in scalar or aggregating style expressions.

When used in Functional Attributes as a scalar function the CREATEPOLYLINE can be used to draw a line between 2 point geometries where both geometries reside in the same table.

Example Scalar Syntax might look like:

```
CREATEPOLYLINE(Input.Geometry1, Input.Geometry2)
```

When used in aggregating style expressions a single point geometry field is specified with an optional order-by attribute. This aggregating style use of CREATEPOLYLINE is most often used in Analytical Merge command.

Example Aggregating Syntax might look like:

```
CREATEPOLYLINE(Input.Geometry, Input.DATE)
```

In the example above the resulting line will connect the points with a polyline and connect the points in the order of their date.

In special cases when using the Accumulate Nearest or Are Nearest To spatial operators in Aggregation, the syntax for the CREATEPOLYLINE expression can use the FIRST(detail.geometry) as in the following example:

1. Use the New button to build a function to create a line between the nearest port and each platform:

```
CREATEPOLYLINE(FIRST(Detail.CoordGeocodePoint),Input.Geometry)
```

If editing an existing query to add a new geometry, you can see the new geometry by using the Home > Legend > Add Legend Entries command. The Add Legend Entries command adds all available geometry columns to the map & legend.
Note:

Recall that in the workflow above we merged the production data by the well number and obtained the operator of the well by using FIRST(Input.Operator). This approach may miss an owner name during a year if the well was sold thus having different owners for different months. The proper solution in such situations may be to:

a) Use Analytical Merge to merge the production data by both the well number AND the Operator (owner). This step simplifies the data to Output the query name as:

Merge_Query1

b) Then again use Analytical Merge using input as Merge_Query1, this time merging only by the Well number. When a list of items is needed such as operator names, text function CONCATENATE could be used. Example: CONCATENATE(""",Input.Operator_Name)

Using the Merge command twice solves the problem of having duplicated concatenated names when using the concatenate function.
Section 2: Right of Way Widening Study

Section Objective

In this section we will use a hypothetical proposed road right of way widening study to demonstrate the use of several analysis tools.

Tools Used

Attribute Query

Used to request particular records from a feature class or query using a Structured Query Language (SQL) syntax to form a filter string (where clause). The where condition is prefixed by a "Select * from [tablename] where". Example: Traffic_Count > 1000

Buffer Zone

Used to generate area features based a user defined radius or distance around subject features. The radius / distance value can be fixed or defined by feature attribution. Used for both visualization and subsequent spatial analysis processes.

Spatial Intersection

Allows overlay of 2 feature classes or queries to return geometries of intersection with combined attributes from each feature class.

Aggregation

Used perform a spatial and/or attribute association of detail feature items to related summary feature items. For each grouping of detailed items, a summarizing expression can be used to summarize each grouping of detailed items to its related summary feature.

Analytical Merge

Use to summarize a single feature class table or query. Organizes records into groupings based on user defined attribute(s) then for each grouping, the records are merged to a single output record. As each group of associated records are merged, summarization expressions can be performed.
Exercise 1: Corridor Analysis

Objective:
In this section you will gain insight and better understanding on how to count items, perform area calculations, calculate percentage of overlap, create and use expressions for logical IF statements and summarize items by selected attributes. We will also observe how GeoMedia queries update using notification when there are changes to the source data and/or query definition.

Analysis commands used include:
- Attribute Query - to isolate data
- Buffer Zone - to delineate area or zone of interest.
- Spatial Query - to locate and isolate items in study area
- Spatial Intersection - to identify the interaction of items within the study area for reporting purposes.
- Aggregation - Summarizing detail items to the zone of study
- Analytical Merge - Final summarization of data.

Task 1: Using Attribute Query to Isolate data

Attribute queries can be used to retrieve records for further analysis. Using an attribute query early in a workflow to isolate data can also provide future flexibility should there be a need isolate and process different records.

When building an attribute query in GeoMedia, you are supplying the conditional statement in a structured query syntax for a where clause. Any filter you build has a “Select * from feature where” prefixed to the filter statement submitted.

GeoMedia typically passes the query directly to the database so the syntax for queries (wildcards etc.) can vary slightly depending on the database type. If the features are not stored in a database (shapefiles, AutoCAD, etc.) then GeoMedia uses its own query parser which is similar to that of Access.

1. Use GeoMedia to open C:\Analysis\GeoWorkspaces\Corridor_Analysis.gws.
   Once the GeoWorkspace opens, a map with city data should be visible.
2. Select Analysis > Attribute Query.
3. In the Select features in drop down, expand the Des Moines Planimetric connection and scroll through the list of features to select STREETCENTERLINE (see graphic below).
4. Click on the **Filter** button.

5. Scroll through the list of Attributes to locate and highlight the FullName attribute field name (see graphic below).

6. Add **FullName** using down ▼ to the Filter field.

7. Key-in or select the = operator.
The = operator is appended to the Filter string FullName =

8. With FullName still highlighted in the Attributes field, select Show Values.
9. Select Yes to the information message.

   This message to confirm the Show Value operation can be disabled using File > Options.

10. Click into the values field and begin to key-in: N Hickory, notice how you can now quickly see N Hickory Blvd for easy selection.
11. Highlight N Hickory Blvd and add the value down to the Filter field.
   The Filter string now reads as FullName = 'N Hickory Blvd' (see graphic below).

12. Select OK on the STREETCENTERLINE Filter dialog.
13. Set the output Query name as: Q1 Find A Street.

   When building queries it is wise to use the description field to describe the input to the query as well as the purpose and logic for the query. Some simple descriptions can help with understanding historic query workflows.
14. Use the *Style* button to select or define a style of your choosing.

15. Uncheck the option to display the data window.

16. Select **OK** to save and run the query adding the results to the map window.

17. Leave the GeoWorkspace open for use in the next task.
Task 2: Creating Buffer Zone for Analysis

In the following example the buffer zone command is used to create a zone of interest representing a hypothetical right of way (ROW). In this lab example we use a fixed or constant distance for the buffer zone, but keep in mind that the buffer zone command also supports a variable distance value that uses feature attribution.

The GeoWorkspace, Corridor_Analysis.gws should still be open and visible.

1. Select **Analysis > Buffer Zone** command.

2. In the Buffer zone around drop-down list, expand the Queries and select the **Q1 Find A Street** query (see graphic below).

3. Set a **Constant buffer Distance** of 25 m.

4. Select the option to **Merge touching buffer zones**.

5. Set the output **Query name** as: **Q2 Buffer Q1 for Zone**.

6. Use the **Style** button to select or define a style of your choosing.

7. Select **OK** to save and display the buffer zone.

8. Leave the GeoWorkspace open for use in the next task.
Task 3: Using Spatial Query to Isolate Data in Zone

A Spatial Query can be used to compare the spatial relationship of one feature class or query to another. For example, a spatial query could be used to find all Buildings that are NOT within 100m of a Fire_Hydrant.

In the following example we will use a spatial query to locate buildings that touch the right of way buffer zone.

The GeoWorkspace, Corridor_Analysis.gws should still be open and visible.

1. Select Analysis > Spatial Query.

2. Click in the Select features list field and expand the Des Moines Planimetric connection; then scroll through the list of features and select PLMBuildingFootPrint.

3. Set the spatial operator to “touch” (see graphic below).

4. Set the Features in list (lower left) to the Q2 Buffer Q1 for Zone query (see graphic below).

5. Set the output Query name: as Q3 Buildings Touching Zone.

6. Use the Style button to select or define a style of your choosing.
7. Uncheck the option to display the data window.
8. Select **OK** to save and display the buildings that spatially touch the buffer zone.
9. Leave the GeoWorkspace open for use in the next task.

---

**Task 4: Spatially Intersecting Geometry for Subsequent Analysis**

Spatial Intersection is a main stream GIS analysis tool that compares the geometry interactions of 2 features and returns portions of the geometry that intersect. The intersecting geometries are returned with the attributes of each feature of intersection. This combining of intersecting attributes can be a very useful pre-process step before summarizing and/or reporting data.

As an example, water wells (points) could be spatially intersected with soil polygons. The resulting points of intersection would carry both the attribute of the well and the soil polygon for each point of intersection.

*The GeoWorkspace, *Corridor_Analysis.gws* should still be open and visible.*

1. Select **Analysis > Spatial Intersection**.
2. Use the *Features in* list field to expand the **Des Moines Planimetric** connection; then scroll through the list of features and select **ParcelProperty**.

This particular data set for parcels also includes parcels that represent existing street right of ways. These existing right of ways are not of interest to our workflow so we can use the Filter button to include only true parcels.

3. Click on the **Filter…** button for **ParcelProperty**.

4. Use the **ParcelProperty Filter** dialog to build the following filter string:
   (see graphic below)
   
   **StreetROW = 'N'**

5. Once the filter string is defined select **OK** to return to the **Spatial Intersection** dialog.

6. Set the spatial operator to "**overlap**" (see graphic below).

7. Set the *Features in* list (lower left) to the **Q2 Buffer Q1 for Zone query** (see graphic below).

8. Set the output **Query name**: as **Q4 Parcels Isect ROW**.

9. Use the **Style** button to select or define a style of your choosing.
10. Uncheck the option to display the data window.

11. Select **OK** to save and display the spatially intersecting geometry where parcels overlap our study area buffer zone.

12. This may be a good time to use the **File > Save** to save the work you’ve done so far.

13. Leave the GeoWorkspase open for use in the next task.
Task 5: Aggregation Analysis of Features Related to Zone

In the following task, we'll use the Aggregation command to count the number of buildings which touch each parcel intersection. Knowing if the right-of-way intersection interacts with a structure can greatly affect the offer price for the property.

The aggregation command uses 2 feature classes or queries. A detail feature class and a summary feature class or query. Detail items are grouped either spatial and/or by attributes to a summary feature. The output is the summary feature with any additional summarized information from the related detail features.

When building functional expressions, both the “input” summary feature attributes (parcel intersections in this case) as well as detail attributes (buildings in this case) are available. Functional expressions using detail attributes must be created to return a single value (aggregating style); example functions that be used to return a single value from detail attributes include SUM, AVG, FIRST, COUNT, etc.

The GeoWorkspace, Corridor_Analysis.gws should still be open and visible.

1. Select Analysis > Aggregation.

2. Set the Summary feature as the Q4 Parcels Isect ROW query.
3. Set the Detail feature as the Q3 Buildings Touching Zone query.
4. Set the spatial operator to Overlap.

5. Click on the Output tab.
6. Set the Resolution operator to largest overlap.

If a detail building feature overlaps 2 parcels, the building in conflict will be associated with the parcel of largest overlap.
The Resolution Operator is used when a detail item qualifies (spatial or attribute relation) for more than one summary feature. The Resolution Operator answers the question: Which summary feature should use the detail item?

7. Right click in the Output functional attribute field and select New > Count(*).

A new output count function is added to the Output field.

8. Select the Properties button.

9. Rename the Functional attribute name to FA_Num_Buildings.

10. Select OK to save the expression and return to the main Aggregation dialog.

11. Click on the New button.

Our goal now is to build a new expression which Sums up the square footage calculation of the detail intersection geometries. The final expression looks like:

\[ \text{AREA(Input.IntersectionGeometry, ProjectedMeas, SquareFoot)} \]

12. Set the output functional attribute name as FA_Isect_SqFt.

13. Click into the Expression field.

14. Click on the Geometry Category (left side).

15. Double click AREA function (center section).
16. Scroll through the list of attributes (right side) and double click on the **Input.IntersectionGeometry** attribute (see graphic below).

![Functional Attribute](image)

17. Press the comma <,> key to append a comma to the string but inside the closing parenthesis.

18. Key-in **ProjectedMeas**.

*The Expression now appears as:*

\[
\text{AREA(Input.IntersectionGeometry, ProjectedMeas)}
\]

19. Again, press the comma <,> key to append a comma to the string but inside the closing parenthesis.

20. Click the **Constants** Category and scroll through the list of constants (center section) to locate and double-click **SquareFoot** (see graphic below).
The expression string should now look like:

\[ \text{AREA(Input.IntersectionGeometry, ProjectedMeas, SquareFoot)} \]

The syntax for AREA function: **AREA(Geometry, MeasureType, Unit)**
where the MeasureType is either ProjectedMeas, or TrueMeas. The measure type and the unit of measure can be selected from Constants category. Other expressions using the same or similar syntax include: LENGTH, PERIMETER, X, Y, Z, ANGLE and others.

21. Click **Add** to save the functional expression.

The form is cleared and ready to build new expressions.

Since our parcel data has the original square footage and now we have the square footage of the spatial intersection, we can easily build an expression to calculate the percent of the parcel that overlaps the buffer zone. Think of this percentage as representing the percent of the parcel that would become part of any proposed right of way.

22. Set the **Functional attribute name** as: **FA_ROW_pct**.

23. Use the Attributes section (right side) to divide the Output.FA_Isect_SqFt by the Input.SHAPE_Area (also stored in square feet in this particular data set).

\[ \text{Output.FA_Isect_SqFt} / \text{Input.SHAPE_area} \]
24. Click **Add**.

We can now build an expression to get an estimate of cost for each parcel. In the most basic form, the estimated price would be the percent of the parcel that is right of way * the parcels total value.

Example: `Output.FA_ROW_pct * Input.TotalValue`

We can however make other considerations such as if a structure must be purchased or if the percentage of the parcel in the right of way demands that we consider the full cost of the property.

To make such considerations we will use an IF statement. In GeoMedia the IF statement syntax looks like:

IF(logical test, Value if True, Value if false)

Example: `IF(FA_ROW_pct > 50, TotalValue, FA_ROW_pct * TotalValue)`

Which states: If the right of way percentage is greater than 50%, then the TotalValue must be used, otherwise, use the formula `FA_ROW_pct * TotalValue`.

If we want to consider the buildings then we might assume that if the ROW intersects any building that the total value must be offered. We can include the buildings in our expression using a conjunctive OR statement:

Example:

IF(Output.FA_Num_Buildings >= 1 OR Output.FA_ROW_pct >= 50, Input.TotalValue, Output.FA_ROW_pct * Input.LandValue)

Which reads as: If the number of buildings is 1 or more OR if the percent of ROW is greater than or equal to 50, then the total value must be paid, otherwise offer the percentage of the total value (or land value).

25. Set the output name as: **FA_Est_Price**.

26. Build the following expression:

   IF(Output.FA_Num_Buildings >= 1 OR Output.FA_ROW_pct >= 50, Input.TotalValue, Output.FA_ROW_pct * Input.LandValue)

27. Optionally set the **Format** as **Currency** expressed to 2 digits.

28. Click **Add** to save the expression.

29. **Close** the Functional Attribute dialog.

30. Set the output **Query name** as: **Q5 Agg for Est Costs**.
31. Click **OK** to run the query.
32. This may be a good time to use the **File > Save** to save the work you’ve done so far.
33. Leave the GeoWorkspace open for use in the next task.

---

**Task 6: Summarizing Results Using Analytical Merge**

The Analytical Merge command takes a single table or query as input, organizes records into groupings based on user defined attribute selections and allows for summarization expressions.

As an example, Analytical merge might be used on the result of a spatial intersection of districts and highways where one could merge by the district name and the highway name to calculate or summarize the total highway mileage for each highway name in each district.

In the following example we will use Analytical Merge to calculate the total estimated cost for each parcel class (residential, commercial, government etc.).
1. Select **Analysis > Analytical Merge**.

2. Set the input **Merge feature** as the **Q5 Agg for Est Costs**.

3. Set the **Merge criteria** to use the **By Attribute** option (see graphic below).

4. Scroll through the list of attributes and enable the **ClassDesc** attribute.

5. Right click in the **Output functional attributes** field and select **New > SUM > Multiple Attributes** option (see graphic below).
6. On the *Multiple Attributes for SUM* dialog, scroll through the list of available attributes for summing and select the functional attribute (FA) calculations made in the previous aggregation query (see graphic below).

7. Select **OK** on the *Multiple Attributes for SUM* dialog.
The expressions are added to the Output functional attributes section.

8. Optionally select the **SumOfFa_est_price** use the Properties button to set the output format as **currency**.

The following shows an example method to perform a conditional count. In this case we want to know how many parcel right-of-way acquisitions will cost more than $100,000.

9. Click on the **New…** button.

10. Set the **Functional attribute name** as: **FA_Num_Over100k**.

11. Click in the Expression field and build the following expression:

   \[
   \text{IF( Input.FA_Est_Price > 100000, 1, 0)}
   \]

12. Try adding the expression by clicking the **Add** option.

   *The following information message is posted:*

   
   ![Evaluation of the expression will result in multiple values. Only one output value is allowed for this command.]

   The informative message reminds us that when creating expressions in Analytical Merge, that we must use aggregating style functions (SUM, AVG, MIN, MAX, etc.) to summarize the individual record calculations within each grouping. In our example recall that we are grouping records based on parcel class (residential, commercial, etc.).

   We can use the **SUM** function to sum up the number of 1’s found by the conditional test where the **FA_Est_Price > 100,000**.
13. Click **OK** on the informational error message.

14. Modify the expression so it is inside the parentheses of a **SUM( )**

Example:  **SUM(IF( Input.FA_Est_Price > 100000, 1, 0))**

While this expression does not technically use the COUNT function, it essentially allows you to perform a conditional count by summing up the number of times a condition is met. This can be very useful for expressions used by Analytical Merge and Aggregation commands.

15. Click **Add** to save the expression.

*The Functional Attributes dialog is cleared and redisplayed.*

16. **Close** the Functional Attributes dialog.

17. Set the output Query name as: **Q6 Cost by Class.**

18. Uncheck the option to display the map window.

19. Enable the option to display the results in a data window.

20. Click **OK** to display the results.
The results of the analytical merge (Q6 Cost by Class) could itself be used as input to another analytical merge for further calculations such as total estimated project cost, total buildings, concatenated lists, etc.

21. Click on the column header for the `SumOffa_est_price`.

22. With column selected in the data window, select Table > Column Statistics.

23. Note that the Statics dialog indicates that the total project right of way acquisition cost is well over $7.7 million (see graphic below).
24. After reviewing the statistics, **Close** the Statistics dialog.

25. This may be a good time to use the **File > Save** to save the work you've done so far.

26. If time allows, try the following challenge sections or Exit and Save the GeoWorkspace.
Challenge 1: Query Notification

Objective:
This short exercise demonstrates the GeoMedia query notification where queries stored in the GeoWorkspace respond to changes in either the data and/or edits to the queries.

Task 7: Example of Query Notification After Query Edit

Recall that the estimated cost of the right of way is over $7.7 million. What would the cost be if we could reduce the width of the right of way zone by 5 meters? Recall that our right of way zone is defined by a buffer query.

1. The GeoWorkspace, Corridor_Analysis.gws should still be open and visible.
2. Select Analysis > Queries.
3. Highlight the Q2 Buffer, then select Properties.
4. Change the buffer Distance to 20 m.
5. Click OK to save the change.
6. After the queries update, Close the Queries dialog.
7. Again review the Table > Statics of the SumOfFa_est_price.

Notice how the cost has been reduced significantly since our right of way expansion is not requiring so many full property purchases where builds are in the zone.
Task 8: Another Query Edit To See Notification

This section shows how the query notification process by modifying the first query in our query pipe line also. For example, the Analysis Queries command could be used to modify the Q1 Find A Street query. Recall that the Q1 Find A Street query was a simple attribute query.

In practice, beginning an analysis workflow using an attribute query adds flexibility to allow future changes as demonstrated below:

1. Select Analysis > Queries.
2. Highlight Q1 Find A Street query and select Properties.
3. Click on the Filter... button.
4. Modify the Filter string as noted below. Note: you can use copy & paste operations in the Filter field.
FullName = 'N Hickory Blvd' OR FullName = 'S Hickory Blvd'

5. Click **OK** to save the filter and **OK** on the Query Properties dialog.

6. After the queries update, **Close** the Queries dialog.

7. After reviewing the results you could even use the same process of modifying the Q1 Find A Street Query to change the filter string to locate other streets.

   **Name = ‘Planned’**

This completes this Challenge.

8. Exit and Save the GeoWorkspace.